gifts2017

Обработка ЗиК 2009 + Приказ ФНС от 30.12.2008 ММ-3-3/694

Опубликовал Илья Никитин (Gorr) в раздел Обработки - Обработка справочников

Доработка обработки ЗиК 2009 в соотв с Приказом ФНС от 30.12.2008 ММ-3-3/694. Оригинальный проект http://infostart.ru/projects/3215/

В обработку добавлено:

1) регистрация новых вычетов с кодами:
108 "1000 руб. на каждого ребенка... (начиная с доходов 2009 года)"
109 "2000 руб. на каждого ребенка-инвалида... (начиная с доходов 2009 года)"
110 "2000 руб. на каждого ребенка единственному родителю ... (начиная с доходов 2009 года)"
111 "2000 руб. на каждого ребенка родителю... при условии отказа второго родителя... от получения вычета... (начиная с доходов 2009 года)"
112 "4000 руб. на каждого ребенка-инвалида... единственному родителю... (начиная с доходов 2009 года)"
113 "4000 руб. на каждого ребенка-инвалида... родителю... при условии отказа второго родителя... от получения вычета... (начиная с доходов 2009 года)"
313 "Сумма, израсходованная налогоплательщиком на новое строительство... в пределах 2 000 000 руб. (начиная с доходов 2008 года)"

2) Закрытие действующих у сотрудников вычетов с кодами 101,102,106,107 на 01.01.2009 31.12.2008 и открытие новых вычетов начиная с 01.01.2009г.

ВАЖНО: Обработка предназначена только для того, что она выполняет. не более. Для корректного расчета НДФЛ в 285 релизе с новыми кодами вычетов потребуется внесение изменений в конфигураторе!

В связи с принятым сотрудниками 1С решением обновления кодов вычетов путем реструктуризации справочника ВидыВычетов, в обработку добавлена возможность отката выполненных ранее изменений. 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1233307788 70,50Kb
25.09.09
313
.1233307788 70,50Kb 313 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Епрст (Ёпрст) 30.01.09 12:55
Ну и...? и чего нового в ней ?
2. Илья Никитин (Gorr) 30.01.09 14:08
1. Добавил описание;)
2. обновил обработку в ней действие вычета 313 установил с 01.01.2008 (в первоначальном варианте было с 2009) хотя думаю это не принципиально.
3. Rybkina Olga (OdinokC) 30.01.09 15:12
НДФЛ считается неправильно.
Жду новую версию Вашей обработки.
Очень нужна.
4. Илья Никитин (Gorr) 30.01.09 16:38
дело тут не в обработке. новые коды вычетов не прописаны в коде. для корректного расчета НДФЛ исчисленного необходимо в глобальном модуле в процедуре глСобратьДанныеДляНДФЛ заменить строку
"ИначеЕсли ((КодВычета=101) или (КодВычета=102) или (КодВычета=106) или (КодВычета=107)) и (ДостиглиПределаДоходов=0) Тогда"
на строку
"ИначеЕсли ((КодВычета=101) или (КодВычета=102) или (КодВычета=106) или (КодВычета=107) или (КодВычета=108) или (КодВычета=109) или (КодВычета=110) или (КодВычета=112) или (КодВычета=111) или (КодВычета=113)) и (ДостиглиПределаДоходов=0) Тогда"
при этом печатная форма 2ндфл за 2009 формируется нормально, а вот печатной формы 1ндфл за 2009 год с новыми кодами вычетов еще нет, придется подождать с этим до нового релиза конфигурации....
lonec; Sol; gutentag; +3 Ответить 1
5. Алексей Споров (Timesoft) 01.02.09 12:35
(4) И правильно, что не прописаны... Приказ ФНС от 30.12.2008 ММ-3-3/694 уже вступил в силу ? Когда ?
6. Looking Кречетов (Looking) 03.02.09 07:24
Зарегистрировано 19.01.2009 (рег. № 13101) и вступило в силу спустя 10 дней после дня официального опубликования.
7. Looking Кречетов (Looking) 03.02.09 07:28
Правда дату официального опубликования не нашёл, кто в курсе опубликовали уже или нет?
8. Светлана Максимова (LanaMax) 03.02.09 09:00
А как быть с этими изменениями:
Доходы в виде материальной выгоды (ст. 212 НК РФ)
Установлено, что при получении физическим лицом доходов в виде материальной выгоды от экономии на процентах по займам и кредитам, выраженным в рублях, налоговая база по НДФЛ определяется как превышение суммы процентов, исчисленной исходя из 2/3 ставки рефинансирования Центрального банка РФ, действующей на дату получения дохода, над суммой процентов, рассчитанной по условиям договора (подп. 1 п. 2).
10. Илья Никитин (Gorr) 04.02.09 03:37
Ввиду того, что автором оригинала проекта Antia была обнаружена ошибка в релизе 284, обработка обновлена.
Данная ошибка может сказаться, при обновлении на 286 релиз если обработка была запущена на релизе ранее 284 да и то при условии, что в 286 релизе ошибку не устранят.
Более подробно см комментарий 58 автора оригинала проекта.
11. Илья Никитин (Gorr) 04.02.09 03:48
(8) эти изменения к предмету данной дороботки не относятся. требуется изменение конфигурации. об этом по-моему уже не раз говорилось. но если же есть желание внести изменения самомтоятельно, в этом нет ничего сложного:)
12. Михаил Плотников (pma) 04.02.09 09:31
13. Алекс (Allex) 04.02.09 11:41
Строку:
// УстановитьВидВычета("103","400 руб. на налогоплательщика, пп.3 п.1 ст.218 НК", 400 ,40000,'01.01.2009');
не надо было комментировать - там предел изменился.
И сообщения типа: "Возможно необходимо установить вид вычета ..."
Там по ходу д.б. [108 или 111] и [109 или 113], а не [110 или 111] и [112 или 113].
В процедуре "ПриВыбореТипаЛьготы" неплохо бы еще добавить:
ИначеЕсли ( КодВычета="313") Тогда
Форма.ИспользоватьСлой("Основной,ИмущественныеВычеты",2);
ОписаниеИмущественногоВычета="Сумма, израсходованная на новое строительство либо приобретение на территории Российской Федерации ";
ОписаниеИмущественногоВычета=ОписаниеИмущественногоВычета+"ж­илого дома, квартиры или доли (долей) в них (кроме сумм, направленных на погашение процентов ";
ОписаниеИмущественногоВычета=ОписаниеИмущественногоВычета+"п­о целевым займам (кредитам) и фактически израсходованных на новое строительство или приобретение ";
ОписаниеИмущественногоВычета=ОписаниеИмущественногоВычета+"н­а територии Российской Федерации жилого дома, квартиры или доли (долей) в них), в размере фактически произведенных ";
ОписаниеИмущественногоВычета=ОписаниеИмущественногоВычета+"и­ документально подтвержденных расходов в пределах 2 000 000 руб., пп.2 п.1 ст.220 Налогового кодекса Российской Федерации.";

А в процедуре ПриОткрытии:
Если РабочаяДата()>='01.01.2008' Тогда
//эти вычеты действуют с 01.01.2008
Льготы.НайтиПоКоду("313");
СписокВычетов.ДобавитьЗначение(Льготы.ТекущийЭлемент(),Льготы.Код + " (" + Льготы.Наименование + ")");
КонецЕсли;

Ну и контроль для 313 вычета в Процедуре ПриЗаписи и Процедуре ПриВводеСуммы, если есть желание...
14. Светлана Максимова (LanaMax) 04.02.09 12:52
103 "400 руб. на налогоплательщика, пп.3 п.1 ст.218 НК" - 400 (до 40000)
а в обработке до 20000 - почему?
15. Алекс (Allex) 04.02.09 18:49
(14) Я же написал - разкомментируйте в обработке строку:
// УстановитьВидВычета("103","400 руб. на налогоплательщика, пп.3 п.1 ст.218 НК", 400 ,40000,'01.01.2009');
16. Илья Никитин (Gorr) 04.02.09 20:43
(13) благодарю. изменения по коду 103 внесены в обработку. а вот в отношении соответствия старых кодов новым хотелось бы услышать аргументы!
Итак мои аргументы: вычеты 108 и 111 абсолютно разные поскольку в первом случае вычет получют оба члена семьи, а во втором только один, да и суммы вычетов отличаются. тоже относится и к паре 109 113. таким образом пары из кодов 108 и 111 не получается равно как и пары из 109 113. в паре [110 111] вычет получает только один родитель и сумма вычетов одинакова, в паре [112 113] тоже что и в [110 111]+инвалидность. что и позволяет их сгруппировать именно таким образом.
вот смотрите: имеем вычет 101 предоставлялся "на каждого" родителя здорового ребенка. в новых кодах группа "на каждого" включает 108 и 109. поскольку код 109 предоставляется на инвалида, то остается код 108. итак нашли однозначное соответствие
101-108
далее 102 предоставлялся "единственному" родителю здорового ребенка. в новых кодах группа "единственных" включает 110,111,112 и 113 коды. из которых 112 и 113 предоставляются на инвалида, таким образом остаются возможные коды [110 111]. итак нашли соответствие
102-[110 111]
далее 106 предоставлялся "на каждого" по инвалидности. в новых кодах группа "на каждого" включает 108 и 109 из которых только код 109 предоставляется по инвалидности. итак нашли однозначное соответствие
106-109
ну и последний код 107 предоставлялся "единственному" родителю по инвалидности. в новых кодах группа "единственных" включает 110,111,112 и 113 к котоым по инвалидности относятся только 112 и 113. итак нашли последнее соответствие
107-[112 113], что собстно и было реализовано.
17. Алекс (Allex) 05.02.09 10:39
111 это вычет не единственному родителю, а вычет одному из родителей при условии что второй вычетами на ребенка не пользуется. Раньше это был 101 вычет. Поэтому можно даже по умолчанию менять 101 на 111. А 108 это вычет на здорового ребенка в том случае, если второй родитель тоже у себя на работе написал заявление на вычет (раньше вычет мог получать только один родитель). Вот исходя из того, что второй родитель скорее всего воспользуется этой новой возможностью и напишет
заявление на вычет (если, конечно, он работающий), потому что з/п одного родителя может и превысить 280000, и тогда получать вычеты двум родителям выгоднее, чем одному, я согласен, что надо по умолчанию менять 101 на 108.
То же самое с парой [109,113].
18. Алекс (Allex) 05.02.09 10:57
(17) А вообще то лучше даже переключатель добавить, вернее два, которые будут определять куда по умолчанию переносить 101 и 106 вычет.
19. Илья Никитин (Gorr) 05.02.09 21:15
(17) не надо ничего усложнять и мудрить!!! вычеты на детей банально делятся всего на две группы "каждому" и "одному" из возможной пары. понятия "единственному" или "одному при отказе второго" равны и относятся к группе "одному".
101, 106, 108, 109 относятся к группе "каждому", а 102, 107, 110, 111, 112, 113 относятся к группе "одному".
20. slige (slige) 05.02.09 23:52
"Зарплата и Кадры" Как изменить размер вычетов по НДФЛ и пределы доходов?

*******************Официальный ответ 1С*************************

Размеры вычетов по НДФЛ, а также величины пределов доходов для исчисления вычетов пользователь может изменить в справочнике "Виды вычетов" (меню "Справочники" - "Классификаторы" - "Виды вычетов"). Изменяемые значения являются периодическими. Поэтому прежде следует указать дату изменения значения периодических реквизитов - 01 января 2009 года. А затем в графах "Сумма вычета" и "Предел доходов для исчисления вычетов" установить размеры вычетов и соответствующих им пределов доходов, действующих с начала текущего года.

По окончании ввода данных пользователь имеет возможность проверки произведенных действий в экранной форме "Значения периодических реквизитов". Форма открывается нажатием кнопки "История
21. Алекс (Allex) 06.02.09 11:40
(19) Не согласен (хотя бы потому, что не может одинокий родитель принести справку об отказе от другого родителя;), но спорить не буду, т.к. в данной ситуации это не принципиально - все равно окончательный выбор будет делать пользователь.
22. nickVZ (nickVZ) 08.02.09 01:38
Чего вы спорите, горячие парни? Коды - всего лишь "сведения". Заменяйте не особенно мудрствовая. Лишь бы "суммовой" смысл подошел. Далее - дело самих расчетчиц применить конкретный код. Это последнее замечание относится к "размноживщимся" кодам. Для "101", например, жесткое соответствие со "108".
"313" код вообще надо из обработки выкинуть: коды этой группы назначаются строго на один год, и строго по справке из ИФНС. Потому никакой "автоматической" отсебятины ;)
23. BIGMAG BIGMAG (BIGMAG) 08.02.09 21:05
Gorr я долёк от з/пл. Объясни мне пожалуйста с этого места.
Цитирую: "Для установки сотрудникам новых вычетов вручную, необходимо внести изменения в модуль формы справочника ВычетыСотрудниковПоНДФЛ:"
сомнение "установка вычетов вручную", я правильно понял, если я выполню твои изменения в конфигурации, то мне что то ещё придется делать вручную?
Тогда подскажи что именно?
Или напиши мне на io2t@ya.ru по подробнее об установке всех этих изменений в з/пл.
И ещё вопрос. У нас на предприятии есть мат.выгода тогда мне нужно выполнить следующие изменения:
Цитирую:
[
(20) Anita, а что ты на счет этого скажешь (ЗиК 285)?
ВидРасчета.МатВыгодаПоСсудам.Модуль Расчета(30):

Если ДатаНачала >= '01.01.2008' Тогда
СтавкаЦБ=Константа.СтавкаРефинансирования.Получить(КонМесяца(ДатаОкончания))*3/400;
Иначе
СтавкаЦБ=Константа.СтавкаРефинансирования.Получить(Макс(Документ.ДатаДок,'01.01.2001'))*3/400;
КонецЕсли;

Имхо, я бы здесь тоже исправил на:
Если ДатаНачала >= '01.01.2009' Тогда
СтавкаЦБ=Константа.СтавкаРефинансирования.Получить(КонМесяца(ДатаОкончания))*2/300;
ИначеЕсли ДатаНачала >= '01.01.2008' Тогда
СтавкаЦБ=Константа.СтавкаРефинансирования.Получить(КонМесяца(ДатаОкончания))*3/400;
Иначе
СтавкаЦБ=Константа.СтавкаРефинансирования.Получить(Макс(Документ.ДатаДок,'01.01.2001'))*3/400;
КонецЕсли;
]
Ух что тоя запутался подскажи….
24. Илья Никитин (Gorr) 09.02.09 14:03
1. Вручную это значит дать возможность расчетчику устанавливать вычеты сотрудникам по мере необходимости в процессе своей нормальной работы. Обработка предназначена для тех сотрудников на которых вычеты уже были установлены до начала этого года. дело в том, что в справочнике ВычетыСотрудниковПоНДФЛ (подчинен справочнику сотрудников ) коды вычетов жестко прописаны и не отображаются все коды которые есть в справочнике ВидыВычетов. поэтому если этого не сделать, расчетчик не сможет установить новые вычеты вновь принятым работникам в этом году.
2. Думаю, все правильно понял.
Скоро должен выйти новый релиз (20.02.09) и если нет нужны можно просто подождать.
другое дело будет ли в нем предусмотрена процедура для закрытия старых вычетов.
25. Александр Волков (Uragan) 19.02.09 12:54
Как и куда установить данный файл?
26. idw idw (idw) 20.02.09 10:50
Откуда информация, что 20 числа выйдет обновление ЗиК?
28. Nata80 (Nata80) 26.02.09 15:09
Всем доброе время суток!

У меня возникла такая проблема. Человеку была начислена материальная помощь на рождение ребенка. А в справке 2-НДФЛ она не отражается. Что делать?
29. Елена (TKENA13071962) 14.03.09 14:09
30. Павел (orsh) 31.03.09 08:46
После обновления полетели коды вычетов по детям.
Пришлось тупо написать вот это. :)
Процедура Сформировать()
Спр=СоздатьОбъект("Справочник.Сотрудники");
Спр1=СоздатьОбъект("Справочник.ВычетыСотрудниковПоНДФЛ");
Спр2=СоздатьОбъект("Справочник.ВидыВычетов");
Спр2.НайтиПокоду("108\101");
Сообщить(Спр2.Наименование);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
Спр1.ИспользоватьВладельца(спр);
Спр1.ВыбратьЭлементы();
Пока Спр1.ПолучитьЭлемент()=1 Цикл
Если Строка(Спр1.ВидВычета)="108" Тогда
Спр1.ВидВычета=спр2.ТекущийЭлемент();
Спр1.Записать();
Сообщить(спр);
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецПроцедуры
31. Илья Никитин (Gorr) 04.06.09 00:42
В связи с принятым сотрудниками 1С решением обновления кодов вычетов путем реструктуризации справочника ВидыВычетов, в обработку добавлена возможность отката выполненных ранее изменений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа