gifts2017

Маленькая реализация закона 152-фз "Защита Персональных Данных"

Опубликовал nekto_789 (nekto_789) в раздел Администрирование - Защита, права, пароли

Закрытие доступа справочника Сотрудники ЗУП 2.5 рел.65.2

Задача стояла следующая. Необходимо было запаролить справочник Сотрудники в ЗУП 2.5.

Итак сама реализация. (не судите строго я только учусь).

1.В справочнике Сотрудники, ФормаСписка, Создаем Панель Ставим по средине и разтягиваем на всю поверхность справочника.

2.Создаем Строку Ввода(ставим галку пароль) , Кнопку (ОК), и Надпись (с текстом ограничения)

3 В процедуре ПриОткрытии добавляес следующие

ЭлементыФормы.СправочникДерево.Доступность = Ложь;
ЭлементыФормы.ПолеРежимОтображенияСписка.Доступность = Ложь;
ЭлементыФормы.Эпицентр.Доступность = Ложь;
ЭлементыФормы.ОсновнаяПанель.Доступность = Ложь;
ЭлементыФормы.МедицинскиеСтраховыеПолисы.Доступность = Ложь;
ЭлементыФормы.КоманднаяПанельМедицинскоеСтрахование.Доступность = Ложь;
ЭлементыФормы.Панель1.Видимость = Истина ;
ЭлементыФормы.ДействияФормы.Доступность = Ложь;
ЭлементыФормы.ПолеВвода1.Видимость = Истина ;
ЭлементыФормы.ПолеВвода1.Доступность = Истина ;
ЭлементыФормы.ОК.Видимость = Истина ;
ЭлементыФормы.ОК.Доступность = Истина ;
ЭлементыФормы.Надпись1.Видимость = Истина ;
ЭлементыФормы.Надпись1.Доступность = Ложь ;
 4.Создаем процедуру ПолеВвода1ПриИзменении

Процедура ПолеВвода1ПриИзменении(Элемент)
Пароль = ЭлементыФормы.ПолеВвода1.Значение ;    
Если пароль = "123456"
    ИЛИ   пароль = "654321"
    ИЛИ   пароль = "15W1Df" Тогда
ЭлементыФормы.СправочникДерево.Доступность = Истина;
ЭлементыФормы.ПолеРежимОтображенияСписка.Доступность = Истина;
ЭлементыФормы.Эпицентр.Доступность = Истина;
ЭлементыФормы.ОсновнаяПанель.Доступность = Истина;
ЭлементыФормы.МедицинскиеСтраховыеПолисы.Доступность = Истина;
ЭлементыФормы.КоманднаяПанельМедицинскоеСтрахование.Доступность = Истина;
ЭлементыФормы.Панель1.Видимость = Ложь ;
ЭлементыФормы.ДействияФормы.Доступность = Истина;
ЭлементыФормы.ПолеВвода1.Видимость = Ложь ;
ЭлементыФормы.ПолеВвода1.Доступность = Ложь ;
ЭлементыФормы.ОК.Видимость = Ложь ;
ЭлементыФормы.ОК.Доступность = Ложь ;
ЭлементыФормы.Надпись1.Видимость = Ложь ;
ЭлементыФормы.Надпись1.Доступность = Ложь ;
КонецЕсли ;                  
    
КонецПроцедуры

5.Кнопочка ОК

Процедура ОКНажатие(Элемент)
    ПолеВвода1ПриИзменении(Элемент)
КонецПроцедуры



См. также

Подписаться Добавить вознаграждение

Комментарии

1. anry mc (AnryMc) 03.06.13 15:47
Насколько я помню, после принятия закона "о защите персональных данных" мелькало сообщение 1С о существовании платформы 8.2z сертифицированной под защиту...
2. Алексей (Drak0n) 03.06.13 15:55
Предложенная вами методика малоэффективна (и не соответствует требованиям Закона) в связи с возможностью отображения персональных данных другими отчетами и формами...
P.S. Но тем не менее, как ответ на хотелку директора (главбуха), имеет место быть.
3. anry mc (AnryMc) 03.06.13 16:08
(2) Drak0n,

Да как минимум нужно ковырять RLS...
4. Vladimir K (KroVladS) 03.06.13 16:09
(0)
Я предполагаю что ЗУП и так соответствует 152-ФЗ.
Разве нет?

http://v8.1c.ru/hrm/
Решения 1С:Зарплата и управление персоналом 8 соответствуют требованиям Федерального закона от 27.07.2006 № 152-ФЗ "О защите персональных данных". В программе реализована возможность регистрации событий, связанных с работой с персональными данными, в частности, доступ и отказ в доступе к персональным данным, включая информацию о том пользователе, с которым данное событие было связано.
5. TMV 03.06.13 21:44
7. Антон Стеклов (asved.ru) 05.06.13 13:03
(5) TMV, я с вами совершенно прав!
8. nekto_789 (nekto_789) 06.06.13 10:47
(4)Как это реализовано ?? Можно конечно порезать все правами (оно в принципе все так и сделано) но когда в крупные орг.приходит инспекция и говорит покажите выполнение 152-фз . И рядовой бух начинает рассказывать что в 1с зуп все это реализовано путем ограничения прав доступа!! Сколько не разговаривал с аудиторами справочник должен быть запаролен !
9. muha muhaha (fr.myha) 16.07.13 11:11
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа