gifts2017

Вариант реализации анимации только средствами 1С

Опубликовал Artem N (Artem N) в раздел Программирование - Практика программирования

Oldskool-плазма.

Всем надоевший Oldskool-compo эффект.

Скачать файлы

Наименование Файл Версия Размер
Oldskool.rar 406
.1235891484 4,17Kb
26.01.13
406
.1235891484 4,17Kb Бесплатно
Oldskool2.rar (by zyto) 106
.1236799957 4,51Kb
26.01.13
106
.1236799957 4,51Kb Бесплатно
Oldskool3.rar (со счётчиком FPS) 110
.1237462567 5,01Kb
26.01.13
110
.1237462567 5,01Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Василий Демидов (Душелов) 01.03.09 12:49
2. Игорь Белышев (biv75) 02.03.09 07:39
Интересно, неординарно ))
3. Кирилл Коновалов (akkvamarin) 02.03.09 11:12
4. Алексей Мутовкин (mrWatson) 02.03.09 11:42
Молоток, ждем вращающийся тор, пламя и что там еще было...
5. Artem N (Artem N) 02.03.09 12:51
2(mrWatson): К сожалению, использованный метод достаточно медленный. Сделай замер производительости...

Именно поэтому такой маленький размер поля и всего 10fps.
6. naus (Danil.Potapov) 02.03.09 15:32
5. чаще обработчик не может работать, 0.1 - это его предел.
7. Artem N (Artem N) 02.03.09 16:03
2(naus): Ага, по документации 1/10 секунды. Но, похоже, имеют место быть "особенности реализации" и обработчик можно вызывать чаще.
8. Сергей Старых (tormozit) 04.03.09 18:00
GREETENGS ARE GOING TO

--AMIGA SCENE--
@THE BLACK LOTUS@
*EPHIDRENA*
"MAD ELKS"

--PC SCENE--
#FAIRLIGHT#
$MFX$

LET'S GO!
9. Денис (xdenx) 07.03.09 20:52
--ZX SCENE--
>EXTREME<
>DMS<
>CODE BUSTERS<

:)
10. zyto (zyto) 10.03.09 12:08
То же самое, без привязки к ПодключитьОбработчикОжидания и его 0.1 сек. Теперь завит только от быстродействия вашего компьютера.
http://www.rapidshare.ru/956950
Сделано на основании этого примерчика:
http://infostart.ru/projects/2460/
11. Artem N (Artem N) 10.03.09 12:15
Класс! :-) Давно искал нечто подобное :-)
12. zyto (zyto) 10.03.09 14:00
13. Artem N (Artem N) 12.03.09 12:48
Ужас!!!
Подключил к плазме вывод fps (код ниже). И что вы думаете?! 5! Всего пять! И это при условии, что обработчик вызывается с параметром "0.1"...
Вариант zyto стабильно выдаёт значение 25.

===
Перем СчётчикФПС;

Процедура ПриОткрытии()
СчётчикФПС = 0;
ПодключитьОбработчикОжидания( "ФПС", 1 );
КонецПроцедуры

Процедура ФПС()
ЭлементыФормы.КоманднаяПанель1.Кнопки.ФПС.Текст = СчётчикФПС;
СчётчикФПС = 0;
КонецПроцедуры

Процедура Нарисовать()
СчётчикФПС = СчётчикФПС + 1;
КонецПроцедуры
===