gifts2017

Перенос контактной информации контрагентов

Опубликовал asady sad (asady) в раздел Обработки - Обработка справочников

Обработка копирует контактную информацию из базы-источника в базу-приемник для контрагентов.
Соответствие контрагентов между базами выполняется по ИНН+КПП и Наименованию.
Обработку можно использовать для переноса информации между типовыми конфигурациями 1С 8.1 (ЗУП, УТ, БП, УПП)

Обработка копирует контактную информацию из базы-источника в базу-приемник для контрагентов.
Поддерживается подключение к файловым и серверным базам 1С 8.0 и 8.1

Соответствие контрагентов между базами выполняется по ИНН+КПП и Наименованию. Поиск осуществляется по ИНН затем ищется совпадение по КПП, если совпадения по КПП нет, а по ИНН есть - будет выбран элемент с меньшим кодом. В случае когда нет совпадений по ИНН поиск будет продолжен по наименованию.


Обработку можно использовать для переноса информации между типовыми конфигурациями 1С 8.1 (ЗУП, УТ, БП, УПП). Базой источником может быть и база на платформе 8.0.

Обработку писал для себя - для быстрого переноса адресов и телефонов.

Скачать файлы

Наименование Файл Версия Размер
Перенос контактной информации контрагентов 172
.epf 18,51Kb
13.04.12
172
.epf 18,51Kb Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. Анатолий Кондратов (kingg) 18.11.10 12:57
сталкнулся с необходимостью перенести контактную инфу из УТ в БУ...обработка полезная, но пришлось немного доработать напильником в торопях (возникали ошибки при СОМ соединении... не мог к файлу БД присоеденить...)
короч изменил одну чуток процедуру и заробило ;)
Процедура КоманднаяПанель1Подключиться(Кнопка)
	Состояние("Подключение к выгружаемой базе данных");
	//Если Приложение81 Тогда
		App = Новый ComОбъект("v81.COMConnector");
	//Иначе	
		//App = Новый ComОбъект("v8.COMConnector");
	//КонецЕсли;	
	Результат="";
	 //подключение к серверному варианту  
	//Если СерверныйВариант Тогда
	// 	СтрокаПодключения="srvr="+Сервер+"; ref="+ИмяИнформационнойБазы+"; usr="+Логин+"; pwd="+Пароль+";";
	//Иначе	
	//КонецЕсли;	
	Попытка
	//СтрокаПодключения ="File="+ПутьКДанным+";Usr="+Логин+";Pwd="+Пароль+";";	

	v8 = App.Connect("File="""+ПутьКДанным+""";Usr="""+Логин+""";Pwd="""+Пароль+""";");
	Исключение
		Результат=ОписаниеОшибки();
	КонецПопытки;
	ЭтаФорма.Закрыть(Результат);
КонецПроцедуры
...Показать Скрыть
2. Евгений Иванов (Incedo@yandex.ru) 11.04.11 16:02
обработка полезная, спасибо автору. Столкнулся со следующими косяками:
1) Не заполнялось наименование пока не добавил в запросе "КАК Наименование";
2) В настоящий момент в конфигурациях БП и УТ наименования элементов справочника "Виды контактной информации" различаются, "Юридический адрес контрагента" и "Юридический адрес". Соответственно обмен работает в одну сторону.
3. V D (dv1111) 17.10.11 13:39
Обработка пригодилась, но тоже помучиласть с подключением к базе. Пришлось исправлять, но получилос все равно быстрее, чем писать сначала, тем более, если переносить вручную.
4. Юлия Фролова (yfrolova) 24.01.12 19:36
а где обработка по переносу, пока вижу только заполнить настройку пользователей 8)
5. Гость 20.02.12 10:23
Обработка пригодилась, но тоже помучился с подключением к базе. Пришлось исправлять, но результат все равно быстрее, чем писать сначала, тем более, если переносить вручную.
6. Сергей м (SergAn) 24.02.12 09:51
7. Алексей (lisav) 12.04.12 07:38
Уважаемый asady!
Скачивается вместо обработки переноса контактной информации контрагентов "ЗаполнитьНастройкуПользователей.epf".
Перезалейте обработку пожалуйста, очень нужно
8. asady sad (asady) 19.04.12 12:07
(7) lisav,
перезалил - что произошло с хранимым файлом непонятно - изначально всё было правильно
9. Антонина Гвоздарева (a-m-gv) 04.12.13 21:50
Спасибо, пригодилась. Пришлось правда дописать ТипДомов, ТипКорпусов, ТипКвартиры. И поля Наименование и Код изначально не заполнялись по кнопке Заполнить...
10. ssvetusik (ssvetusik) 19.12.14 07:11
Спасибо большое за разработку))) очень помогла
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа