Сверка по контрагенту

Отчеты - Бухгалтерские

Своеобразный акт сверки

Своеобразный акт сверки – детализация по выставленным, закрытым и оплаченным документам.

Параметры:

-  установка периода;

-  выбор контрагента;

-  печать отчета.

Описание функционала:

-  если выбранный контрагент – покупатель:

 ×    за выбранный период из регистра «Покупатели» выбираются движения – документы «Реализация»;

 ×    для выбранных документов «Реализация» формируется выборка документов-оснований «Заявка покупателя»;

 ×    для выбранных документов «Заявка покупателя» формируется выборка подчинённых документов «Реализация», «Строка выписки банка (приход)», «Приходный кассовый ордер»;

 ×    выборка подчиненных документов сортируется по дате документа;

 ×    вывод данных в печатную форму:

  • - сначала выводится счёт (первый документ за указанный период);
  • - затем выводятся подчиненные документы (для выведенного счета);
  • - в итоговую строку (для выведенного счета) выводятся суммы: по счету, по оплате, по реализации;
  • - если суммы в итоговой строке не равны – выделяются цветом;
  • - также формируются общие суммы по всем счетам, всей оплате, всей реализации.

-  если выбранный контрагент – поставщик:

 ×    за выбранный период выбираются документы «Поступление ТМЦ»;

 ×    для выбранных документов «Поступление ТМЦ» формируется выборка подчинённых документов «Строка выписки банка (приход)», «Поступление доп. расходов»;

 ×    выборка подчиненных документов сортируется по дате документа;

 ×    вывод данных в печатную форму:

  • - сначала выводится поступление (первый документ за указанный период);
  • - затем выводятся подчиненные документы (для выведенного поступления);
  • - в итоговую строку (для выведенного поступления) выводятся суммы: по поступлению, по оплате;
  • - также формируются общие суммы по всем счетам, всей оплате, всей реализации.

Данный отчет похож на «Акт сверки". Отличие - полная детализация по счетам: счет выставлен, оплачен, закрыт (для покупателя).

Колонка «К» - есть контрольные документы.

* Дата окончания = дате актуальности итогов.

Скачать файлы

Наименование Файл Версия Размер
СверкаПоКонтрагенту.ert
.ert 197,00Kb
10.07.13
24
.ert 197,00Kb 24 Скачать

См. также

Комментарии
1. Татьяна Пономарева (tanuchkap) 27.01.16 21:06 Сейчас в теме
Скачала сверку, но она у меня не работает.
2. Анна Шнипова (АннаШ) 96 28.01.16 08:02 Сейчас в теме
Что конкретно не работает?
3. Роман * (Black Cat) 32 06.12.16 17:45 Сейчас в теме
Скачал сверку, но она не работает. Не хватает функций в глобальном модуле: глУдалениеВедущихНулей, глКонтрагентПоставщик
4. Анна Шнипова (АннаШ) 96 07.12.16 08:07 Сейчас в теме
(3)
глУдалениеВедущихНулей


Функция глУдалениеВедущихНулей(мКод) Экспорт

	Пока Лев(мКод, 1) = "0" Цикл
		мКод = Сред(мКод, 2);
	КонецЦикла;      
	
	Возврат мКод;
	
КонецФункции	// глУдалениеВедущихНулей

Функция глКонтрагентПоставщик(мКонтрагент) Экспорт

	СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");

	СпрКонтрагенты.НайтиПоНаименованию("Поставщики");

	ГруппаПоставщиков = СпрКонтрагенты.ТекущийЭлемент();
	
	Если мКонтрагент.ПринадлежитГруппе(ГруппаПоставщиков) = 1 Тогда
		Возврат 1;
	Иначе
		Возврат 0;
	КонецЕсли;
	
КонецФункции // глКонтрагентПоставщик
...Показать Скрыть
5. Роман * (Black Cat) 32 12.12.16 16:53 Сейчас в теме
Анна, у Вас самописная конфа ? Если нет, то укажите все доработки стандартной конфы, которые нужны для данного отчета.
Опять ошибка:
ТабПодчиненных.Контроль = ДокПодчиненные.ТекущийДокумент().Контроль;
{СВЕРКАПОКОНТРАГЕНТУ.ERT(226)}: Поле агрегатного объекта не обнаружено (Контроль)
6. Сергей (Che) Коцюра (CheBurator) 3381 14.12.16 02:30 Сейчас в теме
мутно. неясно для какой типовой конфигурации.
если для ТИС - то взаиморасчеты покупателей ведутся по документам движения долгов/взаиморасчетов,заявка покупателя - таковым не является. Вдобавок, документы оплаты/отгрузки закрывают долги по ФИФО договора, а не по документам основаниям.
Оставьте свое сообщение