Доходы-убытки от продаж

Опубликовал Анна Шнипова (АннаШ) в раздел Отчеты - Бухгалтерские

Отчет по доходам (убыткам) от продаж

Формирование доходов (убытков) от продаж с детализацией по партиям (приходные документы).

Параметры:

-  установка периода;

-  выбор режима печати отчета;

-  печать отчета.

Описание функционала:

-  за выбранный период из регистра «Партии (наличие)» выбираются движения с видом операции «Продажа» и «Розничная продажа» (документы – «Реализация (купля-продажа)» и «Реализация (розница)», услуги не включаются в отчет);

-  для каждого движения (документа) выбираются:

 ×    номенклатура;

 ×    продажная стоимость;

 ×    себестоимость;

 ×    количество;

 ×    приходный документ;

-  для каждого движения (документа) рассчитывается доход/убыток:

 ×    в рублях: Продажная стоимость - Себестоимость;

 ×    в процентах: ((Продажная стоимость х 100) / Себестоимость) - 100;

-  в отчет выводятся:

 ×    документ реализации, общие суммы (по документу) – продажи, себестоимости, дохода/убытка, проценты;

 ×    детализация по выведенному документу:

  • - номенклатура;
  • - сумма продажи;
  • - сумма себестоимости;
  • - сумма дохода/убытка;
  • - процент дохода/убытка;
  • - партия – приходный документ;

 ×    общие итоги (по всем документам): сумма продажи, себестоимость, сумма дохода/убытка, процент;

-  3 вида отчета:

 ×    все продажи;

 ×    только отрицательные;

 ×    продажи в 0 – доход не превышает 1%.

Отрицательные продажи – выделяются цветом.

Дата окончания = дате актуальности итогов.

Скачать файлы

Наименование Файл Версия Размер
Доходы - убытки.ert
.ert 191,00Kb
10.07.13
26
.ert 191,00Kb 26 Скачать

См. также

Комментарии
1. miramak 17.07.13 12:04 Сейчас в теме
Жаль, что нет такой обработки для Украины. Полезная обработка.
2. Viktor (kurvik) 19.07.13 11:55 Сейчас в теме
Нужная обработка.Дает полную картину по продажам.
3. Роман * (Black Cat) 32 06.12.16 17:54 Сейчас в теме
Её кто нить запустить смог ? Не хватает функции в глобальнике глУдалениеВедущихНулей.
4. Анна Шнипова (АннаШ) 95 07.12.16 08:08 Сейчас в теме
(3)
Функция глУдалениеВедущихНулей(мКод) Экспорт

	Пока Лев(мКод, 1) = "0" Цикл
		мКод = Сред(мКод, 2);
	КонецЦикла;      
	
	Возврат мКод;
	
КонецФункции	// глУдалениеВедущихНулей
...Показать Скрыть
5. Роман * (Black Cat) 32 12.12.16 17:36 Сейчас в теме
Анна, интересная картина получается: если приход был создан документом "Оприходование ТМЦ", то отчет сваливается с ошибкой, т.к. у "Оприходование ТМЦ" нет реквизита "Контрагент".

ПечКонтрагентПартия = Запрос.ДокПартия.Контрагент;
{ДОХОДЫ - УБЫТКИ - КОПИЯ.ERT(144)}: Поле агрегатного объекта не обнаружено (Контрагент)

По хорошему, тут нужна проверка на наличие этого реквизита в документе, например так:
Если глЕстьРеквизитШапки("Контрагент",Запрос.ДокПартия.Вид()) = 1 Тогда
	ПечКонтрагентПартия = Запрос.ДокПартия.Контрагент;
Иначе
	ПечКонтрагентПартия = "";
КонецЕсли;
...Показать Скрыть
6. Роман * (Black Cat) 32 12.12.16 18:18 Сейчас в теме
И еще вопрос: почему верхняя граница отчета всегда переходит на ТА, даже если период установлен меньше ТА ?