gifts2017

Унифицированная форма Т-2 для ЗУП 8.1

Опубликовал Леонид Лесин (Leoway) в раздел Печать - Универсальные печатные формы

Т-2 с учетом требований законодательства (вывод доп. листов по отпускам)

В типовой отчет ЗУП внесены следующие изменения:

  1. В табельном номере, документах приема на работу, кадровом перемещении и увольнении убраны префиксы
  2. В разделе «Прием на работу и переводы на другую работу» выводится информация по документам:
    • Приему на работу
    • Кадровые перемещения (с учетом изменений в подразделении, должности)
  3. В разделе «Отпуск» при заполнении отпусков превышающих 14 строк (28 и т.д.) выводиться дополнительный лист
  4. В разделе 11 «При увольнении» выводиться информация по руководителю кадровой службы
  5. Заменена дата в поле "Дата составления" с текущей даты на дату приема в организацию
  6. Исправлена ошибка (при отсутствии отпуска не выводились 14 пустых строк)
  7. Внесены исправления под релиз Зарплата и Управление Персоналом, редакция 2.5 (2.5.30.4)

Скачать файлы

Наименование Файл Версия Размер
Т-2 631
.erf 50,31Kb
06.12.14
631
.erf 50,31Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Леонид Лесин (Leoway) 24.04.09 14:21
Народ если пригодилось плюсуем
2. AvtoBuhgalter ООО (AvtoBuhgalter) 05.05.09 10:43
Сформировал и сравнил со стандартным отчетом. Не попал приказ о кадровом перемещении сотрудника на другую работу. А в целом замечательная вещь.
3. psp psp (psp) 06.05.09 12:58
и сортировку наш отдел кадров попросил по дате приказа на отпуск...
4. Леонид Лесин (Leoway) 12.05.09 12:33
(2) не совсем понятно что значит "кадровом перемещении сотрудника на другую работу"?
5. AvtoBuhgalter ООО (AvtoBuhgalter) 12.05.09 16:14
(4) Некорректно выразился. Не попадает документ "Кадровое перемещение организаций". (Кадровый учет->Кадровый учет->Кадровое перемещение организаций). В пропускаемом документе только увеличение ежемесячной премии сотрудника. (Оклад остается неизменным)
6. Леонид Лесин (Leoway) 12.05.09 16:39
(5) В кадровом перемещении не отражаются премии - это можно сделать документами: премия, разовые начисления, либо плановыми начислениями. Там есть надбавки, но они в Т-2 не попадают.
7. AvtoBuhgalter ООО (AvtoBuhgalter) 13.05.09 07:56
(6) Проверил изменение оклада. Документ "Кадровое перемещение организаций" не отражается, а во встроенной форме Т-2 отражается. Это не связано с премиями и надбавками. Для проверки нужно просто принять сотрудника на работу скажем с окладом 10000 руб, а затем оформить вышеуказанный документ и установить оклад 15000 руб. (незабываем указать действие изменить). Далее прсто сравнить два отчета встроенный и этот.
8. Леонид Лесин (Leoway) 13.05.09 12:41
(7) См. описание выше
2. В разделе «Прием на работу и переводы на другую работу» выводиться информация по:
- Приему на работу
- Кадровые перемещения с учетом изменений (подразделение, должность)

в Т2 должны отражаться изменения только при изменении подразделения или должности. Так мне сказала мой кадровик, поэтому и убрал.
Если эта информация нужна в модуле объекта заремь строки (825-842) кроме строки 838

//Если ВыборкаРезультата.ПричинаИзмененияСостояния = Перечисления.ПричиныИзмененияСостояния.ПриемНаРаботу Тогда
// Должность = ВыборкаРезультата.Должность;
// Подразделение = ВыборкаРезультата.ПодразделениеОрганизации;
// инд = инд + 1;
//КонецЕсли;
//
//Если ВыборкаРезультата.ПричинаИзмененияСостояния = Перечисления.ПричиныИзмененияСостояния.Перемещение Тогда
//
// Если Должность <> ВыборкаРезультата.Должность
// ИЛИ Подразделение <> ВыборкаРезультата.ПодразделениеОрганизации Тогда
//
// Должность = ВыборкаРезультата.Должность;
// Подразделение = ВыборкаРезультата.ПодразделениеОрганизации;
// инд = инд + 1;
//
// Иначе
// Продолжить;
// КонецЕсли;
//КонецЕсли;

а эту строку оставь!!!!!!!
инд = инд + 1;
9. AvtoBuhgalter ООО (AvtoBuhgalter) 13.05.09 15:45
10. Евгений Кошелев (eljack) 26.05.09 16:39
прикольно. Нашим кадровикам понравилась
11. Леонид Лесин (Leoway) 27.05.09 12:02
(10) ну а если понравилась то и плюсуем, не жмемся в сторонке :). На верху звездочка по ней и щелкаем.
12. Александр (Sanek_159) 24.07.09 12:54
Тоже столкнулись с этой проблемой. Хотел было сам править Т-2, но теперь можно не делать. Спасибо.
13. vlad kan (truba) 21.01.11 11:19
Ошибка по родственникам

// СОСТАВ СЕМЬИ
Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 6
| ФизическиеЛицаСоставСемьи.Имя КАК Родственник,
| ФизическиеЛицаСоставСемьи.СтепеньРодства.Наименование КАК СтепеньРодства,
| ФизическиеЛицаСоставСемьи.ДатаРождения
|ИЗ
| Справочник.ФизическиеЛица.СоставСемьи КАК ФизическиеЛицаСоставСемьи
|ГДЕ
| ФизическиеЛицаСоставСемьи.Ссылка = &Физлицо";

ВыборкаРезультата = Запрос.Выполнить().Выбрать();
инд = 0;
Пока ВыборкаРезультата.Следующий() Цикл
инд = 1 + инд;
ВтораяСтраницаТ2.Параметры["СтепеньРодства"+инд] = ВыборкаРезультата.СтепеньРодства;
ВтораяСтраницаТ2.Параметры["ФИОРодственника"+инд] = ВыборкаРезультата.Родственник;
ВтораяСтраницаТ2.Параметры["ГодРожденияРодственника"+инд] = Формат(ВыборкаРезультата.ГодРождения, "ЧГ="); //<-- ГодРождения
КонецЦикла;

пока без плюсов
14. Мария (mariyanna) 30.10.11 14:22
15. Леонид Лесин (Leoway) 31.10.11 09:28
не за что, пользуйтесь на здоровье
16. Татьяна Сидоркина (sidorkina) 21.11.11 11:17
Большое спасибо за публикацию. Очень помогло. Спасибо за труд.
18. Ирина Пич (i_pich) 18.11.13 09:25