gifts2017

Трюки 1С 8 – Передача формы документа в форму выбора

Опубликовал m b (mbm) в раздел Программирование - Практика программирования

В данной серии статей будут показаны несколько трюков, которые компенсируют отдельные слабости платформы 1С 8, в частности, в области разработки обычных форм.

В числе таких слабостей, к примеру, невозможность подписки на события обычных форм (смотри следующую статью Трюки 1С 8 – Управление обычными формами из общего модуля ) или на событие изменения показателей любого регистра накопления(статья еще не написана).

Для затравки начну с небольшого трюка, связанного со штатным механизмом выбора из подчиненного справочника. Покажу его на реальном примере в конфигурации Комплексная Автоматизация.

При выборе серии номенклатуры по кнопке выбора в табличной части Товары документов СчетНаОплатуПокупателю или РеализацияТоваровУслуг штатный механизм связи (через указание номенклатуры-владельца) выводит на экран все серии для номенклатуры из текущей строки табличной части. Хотя логично было бы ожидать только серии, зарегистрированные на складе, который указан в соответствующем документе.

Казалось бы, напрашивается очевидная и простейшая доработка – добавить в отбор списка серий номенклатуры в форме выбора элемент отбора по нашему складу. Но не все так просто - в форме выбора извне доступно только значение ВладелецФормы, которое является полем ввода серии номенклатуры в форме документа. Платформа не позволяет перейти от элемента управления к форме документа, которая его содержит (наряду с нужным нам полем ввода Склад в шапке формы). К тому же в справочнике серий номенклатуры нет реквизита Склад.

Воспользуемся тем, что предопределенность объектов конфигурации влечет за собой некоторую избыточность их состава. Из нескольких десятков реквизитов любого объекта конфигурации обычно реально используются и инициализируются программистом не более десятка. Посмотрим пристальнее на поле ввода серии номенклатуры и увидим в нем строковый реквизит Подсказка, который обычно пуст и вполне может сгодиться на роль контрабандиста для наших реквизитов.

Суть трюка – перед переходом в форму выбора серий номенклатуры из поля ввода мы добавляем в его реквизит Подсказка ссылку на текущий документ, добавив обработчик события НачалоВыбора:

Процедура ТоварыСерияНоменклатурыНачалоВыбора(Элемент, СтандартнаяОбработка)

   Элемент.Подсказка = Элемент.Подсказка + "$Link$" + ЗначениеВСтрокуВнутр(Ссылка);

КонецПроцедуры

Теперь в форме выбора можно обратиться к форме документа и любым ее элементам, например, реквизиту Склад (и заодно восстановить исходную подсказку):

Процедура ПриОткрытии()

ЭлементУправления = ЭтаФорма.ВладелецФормы;
ТекстПодсказки = ЭлементУправления.Подсказка;
ПозицияСсылки = Найти(ТекстПодсказки, "$Link$");
Если ПозицияСсылки > 0 Тогда
      ДокСсылка = ЗначениеИзСтрокиВнутр(Сред(ТекстПодсказки, ПозицияСсылки + 6));
      Склад = ДокСсылка.ПолучитьФорму().Склад;
      ЭлементУправления.Подсказка = Лев(ТекстПодсказки, ПозицияСсылки - 1);
КонецЕсли;

Используя значение Склад, можно запросом выбрать список кодов нужных серий номенклатуры и использовать его в дополнительном элементе отбора:

СправочникСписок.Отбор.Код.Использование = Истина;

СправочникСписок.Отбор.Код.ВидСравнения = ВидСравнения.ВСписке;

СправочникСписок.Отбор.Код.Значение = СписокКодовСерийНоменклатуры;

В приложенном файле – полный код процедуры ПриОткрытии формы выбора (КА 1.1, 1С 8.2).

 

Штатный подход в обычных формах, как отметил в комментарии awk, более прямолинейный:

Процедура ТоварыСерияНоменклатурыНачалоВыбора(Элемент, СтандартнаяОбработка)

 

     СтандартнаяОбработка = Ложь;

     Форма = Справочники.СерииНоменклатуры.ПолучитьФорму(,Элемент);

     Форма.СправочникСписок.Отбор.Код.Использование = Истина;

     Форма.СправочникСписок.Отбор.Код.ВидСравнения = ВидСравнения.ВСписке;

     Форма.СправочникСписок.Отбор.Код.Значение = СписокКодовСерийНоменклатуры;

     // и т.п.

     Форма.Открыть();

 

КонецПроцедуры

т.е. мы отказываемся от стандартной обработки, инициализируем и открываем форму выбора самостоятельно.

 

Если же обратиться к управляемым формам, то там инструментарий стал еще более обширным (см. комментарий Поручика или, более развернуто, статью http://infostart.ru/public/198797/).

 

 

 

Скачать файлы

Наименование Файл Версия Размер
Код процедуры ПриОткрытии формы выбора.docx 4
.docx 15,52Kb
10.09.13
4
.docx 15,52Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Ожерельев (Поручик) 02.09.13 14:59
(0) Сам бы не догадался. Хотя для меня обычные формы уже не актуальны.
В управляемых тоже самое можно сделать. А с помощью подписки на событие или события ОбработкаПолученияДанныхВыбора организовать и вовсе упоротую обработку.
2. kiv82 (AltF1) 02.09.13 16:48
Управляемое приложение пришлов наш мир, но обычное - активно используется и поддерживается.
3. m b (mbm) 02.09.13 18:25
Это и мешает двигаться вперед - приходится тянуть за собой старые корабли :)
4. m b (mbm) 03.09.13 15:36
(1) Поручик, не совсем понимаю, как тут привязать событие ОбработкаПолученияДанныхВыбора.
Ведь даже из его наименования видно, что с его помощью можно как-то доработать уже
выбранные (и переданные ИЗ формы выбора) данные.
Передо мной стояла обратная задача - мне надо было передать параметры
В форму выбора, чтобы лишние записи при выборе даже не предлагались.
5. BabySG (BabySG) 04.09.13 14:50
(4) mbm, Вы, видимо, не знакомы, как работает этот метод, поэтому Ваше предположение

Ведь даже из его наименования видно, что с его помощью можно как-то доработать уже
выбранные (и переданные ИЗ формы выбора) данные.

в корне не верно
6. Дмитрий Лумбов (Dima69) 04.09.13 19:25
7. Maxim Kolkin (the1) 05.09.13 00:50
Красава, обожаю такие трюки, и нередко сам ими пользуюсь)
8. m b (mbm) 05.09.13 01:51
(5) BabySG, Вы правы, как и (1) Поручик. Логика не всегда способствует приобретению знаний :)
Действительно, в управляемых формах можно делать так: http://infostart.ru/public/198797/
9. Василий Казьмин (awk) 06.09.13 23:52
(0) Это толстый клиент обычное приложение? Если да, то почему нельзя сделать так:

Код
Процедура ТоварыСерияНоменклатурыНачалоВыбора(Элемент, СтандартнаяОбработка)

     СтандартнаяОбработка = Ложь;
     Форма = Справочники.СерииНоменклатуры.ПолучитьФорму();
     Форма.СправочникСписок.Отбор.Код.Использование = Истина;
     Форма.СправочникСписок.Отбор.Код.ВидСравнения = ВидСравнения.ВСписке;
     Форма.СправочникСписок.Отбор.Код.Значение = СписокКодовСерийНоменклатуры;
     // и т.п.
     Форма.Открыть();

КонецПроцедуры
Показать полностью


Зачем надо через ж. в носу ковыряться?
10. m b (mbm) 07.09.13 02:44
(9) awk, почему нельзя? :) Только в моем случае штатная связь остается задействованной и остальной код уже локализован в модуле формы выбора (там еще заодно и остатки с резервами по данной серии показываются для удобства выбора), а в Вашем варианте придется его вынести куда-нибудь в процедуру, ведь выбирать серию приходится во многих документах. Как говорится, на вкус и цвет ...
11. Василий Казьмин (awk) 07.09.13 22:21
(10) mbm, код надо вынести в любом случае - как у меня написано - это дурной тон (плохой код).
12. m b (mbm) 08.09.13 20:06
(11) awk, в данном конкретном случае Ваш подход абсолютно верен. Но статья посвящена более общему вопросу - как через элемент управления получить содержащую его форму. Я привел частичное решение в случае, когда элемент управления является полем ввода. Частичное - потому что передаются только реквизиты, а не сама форма.
То что решение использует поле подсказки не является слабым местом, поскольку ее текст можно запоминать перед входом в форму выбора, а потом восстанавливать, а в самой форме выбора оно не используется.

Но видимо пока формулировал ответ, подсознание нашло полный ответ на поставленный в статье вопрос. Итак, все оказалось достаточно просто, в форме документа:

Процедура ТоварыСерияНоменклатурыНачалоВыбора(Элемент, СтандартнаяОбработка)
Элемент.Подсказка = ЗначениеВСтрокуВнутр(Ссылка);
КонецПроцедуры

а в форме выбора:

ДокСсылка = ЗначениеИзСтрокиВнутр(ЭтаФорма.ВладелецФормы.Подсказка);
ФормаДокумента = ДокСсылка.ПолучитьФорму(); // в форме Склад уже может отличаться от того, что в документе
Склад = ФормаДокумента.Склад;

Ура, спасибо Вам за реплику!
13. m b (mbm) 08.09.13 22:32
А теперь универсальнее - с сохранением текста подсказки:

Процедура ТоварыСерияНоменклатурыНачалоВыбора(Элемент, СтандартнаяОбработка)
Элемент.Подсказка = Формат(СтрДлина(Элемент.Подсказка), "ЧЦ=5; ЧН=00000; ЧВН=; ЧГ=0") +
Элемент.Подсказка + ЗначениеВСтрокуВнутр(Ссылка);
КонецПроцедуры

В форме выбора:

ТекстПодсказки = ЭлементУправления.Подсказка;
Если СтрДлина(ТекстПодсказки) >= 5 Тогда
ДлинаПодсказки = Число(Лев(ТекстПодсказки, 5));
ДокСсылка = ЗначениеИзСтрокиВнутр(Сред(ТекстПодсказки, ДлинаПодсказки + 6));
Склад = ДокСсылка.ПолучитьФорму().Склад;
ЭлементУправления.Подсказка = Сред(ТекстПодсказки, 6, ДлинаПодсказки);
КонецЕсли;
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа