gifts2017

Книга покупок и книга продаж в БП после свертки БД в предприятии со сложным учетом НДС, Как продолжить работу.

Опубликовал Денис Беляев (Dziden) в раздел Программирование - Практика программирования

Данная методология применима к конфигурациям с следющими критериями:
- конфигурация Бухгалтерия предприятия после 1.6,
- в учетной политике установлен флажок "Организация осуществляет реализацию 0% и Без НДС"(Сложный учет НДС),
- выполнена обработка "Свертка информационной базы",
- есть поступления и реализации в различных налоговых периодах с разными ставками НДС по одному товару.

Рассматривается добавление в конфигурацию механизмов для корректной работы учета НДС.

Проблематика такова, что после свертки информационной базы, движения по НДС предъявленному (Дт19 Кт60) старого периода отсутствуют, а при реализации товаров и услуг по ставке отличной от ставки поступления, типовой алгоритм 1с обращается как раз к данному движению (РегистрНакопления НДС предъявленный, отражение по бух проводкам Дт19 Кт60), а так как его не было (свертка пометила документ поступления на удаление), мы имеем в книге продаж записи с пустым контрагентом.

 

Еще раз уточняю, что проблема возникает только при ведении сложного учета НДС при реализации по ставке отличной от ставки поступления, причем поступление и реализация должны быть в разных налоговых периодах.

 

Решается все следующим образом:

Добавляем в конфигурацию два объекта метаданных:

1. Подписку на событие "Исправление реализации", источник: все регистраторы регистра "НДС начисленный", Событие: "При проведении".

2. Общий модуль для процедуры обработки выше описанного события.

 

И в процедуру добавляем код:

Движения = источник.Движения.НДСНачисленный;

    

    Для Каждого Движение ИЗ Движения Цикл

        Если НЕ Движение.Событие = Перечисления.СобытияПоНДСПродажи.ВосстановлениеНДС Тогда

            Продолжить;

        КонецЕсли;

        Если НЕ Движение.Покупатель.Пустая() Тогда

            Продолжить;

        КонецЕсли;                

        

        Движение.Покупатель = Движение.СчетФактура.Контрагент;

    КонецЦикла;

    

    

    Движения = источник.Движения.Хозрасчетный;

    

    Для Каждого Движение ИЗ Движения Цикл

        Если Движение.СчетКТ <> ПланыСчетов.Хозрасчетный.НайтиПоКоду("19.03") И

             Движение.СчетДТ <> ПланыСчетов.Хозрасчетный.НайтиПоКоду("19.03") Тогда

            Продолжить;                        

        КонецЕсли;                        

        

        Если Движение.СубконтоДт.Контрагенты = Справочники.Контрагенты.ПустаяСсылка() Тогда

            Движение.СубконтоДт.Контрагенты = Движение.СубконтоДт.СФПолученные.Контрагент;

        КонецЕсли;

        Если Движение.СубконтоКт.Контрагенты = Справочники.Контрагенты.ПустаяСсылка() Тогда

            Движение.СубконтоКт.Контрагенты = Движение.СубконтоКт.СФПолученные.Контрагент;

        КонецЕсли;        

    КонецЦикла;

 

После этого необходимо :

1. Перепровести все реализации в периоде после свертки,

2. Перезаполнить книги покупок и продаж за текущий налоговый период (предыдущие налоговые периоды отразятся доп листами).

 

Все, теперь у вас снова рабочие книги покупок и продаж.

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.