gifts2017

Расчет аннуитетных платежей по кредиту для 8.1

Опубликовал Пупкин Василий (kirn) в раздел Отчеты - Анализ учета

Обработка для расчета аннуитетных платежей по кредиту

Каждый задумывался о получении кредита.

Зачастую необходимо прикинуть во что обойдется кредит.

Странно, что такой обработки ещё не выложили, может быть не нашел.

Эта обработка как раз нужна, чтобы ещё до похода в банк прозреть и отказаться от этой безумной затеи,

тем более в условиях глобального кризиса :)

 

Всего 3 параметра:

Срок в месяцах,

Годовая ставка в процентах

Сумма кредита

 

Результат выдается в виде отчета:

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Обработка
.1247691334 8,56Kb
17.05.12
144
.1247691334 8,56Kb 144 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. anbxp (anbxp) 16.07.09 01:24
Что-то не так в Датском королевстве, нутром чую:-) (с) Венгер
2. anbxp (anbxp) 16.07.09 08:15
Не, все нормально. Показалось, что в первых периодах суммы процентов должны быть больше
3. Станислав Шепталов (sCHTASS) 16.07.09 08:41
В принципе, штука полезная... Но большого смысла писать подобную обработку не вижу, когда в нете и так полно всевозможных кредитных калькуляторов.
4. Юрий Тимофеев (Tatitutu) 16.07.09 08:56
Опять обработка из раздела на сообразительность
"Посмотри скриншот - и угааааааааааааадай на какой платформе я работаю ))). Слабо !!! Тогда скачай обработку....и попробуй запустить, не запустилась ? Значит у тебе 7.7 !!! Видишь какая "умная" обработка."

Автор! Думаю намек понятен ? (укажите платформу обработки)
5. Igоr Sаulеviсh (gutentag) 16.07.09 10:41
Замечание к обработке: многие Банки требуют что бы первая выплата была только проценты за кредит, а далее аннуитентные платежи.
6. Максим Симонович (mctsimco) 17.07.09 12:36
2 Tatitutu:
Вот для 7.7

//*******************************************
Функция вСтепень(Основание, Степень)
Результат=1;
Для К=1 По Степень Цикл
Результат=Результат*Основание;
КонецЦикла;
Возврат Результат;
КонецФункции

//*******************************************
Процедура СформироватьАннуитет()
НачСумма = СуммаКредита;
ставкаМес = (ставкаГод / 12) / 100;
Игого = 0;
ИгогоПроц = 0;
суммаМесВсего = СуммаКредита *(ставкаМес)/(1-1/вСТЕПЕНЬ((1+ставкаМес), срокКредита));
Для й = 1 По СрокКредита Цикл
суммаПроцентов = НачСумма * ставкаМес;
СуммаМес = суммаМесВсего - суммаПроцентов;
НачСумма = НачСумма - суммаМес;
Игого = Игого + суммаМесВсего;
ИгогоПроц = ИгогоПроц + суммаПроцентов;
тз.НоваяСтрока();
тз.Мес= й;
тз.СуммаОсн = СуммаМес;
тз.СуммаПроц = суммаПроцентов;
тз.Сумма = суммаМесВсего;
КонецЦикла;
Переплата = Игого - СуммаКредита;
сПРЦ = тз.Итог("СуммаПроц");
сВсего = тз.Итог("Сумма");
КонецПроцедуры
7. Игорь <...> (I_G_O_R) 17.07.09 18:09
в exele 5 минут делов, там есть готовая функция, не пойму, зачем всё на 1С писать
8. Игорь <...> (I_G_O_R) 17.07.09 18:17
вот она: ПЛТ(ставка;кпер;пс;бс;тип)
9. Николай Пархоменко (Klondaik) 25.02.12 22:31
Обработка конечно может и полезная, но она для фанатов 1С. Есть более удобная и точная программка для расчета плтежей по кредиту, точно не помню как она называется - вроде что-то PV_Credit, как-то так.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа