IE2017

Орфографическая проверка конфигурации 1.0.1

Программирование - Инструментарий

Орфографическая проверка конфигурации - долой безграмотность.

Проверяются:
- заголовки надписей, переключателей, флажков, страниц панели, рамок групп, кнопок командной панели, колонок табличного поля
- подсказки поля ввода, поля выбора.

Вы можете воспользоваться встроенным инструментом конфигуратора "Выгрузить файлы конфигурации". Например, выгрузить справку и проверить ее.

Рекомендуется использовать справочник слов, который пополняется при проверке. Если в справочнике есть слово то информация о ошибке берется из него. Это ускоряет работу обработки и сокращает количество ошибок.

Системные требования: MS Word.

Подобные разработки:

Проверка правописания - ActiveX-компонента для 1С

 

Скачать файлы

Наименование Файл Версия Размер
-
.1249627272 55,42Kb
20.02.12
140
.1249627272 55,42Kb 140 Скачать

См. также

Комментарии
1. Александр Рытов (Арчибальд) 2660 07.08.09 10:50 Сейчас в теме
Однозначный плюс уже за постановку задачи
2. dushelov (Душелов) 07.08.09 11:05 Сейчас в теме
А какая технология проверки?
3. Антон Степанов (Stepa86) 832 07.08.09 11:10 Сейчас в теме
А можно еще проверку модулей организовать? ЧтобВотТакойВотТекст могла распарсить и проверить?
4. Sensey Master (MSensey) 55 07.08.09 11:19 Сейчас в теме
(2) Системные требования: MS Word.
(3) Она уже есть, нужно выгрузить модули и проверить. Но это будет крайне не информативно, т.к. проверяться будут абсолютно все слова.
5. dushelov (Душелов) 07.08.09 11:23 Сейчас в теме
(4) Для тех, у кото ворда нет, можно использовать мою проверку орфографии.
А проверять в модулях можно строковые переменные.
6. Антон Степанов (Stepa86) 832 07.08.09 11:24 Сейчас в теме
(5) имена функций тоже неплохо бы проверять, хотя бы определения
7. Sensey Master (MSensey) 55 07.08.09 11:24 Сейчас в теме
Исправил код для независимости от конфигурации.
(5) Изучу, странно поиском смотрел не нашел по проверке орфографии обработок.
8. Sensey Master (MSensey) 55 07.08.09 11:27 Сейчас в теме
9. Антон Степанов (Stepa86) 832 07.08.09 11:30 Сейчас в теме
+(6) думаю для проверки модулей нужно:
1) найти регекспом все определения методов (ищем по ключ. словам Процедура или функция) и инициализации переменных (все, что в правой части содержит = , брать переменную только после точки, например из "Рек1.рек2.рек3 = рек4" нужно выбрать только "рек3")
2) Преобразовать "ВотТакойТекст" в "Вот такой текст"
(
// Возвращает строку по правилам "ЭтоПримерСтроки" -> "Это пример строки"
//
Функция ПолучитьНаименованиеПоИмени( Знач пИмя ) Экспорт

лНаименование = "";

Для ц = 1 По СтрДлина( пИмя ) Цикл

ПроверяемыйСимвол = Сред( пИмя , ц , 1 );

Если ПроверяемыйСимвол = ВРег( ПроверяемыйСимвол ) Тогда

ПроверяемыйСимвол = " " + НРег( ПроверяемыйСимвол );

КонецЕсли;

лНаименование = лНаименование + ПроверяемыйСимвол;

КонецЦикла;

лНаименование = СокрЛП( лНаименование );

лНаименование = ВРег( Лев(лНаименование, 1) ) + Прав( лНаименование , СтрДлина( лНаименование ) - 1 );

Возврат лНаименование;

КонецФункции // ПолучитьНаименованиеПоИмени()
)
3) проверить проверяльщиком
10. Sensey Master (MSensey) 55 07.08.09 11:36 Сейчас в теме
(9) Ошибки в названиях переменных, методов не столь важны для продукта.
Если и делать, то проверку строковых значений.
11. dushelov (Душелов) 07.08.09 11:37 Сейчас в теме
12. Антон Степанов (Stepa86) 832 07.08.09 11:38 Сейчас в теме
(10) у меня часто бывают ошибки из-за неправильно набранной переменной, которые всплывают в лучшем случае через месяц... Строковые значения по идее вообще не должны фигурировать в коде, вместо них должны использоваться именованные константы ( не для 1С это правда =( ).
13. Александр Рытов (Арчибальд) 2660 07.08.09 11:41 Сейчас в теме
АВтор, а аВатар проверял?
14. Sensey Master (MSensey) 55 07.08.09 11:49 Сейчас в теме
15. Александр Рытов (Арчибальд) 2660 07.08.09 12:08 Сейчас в теме
(14) Оно понятно. Но афтор прочтет, что это йад для него - и пройдет мимо :)))
16. Антон Степанов (Stepa86) 832 07.08.09 13:29 Сейчас в теме
(0) а можно в результат проверки добавить колонку с вариантами правильного написания? и проверять еще по английскому словарю, а то он мне на слово Word ругается...
17. Доржи Цыденов (support) 4484 08.08.09 10:20 Сейчас в теме
аватар очень подходящий
18. Serj (Serj1C) 463 10.08.09 08:57 Сейчас в теме
По-моему, проверка орфографии модулей, форм и справочной информации - это часть функционала типовой 1С:Автоматизированная проверка конфигураций (http://users.v8.1c.ru/ACC.aspx)
19. Sensey Master (MSensey) 55 10.08.09 09:58 Сейчас в теме
20. Яков Коган (Yashazz) 2097 24.08.10 11:03 Сейчас в теме
На первом же скриншоте первая же фраза: "заголовОки надписей". Аффтар, начни с себя :) :)
21. Sensey Master (MSensey) 55 24.08.10 11:45 Сейчас в теме
(20) Эта ошибка давно исправлена, а скриншот остался старым.
22. Константин Гейнрих (CyberCerber) 155 22.11.12 17:45 Сейчас в теме
Здесь только проверка в конфигураторе, не в предприятии?
23. Антон Стеклов (asved.ru) 33 03.07.14 23:15 Сейчас в теме
Оставьте свое сообщение