Остатки отпусков сотрудников организации. С деньгами!!!

Опубликовал Armando Armando (Armando) в раздел Отчеты - Бухгалтерские

Переработан мой прошлый отчет. Увеличена скорость формирования отчета. Добавлена колонка с денежным эквивалентом.

В отчете используется типовой механизм расчета остатков дней отпуска. Номер версии не ниже 2.5.10, платформа 8.1.12.101
Скриншот снят с демо базы.

Для работы отчета необходимо создать пустой документ "Начисление отпуска работникам организаций" и выбрать его в параметре "Документ".


См. также:
Мои разработки
Мои статьи

Отблагодарить меня:

 Отправить 100 WMR (R342458610221)

Скачать файлы

Наименование Файл Версия Размер
-
.1252524958 35,74Kb
25.09.09
625
.1252524958 35,74Kb 625 Скачать

См. также

Вознаграждение за ответ
Показать полностью
Комментарии
0. Armando Armando (Armando) 1375 11.09.09 13:14 Сейчас в теме
Переработан мой прошлый отчет. Увеличена скорость формирования отчета. Добавлена колонка с денежным эквивалентом.

Перейти к публикации

1. Андрей (СуперСтар) 89 11.09.09 13:14 Сейчас в теме
Попробовал,пока есть только вопросы:
1. Что за загадочная колонка "Дополнительный оплачиваемый", какие дни в ней показывает отчет?
2. Прошлые годы, остатки тех отпусков, кроме текущего, отчет не учитывает? Как настроить, чтоб считал с начала учета?
3. Дополнительные неоплачиваемые отпуска > 14 дней не учитывает?
4. Где в типовой конфигурации можно увидеть типовой механизм расчета остатков отпусков, о котором упоминается?
Наверное я не умею его готовить ;))
2. Armando Armando (Armando) 1375 11.09.09 16:58 Сейчас в теме
(1)
1. Загляни в справочник "Виды ежегодных отпусков"
2. Считает с момента последнего заполнения справочника "Остатки отпусков организаций"
3. Неоплачиваемые отпуска > 14 дней и отпуск по уходу за ребёнком (вопреки закону) учитываются как стаж дающий право на отпуск... Я для себя сам исправлял.
4. В конфигураторе)))
3. Андрей (СуперСтар) 89 14.09.09 12:33 Сейчас в теме
(2)
1. Как бы удалить из отчета этот дополнительный, не удаляя из справочника, может потом понадобится? К сожалению в отборах нет вида отпуска.
3. Ответ не понят. По законодательству неоплачиваемые отпуска (за свой счет) > 14 дней в год уменьшают (или сдвигают) рабочий период для исчисления отпуска. Отчет это учитывает, или гуляй хоть сколько за свой счет - ничего не уменьшится?
4. елена скворцова (nightsun) 30.10.09 11:51 Сейчас в теме
Огромное спасибо.. впервые ничегошеньки не пришлось дописывать, подправлять.. просто подключила и в кадрах праздник
5. C G (sv1233) 04.11.09 10:29 Сейчас в теме
Обновили конфигурацию в октябре и отчет перестал работать, что делать? Подскажите, пожалуйста.
6. Armando Armando (Armando) 1375 04.11.09 13:34 Сейчас в теме
Ждать, когда я обновлю конфигурацию и переделаю отчет :|
7. C G (sv1233) 04.11.09 17:02 Сейчас в теме
Заранее, спасибо, будем ждать.
8. Кондратьев Анатолий (Lectat) 10.11.09 16:03 Сейчас в теме
Почему обработка скачивается, как просто файл?
9. Елена Обухова (filis) 05.02.10 15:25 Сейчас в теме
Выдает ошибку (ТК 2.5.20.3):
{ОбщийМодуль.ПроцедурыУправленияПерсоналом(2011)}: Ошибка при вызове метода контекста (Выполнить): {(6, 2)}: Тип не может быть выбран в запросе
<<?>>&Таблица КАК ТаблицаПериодов
Запрос.Выполнить();
по причине:
{(6, 2)}: Тип не может быть выбран в запросе
<<?>>&Таблица КАК ТаблицаПериодов

Что делать?
10. Александр ягольник (Alex Y) 160 10.02.10 10:42 Сейчас в теме
(9) Необходимо в модуле объекта добавить в функцию ПолучитьТаблицуОстатковОтпусков

следующий код:
	ТаблицаСотрудников.Колонки.Добавить("Сумма", Новый ОписаниеТипов("Число"));
	//10-02-09 добавлен тип для Периода
	ТаблицаСотрудников.Колонки.Добавить("Период", Новый ОписаниеТипов("Дата"));
...Показать Скрыть


Ошибка возникала именно из-за неопределенного типа колонки
11. Александр ягольник (Alex Y) 160 10.02.10 10:50 Сейчас в теме
Не очень удачно решение, требующее создания фиктивного документа. Делается это только для того, чтобы используя механизмы типовой, рассчитать стоимость остатков отпуска.
Мною добавлена проверка заполненности параметра. Если он пуст, то сумма не рассчитывается.
Функция Проверка()
	//ИЗМЕНЕНО 10-02-09
	СсылкаДокумента = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДокументОтпуск")).Значение;
	РасчитыватьСумму = ЗначениеЗаполнено(СсылкаДокумента);
	//СсылкаДокумента = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДокументОтпуск")).Значение;
	//Если Не ЗначениеЗаполнено(СсылкаДокумента) Тогда
	//	Сообщить("Не выбран документ");
	//	РезультатПроверки = Ложь;
	//КонецЕсли;

Функция РассчитатьСуммуОтпуска(СтрокаТаблицыОстатков)
	//ДОБАВЛЕНО 10-02-09
	Если НЕ РасчитыватьСумму Тогда
		Возврат Неопределено;
	КонецЕсли;


Функция ПолучитьТаблицуОстатковОтпусков()
...
	//ИЗМЕНЕНО 10-02-09
    	Если РасчитыватьСумму Тогда
		СтрокаТаблицы.Сумма = ?(СтрокаТаблицы.Количество = 0, 0, РассчитатьСуммуОтпуска(СтрокаТаблицы));
		СтрокаТаблицы.Сумма = СтрокаТаблицы.Сумма * СтрокаТаблицы.Множитель;
	КонецЕсли;
	//конец ИЗМЕНЕНО 10-02-09

...Показать Скрыть


Кстати, без сумм отчет формируется за считанные секунды :)

Ещё не очень удобно, когда в отчет попадают давно уволенные сотрудники.
Но и с этим можно справиться:
В "ОсновнаяСхемаКомпоновкиДанных" у поля "Состояние" снимите галки в ограничениях. Теперь реквизит "ДанныеОРаботнике.Состояние (Текущее состояние)" доступен для отбора. Ставим "Не равно Уволен" и видим чистенький отчет по работающим сотрудникам.

Ну а красиво это оформить в настройках вы сможете и сами. Или дождитесь официального релиза от разработчика.
12. Федор Программист (fedor40) 662 04.03.10 17:58 Сейчас в теме
8.2.10 после конвертации в Параметре можно выбрать только Параметры. Документ. Конкретный документ не дает.
13. Наталья Мурзина (Lui55) 09.03.10 16:14 Сейчас в теме
К сожалению эта обработка перестала работать в версии Зарплата и Управление Персоналом, редакция 2.5 (2.5.19.3) :cry: :cry: :cry:
Выдает ошибку:
{ОбщийМодуль.ПроцедурыУправленияПерсоналом(2167)}: Ошибка при вызове метода контекста (Выполнить): {(6, 2)}: Тип не может быть выбран в запросе
<<?>>&Таблица КАК ТаблицаПериодов
Запрос.Выполнить();
по причине:
{(6, 2)}: Тип не может быть выбран в запросе
<<?>>&Таблица КАК ТаблицаПериодов

Может кто подскажет в чем тут проблема? очень нужный отчет, без него худо :(
14. Николай (nnh) 19.03.10 00:21 Сейчас в теме
Функция ПолучитьТаблицуОстатковОтпусков()
...
...

ТаблицаСотрудников.Колонки.Добавить("Период");
Заменить на:
ТаблицаСотрудников.Колонки.Добавить("Период", Новый ОписаниеТипов("Дата"));



15. Николай (nnh) 19.03.10 00:32 Сейчас в теме
Также

Функция РассчитатьСуммуОтпуска(СтрокаТаблицыОстатков)

...

ПроведениеРасчетов.РассчитатьЗаписиРегистраРасчета("ДополнительныеНачисленияРаботниковОрганизаций", НаборДополнительныеНачисления, , НаборРасчетСреднего, СтрокаТаблицыОстатков.Организация, СтрокаТаблицыОстатков.ОбособленноеПодразделение);

Заменить на ПроведениеРасчетовПереопределяемый.РассчитатьЗаписиРегистраРасчета("ДополнительныеНачисленияРаботниковОрганизаций", НаборДополнительныеНачисления, , НаборРасчетСреднего, СтрокаТаблицыОстатков.Организация, СтрокаТаблицыОстатков.ОбособленноеПодразделение);
16. Елена (kell) 25.05.10 15:19 Сейчас в теме
Спасибо Armando и Alex Y. Всё хорошо, только при расчете остатка отпуска учитывается и тот период когда сотрудник был в декретном отпуске...
17. Serg P (Serg1970) 24.11.10 09:53 Сейчас в теме
Залит файл erf,а не ert,перезалейте нормальный,пожалуйста...
18. Ирина М (RinaMS) 01.12.10 10:23 Сейчас в теме
В последних релизах выдаёт ошибку:

Общий модуль. Типовые отчеты: Модуль

Метод объекта не обнаружен (ПолучитьПараметрыИсполненияОтчета)
ПараметрыИсполненияОтчета = ОтчетОбъект.ПолучитьПараметрыИсполненияОтчета();

В предыдущих релизах в общем модуле была Попытка/Исключение/КонецПопытки, а теперь её убрали и отчёт ругается :(
19. Ирина М (RinaMS) 08.12.10 15:15 Сейчас в теме
Решение нашлось :)

В модуле объекта нужно добавить

Функция ПолучитьПараметрыИсполненияОтчета() Экспорт
СтруктураНастроек = Новый Структура();
Возврат СтруктураНастроек;
КонецФункции
20. dka80 ~ (dka80) 15 11.05.11 14:11 Сейчас в теме
21. Сергей (smartu) 09.09.11 15:02 Сейчас в теме
а как можно увеличить скорость?
22. Mabuta (mabuta_serg) 30.09.11 02:07 Сейчас в теме
Что может означать ошибка (открываю платформой 8.2 конфмгурация УТП Украина релиз 1,2,2,3):
Помилка в схемі компонування даних
через:
Помилка отримання інформації набору даних
через:
Помилка у запиті набору даних
через:
{(4, 30)}: Поле не знайдено "РаботникиОрганизации.ПериодЗавершения"
КОГДА РаботникиОрганизации.<<?>>ПериодЗавершения < &Период
23. Максим (sh_max) 12.10.11 10:20 Сейчас в теме
(21) Сильно тормозит расчет сумм. Для увеличения скорости воспользуйтесь советом Alex Y (11) (ну естественно сумм вы не получите :))
(22) Это значит что в конфигурации УТП для Украины в регистре сведений "РаботникиОрганизации" нет поля "ПериодЗавершения" (возможно оно по другому называется). Для этой конфигурации отчет нужно переделывать.
Автору плюс конечно. Публикация старая, но скачивают неплохо и до сих пор её. Было-бы совсем замечательно если бы подправили ошибочки которые здесь написаны в комментариях(тем более решения тоже описаны). А то получается как в том анекдоте: "доработать напильником".
24. Андрей Якшин (YakshinAnd) 25.10.11 12:07 Сейчас в теме
Спасибо большое за отчет.Формирует суммы конечно медленно, но если надо, то деваться некуда(((Хотелось бы корректировки от самого автора,т.к. скачивают и будут скачивать еще много людей.А без программиста допилить нормально нельзя(
25. Мэри Поппинс (vmv) 14.11.11 14:40 Сейчас в теме
Полезный отчет! Спасибо)))
26. hrust hr (hrust444) 15.12.11 10:55 Сейчас в теме
Вы пишете: Это значит что в конфигурации УТП для Украины в регистре сведений "РаботникиОрганизации" нет поля "ПериодЗавершения" (возможно оно по другому называется). Для этой конфигурации отчет нужно переделывать.
Автору плюс конечно. Публикация старая, но скачивают неплохо и до сих пор её. Было-бы совсем замечательно если бы подправили ошибочки которые здесь написаны в комментариях(тем более решения тоже описаны). А то получается как в том анекдоте: "доработать напильником". Замечательно
нинас; +1 Ответить
27. candy_sk (candy_sk) 29.12.11 10:39 Сейчас в теме
Подскажите в конфигурации 1С:Зарплата и Управление Персоналом 8.2 работает?
28. Elena Zavgorodnyaya (fiyona) 29.12.11 13:05 Сейчас в теме
Очень пригодился отчетик! Спасибо!
29. Нина (нинас) 20.01.12 08:32 Сейчас в теме
Подойдет ли отчет для Комплексной автоматизации?
32. Alex Misanets (Misanets) 332 02.02.12 12:13 Сейчас в теме
Оооо, это как раз то что доктор прописал, плюхаем :)
35. Илья Миннулин (Bomba1911) 27.02.12 12:06 Сейчас в теме
Огромное спасибо.. впервые ничегошеньки не пришлось дописывать, подправлять.. просто подключил и в кадрах праздник
36. Андрей Абрамов (spamyda) 8 28.02.12 03:09 Сейчас в теме
Не знаю с какой версии релиза это началось, но пробовал уже на 2.5.45.3. При формировании выдаёт ошибку:

{ВнешнийОтчет.ОстаткиОтпусковСотрудниковОрганизации.МодульОбъекта(192)}: Метод объекта не обнаружен (РассчитатьЗаписиРегистраРасчета)
ПроведениеРасчетов.РассчитатьЗаписиРегистраРасчета("ДополнительныеНачисленияРаботниковОрганизаций", НаборДополнительныеНачисления, , НаборРасчетСреднего, СтрокаТаблицыОстатков.Организация, СтрокаТаблицыОстатков.ОбособленноеПодразделение);

У кого происходит тоже самое, нужно подправить в модуле объекта в функции РассчитатьСуммуОтпуска(СтрокаТаблицыОстатков):

ПроведениеРасчетовПереопределяемый.РассчитатьЗаписиРегистраРасчета("ДополнительныеНачисленияРаботниковОрганизаций", НаборДополнительныеНачисления, , НаборРасчетСреднего, СтрокаТаблицыОстатков.Организация, СтрокаТаблицыОстатков.ОбособленноеПодразделение);

А в остальном, если подправить ещё и уже вышенаписанное, то работает и на 8.2 после конвертации. Пока ещё не опробовал на своих замороченных организациях, но - спасибо автору!
38. Антон Ворон (ptica-voron) 11.03.12 23:05 Сейчас в теме
Спасибо!
Я не умею читать инструкции заранее...
Сконвертировал отчет под 8.2, исправил все ошибки, добился, чтобы отчет работал в УПП 1.3.22.1, и только потом увидел, что добрые люди в комментариях уже нашли и описали все ошибки :)

Если кому-то нужно сразу рабочий отчет, могу выслать на почту. Или автору могу прислать его же отчет, чтобы перезалить в публикацию
39. Антон Ворон (ptica-voron) 19.03.12 09:41 Сейчас в теме
Я добавил в отчет страховые взносы (жестко забил ставки налогов, но можно в последствии переделать) и доработал процедуру формирования резерва на 96 счете с разбивкой по сотрудникам с использованием документа Отражение зарплаты в регл. учете.

Опять же, могу поделиться с желающими, только автор не торопится отвечать... Товарищи форумчане, подскажите, можно ли сделать новую публикацию, со ссылкой на эту и ее автора? В ней было бы здорово разместить последнюю рабочую версию отчета, плюс механизм начисления резерва. Если в дальнейшем разработаю механизм списания резерва при начислении отпусков, его тоже размещу.
40. Alex Silver (Silver1975) 14 23.04.12 16:13 Сейчас в теме
Огромное спасибо за Ваш труд! Бухгалтерия в восторге!
На конфигурации: Зарплата и Управление Персоналом, редакция 2.5 (2.5.49.2) - после внесенных изменений (описанных выше) работает без проблем!
41. Олег Олег (vechiy) 29 11.07.12 17:54 Сейчас в теме
Как исправить следующую ошибку?

{ВнешнийОтчет.ОстаткиОтпусковСотрудниковОрганизации.МодульОбъекта(180)}: Метод объекта не обнаружен (ПодготовитьДанныеПоРегламентированнымОтпускам)
ВыборкаПоОстаткам = ПроцедурыУправленияПерсоналом.ПодготовитьДанныеПоРегламентированнымОтпускам(ТаблицаСотрудников,,Ложь,);


метод удалили в новом релизе, а другой не добавили?)
42. Антон Ворон (ptica-voron) 12.07.12 16:42 Сейчас в теме
И я тоже столкнулся с тем, что метод удалили. Ищу, что теперь можно сделать. Может кто подскажет?
43. Ирина Костенкова (pandora_x) 13.07.12 09:46 Сейчас в теме
(42) ptica-voron, возьми с прошлых релизов, могу выслать, но не факт, что в новом релизе отчет будет работать корректно
44. Олег Олег (vechiy) 29 09.08.12 09:34 Сейчас в теме
Ну и кто как теперь остатки получает?) Нужно метом новый подставить, я так понимаю) Кто разбирался уже?
45. Антон Ворон (ptica-voron) 10.08.12 16:44 Сейчас в теме
(44)Я на выходных буду разбираться...
46. Наталья Медведева (masik85) 20 16.11.12 10:09 Сейчас в теме
Отчет очень интересный, сейчас метод добавлю и посмотрю что получится
если заменить на
ВыборкаПоОстаткам = ПроцедурыУправленияПерсоналомДополнительный.ПодготовитьДанныеПоУправленческимОтпускам(ТаблицаСотрудников);
то по крайней мере в последнем релизе считает дни ругается на РасчетРегистров..по Допначислениям ,

изменить на:
ПроведениеРасчетовПереопределяемый.РассчитатьЗаписиРегистраРасчета("ДополнительныеНачисленияРаботниковОрганизаций", НаборДополнительныеНачисления, , НаборРасчетСреднего, СтрокаТаблицыОстатков.Организация, СтрокаТаблицыОстатков.ОбособленноеПодразделение);
47. Mikhail Avtaev (m1cro) 20.02.13 15:32 Сейчас в теме
Релиз 2.5.62.1 . - работает правильно!
спасибо masik85. Необходимые изменения!
48. Dmitry Bas (b-dm) 162 13.11.13 13:29 Сейчас в теме
В ЗУП Корп не заработал. Это отчет для ЗУПа подходит? а то он может для УПП ?
Оставьте свое сообщение