gifts2017

Редактор пользователей ИБ (Информационной базы)

Опубликовал Stepan Darchuk (st3pan) в раздел Администрирование - Системное

Обработка предназначена для редактирования пользователей информационной базы в режиме 1С:Предприятия.
Разрабатывалась на 1С:Предприятие 8.2 (8.2.16.352) под обычный интерфейс.

Часто сталкиваемся с ситуацией, когда нужно изменить параметры пользователя, а конфигуратор использует другой программист или ввобще находитесь за компютером пользователя где режим конфигуратора отключен методом отключения доступа к файлу "config.dll".

Для такой простой задачи встраивать подсистемы из типовых конфигураций достаточно затратный процес.

Если вам нужно на некоторое время из менить пароль пользователя, а потом вернуть пароль, который вы не знаете, можно у себя сохранить хешированое(сохраняемое) значение пароля, установить новый, а когда надо вернуть пароль по "ХЕШу".

Если у Вас есть Справочник "Пользователи" который связан с пользователями ИБ по принцепу "Код"="Имя", тогда дополнив конфигурацию обработкой и на форме элемента разместите кнопку с ниже приведенным кодом обработчика.

Процедура ДействияФормыПользовательИБ(Кнопка)

если Модифицированность() Тогда

Сообщить("Перед изменением пользователя ИБ запишите измененные данные");

Возврат;

Иначе

Попытка

ОбработкаИзменения=Обработки.РедакторПользователяИБ.Создать();

ОбработкаИзменения.ИмяПоика=СокрЛП(Код);

ОбработкаИзменения.ИзКарточки=Истина;

ОбработкаИзменения.ПолучитьФорму("Форма").ОткрытьМодально();

Исключение

Сообщить("Функция изменения не доступна.");

КонецПопытки;

КонецЕсли;

КонецПроцедуры

Также можно расширить функционал Подсистемы "Инструменты разработчика" модификацией формы обработки "Список пользователей (ИР)"

Процедура ПользователиПередНачаломДобавления(Элемент, Отказ, Копирование)

Отказ = Истина; 

ОбработкаИзменения=Обработки.РедакторПользователяИБ.Создать();

ОбработкаИзменения.ИмяПоика=?(Копирование,ОсновнойЭУ.ТекущиеДанные.Имя,"");

ОбработкаИзменения.Копирование=Копирование;

ОбработкаИзменения.ПолучитьФорму("Форма").ОткрытьМодально();

УправлениеСпискомПользователей_ОбновитьСписокПользователей();

КонецПроцедуры

Процедура ПользователиПередНачаломИзменения(Элемент, Отказ)

Отказ = Истина;

ОбработкаИзменения=Обработки.РедакторПользователяИБ.Создать();

ОбработкаИзменения.ИмяПоика=ОсновнойЭУ.ТекущиеДанные.Имя;

ОбработкаИзменения.ПолучитьФорму("Форма").ОткрытьМодально();

УправлениеСпискомПользователей_ОбновитьСписокПользователей();

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
РедакторПользователяИБ.epf 14
.epf 15,92Kb
27.11.13
14
.epf 1.0 15,92Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение
Комментарии
1. kiv82 (AltF1) 29.11.13 08:11
Плюсую. Простенько и со вкусом.