gifts2017

Вызов конструктора запроса для кода на встроенном языке 1С, заданного в пользовательском режиме

Опубликовал Владимир Литвиненко (VladimirL) в раздел Программирование - Практика программирования

Конструктор запроса легко вызывается для строки, содержащей готовый текст запроса. Так работают все консоли запросов. Но задача становится нетривиальной, если у нас есть код не на языке запросов, а на встроенном языке 1С:Предприятия. В нём запрос является лишь частью текста и он представлен не в чистом виде, а в виде строковой константы с переносами строк, двойными кавычками и прочими "неудобствами".

Необходимость задавать исполняемый код в пользовательском режиме появляется не так уж и редко. Для этого создано множество инструментов - универсальные регламентные задания,  консоли кода,  динамические подписки на события и т.д. С помощью этих инструментов можно создавать код, содержащий запросы, и хорошо бы иметь возможность вызывать для этих запросов конструктор. Более того, во всем известных "Инструментах разработчика" уже есть решение этой задачи для обычных форм с применением библиотеки регулярных выражений (внешней библиотеки, подключаемой как COM-объект).


Мы же рассмотрим решение исключительно средствами 1С, которое вы сможете легко встраивать в свои формы, и которое будет подходить как для обычной, так и для управляемой формы (в толстом клиенте). Следующая иллюстрация показывает, чего мы хотим добиться от нашего алгоритма:

 

То есть нам необходимо получить возможность работать с запросами в коде аналогичную той, что дает Конфигуратор - открывать существующий запрос, изменять его, и затем возвращать измененный запрос в код на языке 1С с форматированием и сохранением позиции курсора. Эта задача сложна лишь потому, что у поля тестового документа 1С мало методов для работы с текстом и их придется "изобретать" самостоятельно.


Сначала опишем алгоритм на человеческом языке, а затем перейдем к реализации алгоритма на языке платформы.
Нам нужно:

1) Определить позицию курсора в поле текстового документа на форме.

2) Извлечь текст до курсора и после курсора.

3) В тексте, расположенном до курсора, найти открывающую запрос кавычку. В тексте расположенном после курсора найти первую несдвоенную кавычку от начала строки, это будет закрывающая кавычка.

4) Отделить текст запроса, расположенный между открывающей и закрывающей кавычками. А также выделить код, расположенный до начала запроса и после него.

5) Преобразовать код запроса таким образом, чтобы он нормально воспринимался конструктором запроса. Вместо двойных кавычек подставить одинарные, убрать символы вертикальной черты. После чего передать полученный текст в конструктор.

6) После закрытия конструктора сделать обратное преобразование полученного из него кода запроса. Добавить отступы и привести его к виду, который будет нормально воспринят интерпретатором языка 1С.

7) Соединить новый код запроса с текстом, который раньше располагался до и после текста запроса. Загрузить полученный код в поле формы и восстановить позицию курсора.

 


 

Теперь перейдем к поэтапной реализации этого алгоритма на языке 1С. Для демонстрации выберем обычную форму. Для управляемой формы код будет отличаться всего несколькими строками, и он также есть в прикрепленном к этой публикации файле. Пусть поле текстового документа на нашей форме имеет имя "Поле".


1) Упростим процесс кодирования введением дополнительных переменных и определим текущую позицию курсора. Позицию курсора запишем в переменные НачалоСтроки и НачалоКолонки. Значение переменной НачалоСтроки  в ходе алгорима менять не будем. Оно понадобится в конце для восстановления позиции курсора: 

    //БЛОК №1 - ИНИЦИАЛИЗАЦИЯ ПЕРЕМЕННЫХ

   
ЭлементПоля = ЭлементыФормы.Поле;
   
Кавычка = """";
   
ДвойнаяКавычка = """""";
   
ЗаменаДляДвойнойКавычки = Строка(Новый УникальныйИдентификатор);
   
КоличествоСтрок = ЭлементПоля.КоличествоСтрок();

   
НачалоСтроки = 0;
   
НачалоКолонки = 0;
   
КонецСтроки = 0;
   
КонецКолонки = 0;

   
ЭлементПоля.ПолучитьГраницыВыделения(НачалоСтроки, НачалоКолонки, КонецСтроки, КонецКолонки);
   
ЭлементПоля.УстановитьГраницыВыделения(НачалоСтроки, НачалоКолонки, Началостроки, НачалоКолонки);

 

2) Определим текст, расположенный до курсора и после него. Для этого поле текстового документа дает нам только одну возможность - устанавливать границы выделения и получать выделенный текст. Далее нам придется искать открывающую и закрывающую запрос кавычку. Сильной помехой в этом могут оказаться двойные кавычки. Чтобы избежать лишнего кода по обработке двойных кавычек используем следующий прием. Временно заменим все двойные кавычки на уникальную строку. Обратную замену будем проводить в конце алгоритма, при получении нового кода:

    //БЛОК №2 - ОПРЕДЕЛЕНИЕ ТЕКСТА ДО КУРСОРА И ПОСЛЕ КУРСОРА
   
ЭлементПоля.УстановитьГраницыВыделения(1, 1, Началостроки, НачалоКолонки);
   
ТекстДоКурсора = ЭлементПоля.ВыделенныйТекст;
   
ЭлементПоля.УстановитьГраницыВыделения(НачалоСтроки, НачалоКолонки, КоличествоСтрок+1, 1);
   
ТекстПослеКурсора = ЭлементПоля.ВыделенныйТекст;

   
ЭлементПоля.УстановитьГраницыВыделения(НачалоСтроки, НачалоКолонки, Началостроки, НачалоКолонки);

   
//гарантируем отсутствие в тексте двойных кавычек
   
ТекстДоКурсора = СтрЗаменить(ТекстДоКурсора, ДвойнаяКавычка, ЗаменаДляДвойнойКавычки);
   
//в тексте после курсора необходимо оставить первую кавычку, если сразу после нее идет двойная
    //случай подряд идущих кавычек в количестве более 5-ти штук обрабатывать не будем
   
ТекстПослеКурсора СтрЗаменить(Лев(ТекстПослеКурсора, 1) +
         
СтрЗаменить(Сред(ТекстПослеКурсора, 2), ДвойнаяКавычка, ЗаменаДляДвойнойКавычки), ДвойнаяКавычка, ЗаменаДляДвойнойКавычки) ;

 

3) Двигаясь по строке кода, расположенного до курсора, находим открывающую запрос кавычку. Поскольку мы избавились от двойных кавычек, то найти ее несложно. Нужно просто найти кавычку, которая не была закрыта следующей за ней. Правда, нужно учитывать, что кавычки в комментариях надо пропустить, перемещаясь сразу к концу строки, а также то, что курсор сам мог находиться внутри двойной кавычки в строке запроса:

    //БЛОК №3 - ИЩЕМ ПОЗИЦИЮ ОТКРВАЮЩЕЙ И ЗАКРЫВАЮЩЕЙ КАВЫЧКИ ДЛЯ СТРОКИ ЗАПРОСА

   
ПозицияОткрывающейКавычки = 0;
   
ПозицияЗакрывающейКавычки = 0;

   
ВСтроке = Ложь;
   
КавычкиЕсть = Ложь;
   
ПозицияПредыдущейКавычки = 0;
   
ПоизцияПоследнейКавычки = 0;

   
Позиция = 1;
   
ДлинаТекстаДоКурсора = СтрДлина(ТекстДоКурсора);

   
//ИЩЕМ ОТКРЫВАЮЩУЮ КАВЫЧКУ
   
Пока Позиция <= ДлинаТекстаДоКурсора Цикл

       
ТекущийСимвол = Сред(ТекстДоКурсора, Позиция, 1);

       
ПредыдущийСимвол = " ";
        Если
Позиция > 1 Тогда
           
ПредыдущийСимвол = Сред(ТекстДоКурсора, Позиция-1, 1);
        КонецЕсли;

        Если
ТекущийСимвол = Кавычка Тогда
           
ВСтроке = НЕ ВСтроке;
           
ПозицияПредыдущейКавычки = ПоизцияПоследнейКавычки;
           
ПоизцияПоследнейКавычки = Позиция;
           
КавычкиЕсть = Истина;
        КонецЕсли;

       
//Обработка комментария - начало
       
Если НЕ ВСтроке И ПредыдущийСимвол = "/" И ТекущийСимвол = "/" Тогда
           
//это комментарий, пропускаем символы до конца строки
           
Пока ТекущийСимвол <> Символы.LF И ТекущийСимвол <> Символы.CR Цикл
               
Позиция = Позиция +1;
                Если
Позиция > ДлинаТекстаДоКурсора Тогда
                    Прервать;
                КонецЕсли;
               
ТекущийСимвол = Сред(ТекстДоКурсора, Позиция, 1);
            КонецЦикла;

            Продолжить;
        КонецЕсли;
       
//Обработка комментария - конец

       
Позиция = Позиция + 1;
    КонецЦикла;

   
//ОСОБЫМ ОБРАЗОМ ОБРАБОТАЕМ СЛУЧАЙ НАХОЖДЕНИЯ КУРСОРА В
    //ДВОЙНОЙ КАВЫЧКЕ ВНУТРИ СТРОКИ ЗАПРОСА
   
Если НЕ ВСтроке И КавычкиЕсть И СтрДлина(ТекстПослеКурсора) > 0 Тогда
        Если 
Сред(ТекстДоКурсора, ДлинаТекстаДоКурсора, 1) = Кавычка И Лев(ТекстПослеКурсора,1) = Кавычка Тогда
           
ВСтроке = Истина;
           
ПоизцияПоследнейКавычки = ПозицияПредыдущейКавычки;
           
ТекстДоКурсора = Лев(ТекстДоКурсора, ДлинаТекстаДоКурсора-1);
           
ТекстПослеКурсора = ЗаменаДляДвойнойКавычки + Сред(ТекстПослеКурсора, 2);
        КонецЕсли;
    КонецЕсли;

   
//ЕСЛИ НАШИЛИ ОТКРЫВАЮЩУЮ КАВЫЧКУ, ТО ИЩЕМ ЗАКРЫВАЮЩУЮ
   
Если ВСтроке Тогда
       
ПозицияОткрывающейКавычки = ПоизцияПоследнейКавычки;
       
ПозицияЗакрывающейКавычки = Найти(ТекстПослеКурсора, Кавычка);
    КонецЕсли;

 

4) Теперь можно выделить код между кавычками (запрос) и код расположенный до и после запроса. Чтобы текст запроса был воспринят конструктором его необходимо преобразовать, убрав из начала каждой его строки вертикальную черту:

    //БЛОК №4 - ОПРЕДЕЛЯЕМ ТЕКСТ ДО ЗАПРОСА, ТЕКСТ ЗАПРОСА И ТЕКСТ ПОСЛЕ ЗАПРОСА
    //ПОСЛЕ ЧЕГО ВОЗРАЩАЕМ ДВОЙНЫЕ КАВЫЧКИ В КОД, НЕ ЯВЛЯЮЩИЙСЯ ЧАСТЬЮ ЗАПРОСА

   
Конструктор = Новый("КонструкторЗапроса");
   
ГраницыЗапросаНайдены = ПозицияОткрывающейКавычки <> 0 И ПозицияЗакрывающейКавычки <> 0;

    Если НЕ
ГраницыЗапросаНайдены Тогда
       
Сообщение = "ЗАПРОС НЕ ОБНАРУЖЕН, БУДЕТ СОЗДАН НОВЫЙ ЗАПРОС";
       
ПоказатьОповещениеПользователя(Сообщение, , Сообщение);
       
ТекстДоНачалаЗапроса = ТекстДоКурсора + Кавычка;
       
ТекстПослеКонцаЗапроса = Кавычка + ТекстПослеКурсора ;
    Иначе

       
ТекстДоНачалаЗапроса = Лев(ТекстДоКурсора, ПозицияОткрывающейКавычки);
       
ТекстПослеКонцаЗапроса = Сред(ТекстПослеКурсора, ПозицияЗакрывающейКавычки);

       
ТекстЗапросаССимвовамиВертикальнойЧерты = Сред(ТекстДоКурсора, ПозицияОткрывающейКавычки + 1)

                + Лев(ТекстПослеКурсора, ПозицияЗакрывающейКавычки -1);

        //для конструктора запроса вместо двойной кавычки будем подставлять одинарную
       
ТекстЗапросаССимвовамиВертикальнойЧерты =

                СтрЗаменить(ТекстЗапросаССимвовамиВертикальнойЧерты, ЗаменаДляДвойнойКавычки, Кавычка);

       
КоличествоСтрокВТексте = СтрЧислоСтрок(ТекстЗапросаССимвовамиВертикальнойЧерты);
       
ТекстЗапроса = "";
        Для
К = 1 To КоличествоСтрокВТексте Цикл
           
СтрокаИзТекстаЗапроса = СокрЛП(СтрПолучитьСтроку(ТекстЗапросаССимвовамиВертикальнойЧерты, К));
            Если
Лев(СтрокаИзТекстаЗапроса, 1) = "|" Тогда
               
//для конструктора запроса убираем вертикальную черту в начале строки
               
СтрокаИзТекстаЗапроса = Сред(СтрокаИзТекстаЗапроса, 2);
            КонецЕсли;

           
ТекстЗапроса = ТекстЗапроса + СтрокаИзТекстаЗапроса + Символы.LF;
        КонецЦикла;

       
Конструктор.Текст = ТекстЗапроса;
    КонецЕсли;

   
//возвращаем двойные кавычки
   
ТекстДоНачалаЗапроса = СтрЗаменить(ТекстДоНачалаЗапроса, ЗаменаДляДвойнойКавычки, ДвойнаяКавычка);
   
ТекстПослеКонцаЗапроса = СтрЗаменить(ТекстПослеКонцаЗапроса, ЗаменаДляДвойнойКавычки, ДвойнаяКавычка);

 

5) Передаем текст запроса в конструктор и, если конструктор отработал успешно, вычисляем отступ, который будем добавлять к строкам запроса. Отступ необходимо добавлять, чтобы код запроса вставился на форму красиво, а не безусловно лепился к левому краю текстового поля:

    //БЛОК №5 - ОТКРЫВАЕМ КОНСТРУКТОР ЗАПРОСА С ПОЛУЧЕННОЙ СТРОКОЙ ЗАПРОСА И В СЛУЧАЕ УСПЕШНОГО
    //РЕЗУЛЬТАТА ВЫЧИСЛЯЕМ ОТСТУП, КОТОРЫЙ БУДЕМ ДОБАВЛЯТЬ К КАЖДОЙ СТРОКЕ ЗАПРОСА

   
Если НЕ Конструктор.ОткрытьМодально() Тогда
        Возврат;
    КонецЕсли;

   
ТекстЗапроса = Конструктор.Текст;
    Если
ПустаяСтрока(ТекстЗапроса) Тогда
        Возврат;
    КонецЕсли;


   
ДлинаТекстаДоНачалаЗапроса = СтрДлина(ТекстДоНачалаЗапроса);
   
Позиция = ДлинаТекстаДоНачалаЗапроса-1;

    Пока
Позиция >= 1 Цикл
        Если
Сред(ТекстДоНачалаЗапроса, Позиция, 1) = Символы.LF Тогда
            Прервать;
        КонецЕсли;
       
Позиция = Позиция - 1;
    КонецЦикла;

   
СтрокаОтступа = Сред(ТекстДоНачалаЗапроса, Позиция+1, ДлинаТекстаДоНачалаЗапроса - Позиция -1);
   
ДлинаСтрокиОтступа = СтрДлина(СтрокаОтступа);
   
СтрокаОтступаИзПробеловИТабуляций = "";


    Для
К = 1 To ДлинаСтрокиОтступа Цикл
        Если
Сред(СтрокаОтступа, К, 1) = Символы.Tab Тогда
           
СтрокаОтступаИзПробеловИТабуляций = СтрокаОтступаИзПробеловИТабуляций + Символы.Tab;
        Иначе
           
СтрокаОтступаИзПробеловИТабуляций = СтрокаОтступаИзПробеловИТабуляций + " ";
        КонецЕсли;
    КонецЦикла;

 

6) Теперь у нас есть текст запроса на языке запросов. Нужно преобразовать его в строку на встроенном языке 1С. Добавляем символы вертикальной черты и отступы, преобразуем одинарные кавычки в двойные:

    //БЛОК №6 - ОБРАБАТЫВАЕМ РЕЗУЛЬТАТ, ЗАМЕНЯЕМ ОДИНАРНЫЕ КАВЫЧКИ НА ДВОЙНЫЕ,
    //ДОБАВЛЯЕМ ОТСТУП И ВЕРТИКАЛЬНУЮ ЧЕРТУ СТРОКАМ ЗАПРОСА НАЧИНАЯ СО ВТОРОЙ

   
ТекстЗапроса = СтрЗаменить(ТекстЗапроса, Кавычка, ДвойнаяКавычка);
   
КоличествоСтрокВТексте = СтрЧислоСтрок(ТекстЗапроса);
   
ТекстЗапросаССимвовамиВертикальнойЧерты = СтрПолучитьСтроку(ТекстЗапроса, 1);

    Для
К = 2 To КоличествоСтрокВТексте Цикл
       
ТекстЗапросаССимвовамиВертикальнойЧерты = ТекстЗапросаССимвовамиВертикальнойЧерты +

                   Символы.LF + СтрокаОтступаИзПробеловИТабуляций + "|" + СтрПолучитьСтроку(ТекстЗапроса, К);
    КонецЦикла;


7) Задача фактически решена. Склеиваем код, располагавшийся до запроса, новую строку запроса и код, располагавшийся после запроса. Загружаем получившуюся строку в поле формы и восстанавливаем позицию курсора:

    //ЗАГРУЖАЕМ НОВЫЙ КОД В ТЕКСТОВОЕ ПОЛЕ И УСТАНАВЛИВАЕМ КУРСОР НА ПРЕЖНЮЮ ПОЗИЦИЮ
   
ИтоговыйКод = ТекстДоНачалаЗапроса + ТекстЗапросаССимвовамиВертикальнойЧерты + ТекстПослеКонцаЗапроса;
   
ЭлементПоля.УстановитьТекст(ИтоговыйКод);

   
НоваяКолонка = СтрДлина(СтрокаОтступаИзПробеловИТабуляций)+2;
   
ЭлементПоля.УстановитьГраницыВыделения(НачалоСтроки, НоваяКолонка, НачалоСтроки, НоваяКолонка);
   
ЭтаФорма.ТекущийЭлемент = ЭлементПоля;

 


 

Для применения этого метода в своих разработках вам достаточно заменить в коде имя одного элемента формы - поля текстового документа.

К публикации прилагается обработка с реализацией этого алгоритма, в которой есть обычная и управляемая форма. Обработка предназначена для работы в толстом клиенте управляемого или обычного приложения. При работе с управляемой формой есть незначительные отличия в коде. Например, восстанавливать положение курсора приходится через отложенный вызов процедуры, через обработчик ожидания.

 

Алгоритм был создан с целью применения в новой версии универсальной подсистемы   Динамические подписки на события v.3.  Не проходите мимо этой разработки, она может облегчить поддержку ваших баз:

 

  

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ВызовКонструктораЗапросовВКонсолиКода.epf
.epf 15,34Kb
25.12.13
46
.epf 1 15,34Kb 46 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дамир Закиров (Dzenn) 26.12.13 07:34
я ничего не понял из написанного
2. Дамир Закиров (Dzenn) 26.12.13 07:36
хотелось бы, чтобы гифки шли помедленнее, либо сопроводить их набором жпегов
3. Владимир Литвиненко (VladimirL) 26.12.13 08:13
(1) Публикация предназначена для тех, кто создаёт или планирует создавать инструменты, позволяющие управлять исполняемым кодом 1С прямо из пользовательского режима. Если вам интересно, то пройдите по приведенным в начале публикации ссылкам. Консоль кода - простейший пример инструмента, где это может пригодиться.

А писалось всё это дело для "динамических подписок", которые позволяют не лезть каждый раз в конфигуратор и выгонять пользователей из базы, чтобы добавить/изменить подписку на событие, а задать нужный код из режима 1С:Предприятия.

Это особенно полезно, когда нужно срочно добавить какой-нибудь контроль/запрет при создании/изменении объектов базы. Конструктор запросов позволяет быстрее вносить изменения в такой код.

(2) Учту.
4. OneS (OneS) 26.12.13 11:24
Вот какое дело... Человеку не знающему, в контексте поставленной задачи, конструктор не поможет. А кто знает, тому конструктор как то уже и не очень нужен. Консоль запросов тому подтверждение.

Опять же, нужно ли подвергать себя риску обрушить базу ваяя на лету в пользовательском режиме нечто настолько сложное, что без конструктора не обойтись?

Однако автор старался, так что респект однозначно.
5. Владимир Литвиненко (VladimirL) 26.12.13 12:23
(4) Первую часть вопроса не очень понял. И консоль запросов и консоль кода все активно используют. Более того, есть разработки, где большая часть нового кода задается сначала в пользовательском режиме. Например Мета-конфигуратор в "СКАТ-Профессионал".

В пользовательском режиме можно не "ваять на лету" новые запросы, а быстро изменять уже существующие.

Представьте, что Вам поставили задачу запретить изменение документов, удовлетворяющих сложному условию, которое оптимальнее проверять через запрос. Что вы сделаете? Добавите в конфигураторе подписку на событие "ПередЗаписью" и выгоните всех пользователей из базы? А если через некоторое время это условие поменяется, ведь бизнес у нас переменчив?

Вместо того, чтобы каждый раз менять конфигурацию или придумывать разные регистры правил, которые могут никогда больше не пригодиться, гораздо проще немного откорректировать запрос в пользовательском режиме. Большинству программистов это будет под силу без риска обрушить базу :) Ну а если не хотите рисковать, то всегда есть тестовая база, где можно никому не мешая и в конфигураторе код написать и в пользовательском режиме его протестить.

Посмотрите вот этот скриншот:
http://infostart.ru/upload/iblock/b8e/Pic5.PNG
6. Vladimir A (wowik) 26.12.13 13:17
я так понял это аналог обработок "Выполнить" из ИР.
7. Яков Коган (Yashazz) 26.12.13 13:32
Баян, да ещё и некрасиво сделанный. Я решил такую задачу давным-давно и её решений видел несметно, ибо элементарщина. Воистину, скоро дождёмся мегапопулярных публикаций на тему "как выбрать элементы из справочника", но зато красивых, с гифками и попунктным разжёвыванием каждой строки.

8. Владимир Литвиненко (VladimirL) 26.12.13 14:23
(6) wowik,
Да, ориентировался на ИР и сначала хотел использовать именно функции ИР для вызова конструктора. Но оказалось, что они используют внешние библиотеки для разбора строк, чего хотелось бы избежать. Еще не получилось связать ИР-овский конструктор и управляемую форму. Может быть плохо старался и еще получится это сделать :) Надеюсь что смогу использовать ИР для вызова контекстной подсказки, там тоже внешние библиотеки задействованы, но без этого уже не обойтись.

(7) Yashazz,
Я рад, что где-то в недрах Ваших обработок существует подобный алгоритм. Осталось подождать пока Вселенский Коллективный Разум объединит мозги всех 1С-ников в единое целое. Тогда мы перестанем делиться алгоритмами и будем создавать идеальные разработки. Кстати не нашел подобного в Ваших публикациях. Вот это не в счет. Там просто строка вставляется, а открыть запрос в конструкторе нельзя.
9. Яков Коган (Yashazz) 26.12.13 15:55
(8) Не, там нету, я в первую очередь о ней вспомнил и проверил, нифига. В других каких-то было, сейчас не вспомню.

Дело в другом - это ведь фрагмент, кусок, не очень понимаю смысл так его разжёвывать. Впрочем, это лично моё недоумение.
А что до "некрасиво" - после того, как я видел подобные решения на регулярных выражениях, всё остальное меркнет...
10. Владимир Литвиненко (VladimirL) 26.12.13 16:38
(9) Yashazz,
Разжевывать нужно чтобы не только "суперпрофессионалы" всё поняли. Жаль, что многие программисты забывают, что они не всегда были гуру, а когда-то тоже учились.

К тому же политика Инфостарта такова, что для скачивания нужно потратить 1$m и насколько я понял для многих это проблема. Поэтому код по возможности вставляю в статью. Дополнительные комментарии по сравнению с этим - мелочь.



Что до RegExp, то это внешняя по отношению к 1С библиотека. Конечно это своего рода стандарт, но "стандарт" и 1С - вещи слабо совместимые. RegExp используется в 1С через COM-интерфейс, который например не поддерживается в Linux, для которого с недавнего времени тоже есть толстый клиент. Если писать простое универсальное решение для 1С, то лучше чтобы оно зависело только от 1С.
11. Ivan Veres (MrFlanker) 26.12.13 19:11
Гифики помедленей пожалуйста, ну непонятно что ж такое происходит.
12. Сергей Старых (tormozit) 26.12.13 22:59
Кроссплатформенную замену VBScript.RegExp обещал Орефков, но что то тишина у него уже пол года. Видимо крепко засел над снегопатом для 8.3. Кстати в ИР уже давно есть поддержка его компоненты, но отключено внутри, т.к. она пока в некоторых случаях аварийно завершает приложение. Качественный багрепорт ему я еще весной отправил.
13. Владимир Литвиненко (VladimirL) 27.12.13 02:16
(12) Интересно, иметь такой инструмент было бы хорошо. Будем ждать.
А реализация планировалась средствами 1С или через какую-то библиотеку?
14. Сергей Старых (tormozit) 27.12.13 08:17
15. Яков Коган (Yashazz) 27.12.13 16:19
(10) Учить новичков - это не на ИС, а на других сайтах, флаг в руки. Здесь - сайт профессионалов.
(12) Ага, я про это и говорил. Безо всяких ВК, сам пробовал, нормально работает.
16. Владимир Литвиненко (VladimirL) 28.12.13 04:10
(15) Субъективное суждение. Потому что одни из самых рейтинговых публикаций на ИС - это разного рода обучалки, переработанные пересказы документации и обработки, направленные на самую широкую аудиторию. Значит есть люди, для которых это полезно и нет ничего плохого в том, чтобы с ними этим делиться.

И мне тоже бывает интересно увидеть новую интерпретацию уже знакомой информации. Не думаю что имеет смысл это обсуждать ибо ведет к холивару.
17. Владимир Литвиненко (VladimirL) 28.12.13 04:14
(15) Это все таки ВК:
В поставку входит два файла:
•rex32.dll - для работы в 32-битных клиентах и сервере
•rex64.dll - для работы в 64-битном сервере
Основные планы на ближайшее будещее - сделать linux-версию.
18. Сергей Старых (tormozit) 28.12.13 07:57
(17) Нет. Это "полуВК" и "полуРасширениеОбъектнойМодели". Когда попробуешь, поймешь.
19. Александр (Sitex) 30.12.13 09:13
(10) VladimirL, в целом неплохо. Особенно когда в рутине дел это может позабыться.

(15) Yashazz, По вашему суждению, можно при регистрации сделать на ИС сдачу теории...т.п. Чтобы лишних как статье так и комментариев не было.
Прикрепленные файлы:
20. Яков Коган (Yashazz) 31.12.13 18:36
(19) Это не моё суждение, это определение сайта как такового, посмотрите сами. Впрочем, увы, ИС действительно медленно, но верно превращается во второй DevTrain. :(
21. Владимир Литвиненко (VladimirL) 01.01.14 08:33
(20)
ИС действительно медленно, но верно превращается во второй DevTrain

Ваши претензии безосновательны. Вы не привели ссылку на другую публикацию, где аналогичная работа с конструктором велась бы без подключения внешних dll-библиотек. То, что именно это является целью данной публикации указано в самом её начале. Подробность изложения материала также считаю плохой мишенью для критики.


Дальнейшее обсуждение "элементарщины", "баянов" и причитания о судьбе Инфостарта предлагаю перенести в ЭТУ или ЭТУ публикации за Вашим авторством. Они подходят для этого гораздо больше. Признак непрофессионализма - это тратить время на поиск соринки в чужом глазу, вместо того, чтобы улучшать качество собственных работ.
МимохожийОднако; +1 Ответить 1
22. Александр (МимохожийОднако) 01.01.14 09:19
23. Саша Безымяный (help1Ckr) 01.01.14 15:02
Спасибо за статью, особенно за то что выложили здесь подробное описание алгоритма.
24. Яков Коган (Yashazz) 01.01.14 22:54
(21) Вы, вероятно, не видели вот этого: http://infostart.ru/about/, где в первой же строке сказано "Профессиональное сообщество". Ознакомьтесь, потом будете спорить.Это и вообще всех касается, кто считает ИС "лягушатником для начинающих". И про специалистов, оказывающих профессиональные услуги, тоже, считаю, доступно написано.

Что до меня, я всегда честно оговариваю, что является баяном и что нет, поэтому вы можете переносить разговор куда угодно и о чём угодно, но реплика про соринку и качество работ в любом случае мимо, уважаемый. Признак непрофессионализма в данном случае - явный переход на личности, попытка флейма и переваливания с больной головы на здоровую (сиречь попытки переноса в темы, не имеющие отношения к). Советую быть вежливее и терпимее, и не путать критику публикации с критикой автора. Учитесь уважать окружающих.
Засим участие прекращаю, ибо бессмысленно тратить время не привык.
25. Владимир Литвиненко (VladimirL) 02.01.14 12:28
Да я и так старался избежать перехода на личности. Но сообщения (7), (15) и (20) написанные в резком обвинительном тоне не оставили выбора. Уж извините.
26. Яков Коган (Yashazz) 05.01.14 01:41
(25) Ладно, проехали. С праздниками всех, кстати. Просто у меня пунктик - очень не люблю баянить сам, иногда и других начинаю пинать, увлёкшись. Прошу пардону.
27. Кикос Одинэсенко (servs) 08.01.14 13:43
Обращаю внимание критиков: способность писать код на языке 1С, не прибегая при этом к dll - это критерий, по которому можно отличить новичков (или лентяев :-) ) от грамотных программистов 1С.

Не использование dll в конкретной задаче - это изюминка статьи,
+ алгоритм также полезен не менее.

Многим профессионалам есть чему поучиться, ящетаю)))

Спасибо за статью! Ставлю жирный плюс!

П.С.: Есть статьи на ИС, которые иногда вызывают у меня такую же реакцию как у критиков выше (например, обработка запуска амми из 1С). Эта статья заслуживает на похвалу. Нужно уметь понять ее ценность, что не каждому дано.
28. Алекс Одинэсник (Alex1Cnic) 21.01.14 12:45
А что, интересная статья. Люблю, когда все по-полочкам разложено...
29. Ivon (Ivon) 16.07.14 17:23
Вообще молодец. Плюсанул.
30. Олег Шалимов (CaSH_2004) 21.09.16 21:29
Спасибо, полезная штука, сам такой давно написал, но были огрехи и не хотелось вникать, а тут скопировал, вставил и все взлетело.
31. Денис Лопато (Terve!R) 31.10.16 12:55
Ну вот, думал скачать и сразу использовать, но как всегда пришлось допилить)

Автор, открытие конструктора в тонком клиенте возможно, начиная с версии платформы 8.3.5! А здесь проверка на толстый клиент и привет!
Во-вторых, пришлось переделывать на открытие конструктора через Показать() и оповещение, модальный вызов в тонком клиенте не работает.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа