gifts2017

Загрузка банков с сайта ГАРАНТ

Опубликовал Сергей (seermak) в раздел Обработки - Обработка справочников

Альтернативная загрузка данных банков с сайта Гарант

   Стандартный классификатор банков с сайта РБК загружает данные сразу по всем банкам долго и нудно.  Моей обработкой (на управляемых формах) все гораздо веселее - загружается список всех регионов, а данные банков только для выбранного региона (см. рис).

Перенос данных в базу для стандарных конфигураций сделаю "за отдельную плату" (у меня конфигурация нестандартная).

Скачать файлы

Наименование Файл Версия Размер
Загрузка банков с сайта Гарант 9
.epf 12,12Kb
26.12.13
9
.epf 12,12Kb Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. OBEH (OBEH) 01.01.14 10:48
Странная цитата "Перенос данных в базу для стандарных конфигураций сделаю "за отдельную плату" (у меня конфигурация нестандартная)."
Выходит, что для всех будет "за отдельную" плату. Ведь, как правило, интересует работа в стандартной конфигурации. А если не стандартная, то я сомневаюсь, что она совпадает с конфигурацией автора. Если, конечно, эту "нестандартную конфу" автор свою не устанавливал.
2. Сергей (seermak) 01.01.14 13:01
(1) в стандартной конфигурации надо прописывать событие "Обработка оповещения"
Вот если совсем лень думать
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
Если ИмяСобытия = "ЗаполненаТаблицаБанков" И ТипЗнч(Параметр) = Тип("Структура") Тогда
ОбработкаОповещения_Сервер(Параметр.ТД);
КонецЕсли;
КонецПроцедуры
&НаСервереБезКонтекста
Процедура ОбработкаОповещения_Сервер(ТаблЗнач)
Спр = Справочники.Банки;
Для каждого СтрокаТЗ Из ТаблЗнач Цикл
ПоискБИК = СокрЛП(СтрокаТЗ.БИК);
НайденнаяСсылка = Спр.НайтиПоРеквизиту("БИК",ПоискБИК);
Если НайденнаяСсылка = Спр.ПустаяСсылка() Тогда
//Если СтрокаТЗ.ПРЕКРАЩЕНА Тогда
//Продолжить;
//КонецЕсли;
НовыйЭлемент = Спр.СоздатьЭлемент();
НовыйЭлемент.БИК = ПоискБИК;
НовыйЭлемент.Наименование = СтрокаТЗ.КОРСЧЕТ;
НовыйЭлемент.Родитель = НайтиРодителя(СтрокаТЗ.РАЙОН,СтрокаТЗ.НП, Спр);
НовыйЭлемент.НаименованиеБанка = СтрокаТЗ.НАИМЕНОВАНИЕ;
НовыйЭлемент.Адрес = СтрокаТЗ.АДРЕС;
НовыйЭлемент.ТипБанка = СтрокаТЗ.ТИП_УЧАСТНИКА;
НовыйЭлемент.Телефон = СтрокаТЗ.ТЕЛЕФОН;
НовыйЭлемент.ПометкаУдаления = СтрокаТЗ.ПРЕКРАЩЕНА;
Попытка
НовыйЭлемент.Записать();
Исключение
КонецПопытки;
Иначе //найдено
ОбъектБанк = НайденнаяСсылка.ПолучитьОбъект();
Если СтрокаТЗ.ПРЕКРАЩЕНА Тогда
ОбъектБанк.УстановитьПометкуУдаления(Истина);
Иначе
ОбъектБанк.Адрес = СтрокаТЗ.АДРЕС;
ОбъектБанк.НаименованиеБанка = СтрокаТЗ.НАИМЕНОВАНИЕ;
ОбъектБанк.Родитель = НайтиРодителя(СтрокаТЗ.РАЙОН,СтрокаТЗ.НП, Спр);
ОбъектБанк.Телефон = СтрокаТЗ.ТЕЛЕФОН;
ОбъектБанк.ТипБанка = СтрокаТЗ.ТИП_УЧАСТНИКА;
КонецЕсли;

Попытка
ОбъектБанк.Записать();
Исключение
КонецПопытки;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа