gifts2017

Материальный отчет

Опубликовал Василий Майоров (WasiliyMay) в раздел Отчеты - Бухгалтерские

Материальный отчет и реестр материалов по счету: 10-"Материалы"

Материальный отчет и реестр материалов по счету: 10-"Материалы" с отбором по складу.

Для Конфигурации: Бухгалтерия Предприятия (ред. 3.0)

Скачать файлы

Наименование Файл Версия Размер
МатОтчет.erf 78
.erf 21,90Kb
12.02.14
78
.erf 21,90Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. anry mc (AnryMc) 12.02.14 18:05
Я понимаю: "Краткость - сестра таланта..,", но не до такой же степени...

Хоть напишите (если не указываете конфигурацию) - как называется план счетов из которого беруться данные (в разных конфигурациях - могут отличаться, например, для хозрасчетных и бюджетных)...
2. Елена Миловицкая (milka12371) 19.02.14 21:11
Добрый вечер! Подскажите пожалуйста, как настроить страничку на печать с закладкой "материалы"? Шапка на одной странице а весь отчет на других. Через Таблицу-настройка печати- неактивно.
3. Василий Майоров (WasiliyMay) 19.02.14 22:19
(2) milka12371, Необходимо в модуле объекта, в процедуре "СформироватьОтчет" Заменить:
		ОбластьМакета = Макет.ПолучитьОбласть("Строка");
		ОбластьМакетаСчет = Макет.ПолучитьОбласть("Счет");
		ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка");
		ВыборкаДетальныеЗаписи = Результат.Выбрать();
		ПредСчет = "";
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			Если ПредСчет<>ВыборкаДетальныеЗаписи.Счет Тогда
				ОбластьМакетаСчет.Параметры.Счет = ВыборкаДетальныеЗаписи.Счет.Код+": "+ВыборкаДетальныеЗаписи.Счет.Наименование;	
				ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
				ТабличныйДокумент.Вывести(ОбластьМакетаШапка);
				ТабличныйДокумент.Вывести(ОбластьМакетаСчет);						
			КонецЕсли;
...Показать Скрыть


на:

		ОбластьМакета = Макет.ПолучитьОбласть("Строка");
		ОбластьМакетаСчет = Макет.ПолучитьОбласть("Счет");
		ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка");
		ТабличныйДокумент.Вывести(ОбластьМакетаШапка);		
		ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();		
		ВыборкаДетальныеЗаписи = Результат.Выбрать();
		ПредСчет = "";
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			Если ПредСчет<>ВыборкаДетальныеЗаписи.Счет Тогда
				ОбластьМакетаСчет.Параметры.Счет = ВыборкаДетальныеЗаписи.Счет.Код+": "+ВыборкаДетальныеЗаписи.Счет.Наименование;	
				ТабличныйДокумент.Вывести(ОбластьМакетаСчет);						
			КонецЕсли;
...Показать Скрыть
4. Елена Миловицкая (milka12371) 20.02.14 00:53
&НаКлиенте
Процедура СформироватьОтчет(Команда)
	
	ОчиститьСообщения();
	
	ОтключитьОбработчикОжидания("Подключаемый_ПроверитьВыполнениеЗадания");
	
	РезультатВыполнения = СформироватьОтчетНаСервере();
	Если Не РезультатВыполнения.ЗаданиеВыполнено Тогда
		ДлительныеОперацииКлиент.ИнициализироватьПараметрыОбработчикаОжидания(ПараметрыОбработчикаОжидания);
		ПодключитьОбработчикОжидания("Подключаемый_ПроверитьВыполнениеЗадания", 1, Истина);
		ОбщегоНазначенияКлиентСервер.УстановитьСостояниеПоляТабличногоДокумента(Элементы.Результат, "ФормированиеОтчета");
	КонецЕсли;

КонецПроцедуры
...Показать Скрыть
5. Елена Миловицкая (milka12371) 20.02.14 00:54
Вот что у меня, может не там ищу(((
6. Василий Майоров (WasiliyMay) 20.02.14 10:49
(5) milka12371, Вы точно смотрите в модуле объекта?
7. Sergei (kauksi) 08.04.14 23:51
отчет классный по своей задумке, нету Итого по материалам

и с какой радости отбор Членов комиссии установлен в ДоступныНеПринятые(Истина)
у меня кадровый учет ведется в другой базе... может не надо было...
8. Василий Майоров (WasiliyMay) 11.04.14 14:05
(7) kauksi,Без этой настройки программа позволяла выбирать только принятых на работу сотрудников
9. Константин Марков (markovki) 15.08.14 16:09
К сожалению не формирует табличную часть, только шапка и подвал, да и не печатает - "Ошибка печати".
Использую БП 3.0.34.17, платформа 8.3.4.482
10. Василий Майоров (WasiliyMay) 18.08.14 16:55
(9) markovki, Проверил на типовой конфигурации (Бухгалтерия предприятия, редакция 3.0 (3.0.34.18)). Все работает нормарьно