gifts2017

Изменение розничной цены на процент в документе "Установке цен номенклатуры" на основании закупочной

Опубликовал Алексей Беспалов (FreeArcher) в раздел Обработки - Обработка документов

Внешняя обработка позволяет изменить цену по в документе "Установка цен номенклатуры" на основании другой цены.
(Розница 2.1)

Есть такое неудобство в Рознице 2.1, в документе "Установка цен номенклатуры", что нельзя изменить розничную цену на процент относительно закупочной.

Вроде бы элементарная вещь, а не реализовано. Можно задать формулу расчета, но не всегда же цена считается точно по формуле. А в таком случае удобнее изменять на процент розничную цену относительно закупочной. Сейчас же в текущей версии Розныцы 2.1.2.8, есть возможность пересчитать на процент уже расчитанную розничную цену.

Обычно из этой ситуации выходят изначально устанавливая розничную цену равной закупочной и потом увеличивают розничную цену на нужный процент.

Я написал простую обработку в которой можно изменить на заданный процент наценки\уценки цену прёимник относительно цены источник.

Скачать файлы

Наименование Файл Версия Размер
ИзменитьЦенуНаПроцентВУстановкеЦенПоБазовой.epf 41
.epf 9,44Kb
06.06.14
41
.epf 9,44Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Алекс Свк (sancho86) 10.06.14 09:38
Тоже впал в ступор когда показывал клиентам... Оказывается "из коробки" на процент изменяется только от уже установленной цены. гениально.
Спасибо за обработку, думаю понадобится.
2. Алексей Беспалов (FreeArcher) 10.06.14 11:25
(1) Спасибо! Посмотри у меня в публикациях, я там уже штук 5 написал для розницы 2.1, таких же мелких, но без которых не обойтись.
3. Антон Скородумов (Novkin) 17.07.14 18:44
Вот купил аж доступ (пакет) что бы только скачать этот обработчик. Думал что аналогично работает с конкретно выделенными строками как стандартный функционал. А в итоге применяется на все строки (номенклатуру) в документе :(
4. Алексей Беспалов (FreeArcher) 18.07.14 06:59
(3) С помощью внешней обработки нельзя по выделенным строкам сделать, ну или это будет очень сложно, весь функционал формы документа реализовывать придется.

Я делал и по выделенным строкам чтобы работало, но это пришлось конфу править уже.
5. Алексей Ахмадеев (Alexey_A) 09.12.14 15:53
спасибо!
почти что надо, я ее доработаю под нужды моего заказчика, там будет процентовка различаться по номенклатурным группам. вообще если честно после ут, тоже как-то не в своей тарелке почувствовал себя, вроде такая простейшая вещь, а ее здесь нету :(
6. rhtr Иванов (rhtr) 10.02.16 20:28
Скачал, но мне не помогло, пришлось самому ковырять.

Округление не действует, а это для розницы плохо, так же не проставляется процент наценки в колонке "наценка".

В итоге, добавил на командную панель табличной части "ДеревоЦен" кнопку "Установить наценку":


Процедура КР_УстановитьНаценку(Команда)
	
	Процент = 0;
	
	Массив = Новый Массив;
	Массив.Добавить(Тип("Число"));
	КЧ = Новый КвалификаторыЧисла(4,2);
	
	
	ПоказатьВводЗначения(Новый ОписаниеОповещения("КР_УстановитьНаценкуЗавершение", ЭтотОбъект, Новый Структура("Процент", Процент)), Процент,,Новый ОписаниеТипов(Массив,КЧ));
	
КонецПроцедуры

&НаКлиенте
Процедура КР_УстановитьНаценкуЗавершение(Значение, ДополнительныеПараметры) Экспорт
	
	Процент = ?(Значение = Неопределено, ДополнительныеПараметры.Процент, Значение);
	
	
	Для Каждого ТекущаяСтрока Из ДеревоЦен.ПолучитьЭлементы() Цикл  
		
		Если ТекущаяСтрока <> Неопределено Тогда
			
			Для Каждого ЭлементФормы Из Элементы Цикл
				
				Если Найти(ЭлементФормы.Имя, "ПроцентНаценки") > 0 Тогда
					
					Если ТипЗнч(ЭлементФормы) = Тип("ПолеФормы") Тогда
						
						ИмяКолонкиЦены = СтрЗаменить(СтрЗаменить(ЭлементФормы.Имя,"ДеревоЦен",""),"ПроцентНаценки", "");
						
						ВЫПОЛНИТЬ("ТекущаяСтрока."+ИмяКолонкиЦены+" = "+Процент+";");
						
						ИдентификаторСтроки = ТекущаяСтрока.ПолучитьИдентификатор();
						ПроцентНаценкиПриИзменении(ИдентификаторСтроки, ИмяКолонкиЦены, Процент);
						
						Прервать;
						
					КонецЕсли;
				КонецЕсли;
				
			КонецЦикла;
		КонецЕсли;
		
	КонецЦикла;
	
	
КонецПроцедуры
...Показать Скрыть