gifts2017

Загрузка данных из ТСД с возможностью создания (определения) товаров с неизвестным штрихкодом + очистка справочника после загрузки.

Опубликовал Артем Медведев (Consultant_1C) в раздел Оборудование - Терминал сбора данных

Загрузка данных из ТСД с возможностью создания (определения) товаров с неизвестным штрихкодом + очистка справочника после загрузки.

Обработка позволяет по время загрузки создать (определить) товар для неизвестных штрихкодов. Тестировал на ТСД Opticon SMART с MobileLogistic: Сбор Данных.

В архиве приложено два файла:

  1. Обработка взаимодествия с ТСД от Атол;
  2. Обработка Загрузка данных из ТСД;

Для возможности очистки ТСД после загрузки необхтдимо в обработку ТОСервер добавить функцию:

Функция ОчиститьТаблицуТСД(Идентификатор)Экспорт

	Обработка = Неопределено;
	Объект    = Неопределено;
	Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);

	Если НЕ ЗначениеЗаполнено(Результат) Тогда
		Результат = Обработка.ОчиститьТаблицу(Объект);
		мОписаниеОшибки = Объект.ОписаниеОшибки;
	Иначе
		мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ТСД");
	КонецЕсли;

	Возврат Результат;

КонецФункции
В обработке заполнения табличной части "Загрузка данных из ТСД" в процедуре "Инициализировать" убрать комментарий со строк:
	//Очистка	
	//Текст = "Желаете очистить ТСД?";
	//Режим = РежимДиалогаВопрос.ДаНет;
	//Ответ = Вопрос(Текст, Режим);
	//Если Ответ = КодВозвратаДиалога.Да Тогда
	//	Результат = ПолучитьСерверТО().ОчиститьТаблицуТСД(Терминал);
	//	Ошибки = ПолучитьТекстОшибкиТСДТО(Результат);
	//	Если НЕ ПустаяСтрока(Ошибки) Тогда
	//		Сообщить("Не удалось очистить данные:" + Символы.ПС + Ошибки);	
	//	КонецЕсли;
	//КонецЕсли;
	//
 

Скачать файлы

Наименование Файл Версия Размер
Обработка табличной части (Загрузка данных из ТСД) 45
.7z 37,98Kb
19.03.14
45
.7z 37,98Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа