gifts2017

Регистр сведений для хранения дополнительных данных

Опубликовал Дмитрий (petname) в раздел Программирование - Практика программирования

Бывает необходимость для хранения доп данных в зависимости от места расположения базы и пользователя, для этого был создан дополнительный Регистр Сведений

Измерения

  Пользователь     (СправочникСсылка.Пользователи)

  Контекст             (Строка 100)

  Идентификатор (Строка 100)

  СтрокаСоединенияСИБ (Строка 100)

Ресурсы

  Значение            (ЛюбаяСсылка, Булево, Строка, Дата, Число)

 

 

В модуле ФормыСписка на событие ПриНачалеРедактирования написано условие на добавление новой строки.

Процедура РегистрСведенийСписокПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока Тогда
        ТекСтрока = ЭлементыФормы.РегистрСведенийСписок.ТекущиеДанные;
        ТекСтрока.СтрокаСоединенияСИБ = СтрокаСоединенияИнформационнойБазы();
    КонецЕсли;
КонецПроцедуры

В модуль объекта добавлена функция:

Функция ПолучитьЗначение(Контекст,Идентификатор) Экспорт
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    Нов_Константы.Значение
    |ИЗ
    |    РегистрСведений.Нов_Константы КАК Нов_Константы
    |ГДЕ
    |    Нов_Константы.Пользователь В (&Пользователь, ЗНАЧЕНИЕ(Справочник.Пользователи.ПустаяСсылка))
    |    И Нов_Константы.Контекст = &Контекст
    |    И Нов_Константы.Идентификатор = &Идентификатор
    |    И Нов_Константы.СтрокаСоединенияСИБ В (&СтрокаСоединенияСИБ, """")
    |
    |УПОРЯДОЧИТЬ ПО
    |    Нов_Константы.СтрокаСоединенияСИБ УБЫВ,
    |    Нов_Константы.Пользователь УБЫВ";
    
    Запрос.УстановитьПараметр("Пользователь",ПараметрыСеанса.ТекущийПользователь);
    Запрос.УстановитьПараметр("Контекст",Контекст);
    Запрос.УстановитьПараметр("Идентификатор",Идентификатор);
    Запрос.УстановитьПараметр("СтрокаСоединенияСИБ",СтрокаСоединенияИнформационнойБазы());
    Выборка = Запрос.Выполнить().Выбрать();
    
    Если Выборка.Следующий() Тогда
        Значение = Выборка.Значение;
    Иначе
        Выборка = Неопределено;
    КонецЕсли;
    
    Возврат Значение;    
    
КонецФункции

 

Пример использования данного регистра:

СоздатьПисьмо(РегистрыСведений.Нов_Константы.ПолучитьЗначение("Почта","НовыеКонтрагенты"),МассивСтрок);

P.S. Идея не моя, но очень хорошая в плане использования регл. заданий, внешних обработок и т.п.

       В дальнейшем думаю выложить пару вещей с использованием данного регистра.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Павел Чистов (GROOVY) 20.03.14 00:03
Поправьте "индификаторы" и "регламентированные", а то очень глаза режет.

О чем статья не понял.
2. Дмитрий (petname) 20.03.14 11:08
(1) GROOVY, спасибо, если не трудно посмотрите еще разок после редактирования. Коряво конечно, но мысль заключается в том чтобы хранить данные которые будут завязаны не только на определенные идентификатор, но и на пользователя и место соединения с базой.

PS русский не был моим любимым предметом в школе. (((
3. Саша Безымяный (help1Ckr) 26.03.14 12:30
(2) petname, поддержу Павла - непонятна суть регистра. Что именно собираетесь хранить в регистре сведений?
4. Дмитрий (petname) 26.03.14 15:03
(3) help1Ckr, в данный момент там хранятся ссылки на базы пользователи и пароли для ком соединения, почтовые адреса для рассылки специальных писем из внешних обработок (из клиент банка изменения посылаю ответственным лицам например)
5. Алексей Т. (CratosX) 26.03.14 21:43
А где в новом дизайне сайта можно ставить "минус"?
6. Александр Журавлев (apostal86) 03.04.14 11:06
Это у Вас пример для типовой конфигурации какой-то или самописной? Если для типовой, то не помогает механизм дополнительных свойств и категорий(по другому доп. реквизитов), для справочников и документов? Меня этот механизм часто спасал, чтоб можно было хранить доп. данные без доработки конфы и работат/обрабатывать эти дополнительные данные.
7. Дмитрий (petname) 03.04.14 11:26
(6) apostal86, Забыл указать что права на его просмотр и добавления ограничены. это помогает при обновлении. конфига ЗУП правда переписанная в хлам.
8. mikhailovaew (mikhailovaew) 10.04.14 17:48
Не вполне понятно назначение измерения СтрокаСоединенияСИБ. При работе с одной и той же базой (куда интегрирована Ваша подсистема) значение не будет меняться. Для каких целей понадобилось это измерение?
9. Дмитрий (petname) 10.04.14 19:53
(8) mikhailovaew, работаешь с копией а забыл например отключить регламентные задания по выгрузке в другие базы
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа