gifts2017

Загрузка курсов валют на клиенте для БП 3 и ERP 2

Опубликовал Константин Хрипков (mbreaker) в раздел Обработки - Обработка справочников

Данные по курсам валют с сайта РБК загружаются на стороне клиента и передаются на сервер для обработки. Обработка полезна когда на сервере 1С:Предприятия нет выхода в интернет, а на локальном клиенте есть.

Штатная обработка загрузки курсов не работает в клиент-серверном варианте, если на сервере нет выхода в интернет. Эта модифицированная её версия решает данную проблему, закачивая файлы на стороне клиента.

Обработка соответствует требованиям БСП 2.2 и легко подключается в качестве дополнительной обработки.

Основные отличия от штатной:

  • Данные загружаются на локальном компьютере, а не на сервере
  • Форма обработки не закрывается автоматически в случае актуальных курсов
  • Обработка не формирует оповещения для открытых форм после загрузки курсов

Основана на штатной обработке.

Версии для БП и ERP различаются. Будьте внимательны!

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Внешняя подключаемая обработка "Загрузка курсов валют на клиенте для БП 3"
.epf 17,21Kb
10.08.16
59
.epf 1.1 17,21Kb 59 Скачать
Внешняя подключаемая обработка "Загрузка курсов валют на клиенте для ERP 2"
.epf 19,04Kb
10.08.16
1
.epf 1.1 19,04Kb 1 Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. Nick (Puk2) 01.09.14 17:01
В дополнительные параметры запуска базы прописываем "/Execute "U:\1C\Files\ЗагрузкаКурсовВалютКлиент.epf"", подпиливаем обработку, что бы при открытии не открывался диалог, а курсы обновлялись в тихую от последней даты, если в этом есть необходимость. Пользователь в правом нижнем углу только увидит уведомление о том, что курсы актуальны, либо загрузились.
Вроде качал эту обработку, изменения следующие в модуле формы:
&НаКлиенте
Процедура ЗагрузитьКурсыСРБК() 
...
	Состояние(НСтр("ru = 'Загрузка курсов валют завершена.'")); //+++АК---
	
	//ОбновитьСведенияВСпискеВалют(); //+++АК---
	
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	Если СообщитьЧтоКурсыАктуальны Тогда
		РаботаСКурсамиВалютКлиент.ОповеститьКурсыАктуальны();
		Закрыть(); //+++АК---
		Возврат; //+++АК---
	КонецЕсли;
	
	ЗагрузитьКурсыВалют(); //+++АК---
	Закрыть(); //+++АК---
	
	//ПодключитьОбработчикОжидания("ПроверитьСписокЗагружаемыхВалют", 0.1, Истина);
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

	//+++АК+++
	Если Не ПравоДоступа("Изменение", Метаданные.РегистрыСведений.КурсыВалют) Тогда
		Отказ = Истина;
		Возврат;
	КонецЕсли;
	//---АК---
...
КонецПроцедуры
...Показать Скрыть
2. Константин Хрипков (mbreaker) 01.09.14 17:54
(1) Puk2, автозагрузка курсов при старте? ну да, как один из вариантов применения...
3. Nick (Puk2) 01.09.14 18:50
(2) mbreaker, да. Сейчас читаю своё сообщение и понимаю, что чего-то не хватает. Именно для этой цели необходимо сделать описанные действия. Правда есть один минус - право на запуск внешних обработок. Ещё не разбирался, но по-моему в механизмах БСП нет возможности прописать запуск обработки, зарегистрированной как дополнительная.
4. andrey a (zager) 06.02.15 05:57
Спасибо за обработку!
Не подгружались курсы в клиент-сервере. Прав никаких не было, а нужно было "еще вчера"
5. Константин Хрипков (mbreaker) 09.02.15 10:34
(4) zager, примерно такая же история и побудила на создание этой обработки.
7. Денис Коробов (Torin57) 06.06.15 20:35
Отличная штука. У нас в организации тоже нет интернета на сервере. Возникла проблема при работе с базой через браузер. Выскакивает ошибка тип не определен 'HTTPСОЕДИНЕНИЕ'. В тонком клиенте через веб работает нормально.
Есть ли способ эту ошибку побороть?
Можно ли в принципе закачать курсы валют в веб клиенте?
8. Сергей Кудашкин (sikuda) 23.05.16 17:44
Бухгалтерия предприятия, редакция 3.0 (3.0.43.206)
ЗагрузитьКурсВалютыИзФайла уже не экспортная функция, ее пришлось перенести в обработку стр 170.
Еще переносим ВыделитьПодСтроку и все прекрасно работает.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа