IE 2016

COM соединения к базам 1С на различных версиях платформы

Опубликовал leonid_kirienko в раздел Программирование - Практика программирования

Долгое время искал возможность подключаться через COM соединение к серверным БД 1С, расположенных на разных серверах (с разными версиями платформ). Перечитал множество публикаций на эту тему, но однозначного для себя ответа не находил. Хочу поделиться своим скромным опытом в решении этой задачи. Может кому и пригодится...

Для создания COM соединения с рабочей станции необходимо наличие в составе установки библиотеки comcntr.dllДумаю об этом лишний раз напоминать не нужно.

Соответственно, для соединения с БД на различных серверных платформах необходимо иметь в комплекте библиотеки всех нужных версий. 

Предполагается, что клиентские платформы установлены в стандартных каталогах и добраться до библиотек можно по пути типа: C:\Program Files (x86)\1cv82\8.2.18.61\bin\comcntr.dll

Для начала создадим для коннектора обертку COM+, чтобы вызовы происходили не в контексте 1cv8.exe (1cv8c.exe), а в контексте dllhost.exe

В интернете достаточно публикаций на тему как это сделать... Для начала можно указать comcntr любой имеющейся версии.

При регистрации comcntr.dll в реестре делается запись: 

HKEY_CLASSES_ROOT\CLSID\{2B0C1632-A199-4350-AA2D-2AEE3D2D573A}\InprocServer32 для 32 битной ОС

или HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{2B0C1632-A199-4350-AA2D-2AEE3D2D573A}\InprocServer32 для 64 битной ОС

значение по умолчанию которой указывает на расположение загружаемой библиотеки: C:\Program Files (x86)\1cv82\8.2.18.61\bin\comcntr.dll

Этим значением мы и будем оперировать. Перед установкой соединения читаем реестр, проверяем текущую версию коннектора и при необходимости заменяем ее на требуемую. После установки соединения в память загружается dllhost.exe, в контексте которого и работает коннектор. Для инициализации соединения к другой базе (с отличающейся версией платформы), ранее отработавшую библиотеку нужно выгрузить из памяти. К сожалению, у меня не получилось сделать это более цивилизованно, чем taskkill.exe /f /im dllhost.exe. Наверняка можно что-то покрасивее придумать...

Ну и самое главное: не забываем, что работать это будет только при запуске 1С с административными правами. Иначе взлетит исключение.

В итоге получаем примерно такой код:


 

Функция ОбновитьКлючРеестра(знач Ключ, знач ТребуемаяВерсия)
	WshShell = Новый COMОбъект("WScript.Shell");	
	Значение = WshShell.RegRead(Ключ);
	Значение1= СтрЗаменить(Значение, "\", Символы.ПС);
	ВерсияОпределена = ложь;
	Для ТекНомер=1 По СтрЧислоСтрок(Значение1) Цикл
		ТекущаяВерсия = СтрПолучитьСтроку(Значение1, ТекНомер);
		Если Лев(ТекущаяВерсия,2)="8." Тогда
			ВерсияОпределена = истина;
			прервать;
		КонецЕсли; 
	КонецЦикла; 
	Если ВерсияОпределена и ТекущаяВерсия<>ТребуемаяВерсия Тогда
		Значение = СтрЗаменить(Значение, ТекущаяВерсия, ТребуемаяВерсия);
		WshShell.RegWrite(Ключ, Значение);
		Возврат Истина;
	иначе 
		Возврат ложь;
	КонецЕсли; 
КонецФункции

Процедура НастроитьКоннектор(знач ТребуемаяВерсия)
	Обновлен = ОбновитьКлючРеестра("HKEY_CLASSES_ROOT\CLSID\{2B0C1632-A199-4350-AA2D-2AEE3D2D573A}\InprocServer32\", ТребуемаяВерсия);
	Если Обновлен Тогда
		ЗапуститьПриложение("taskkill.exe /f /im dllhost.exe",,Истина);
	КонецЕсли; 
КонецПроцедуры

 


Сам вызов осуществляю примерно так:

Для каждого СтрокаТЧ Из СписокБаз Цикл
    НастроитьКоннектор(СтрокаТЧ.Платформа);
    V8 = Новый COMObject ("V82.COMConnector");

    ............

КонецЦикла

Если два последовательных соединения требуют коннектора одной и той же версии, то модификации реестра не происходит и библиотека из памяти не выгружается, что несколько сокращает "накладные расходы"... 

 Опробовано на COM соединениях из толстого клиента к серверным базам на платформах 8.2.x.x

См. также

Лучшие комментарии

8. Созинов 15.05.2014 10:09
(6) EvgeniuXP, проблемы возникают из-за разных релизов на сервере. Бывают ситуации когда приходится держать разные версии серверов (у нас допустим это 8.2.15.319, 8.2.18.61, 8.2.19.90 и 8.1 и 8.3.3.721) и если стоит задача получать данные со всех серверов - то это трудновато через COM.
Автору +
+ 2 [ winterspring; pt_olga; ]
# Ответить
9. kiruha 04.06.2014 10:25
Мы обычно делаем банально
regsvr32 "C:\Program Files (x86)\1cv82\8.2.18.61\bin\comcntr.dll" (для 8.2.18.61 из сабжа например)
Зачем нужна обертка ? И чем плох такой простой метод ?
+ 1 [ awk; ]
# Ответить

Комментарии

1. fancy 08.05.2014 07:01
А если убьете "чужой" dllhost?
ЗапуститьПриложение("taskkill.exe /f /im dllhost.exe",,Истина);
# Ответить
2. JusteRU 08.05.2014 08:02
Про административные права немного не понял. Т.е. требуется запускать сервер приложений с административными правами?
Ответили: (3)
# Ответить
3. kapustinag 10.05.2014 16:09
(2) JusteRU, Административные права нужны не серверу приложений, а клиентскому процессу 1С-Предприятие, из которого будут выполняться перенастройки ключа реестра, в котором содержится путь к comcntr.dll.
# Ответить
4. amon_ra 14.05.2014 10:15
способ отличный, но вот только права админа все омрачают(((
# Ответить
5. mmch 14.05.2014 10:24
Недавно столкнулся с похожей проблемой при переходе на 8.3, КОМ соединение вызывалось именно &НаСеревере
в итоге была ОШИБКА ПРИ СОЗДАНИИ COMОбъект Интерфейс не поддерживается.

После этого выработал инструкцию по установке платформы 1с для работы с COM-соединением, может кому пригодится...

Переустановка платформы 1с, установка сервера:

*Ставим серверную версию из дистрибутива \\Платформа\X.X.XX.XX\windows64.rar на все рабочие сервера 1с
*обязательно ставим возможность подключения через COM-соединение
*обязательно ставим возможность подключения через WEB-соединение
*Ставим клиентскую часть на все компьютеры в сети из дистрибутива \\Платформа\X.X.XX.XX\windows.rar
*Обязательно ставим клиентскую часть на сервера, т.к. без этого не будут работать подключения через COM-объект
*обязательно ставим возможность подключения через WEB-соединение
*ОШИБКА ПРИ СОЗДАНИИ COMОбъект Интерфейс не поддерживается при всех выполненных действиях:
*Например при запуске на сервере 83, COMОбъект 82, тогда необходимо пользователя USR1CV8 добавить в группу Локальные Администраторы (Диспетчер сервера - Конфигурация - Локальные пользователи - группы - Администраторы)

тогда подключение работает в контексте 1cv8.exe...
* правда администраторам придется поступиться безопасностью...
# Ответить
6. EvgeniuXP 14.05.2014 18:15
По-моему с 8.х нет проблем соединяться и получать и отправлять данные по COM-соединению... а вот как сделать для 7.7 - тоже кучу нарыл, но так еще не сделал - либо простые способы, где ТЗ не знаешь как передать, либо - сложно - какие-то dll, как их к веб-сервису прикрутить и потом в 1С-ке "получить" OLE и передать параметром ТЗ, а в 7.7 на основании этой ТЗ создать элементы справочника. Только нашел как вызывать глобальные функции, да примитивные типы передавать... с ТЗ подружить не могу пока что...
Ответили: (8)
# Ответить
7. EvgeniuXP 14.05.2014 18:20
хотя уже на всё плюнул 8.3 (отправка ТЗ) -> веб-сервис -> 7.7 (получение ТЗ и создание элементов в справочнике)

и начал изучать основательно С#.
# Ответить
8. Созинов 15.05.2014 10:09
(6) EvgeniuXP, проблемы возникают из-за разных релизов на сервере. Бывают ситуации когда приходится держать разные версии серверов (у нас допустим это 8.2.15.319, 8.2.18.61, 8.2.19.90 и 8.1 и 8.3.3.721) и если стоит задача получать данные со всех серверов - то это трудновато через COM.
Автору +
+ 2 [ winterspring; pt_olga; ]
# Ответить
9. kiruha 04.06.2014 10:25
Мы обычно делаем банально
regsvr32 "C:\Program Files (x86)\1cv82\8.2.18.61\bin\comcntr.dll" (для 8.2.18.61 из сабжа например)
Зачем нужна обертка ? И чем плох такой простой метод ?
+ 1 [ awk; ]
# Ответить
10. DoctorRoza 04.06.2014 15:35
ИМХО, все как в России, когда полы грязные, не ноги отряхиваем, а щетку апгрейдим! Когда в it-экосистеме предприятия стоят разные версии 8.x, тогда нужно давать по рукам админу! А за статью плюс! :)
Ответили: (11) (16)
# Ответить
11. servs 06.06.2014 13:16
(10) бывают фирмы, которые обслуживают базы клиентов на своем сервере, у каждого клиента должна быть своя версия. (это я Вам для расширения кругозора объяснил)
Ответили: (18)
# Ответить
12. Serg3141 30.06.2014 11:54
супер, мне помогло - на двух серверах разные версии 1С, необходимо было сделать передачу, а приводить версии в соответствие не дает начальник из-за загруженности на более старом сервере 1С и из-за принципа "не трожь, все и так работает"
# Ответить
13. zakiap 14.10.2014 03:43
А не проще ли сделать алиасы на COM объекты в нужном виде и использовать их потом так:

В8 = Новый COMОбъект("V8.2.19.83.COMConnector");
В8 = Новый COMОбъект("V8.3.5.1119.COMConnector");
Ответили: (14)

Прикрепленные файлы:

Снимок экрана.png
# Ответить
14. leonid_kirienko 15.10.2014 18:51
(13) zakiap, для разных версий (8.2, 8.3) применение алиасов может и пройдет, но для разных сборок одной версии платформы - нет. UID коннектора один и тот же - вот беда.
# Ответить
15. Tolpinski 16.10.2014 09:27
Через "regsvr32 "C:\Program Files (x86)\1cv82\8.2." срабатывает как то странно, с задержкой, видно как и пишется из за "dllhost.exe"
В общем спасибо, работает!
# Ответить
16. besica 11.12.2014 23:44
(10) DoctorRoza, 1С бух не хочет работать на платформах ниже 8.3.5.... А не типовая база на 100+ пользователей произвольно виснет у различных пользователей на 8.3.5. платформе, при этом на 8.3.4 все отлично работает. А базы друг с другом общаться должны по чуть чуть и по запросу, но в течении дня.
Автору огромный +)))
# Ответить
17. kostyaomsk 17.12.2014 20:11
Тоже хороший материал для создания универсальных обработок, которые должны работать "где попало и подцепляться куда попало". Поставил плюс чтоб запомнить.
# Ответить
18. selig 27.04.2015 09:31
(11) servs, а еще бывают конфигурации от горячо любимых разработчиков, которые тупят на новых версиях платформы
# Ответить
19. e.kogan 19.03.2016 21:46
Ветки реестра нет :(
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл






IE 2016