gifts2017

Остатки отпусков

Опубликовал Piotr (Tolpinski) в раздел Отчеты - Бухгалтерские

Остатки отпусков по списку сотрудников, данные аналогичны Справке по отпуску
Остатки отпусков по списку сотрудников, данные аналогичны Справке по отпуску
+Подразделение
+Должность
Остаток как и в оригинале делится на основной и дополнительный.
Заполнение списка стандартное для ЗУП, с фильтрами, подбором.



До сих пор выявляем кривости перехода с 7.7

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Остатки отпусков основные и дополнительные.erf
.erf 11,68Kb
17.07.14
35
.erf 01 11,68Kb 35 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. VeRkA 16.07.14 05:54
Остатки дополнительного тоже считает, или только основной?
sergiobargio1; +1 Ответить 1
2. Piotr (Tolpinski) 16.07.14 07:39
(1) VeRkA,
И основной и дополнительный. Картинки с демо базы, а там доп. не нашлось :)
Прикрепленные файлы:
3. Sergio Bargio (sergiobargio1) 17.07.14 12:30
Tolpinski? подскажите, пожалуйста, как прикреплять или вызывать доп.внеш.отчёт? Традиционно прикрепил, при нажатии кнопки "Заполнить" выдаёт сообщение: "Не указана организация, отобрать список сотрудников невозможно!". Нажатие кнопки "Сформировать" выдаёт не заполненную таблицу. Где указать организацию?
4. Piotr (Tolpinski) 17.07.14 13:15
(3) sergiobargio1,
Берется "Основная организация" пользователя, Сервис-Настройка пользователя > Основная организация.
5. Gingema *** (Gingema) 20.08.14 17:43
Отличный отчет, спасибо, пригодился
Tolpinski; +1 Ответить
6. Gingema *** (Gingema) 21.08.14 10:33
Жаль только что в отчет не попадают всетаки доп. отпуска (((
7. Gingema *** (Gingema) 21.08.14 12:04
(6) Gingema, немножко подправила, может кому пригодится

Для Каждого Стр Из Результат Цикл
		ОбластьМакетаСтрока.Параметры.Заполнить(Стр);
		
		ОбластьМакетаСтрока.Параметры.Основной = 0;
		ОбластьМакетаСтрока.Параметры.Дополнительный = 0;
		
		Для Каждого Индекс Из Стр.ОстатокНаДатуПоВидамЕжегодныхОтпусков Цикл                //Стр2
			Если СокрЛП(Индекс.ВидЕжегодногоОтпуска.Наименование) = "Основной ежегодный отпуск" Тогда        //Стр2
				ОбластьМакетаСтрока.Параметры.Основной = Индекс.КоличествоДней;      //стр2
			КонецЕсли;	
			Если СокрЛП(Индекс.ВидЕжегодногоОтпуска.Наименование) = "Ежегодный дополнительный отпуск" Тогда  //стр2
				ОбластьМакетаСтрока.Параметры.Дополнительный = Индекс.КоличествоДней;    //стр2
			КонецЕсли;
			ОбластьМакетаСтрока.Параметры.Всего = ОбластьМакетаСтрока.Параметры.Основной + ОбластьМакетаСтрока.Параметры.Дополнительный;
		КонецЦикла;	
...Показать Скрыть

8. Piotr (Tolpinski) 21.08.14 16:13
(7) Gingema,
Не смог смоделировать не попадание доп. отпуска..

Внимательно изучил код, разницу вижу только в
ОбластьМакетаСтрока.Параметры.Всего = ОбластьМакетаСтрока.Параметры.Основной + ОбластьМакетаСтрока.Параметры.Дополнительный;
только тогда и макет надо вылаживать
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа