gifts2017

Сравнение документов любых конфигураций

Опубликовал Александр Пирожков (Stavsles) в раздел Обработки - Универсальные обработки

Обработка позволяет сравнить любые документы в 2-х базах с любыми конфигурациями по любым реквизитам по любым видам документов.

Обработка позволяет сравнить документы в двух базах, с любыми конфигурациями (например УТ-БП), при этом сравниваются только найденные реквизиты.

Поиск идет по уникальному идентификатору, если кому не подойдет, можете переделать на поиск по номеру (изменить придется 2-3 строки).

Обработка создавалась для проверки обмена и пресечения редактирования документов после выгрузки. Сравнивает любые документы, реквизиты и табличные части.

Работает с 8.1 - 8.2 в режиме обычного приложения. Можно выбрать как список видов документов для сравнения, так и конкретный вид документа, тогда появляется возможность настройки полей для отбора (реквизитов документа и ТЧ).

Работает быстро (Сравнивал на 10 тыс. документов, отрабатывала примерно 5 минут). 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Сравнение документов
.epf 35,44Kb
18.08.14
256
.epf 35,44Kb 256 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Макас (makas) 19.08.14 12:00
Обработка в базах SQL (УТ и БП) будет сравнивать документы?
2. Александр Пирожков (Stavsles) 19.08.14 14:23
Да, там есть возможность выбора файловой или серверной базы.
3. ceramica (ceramica) 04.09.14 09:41
А для УФ будет? Хотелось бы так, как тенденция всеобщего перехода на УФ прогрессирует
4. Александр Пирожков (Stavsles) 04.09.14 12:21
(3) ceramica, В ближайшее время точно не будет. У меня не хватает времени взяться за переработку этой обработки. Но в будущем вполне возможно что сделаю.
5. Павел (Yimaida) 09.09.14 14:01
Добрый день.
Stavsles, опишите, пожалуйста, как идет сопоставление (сравнение) справочников. А так же как отрабатывается ситуация перемешивания строк в документах, т.е. когда поменялся порядок строк.
6. Александр Пирожков (Stavsles) 09.09.14 13:32
(5) Yimaida,
Добрый день! Обработка сравнивает справочники по наименованию. Имеется возможность выбора реквизитов для сравнения, например если из одной базы документы перебрасываются в другую на другую организацию, то можно просто исключить этот реквизит из проверки и обработка не будет по нему искать различия. В случае, когда поменялся порядок строк обработка выдаст сообщение о том, что строки различаются, сопоставление идет по номеру. Посмотрев на подробный отчет вы можете легко понять, что кроме порядка ничего не поменялось.
8. dassin A (dassin) 31.07.15 08:58
Спасибо за работу. Обработка пригодилась, хотя снимать галочки по полям было неудобно. В открывающемся диалоговом окне "Список полей для выбора" неплохо бы добавить возможность снятия пометок со всех полей (и наоборот), потому что по всем абсолютно полям не всегда нужно сравнивать. Зачем нужен раздел "дополнительные поля" совсем непонятно. :)
9. Александр Пирожков (Stavsles) 31.07.15 16:52
(8) dassin,
Рад что обработка пригодилась! По галочкам в контексте моей задачи как раз необходимо было сравнение по всем полям, исключая лишь некоторые, поэтому о кнопке убрать все и отметить все я сразу и не подумал. Дополнительные поля необходимы для удобства просмотра найденных различий по документу непосредственно на форме обработки, в табличной части "Обнаруженные различия".
10. Tanka07 Tanka07 (Tanka07) 24.08.15 13:20
Здравствуйте! Очень нужна данная обработка, но не могу с ней справиться, выдает ошибку:

{Форма.Форма.Форма(833)}: Ошибка при вызове конструктора (ComObject)
ComConnection = Новый ComObject(СтрокаВерсияКоннектора);
по причине:
Недопустимая строка с указанием класса

Пытаюсь сравнить две базы Бухгалтерия предприятия, редакция 2.0 (2.0.64.20)
Файловая версия
Пользователя указываю, он без пароля
Пробовала когда вторая база не запущена и когда запущена, ошибка одна и та же

Платформа: 8.2.19.102
Win 7
Прикрепленные файлы:
11. Tanka07 Tanka07 (Tanka07) 24.08.15 14:17
Все работает. нужно было зарегистрирвоать comcntr.dll
12. Михаил Пинягин (mikepin) 19.07.16 08:07
13. Сергей (armeec) 19.07.16 16:43
Проблемная часть обработки (стр. 240-256) (Превращает реквизит типа Счет плана счетов из ,например, "60.02" просто в "60" ->Число->Окр->Строка....):

ЗначениеПодключеннойБазы = ПодключеннаяБаза.String(ВыборкаДокументовПодключеннойБазы[Реквизит.Значение]);
//
//Если ЗначениеПодключеннойБазы = "Да" Тогда
// ЗначениеПодключеннойБазы = "истина";
//КонецЕсли;
//Если ЗначениеПодключеннойБазы = "Нет"
// Тогда ЗначениеПодключеннойБазы = "ложь";
//КонецЕсли;
Если Не(ЗначениеПодключеннойБазы = "истина" или ЗначениеПодключеннойБазы = "ложь") Тогда
Попытка
ЗначениеПодключеннойБазы = Число(ЗначениеПодключеннойБазы);
ЗначениеПодключеннойБазы = Окр(ЗначениеПодключеннойБазы,ВидДокументаОбъект.Реквизиты[Реквизит.Значение].Тип.КвалификаторыЧисла.РазрядностьДробнойЧасти);
ЗначениеПодключеннойБазы = Строка(ЗначениеПодключеннойБазы);
Исключение
КонецПопытки;

КонецЕсли;


Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа