Версионирование объектов. Отчет "История изменений за период"

Опубликовал Тактик 1С (Taktic) в раздел Администрирование - Журнал регистрации

Странно, но в подсистеме "версионирование объектов" в УПП и КА 8 всего один отчет "История изменений объектов", который позволяет сравнить версии одного объекта. Ни для чего больше подсистема не используется.
Простой отчет и небольшая доработка конфигурации позволит получать информацию за период о том, кто и какие версионируемые объекты изменял и что именно было в них изменено.

1. Необходимо добавить в форму отчета "История изменений объектов" реквизит формы "ПараметрИспользуемыйПриОткрытии".

2. Добавить процедуру в модуль формы

Процедура ПриОткрытии()
	
	СсылкаНаОбъект = ПараметрИспользуемыйПриОткрытии;
	СформироватьТаблицуВерсий();
	Если СписокВерсий.Количество()>1 Тогда

		ЭлементыФормы.СписокВерсий.ТекущаяСтрока = СписокВерсий[СписокВерсий.Количество()-1];
		Для Счетчик = СписокВерсий.Количество()-2 По СписокВерсий.Количество()-1 Цикл
			ЭлементыФормы.СписокВерсий.ВыделенныеСтроки.Добавить(СписокВерсий[Счетчик]);
		КонецЦикла;
		ОсновныеДействияФормыДействиеОтчетПоИзменениям(Неопределено);
		
	КонецЕсли;
	
КонецПроцедуры

3. Добавить в конфигурацию сам отчет или использовать его как внешний.

Скачать файлы

Наименование Файл Версия Размер
ИсторияИзмененийЗаПериод.erf
.erf 14,51Kb
25.09.14
51
.erf 14,51Kb 51 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Александр Чесноков (chesnokov-a-v) 97 28.01.17 19:10 Сейчас в теме
Отчет работает, но нужно поменять порядок сравнения версий. А то сейчас получается если в документ добавили новую строку в таб. часть - отчет показывает как-будто ее наоборот удалили.
2. Александр Чесноков (chesnokov-a-v) 97 28.01.17 19:21 Сейчас в теме
ЭлементыФормы.СписокВерсий.ТекущаяСтрока = СписокВерсий[СписокВерсий.Количество()-2];


Т.е. вместо 1 нужно всего лишь поставить 2. Все.
Отчет классный.