gifts2017

АРМ "Запись на ремонт" для Альфа-Авто: Автосервис+Автозапчасти. Редакция 4.1

Опубликовал Князь (Князь) в раздел Обработки - Рабочее место

АРМ записи на ремонт, правленный под контекст 4 редакции Альфа-Авто.

Как известно, АРМы объявились лишь в 5 редакции Альфа-Авто. Но некоторые официальные пользователи не могут перейти на эту редакцию ввиду сильной измененности типовой конфигурации, а новые возможности заполучить хочется.

Поэтому предлагается вашему вниманию измененная обработка под предыдущую редакцию, а также файл отчёта о сравнении, содержащий необходимые малочисленные изменения в конфигурации помимо добавленной обработки.

Скачать файлы

Наименование Файл Версия Размер
Обработка АРМа 22
.epf 198,15Kb
17.11.14
22
.epf 198,15Kb Скачать
Отчёт о сравнении конфигураций с необходимыми изменениями 14
.mxl 167,87Kb
17.11.14
14
.mxl 167,87Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Илья Коротков (molodoi1sneg) 17.11.14 15:11
Сделайте нормальные скриншоты!
2. Князь (Князь) 18.11.14 10:14
Такие скриншоты нормальные?! :-)
3. Oleg karp (Oleg1708) 19.11.14 14:50
Вообще в 4.1 есть запись на ремонт. обработка "ЗаписьНаРемонтИОбслуживание". Очень похожее на то что представлено. Шаг времени задан большой.
4. Max Popov (rngstr) 05.02.15 06:32
Добрый день. Вываливается ошибка при запуске.

{Форма.ИнтерфейсЗаписьНаРемонт.Форма(301,36)}: Переменная не определена (Планирование)
Для Каждого СтрокаПланирования Из <<?>>Планирование Цикл
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(335,2)}: Переменная не определена (Планирование)
<<?>>Планирование.Очистить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(346,10)}: Переменная не определена (Планирование)
Пока <<?>>Планирование.НайтиСтроки(Новый Структура("РабочееМесто,
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(358,27)}: Переменная не определена (Планирование)
НоваяСтрокаДокумента = <<?>>Планирование.Добавить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(372,25)}: Переменная не определена (Планирование)
ТаблицаПланирования = <<?>>Планирование.Выгрузить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(415,19)}: Переменная не определена (Планирование)
НоваяСтрока = <<?>>Планирование.Добавить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(428,36)}: Переменная не определена (Планирование)
Для каждого СтрокаПланирования Из <<?>>Планирование Цикл
5. Князь (Князь) 05.02.15 07:37
(4) rngstr, А конфигурация Альфа-Авто? Такая ошибка может выходить, если в конфигурации нет документа ЗаявкаНаРемонт с его табличной частью Планирование.
6. Иван Булхов (Touh_Of_soul)) 18.11.16 15:44
А можно конфу заместо файла Отчёт о сравнении конфигураций с необходимыми изменениями не понятно как по нему изменения вносить..
7. Вадим Алва (Бывалый77) 23.11.16 04:35
Альфа-Авто: Автосалон +Автосервис + Автозапчасти. Редакция 4.1 (4.1.01.20)

-------------
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(3553,96)}: Слишком много фактических параметров (ЗаполнитьРаботамиПоВидуРемонта)
8. Вадим Алва (Бывалый77) 23.11.16 04:50
Потребовалось 2 исправления:
//1.
//++
Макет	= ОбработкаОбъект.ПолучитьМакет("HTMLStyles");//Обработки.АРМЗаписьНаРемонт.ПолучитьМакет("HTMLStyles");
//--

//-----------------------------------------------------------------------------------------------

//2. 
//Процедура ПредложитьЗаполнитьРаботамиПоВидуРемонта(ЭтаФорма=Неопределено)  Экспорт
//....
			//++
			//ЗаполнитьРаботамиПоВидуРемонта(РежимОбработкиРаботы,РежимОбработкиПланирование,ТаблицаРабот,ЭтаФорма);
			ЗаполнитьРаботамиПоВидуРемонта_неТиповая(РежимОбработкиРаботы,РежимОбработкиПланирование,ТаблицаРабот,ЭтаФорма);
			//--
			
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

// Заполнение табличных частей "Работы" и "Планирование" по виду ремонта
// Параметры: РежимРаботы,РежимПланирование - обработка табличных частей
// 0 - не обрабатывать, 
// 1- заполнять без очистки, 
// 2 - заполнять с очисткой, 
// 3 - калькуляция, заполнять работы без исполнителей без очистки,
// 4 - калькуляция, заполнять работы без исполнителей с очисткой
Процедура ЗаполнитьРаботамиПоВидуРемонта_неТиповая(РежимРаботы=0, РежимПланирование=0, РаботыПоВидуРемонта, ЭтаФорма=Неопределено)  Экспорт
	
	Если РаботыПоВидуРемонта = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	// Очистим табличные части в зависимости от режимов
	Если РежимРаботы = 2 Тогда
		ЭтотОбъект.Работы.Очистить();
		ЭтотОбъект.Исполнители.Очистить();
	КонецЕсли;
	Если РежимРаботы = 4 Тогда
		ЭтотОбъект.Работы.Очистить();
	КонецЕсли;
	Если РежимПланирование = 2 Тогда
		ЭтотОбъект.Планирование.Очистить();
	КонецЕсли;
	
	// Заполним  
	МассивДобавленныхРабот = Новый СписокЗначений;
	Для Каждого СтрокаРабот Из РаботыПоВидуРемонта Цикл
		////ВидИспользованияАвтоработы = обПолучитьЗначениеСвойства(СтрокаРабот.Авторабота,ПланыВидовХарактеристик.СвойстваОбъектов.ВидИспользованияАвтоработы,Перечисления.ВидыИспользованияАвторабот.Производство);
		Если РежимРаботы > 0 Тогда
			// Поищем строку с такой работой в табличной части
			ТекСтрока = ЭтотОбъект.Работы.Найти(СтрокаРабот.Авторабота,"Работа");
			Если ТекСтрока <> Неопределено Тогда
				ТекСтрока.Количество = ТекСтрока.Количество + СтрокаРабот.Количество;
				ОбработкаРеквизита("Работы.Количество",ТекСтрока);
			Иначе
				ТекСтрока = ЭтотОбъект.Работы.Добавить();
				ТекСтрока.Работа = СтрокаРабот.Авторабота;
				ТекСтрока.Количество = СтрокаРабот.Количество;
				ОбработкаРеквизита("Работы.Работа",ТекСтрока);
				ТекСтрока.ИдентификаторРаботы = Новый УникальныйИдентификатор;
				Если ЭтаФорма<>Неопределено Тогда
					ЭтаФорма.ИдентификаторТекущейРаботы = ТекСтрока.ИдентификаторРаботы;
				КонецЕсли;
				МассивДобавленныхРабот.Добавить(ТекСтрока);
			КонецЕсли;
		КонецЕсли;
		Если РежимПланирование > 0 Тогда
			НоваяСтрока = ЭтотОбъект.Планирование.Добавить();
			НоваяСтрока.Авторабота = СтрокаРабот.Авторабота;
			ОбработкаРеквизита("Планирование.Авторабота",НоваяСтрока);
		КонецЕсли;
	КонецЦикла;
		
	////Если ЭтаФорма<>Неопределено Тогда
	////	Если МассивДобавленныхРабот.Количество() > 0 И РежимРаботы < 3 Тогда
	////		зфЗНЗаполнениеИсполнителей(ЭтаФорма,МассивДобавленныхРабот);	
	////	КонецЕсли;
	////КонецЕсли;
	
	#Если Клиент Тогда
	Если ЭтаФорма <> Неопределено Тогда
		Если РежимРаботы > 1 Тогда
			ВывестиПодвалСкидокРабот(ЭтаФорма);
		КонецЕсли;
		дкВывестиЗаголовокСуммаДокумента(ЭтаФорма);
	КонецЕсли;
	#КонецЕсли
	
КонецПроцедуры
...Показать Скрыть





Князь; +1 Ответить 1
9. Иван Булхов (Touh_Of_soul)) 28.11.16 10:16
(8)
Привет поделись мне как ты обновлял конфу через файл Отчёт о сравнении конфигураций с необходимыми изменениями ?


У меня версия Альфа-Авто: Автосалон +Автосервис + Автозапчасти. Редакция 4.1 (4.1.01.28)
Строки совсем не совпадают..
10. Иван Булхов (Touh_Of_soul)) 28.11.16 10:19
Жаль у него нет возможности вывода горизонтально исполнителей
11. Олег Сенцов (Agasaki) 29.11.16 10:23
Здравствуйте! Вылетает такая ошибка:
{Обработка.АРМЗаписьНаРемонт.Форма.ИнтерфейсЗаписьНаРемонт.Форма(3553,96)}: Слишком много фактических параметров (ЗаполнитьРаботамиПоВидуРемонта)
ЗаполнитьРаботамиПоВидуРемонта(РежимОбработкиРаботы,РежимОбработкиПланирование,ТаблицаРабот,<<?>>ЭтаФорма); (Проверка: Толстый клиент (обычное приложение))
{Обработка.АРМЗаписьНаРемонт.Форма.ИнтерфейсЗаписьНаРемонт.Форма(3566,11)}: Процедура или функция с указанным именем уже определена (ЗаполнитьРаботамиПоВидуРемонта)
Процедура <<?>>ЗаполнитьРаботамиПоВидуРемонта(РежимРаботы=0, РежимПланирование=0, РаботыПоВидуРемонта, ЭтаФорма=Неопределено) Экспорт (Проверка: Толстый клиент (обычное приложение))
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа