gifts2017

Отчёт по просроченной дебиторской задолженности для бухгалтерии (ФИФО)

Опубликовал AZel84 (AZel84) в раздел Отчеты - Бухгалтерские

Просроченная дебиторская задолженность по регистру бухгалтерии по 62-му счёту. Оплаты распределяются по методу ФИФО.
  • Отчёт на СКД.
  • По регистру бухгалтерии Хозрасчётный.
  • По 62-му счёту (при желании можно переделать на 60-й счёт).

Оплата покупателей распределяется на документ расчётов по методу ФИФО.

Алгоритм взят из следующих публикаций:

http://infostart.ru/public/75089/ - для БП 2.0

http://infostart.ru/public/122490/ - для УТ 10.3

 

Будет полезен, если:

  • не ведутся взаиморасчёты по документам расчёта (то есть на 62-м только субконто контрагент и договор).
  • ведутся взаиморасчёты по документам расчёта, но последовательность не восстановлена и невозможно добиться каждодневного восстановления последовательности. Так как после восстановления последовательности распределение долга по документам скорее всего будет меняться.
  • если невозможно получить данные из регистров накопления, например, есть ручные корректировки 62-го счёта
Особенности
  • Отчёт создавался для коплексной конфигурации, поэтому количество дней просрочки задаётся как дополнительное свойство договора контрагента "Дней отсрочки". Это свойтво нужно создать вручную, либо доработать отчёт.
  • В отчёт попадают авансы, как отрицательный долг, даже если документов, увеличивающих долг не было. Таким образом отчёт полностью сходится с ОСВ по 62-му.

Скорость работы
Зависит от объёма данных.
На тестовой базе заказчика формируется 3 секунды по всем контрагентам.
Для сравнения отчёт из публикации http://infostart.ru/public/75089/ формируется 1-1.5 минуты.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ОтчётПоПросроченнойЗадолженности_БП_ФИФО.erf
.erf 19,88Kb
20.11.14
77
.erf 1 19,88Kb 77 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей (ildarovich) 24.11.14 12:36
У меня вопрос:
Будет полезен, если:

не ведутся взаиморасчёты по документам расчёта (то есть на 62-м только субконто контрагент и договор).
а разве такое когда-нибудь бывает?
2. AZel84 (AZel84) 24.11.14 13:12
(1) ildarovich, если это не риторический вопрос :), то вот скрин из БП 3.0
3. Сергей (ildarovich) 24.11.14 14:48
(2) AZel84, ничего из этого скрина не понял. На мой взгляд, он показывает, что третье (документы взаиморасчетов) субконто на 62-м счете есть. Его нельзя отключить в настройках. Значит, взаиморасчеты по документам ведутся в БП всегда и отчет по ФИФО в этой конфигурации не нужен.
Вопрос не риторический. Я хотел свою разработку ускоренного ФИФО применить в БП, но решил, что там этот метод будет бесполезен, поскольку незакрытые отгрузки видны сразу из ОСВ по счету. А значит, просроченные долги определяются очень просто без всякого ФИФО.

Ну и лозунги на скриншоте абсолютно неуместны в контексте данного обсуждения.
4. Сергей (Che) Коцюра (CheBurator) 24.11.14 16:19
(3) По моему можно отключить ведение взаиморасчетов в разрезе расчетных документов.
5. Сергей (ildarovich) 24.11.14 16:27
(4) CheBurator, в Бухгалтерии 2.0 и Бухгалтерии 3.0 такой возможности я не нашел.
6. AZel84 (AZel84) 24.11.14 18:11
(5) ildarovich, ведение взаиморасчётов в разрезе расчётных документов явно в БП не отключается. Это зависит от учётной политики организации, а именно от способа оценки стоимости МПЗ при выбытии (на закладке запасы). Там 2 варианта "по средней" и "ФИФО". Если ведётся "по средней", то 3-е субконто будет оставаться пустым при проведении документов.
Кстати в метаданных конфигурации изначально не заполнено 3-е субконто на 60-м и 62-м. Оно заполняется при создании новой базы и отключить его заполнение нельзя. По коду видно, что ранее это субконто заполнялось только если для любой из организаций выбран способ "ФИФО".

Отчёт писался для комплексной конфигурации 1.1.48.1 релиза. В базе 3-е субконто пустое. Кстати не смотря на то, что выбран способ "ФИФО"...

В общем для БП такой отчёт может понадобиться, если не ведётся учёт в разрезе расчётных документов (выбран способ учёта "по средней").
7. Сергей (ildarovich) 24.11.14 20:05
(6) AZel84, я еще проверю, но пока кажется, что способ оценки стоимости МПЗ при выбытии не должен влиять на проведение документов по 62-му счету.
Какая тут связь?
Теоретически это скорее относится к 10, 41, 43-му. Там тоже есть третье субконто. Которое может быть пустым при проведении по этим счетам, но не по 62-му.
Там это субконто всегда задействовано (не бывает пустым).
А то, что оно пустое в комплексной, легко объяснимо, так как там учет взаиморасчетов сделан на регистрах накопления и третье субконто не нужно.
Так что пока остаюсь при своем мнении - для типовых конфигураций бухгалтерий 2.0 и 3.0 отчет "взаиморасчеты по ФИФО" не нужен.
8. AZel84 (AZel84) 25.11.14 05:25
(7) ildarovich, действительно, вчера вечером уже смотрел, ошибся. Настройка в запасах никак не влияет на взаиморасчёты (это и логично). Так что, похоже вы правы, для типовых БП отчёт в этом виде не нужен.
Ещё раз повторюсь, делал для комплексной, причём для такой, где иначе отчёт написать было нельзя.
9. AZel84 (AZel84) 25.11.14 08:22
Вообще меня смутил этот код:

Функция ПроверитьАналитикуПередЗаписью()
	
	Если СпособОценкиМПЗ = Перечисления.СпособыОценки.ФИФО Тогда
		
		// Проверка ведения партионного учета
		Сч41 = ПланыСчетов.Хозрасчетный.Товары.ПолучитьОбъект();
		ПартионныйУчет = ?(Сч41.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Партии, "ВидСубконто") = Неопределено, Ложь, Истина);
		
		Сч60 = ПланыСчетов.Хозрасчетный.РасчетыСПоставщиками.ПолучитьОбъект();
		УчетПоРасчетнымДокументам = ?(Сч60.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ДокументыРасчетовСКонтрагентами, "ВидСубконто") = Неопределено, Ложь, Истина);

		Если НЕ ПартионныйУчет ИЛИ НЕ УчетПоРасчетнымДокументам Тогда
			
			Если НЕ РольДоступна("ПолныеПрава") Тогда
				
				Предупреждение("Для указанных параметров учетной политики необходимо включаение дополнительных разрезов аналитического учета.
								|Недостаточно прав для изменения разрезов аналитического учета. Учетная политика не может быть записана!");
								
				Возврат Истина;
				
			КонецЕсли;
			
			Если НЕ ПартионныйУчет Тогда
				ТекстСообщения = " партионный учет МПЗ.";
			КонецЕсли;			
			Ответ = Вопрос("Для указанных параметров учетной политики необходимо включить дополнительные разрезы аналитического учета.", РежимДиалогаВопрос.ОКОтмена, , КодВозвратаДиалога.ОК, "");

			Если Ответ = КодВозвратаДиалога.ОК Тогда
				Если НЕ ПартионныйУчет Тогда
					СкладскойУчет = НЕ (Сч41.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады, "ВидСубконто") = Неопределено);
					СуммовойУчет = ?(СкладскойУчет, Сч41.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады, "ВидСубконто").Суммовой, Ложь);
					ОбщегоНазначения.ПрименитьПараметрыАналитикиМПЗ(Истина, СкладскойУчет, СуммовойУчет,);
				КонецЕсли;
				
				Если НЕ УчетПоРасчетнымДокументам Тогда
					ОбщегоНазначения.ПрименитьПараметрыАналитикиРасчетов(Истина,);
				КонецЕсли;
				
			Иначе
				Возврат Истина;
			КонецЕсли;
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции
...Показать Скрыть


Эта процедура вызывается при записи учётной политики.
Выполняется процедура ОбщегоНазначения.ПрименитьПараметрыАналитикиРасчетов(Истина,)
Если СпособОценкиМПЗ = Перечисления.СпособыОценки.ФИФО
10. AZel84 (AZel84) 27.11.14 14:02
Ещё вспомнил немаловажный момент. Учёт на 62-м счёте в разрезе документов расчётов ведётся при условии корректно восстановленной последовательности документов.
Восстановление последовательности часто проводится лишь при закрытии месяцев. Следовательно данные в подобных отчётах могут постоянно меняться. При расчёте долга по ФИФО изменения в отчёте отражаются сразу, так как распределение оплат происходит каждый раз заново.
Так что даже при наличии 3-го субконто, отчёт имеет место быть.

Так же обнаружил ещё одну базу БП 2.0, где учёт по документам расчёта не ведётся.
11. Ольга Фигуркина (@Sonya) 04.02.15 15:13
Отчет работает как надо, спасибо. Применяю на СКАТе.
Замечания:
1) Если по документу просрочки еще нет, отрицательное число хорошо бы обнулить
2) Если задолженность отрицательная, можно было бы ее не показывать. Мы ведь дебиторку подразумеваем?
(у себя исправила)
12. Юлия Чаюк (Salty) 01.10.15 09:24
Очень полезный отчет, работает замечательно. Большое спасибо.
13. Финевич Анна (AnneF) 13.11.15 21:30
Как вставить "Дней отсрочки" для БУ 2.0. Из справочника Договора не берется.
14. Финевич Анна (AnneF) 22.11.15 22:39
Для бухгалтерии 3.0 совсем не работает
15. Олег Рысев (olegale) 15.01.16 15:52
Как я понял работает только от календарных дней отсрочки.А как же рабочие дни?
16. AZel84 (AZel84) 15.01.16 21:44
(15) olegale, да, только количество дней отсрочки. Для нужд многих клиентов этого достаточно.
Можете доработать. Использовать производственный календарь, который должен быть заполнен. Примеры на инфостарте есть.
17. Дамир Ким (zmo) 20.04.16 17:06
Для 1С 8.2 Бухгалтерия предприятия, редакция 2.0 (2.0.65.7)
не подтягивается "Дней отсрочки"

как быть?
18. Slava Mishyn (SlaSla) 10.08.16 22:13
Возвраты каким образом отображаются в этом отчете?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа