gifts2017

Консоль запросов для управляемых форм

Опубликовал Михаил Семенов (mvsemenov) в раздел Программирование - Инструментарий

Консоль запросов для управляемого приложения с обработкой результата и выводом в табличный документ.

Консоль запросов УФ сделана на основе стандартной консоли запросов, диск ИТС декабрь 2014.

Отличия:

 1) возможность обработки результата запроса: необходимо установить "Сохранять результат для обработки", далее через "Алгоритм". Доступно в толстом и в тонком клиентах.

2) Возможность отключения иерархии

3) Вывод NULL значений как "NULL"

4) Расшифровка подзапроса табличной части в отдельном окне

5) Конструктор запроса в тонком клиенте

6) Автосумма выделенных ячеек результата

Внимание: консоль работает начиная с версии 8.3.3

Скачать файлы

Наименование Файл Версия Размер
Консоль запросов УФ 33
.epf 102,96Kb
09.09.15
33
.epf 102,96Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Максим Сердюков (Caliban) 15.12.14 12:52
Не вводите в заблуждение - для 8.2 не подходит
2. Михаил Семенов (mvsemenov) 16.12.14 15:07
Описание исправлено, добавлена возможность выполнения алгоритмов под тонким клиентом.
3. Константин Исиченко (IsiKosta) 19.12.14 07:11
"Самописная" конфигурация, скрин с ошибкой вложен
Прикрепленные файлы:
4. BigB (BigB) 19.12.14 22:21
(3) IsiKosta, вероятнее всего, у Вас в свойствах конфигурации установлен "Режим совместимости".
5. Смирнов Александр (Sander80) 19.12.14 22:29
Так будет в 8.2 работать консоль запросов в тонком клиенте, или это только для 8.3?
6. Михаил Семенов (mvsemenov) 24.12.14 10:10
Консоль работает только под 8.3
7. Михаил Семенов (mvsemenov) 24.12.14 10:22
Добавлена возможность отключать вывод "NULL" плюс мелкие изменения.
8. Роман Ложкин (webester) 01.03.15 11:57
9. Елена Пименова (Bukaska) 01.03.15 20:26
(8) webester, А если в интерфейсе такси пробовать открыть?
10. Михаил Семенов (mvsemenov) 02.03.15 12:45
Какая у вас конфигурация и версия платформы?
Консоль проверялась под УТ 11, Бух 3, платформа должна быть 8.3 управляемое приложение.
Под такси все работает.
11. Михаил Семенов (mvsemenov) 02.03.15 13:18
Разобрался работает начиная с версии 8.3.3.
Режим совместимости 8.3.1 и 8.3.2 - не поддерживается.
12. Роман Ложкин (webester) 06.03.15 08:10
(10)(11)Понятно, спасибо за участие.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа