gifts2017

Внешняя печатная форма ТТН для УТ 11.1 (Товарно-транспортная накладная (1-Т))

Опубликовал Евгений Мусатов (musatov1c.ru) в раздел Печать - Печатные формы документов

Внешняя печатная форма ТТН для УТ 11.1 Товарно-транспортная накладная (Управляемая форма) с регистрацией в справочнике Дополнительные отчеты и обработки. Реквизиты для заполнения хранятся в документе Транспортная накладная. Доступна для печати из документа Реализация товаров и услуг, как дополнительная внешняя печатная форма с возможность задания параметров в форме. Есть возможность отладки.

Для печати ТТН в УТ 11.1 используется специальный документ Транспортная накладная без возможности подцепить к нему внешнюю печатную форму. Поэтому пришлось делать печать из документа Реализация товаров и услуг.
Внешняя печатная форма разработана под заказ клиента для реального применения. Открыта для изменения. Возможно использовать для доработок и как заготовка для подобных разработок.
Платформа 1С:Предприятие 8.3 (8.3.5.1460)
Конфигурация Управление торговлей, редакция 11.1 (11.1.9.70)

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ТТН (внешняя печатная форма)
.epf 24,98Kb
10.03.15
130
.epf 1 24,98Kb 130 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Джон Смит (rusagroset) 07.04.15 15:03
Спасибо, вещь полезная.
Вопрос всем НДС в ТТН должен быть или нет?
2. Евгений Мусатов (musatov1c.ru) 11.04.15 11:01
(1) rusagroset, в моем случае ндс там появился по прямой просьбе бухгалтера - постановщика задачи. Рекомендую спросить у бухгалтера.
3. Джон Смит (rusagroset) 13.04.15 16:57
ТО же добавили, хотя в типовых нет.
4. John Smith (AndrewAks) 26.11.15 15:48
Не работает, ошибка "Индекс находится за границами массива". Управление торговлей, редакция 11.1 (11.1.10.145). Зря только $ выкинул :(
5. John Doe (winterspring) 25.01.16 15:47
(4) AndrewAks, Ошибка возникла из-за того, что не создана ТТН, чтобы не было сообщения об ошибке пришлось немного изменить
Функция СформироватьПечатнуюФормуТТН(МассивОбъектов, ОбъектыПечати, ПараметрыПечати, КомплектыПечати = Неопределено, Отладка) Экспорт
	ПараметрыПечати = Новый Структура;
	СтарыйМассив = МассивОбъектов;
	НовыйМассив = Новый Массив;
	Для Каждого ЗначениеМассива Из СтарыйМассив Цикл
		Запрос = Новый Запрос("ВЫБРАТЬ Док.Ссылка ИЗ Документ.ТранспортнаяНакладная как Док ГДЕ Док.ДокументыОснования.ДокументОснование = &СсылкаА");
		Запрос.УстановитьПараметр("СсылкаА", ЗначениеМассива);
		Выборка = Запрос.Выполнить().Выбрать();
		Если Выборка.Следующий() Тогда
			НовыйМассив.Добавить(Выборка.Ссылка);
		КонецЕсли;;
	КонецЦикла;
	//МассивОбъектов = НовыйМассив;
	УстановитьПривилегированныйРежим(Истина);
	//sb->
	Если НовыйМассив.Количество()>0 Тогда
		ТипДокументов = ТипЗнч(НовыйМассив[0]);
	Иначе
	//sb<-	
		ТипДокументов = Неопределено;	
	КонецЕсли;                       //sb

	Если ТипДокументов <> Тип("ДокументСсылка.ТранспортнаяНакладная") Тогда 
//		СтруктураВозврата = УправлениеПечатьюУТВызовСервера.ПолучитьТранспортныеНакладныеНаПечать(НовыйМассив);   //sb
		СтруктураВозврата = УправлениеПечатьюУТВызовСервера.ПолучитьТранспортныеНакладныеНаПечать(СтарыйМассив);
...Показать Скрыть


Так же для УТ(11.2.3.66) Пришлось подправить определения коэффициента в процедуре ЗаполнитьТабличныйДокументТТН
КоэффициентПересчетаВТонны     = ДоставкаТоваров.КоэффициентПересчетаВТонны();    //sb
6. Евгений Мусатов (musatov1c.ru) 01.02.16 11:36
(5) winterspring,
Да, спасибо за ответ. Я делал именно с расчетом наличия ТТН. В документ добавлялись некоторые реквизиты, которых не было в Реализации. И расчет веса по моему делался именно под клиента.
7. Михаил Минеев (kamrti164) 18.02.16 09:30
добрый день. Подскажите пожалуйста, есть ли в данной обработке возможность сохранения занесенных в ТТН реквизитов? Нам часто приходится в 1-н автомобиль грузить товар для большого количества клинтов
8. Евгений Мусатов (musatov1c.ru) 19.02.16 08:20
(7) kamrti164, эта печатная форма берет данные из документа ТТН. В этом документе и должны храниться все реквизиты, про которые вы спрашиваете :)
9. Татьяна (Душечка) 29.11.16 22:15
Огромное Спасибо !!!! Как всегда программисты Инфостарта выручают !!!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа