gifts2017

Облегчение вызовов журнала регистрации с отбором по объекту

Опубликовал Дмитрий Тарасов (tarassov) в раздел Администрирование - Журнал регистрации

Регулярно возникает необходимость просмотреть журнал регистрации по одному объекту.
С минимальными изменениями можно автоматизировать установку отбора и вызов непосредственно из формы объекта данных

В конфигурациях, основанных на БСП, стандартно присутствует обработка ЖурналРегистрации, формирующая и показывающая общий журнал регистрации.

В обработке предусмотрена команда ЖурналРегистрации (Группа: Панель навигации.Обычное). Обработчик команды малофункционален.

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
  ОткрытьФорму("Обработка.ЖурналРегистрации.Форма",, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно);
КонецПроцедуры

Видно, что в форме все необходимые параметры предусмотрены.

Будет достаточно заменить обработчик команды следующим образом

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
	
	Параметры = Новый Структура;
	Параметры.Вставить("Данные", ПараметрКоманды);
	Параметры.Вставить("Пользователь", "");
	Параметры.Вставить("СобытиеЖурналаРегистрации", "");
	
	ПараметрДата = Новый Структура;
	ПараметрДата.Вставить("Дата");
	ЗаполнитьЗначенияСвойств(ПараметрДата, ПараметрКоманды);
	Если ЗначениеЗаполнено(ПараметрДата.Дата) Тогда
		Параметры.Вставить("ДатаНачала", ПараметрДата.Дата);
	КонецЕсли;
	
	ОткрытьФорму("Обработка.ЖурналРегистрации.Форма", Параметры, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно);

КонецПроцедуры

 и изменить свойства команды

Группа - Панель навигации формы.См. также

Тип параметра команды - Составной тип данных (Указать все интересующие справочники, документы, регистры сведений и т.п.)

 

В результате - команда доступна в разделе "См.также" всех выбранных объектов

При ее вызове журнал регистрации фильтруется по событиям текущего объекта

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Юрий Муллабакиев (mulla1979) 26.03.15 22:09
Интересненько, надо попробовать
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа