gifts2017

Отчет СКД с картинками, стандартными пользовательскими настройками (УТ 10.3)

Опубликовал Виталий Татарских (vtatarskih) в раздел Программирование - Практика программирования

Ничего особенного... Публикация для тех, кто впервые столкнулся с такой задачей. Мой опыт и консолидация информации из инета в тему "СКД с картинками".
При компоновке отчета поле "Картинка" обладает всеми свойствами любого другого поля в отчете, в том числе выступать как уровень группировки - как это показано в примере.

В данном случае требовался отчет по розничным складам. Вся нужная информация выбиралась из базы следующим запросом в схеме компановке данных:

ВЫБРАТЬ
ТоварыВРозницеОстатки.Склад,
ТоварыВРозницеОстатки.Номенклатура,
ТоварыВРозницеОстатки.ХарактеристикаНоменклатуры,
ТоварыВРозницеОстатки.Качество,
ТоварыВРозницеОстатки.КоличествоОстаток,
ТоварыВРозницеОстатки.СуммаПродажнаяОстаток,
NULL КАК КоличествоРасход,
NULL КАК СуммаПродажнаяРасход
ИЗ
РегистрНакопления.ТоварыВРознице.Остатки({(&КонецПериода)}, ) КАК ТоварыВРозницеОстатки

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
ТоварыВРозницеОбороты.Склад,
ТоварыВРозницеОбороты.Номенклатура,
ТоварыВРозницеОбороты.ХарактеристикаНоменклатуры,
ТоварыВРозницеОбороты.Качество,
NULL,
NULL,
ТоварыВРозницеОбороты.КоличествоРасход,
ТоварыВРозницеОбороты.СуммаПродажнаяРасход
ИЗ
РегистрНакопления.ТоварыВРознице.Обороты(, , Регистратор, ) КАК ТоварыВРозницеОбороты
ГДЕ
ТоварыВРозницеОбороты.Регистратор ССЫЛКА Документ.ОтчетОРозничныхПродажах
ИЛИ ТоварыВРозницеОбороты.Регистратор ССЫЛКА Документ.ЧекККМ
{ХАРАКТЕРИСТИКИ
ТИП(Справочник.Номенклатура)
ВИДЫХАРАКТЕРИСТИК ПланВидовХарактеристик.СвойстваОбъектов
ПОЛЕКЛЮЧА Ссылка
ПОЛЕИМЕНИ Представление
ПОЛЕТИПАЗНАЧЕНИЯ ТипЗначения
ЗНАЧЕНИЯХАРАКТЕРИСТИК РегистрСведений.ЗначенияСвойствОбъектов
ПОЛЕОБЪЕКТА Объект
ПОЛЕВИДА Свойство
ПОЛЕЗНАЧЕНИЯ Значение }

Самого поля вывода изображения в запросе нет. Стоит обратить внимание на текст в запросе:

{ХАРАКТЕРИСТИКИ
ТИП(Справочник.Номенклатура)
ВИДЫХАРАКТЕРИСТИК ПланВидовХарактеристик.СвойстваОбъектов
ПОЛЕКЛЮЧА Ссылка
ПОЛЕИМЕНИ Представление
ПОЛЕТИПАЗНАЧЕНИЯ ТипЗначения
ЗНАЧЕНИЯХАРАКТЕРИСТИК РегистрСведений.ЗначенияСвойствОбъектов
ПОЛЕОБЪЕКТА Объект
ПОЛЕВИДА Свойство
ПОЛЕЗНАЧЕНИЯ Значение }

который позволит выводит поля и использовать в условиях отбора отчета свойства и характеристики номенклатуры. Этот текст формируется автоматически конструктором запроса в схеме компановки данных при заполнении вкладки "Характеристики":

 Заполнение вкладки характеристики

Само поле вывода изображения формируем введением дополнительного вычисляемого поля:

Вычисляемое поле

Выражение представления ("Нет изображения " + Номенклатура.Код) в последующем выполнит свою функцию в процедуре программного вывода отчета.

Для программного вывода отчета с выводом изображений существует всего одна процедура в модуле отчета:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь; // Отключаем стандартную обработку 
	
	//Настройки = КомпоновщикНастроек.ПолучитьНастройки(); Эта строка работает если не надо лезть и изменять настройки, 
	//но мы не ищем легких путей если надо о чем-то рассказать по подробнее.. Если надо поменять пользовательские настройки
	// ручками - делаем приблизительно так:
	Настройки = КомпоновщикНастроек.Настройки; // Получаем настройки отчета 
	
	// Изменяем отборы по пользовательским настройкам
	ТаблицаОтборов = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
	Для Каждого ЭлементОтбора Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл		
		НайденнаяПользовательскаяНастройка = 
			ТаблицаОтборов.Найти(ЭлементОтбора.ИдентификаторПользовательскойНастройки);		
		Если НайденнаяПользовательскаяНастройка <> Неопределено Тогда
			ЭлементОтбора.ВидСравнения = НайденнаяПользовательскаяНастройка.ВидСравнения;
			ЭлементОтбора.Использование = НайденнаяПользовательскаяНастройка.Использование;
			ЭлементОтбора.ПравоеЗначение = НайденнаяПользовательскаяНастройка.ПравоеЗначение;
		КонецЕсли;		
	КонецЦикла;
		
	ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;      		
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;    	
	
	// Создаем макет компоновки данных
	СхемаКомпоновкиДанных = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
	МакетКомпоновки = 
		КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	
	// Инициализируем процессор компоновки
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки);
	
	ДокументРезультат.Очистить();
	
	// Выводим результат отчета в табличный документ "ДокументРезультат"
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);		
	
	//ПроцессорВывода.Вывести(ПроцессорКомпоновки);  на этом можно было бы закончить вывод отчета в стандартном виде... 
	//но нам нужны картинки.
	
	
	ПолеПоКоторомуНеобходимоПолучитьЗначение = "Картинка";
    	ПроцессорВывода.НачатьВывод();
     	Пока истина Цикл
     		ЭлементРезультата = ПроцессорКомпоновки.Следующий();
      		Если ЭлементРезультата = Неопределено Тогда
      			прервать;
      		КонецЕсли;	
      		ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
			Если ЭлементРезультата.ЗначенияПараметров.Количество() > 0 Тогда
       			ЗначениеВыводимыхДанных = Неопределено;
				Для каждого ЗначениеПараметра из ЭлементРезультата.ЗначенияПараметров Цикл
       				Если ТипЗнч(ЗначениеПараметра.Значение) = Тип("ИдентификаторРасшифровкиКомпоновкиДанных") Тогда
        					ПоляРасшифровки = ДанныеРасшифровки.Элементы[ЗначениеПараметра.Значение].ПолучитьПоля();
         					Для Каждого ПолеРасшифровки из ПоляРасшифровки Цикл
         						Если ПолеРасшифровки.Поле = ПолеПоКоторомуНеобходимоПолучитьЗначение Тогда
         							ЗначениеВыводимыхДанных = ПолеРасшифровки.Значение;
         							Прервать;
         						КонецЕсли;	
         					КонецЦикла;	
         				КонецЕсли;	
         			КонецЦикла;	
         			Если ЗначениеЗаполнено(ЗначениеВыводимыхДанных) Тогда
						мОбъект = ЗначениеВыводимыхДанных.ПолучитьОбъект();
						мТекущееОсновноеИзображение = мОбъект.Хранилище.Получить();
						Если НЕ (мТекущееОсновноеИзображение = Неопределено) Тогда
							Рис = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
							Рис.РазмерКартинки = РазмерКартинки.Пропорционально;
							Индекс = ДокументРезультат.Рисунки.Индекс(Рис);
							ДокументРезультат.Рисунки[Индекс].Картинка = мТекущееОсновноеИзображение;
							ВысотаТабДок = ДокументРезультат.ВысотаТаблицы;
							ОбластьДляКартинки = ДокументРезультат.НайтиТекст("Нет изображения " + мОбъект.Объект.Код);
							Если ОбластьДляКартинки <> Неопределено Тогда
								ОбластьДляКартинки.ВысотаСтроки = 90;
								ДокументРезультат.Рисунки[Индекс].Расположить(ОбластьДляКартинки);
								ОбластьДляКартинки.Текст = "";
							КонецЕсли;
						КонецЕсли;
         			КонецЕсли;	
         		КонецЕсли;	
			
			КонецЦикла;
			ПроцессорВывода.ЗакончитьВывод();
				
КонецПроцедуры

Логика работы процедуры в комментариях кода. 

Буду рад любой критике и научениям )

Скачать файлы

Наименование Файл Версия Размер
СКД с картинками 18
.erf 8,40Kb
17.04.15
18
.erf a1 8,40Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Наталия Тимофеева (Шапокляк) 24.03.16 19:10
Огромное спасибо! Наконец-то у меня СКД с картинками!
По разработке есть одно дополнение.
У вас на картинке вкладки Характеристика описано присоединение свойств. Наверняка вы столкнулись с неудобством отбора, когда в отбор лезут все имеющиеся свойства, а не только свойства номенклатуры. Я вышла из положения использованием Запроса, а не таблицы:
Все то же самое, только Источник видов Запрос с таким текстом
ВЫБРАТЬ
			СвойстваОбъектов.Ссылка,
			СвойстваОбъектов.Наименование,
			СвойстваОбъектов.НазначениеСвойства,
			СвойстваОбъектов.ТипЗначения
		ИЗ
			ПланВидовХарактеристик.СвойстваОбъектов КАК СвойстваОбъектов
		ГДЕ
			СвойстваОбъектов.ПометкаУдаления = ЛОЖЬ
			И СвойстваОбъектов.НазначениеСвойства = ЗНАЧЕНИЕ(ПланВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура)
...Показать Скрыть
vtatarskih; +1 Ответить 1
2. Виталий Татарских (vtatarskih) 25.03.16 03:41
(1) Шапокляк, спасибо за дополнение )