gifts2017

Акт об оказании услуг (со скидками) - внешняя печатная форма для Управление торговлей 11.1.10.86

Опубликовал Константин Юрин (kostyaomsk) в раздел Печать - Печатные формы документов

Данная промежуточная редакция может использоваться как шаблон для собственных ВПФ на версии релиза УТ 11.1.10 и старше. Предназначен для документа УТ 11.1.10 "Реализация товаров и услуг" (где есть услуги).

Решил вытащить редко используемую ВПФ из недр УТ 11.1.10. Надеюсь, свежая версия данной ВПФ Акт об оказании услуг для документа РеалазацияТоваровУслуг будет полезной. Возможно, ради универсальности вызова разработчики типовой конфигурации закинули ее вместе с макетом в код обработки конфигурации "ПечатьАктОбОказанииУслуг" и сам код печати в модуль менеджера обработки (см. рисунок 1).

 

Рисунок 1. Место расположения источника данных для обработки.

На рисунке 2 можно увидеть исходные данные для печати - экранную форму документа РеализацияТоваровУслуг типовой конфигурации управление торговлей 11.1.10:

 

Рисунок 2. Источник данных для печати.

А на рисунке 3 формируемую внешнюю печатную форму.

Рисунок 3. ВПФ Акт об оказании услуг для печати.

Порядок действий по подключению ВПФ в УТ 11.1.10 (кто не знает) приведен на нижележащих рисунках с 4-го по 7-й:

Рисунок 4. Панель разделов "Администрирование" -> "печатные формы, отчеты и обработки".

Рисунок 5. Место регистрации отчета.

Рисунок 6. Конечный шаг регистрации ВПФ загрузка в УТ 11.1.10




Рисунок 7. Меню вызова стандартных и дополнительных печатных форм. Показан вызов "оригинальной" формы акта из конфигуратора. Добавляемая имеет префикс "ВПФ".

Жду Ваших замечаний и предложений по данной ВПФ.

Скачать файлы

Наименование Файл Версия Размер
ВПФ Акт об оказании услуг (со скидками) 15
.epf 14,84Kb
02.06.15
15
.epf 1.0.0 14,84Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир Конырев (Vladimir_Konyrev) 17.09.15 22:31
2. Константин Юрин (kostyaomsk) 17.09.15 22:44
Спасибо за тестирование. А я как раз делаю новую публикацию (по запросу одного из интересных клиентов) Акт об оказании услуг со скидками с факсимиле (сканом печати и подписи) для редакций УТ 11.1.10 на на примере этого Акта об оказании услуг для УТ 11.1 для поддержки печати факсимилье (скана печати и подписи) с подробной инструкцией для опытного пользователя и начинающих программистов - в конфигуратор видел для правки просто полей и выравнивания научились уже главбухи преклонных лет.
Достаточно внедрить небольшой код:

// Фрагмент вывода области печати 
ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
ДобавитьФаксимиле(ДанныеПечати, ОбластьМакета);
ТабличныйДокумент.Вывести(ОбластьМакета);


Процедура ДобавитьФаксимиле(ПарПечати, Обл)
	//Доработка для печати факсимиле в Акт
	Попытка
		Орг = ПарПечати.Организация;
		ФайлКартинки = ОбщегоНазначения.ПолучитьЗначениеРеквизита(Орг, "ФайлФаксимильнаяПечать");
		Если Не ЗначениеЗаполнено(ФайлКартинки) Тогда
			Возврат;
		КонецЕсли;
		ДвоичныеДанныеФайла = ПрисоединенныеФайлы.ПолучитьДвоичныеДанныеФайла(ФайлКартинки);
		
		Если ТипЗнч(ДвоичныеДанныеФайла) = Тип("Картинка") Тогда
			Картинка = ДвоичныеДанныеФайла;
		ИначеЕсли ТипЗнч(ДвоичныеДанныеФайла) = Тип("ДвоичныеДанные") Тогда
			Картинка = Новый Картинка(ДвоичныеДанныеФайла);
		Иначе
			Картинка = Новый Картинка;
		КонецЕсли; 
		
		Обл.Рисунки.Подпись.Картинка = Картинка; // Самое важное вот!!!
		
	Исключение
		СП = Новый СообщениеПользователю;
		Релиз = СокрЛП(Метаданные.Версия);
		СП.Текст = "В текущем релизе УТ "+Релиз+" не предусмотрена печать факсимиле. Подробно "+ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() );
		СП.Сообщить();
	КонецПопытки;
	// конец доработки
КонецПроцедуры
...Показать Скрыть


и проделать операции по сканированию и правке в конфигурации и документы приобретают "официальный смысл" (правда налоговая и прочие контролирующие органы очень сильно это дело не любят, когда рисуют печати и подписи). Это уже на усмотрение того, кто ведет учет :)
Прикрепленные файлы:
Как создать факсимильную подпись и печать - Иванов И.И. (Организация) - 17.09.2015 (1).pdf
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа