gifts2017

Панель отчетов

Опубликовал Владимир Полухин (pv94384) в раздел Обработки - Универсальные обработки

Выводит все отчеты, выбранные в правой панели, в одном поле в соответствии с указанным периодом и выбранными настройками.

Для чего была сделана: для того, чтобы руководитель мог видеть все отчеты в одном поле.

Для корректной работы необходимо внести изменения в конфигурацию:

В модуле объекта Отчет.УниверсальныйОтчет в процедуре СформироватьОтчет() заменить

Если Очищать Тогда

ТабличныйДокумент.Очистить();

КонецЕсли;

на

Попытка
Если ТабличныйДокумент.Имя = "Результат" тогда
Иначе 
Если Очищать Тогда

ТабличныйДокумент.Очистить();

КонецЕсли;
КонецЕсли;
Исключение
Если Очищать Тогда

ТабличныйДокумент.Очистить();

КонецЕсли;
КонецПопытки;


Скачать файлы

Наименование Файл Версия Размер
Панель отчетов 7
.epf 15,60Kb
20.06.16
7
.epf 15,60Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение
Комментарии
1. Александр T (AlexAuto) 04.06.15 12:33
Классная штука! Мне понравилось! А можно сделать боковую панель прячущейся ? (накидал отчетов и скрыл, надо развернул)
2. Владимир Полухин (pv94384) 04.06.15 13:20
(1) AlexAuto, дописал, забирайте)
AlexAuto; +1 Ответить
3. Александр T (AlexAuto) 04.06.15 18:34
еще раз качать ((( может в почту??? плз
4. Владимир Полухин (pv94384) 04.06.15 18:48
(3) AlexAuto, скидывайте в личку адрес, завтра отправлю)
5. Александр T (AlexAuto) 08.06.15 10:13
Спасибо, все получилось, на копии взлетело ))), буду радовать руководителя )))
6. Александр T (AlexAuto) 08.06.15 16:06
Есть еще один вопрос, а диаграммы почему то не подтягиваются??? В режиме отчета сохраняется настройка как "основная" (без выбора вариантов) и при добавлении в панель этой настройки не видно - результат ошибка (((
7. Александр T (AlexAuto) 08.06.15 16:08
И расшифровки не работают
8. Владимир Полухин (pv94384) 09.06.15 12:26
(7) AlexAuto, расшифровки добавил) Остальное в ближайшее время))
9. Владимир Полухин (pv94384) 10.06.15 09:46
(6) AlexAuto, по настройкам не понял, вроде всё хорошо с ними..
10. Александр T (AlexAuto) 10.06.15 13:10
Ситуация следующая: УТ10.3 отчет продажи (диаграмма) при сохранении настройки нет возможности сохранить свой вариант настройки отчета и он сохраняется только как основной. При добавлении этого отчета в панель, при выборе настройки она не отображается в поле выбора и соответственно диаграмма не формируется, как то исправить можно?