gifts2017

1С:Бухгалтерия 3.0. Как заглянуть в расчет себестоимости отладчиком

Опубликовал Дмитрий Ивакин (pit201201) в раздел Программирование - Практика программирования

Простой и эффективный метод ознакомления и изучения содержимого временных таблиц, которые мигрируют из функции в функцию через общий МенеджерВременныхТаблиц.

Случилось страшное, и мне пришлось заглянуть в функцию РасчетСебестоимости.РассчитатьСебестоимость(Период, Организация, Ссылка, Режим = "Запасы") из выше означенной конфигурации.

В ней в свою очередь вызывается несколько однотипных процедур, в которые передается ссылка на МенеджерВременныхТаблиц,  и они в нем добавляют (удаляют, меняют) временные таблицы. Иногда хочется посмотреть эти промежуточные результаты во время отладки.

Выходом из ситуации стала функция:

 

Функция ВыполнитьЗапросДляОтладчика(ИсходныйЗапрос,МенеджерВременныхТаблиц) Экспорт
    
    МногоТЗ = Новый Массив;
    
    Запрос = Новый Запрос;
    Запрос.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;
    Запрос.Текст = ИсходныйЗапрос.Текст;
    
    Для Каждого Элемент Из ИсходныйЗапрос.Параметры Цикл
        Запрос.УстановитьПараметр(Элемент.Ключ,Элемент.Значение);
    КонецЦикла;
    
    Табл = Новый ТаблицаЗначений;
    Табл.Колонки.Добавить("ИмяВРТаблицы");
    Табл.Колонки.Добавить("Колво");
    
    regExp = Новый COMОбъект("VBScript.RegExp");
    RegExp.Pattern = "(ПОМЕСТИТЬ [А-Яа-я0-9_]+)";
    RegExp.Global = Истина;
    RegExp.Multiline = Истина;
    Matches = RegExp.Execute(ИсходныйЗапрос.Текст);
    Для Счетчик = 0 По Matches.Count - 1 Цикл 
        Match = Matches.Item(Счетчик);
        Стр = Табл.Добавить();
        Стр.ИмяВРТаблицы = СокрЛП(СтрЗаменить(Match.Value,"ПОМЕСТИТЬ ",""));
        Стр.Колво = 1;
    КонецЦикла;    
    
    RegExp.Pattern = "(УНИЧТОЖИТЬ [А-Яа-я0-9_]+)";
    RegExp.Global = Истина;
    RegExp.Multiline = Истина;
    Matches = RegExp.Execute(ИсходныйЗапрос.Текст);
    Для Счетчик = 0 По Matches.Count - 1 Цикл 
        Match = Matches.Item(Счетчик);
        Стр = Табл.Добавить();
        Стр.ИмяВРТаблицы = СокрЛП(СтрЗаменить(Match.Value,"УНИЧТОЖИТЬ ",""));
        Стр.Колво = -1;
    КонецЦикла;    
    
    Попытка
        
        Запрос.Текст = ИсходныйЗапрос.Текст;
        
        Табл.Свернуть("ИмяВРТаблицы","КолВо");
        
        Для Каждого Стр Из Табл Цикл
            Если Стр.Колво = 1 Тогда
                Запрос.Текст = СтрЗаменить(Запрос.Текст," "+Стр.ИмяВРТаблицы," ТЕСТТЕСТ_" + Стр.ИмяВРТаблицы);
                Запрос.Текст = Запрос.Текст + Символ(10) + Символ(13) + "; ВЫБРАТЬ * ИЗ ТЕСТТЕСТ_" + Стр.ИмяВРТаблицы;
                Запрос.Текст = Запрос.Текст + Символ(10) + Символ(13) + "; УНИЧТОЖИТЬ ТЕСТТЕСТ_" + Стр.ИмяВРТаблицы;
            КонецЕсли;
		КонецЦикла;        
		       
		МногоТЗ = Запрос.ВыполнитьПакет();
		Для Индекс = 0 по МногоТЗ.ВГраница() Цикл
			Если ТипЗнч(МногоТЗ[Индекс]) = Тип("РезультатЗапроса") Тогда
        		МногоТЗ[Индекс] = МногоТЗ[Индекс].Выгрузить(ОбходРезультатаЗапроса.Прямой);
			КонецЕсли;
		КонецЦикла;
	
      
        
    Исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    Возврат МногоТЗ;
    
КонецФункции   
 

Как использовать ее, наверное, понятно. На всякий случай ...

 

 



Вот, собственно, и все!

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Сергей Погодин (spogo) 04.06.15 09:51
Добрый день.
Функция ПолучитьВТ(МенеджерВТ, ИмяВТ) Экспорт
 
	Запрос = Новый Запрос;
	Запрос.МенеджерВременныхТаблиц = МенеджерВТ;
	Запрос.Текст = "ВЫБРАТЬ * ИЗ " + ИмяВТ + " КАК ВТ";
	
	Попытка
		Возврат Запрос.Выполнить().Выгрузить();
	Исключение
		Возврат "Ошибка получения временной таблицы: " + ОписаниеОшибки(); 
	КонецПопытки;
 
КонецФункции
...Показать Скрыть

А так не проще?
Krio2; Восьмой; Bassgood; LsrGroup; +4 Ответить 1
2. Дмитрий Ивакин (pit201201) 04.06.15 17:14
(1) spogo,
Остается только посмотреть длинный запрос на несколько экранов и найти ИмяВТ. Потом подставить его в строчку отладчика и ... тот же самый результат.
Я оказался чуть ленивее и ИмяВТ у меня само находится.
JohnyDeath; +1 Ответить 1
3. Сергей Погодин (spogo) 05.06.15 12:32
(2) pit201201,
Остается только посмотреть длинный запрос на несколько экранов и найти ИмяВТ.
или нажать CTRL+F и найти "ПОМЕСТИТЬ"

пысы: ничего не имею против вашего способа.
4. Дмитрий Ивакин (pit201201) 05.06.15 12:59
(3) spogo,
... а потом проверить не удалилась ли она в середине текста. Обратно же просто - СTRL-F. На листочек выписываем временные таблицы которые есть, потом вычеркиваем - которые удалены. А потом нажимаем Shift-F9 и переписываем с листочка ПолучитьВТ(Менеджер, ИмяВТс Листочка).
Зачем все это делать, когда можно не делать, а дать поручение сделать это за тебя.
В общем, я допускаю когда на кнопках клавы WASD надписи стерты, а потертые кнопки Ctrl и F мне не нравятся. :)
5. г. Казань Рустем Гумеров (Rustig) 14.06.15 20:31
(0) вопросы: у вас только одна временная таблица выгружается в ТЗ? А если запрос содержит несколько временных таблиц? Какая из них выгрузится в таблицу значений? Как в отладчике выбирать как запрос анализировать? и почему бы при отладке не проверить временные таблицы, которые в дальнейшем - после использования - будут уничтожены?
предложение: консоль запросов позволяет обрабатывать только часть выделенного текста в запросе. Я использую эту возможность при просмотре результата временных и вложенных таблиц или при редактировании только части запроса, входя в конструктор выделенного текста запроса.
Для просмотра временных таблиц следует закомментировать выражение «Поместить», выделить часть текста запроса и нажать «Выполнить». После просмотра следует не забыть удалить комментарии в строке «Поместить»
6. Дмитрий Ивакин (pit201201) 22.06.15 12:39
(5) Rustig,
маленько подправил текст процедуры
МногоТЗ = Запрос.ВыполнитьПакет();
...

теперь на выходе имеем массив таблиц значений в каждую из которых можно заглянуть.

Уничтожаемые в запросе таблицы можно и оставлять для анализа, появится необходимость доработаю.

Остался небольшой косяк : слова ПОМЕСТИТЬ и УНИЧТОЖИТЬ должны быть написаны в исходном запросе БОЛЬШИМИ буквами.
7. Дмитрий Ивакин (pit201201) 22.06.15 12:49
(5) Rustig,
Против консоли запросов ничего не имею и сам активно использую ее. В предложенном Вами варианте затруднение (замедление процесса поиска багов) возникает при передаче параметров. Еще мне не совсем понятно как консолью отладить запрос в котором используется ВременнаяТаблица из другого запроса. Предложенная процедура это своего рода экспресс анализатор текущего состояния МененджераВременныхТаблиц.
8. Никита Коротаев (bforce) 25.06.15 07:38
Для просматра временных таблиц написано много разных фунцкий, в том числе, в типовых попадаются. Но я ставлю плюс за использование регулярных выражений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа