gifts2017

ФМС. Уведомление о заключении/расторжении трудового договора 2015. ЗУП 2.5

Опубликовал Дмитрий Веточкин (MiniMuk) в раздел Печать - Печатные формы документов

1. Внешняя печатная форма для Libra Office, заполняющая шаблон, подключаемая к документам "Прием на работу в организацию", "Увольнение из организации".
2. Приложение № 19 к Приказу ФМС России от 28.06.2010 № 147 (в ред. Приказа ФМС России от 12.03.2015 № 149)
3. Приложение № 20 к Приказу ФМС России от 28.06.2010 № 147 (в ред. Приказа ФМС России от 12.03.2015 № 149)

Добрый день. 

 В нашей организации работают иностранцы, приезжают к нам по договору и почти все без первичных документов. Обычно есть только  миграционная карта. Возникла необходимось массово заполнять бланки уведомления/расторжении трудовых отношений. Причем бланки достаточно неудобные, каждая буква в отдельной клеточки.  

Было придумано такое решение на базе сalc  Libra Office версии 4..0 и выше. Внешная печатная форма  (ВПФ) забирает шаблон, в шаблоне есть лист Данные. На этом листе записываются реквизиты, какие необходимо заполнить из 1С. В ВПФ передаю объект и  шаблон. ВПФ запрашивает в шаблоне нужные реквизиты, потом ищет анологичные реквизиты в переданном объекте и их заполняет. А средствами libra office я делю полученные значения реквизитов на буквы и заполняю клеточки (пример формулы =RIGHTB(LEFTB(IF(LEN(Данные!R1C2)>=Данные!R[-42]C[-14];Данные!R1C2;" ");Данные!R[-42]C[-14]);1))

Причем если это документ с табличной частью, еще возьмет реквизиты табличной части. Если справочник Сотрудник, возьмет физлицо и его реквизиты тоже. Также я данную обработку использую при заполнении трудового договора, ее функционала вполне достаточно. При выходе новых форм, я думаю, вполне достаточно будет заново произвести заполнение нового шаблона.

 

Настройки ВПФ для документа прием /увольнение (см. рисунки):

Заходим в настройки ВПФ, тыкаем шаблон обработки,  создаем 3 текстовых параметра, где:

Шаблон = путь к шаблону, где лежит файл

ТабличнаяЧасть = табличная часть для обработки, как она называется в конфигураторе

Сотрудник = реквизит табличной части, по которому будет заполняться документ. (Заберутся значения реквизитов этого параметра.)

Примерное начало обработки шаблона

Функция Печать() Экспорт     
	ФайлШаблона = ПолучитьШаблон();
	Если ФайлШаблона = Неопределено  Тогда 
		ОбщегоНазначенияЗК.СообщитьОбОшибке("Файл шаблона не найден!" + Символы.ПС + "Добавьте шаблон " + ПутьПоУмолчанию + Символы.ПС + " или инициализируйте путь к  новому шаблону во внешних печатных формах через дополнительные параметры.");
		Возврат Неопределено;
	КонецЕсли;
	
	Если ТипЗнч(СсылкаНаОбъект) = Тип("СправочникСсылка.СотрудникиОрганизаций") Тогда 
		ЗаполнитьШаблон(ФайлШаблона, СсылкаНаОбъект);
	Иначе 
		ТабличнаяЧасть = "";
		Сотрудник = "";
		СписокПеременных.Вставить("НомерДокумента",       СсылкаНаОбъект.Номер);
		СписокПеременных.Вставить("ДатаДокумента",        СсылкаНаОбъект.Дата);

		Если ПолучитьДопПарметры("ТабличнаяЧасть",  ТабличнаяЧасть) и ПолучитьДопПарметры("Сотрудник", Сотрудник ) Тогда 
			Для каждого СтрСотрудник Из СсылкаНаОбъект[ТабличнаяЧасть] Цикл
				
				ЗаполнитьШаблон(ФайлШаблона, СтрСотрудник[Сотрудник]);
				ЗаполнитьЗначенияСвойств(СписокПеременных, СтрСотрудник );
			КонецЦикла;
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат Неопределено;
КонецФункции
 

Скачать файлы

Наименование Файл Версия Размер
Внешняя печатная форма заполнения шаблона 19
.epf 17,22Kb
30.07.15
19
.epf 17,22Kb Скачать
Приложение 19 18
.ods 45,39Kb
30.07.15
18
.ods 45,39Kb Скачать
Приложение 20 15
.ods 47,11Kb
30.07.15
15
.ods 47,11Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дмитрий Веточкин (MiniMuk) 10.09.15 08:51
Отвечаю на вопросы, пожелания рекомендации
2. ALL Ss (a16a05m11) 28.06.16 01:31
Для формы № 20 на Увольнение мне ругается чт-то про Форму 19 (это Прием) и вконце концов выводит сообщение "Не удалось сформировать внешнюю печатную форму! Значение не является значением объектного типа (getSheets)" Кстати, про "сalc Libra Office версии 4..0 " я ничего не понимаю - это мне можно настроить у себя при 8 уиндосе? Заранее спасибо за ответ , буду признательна.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа