gifts2017

Три приёма, позволяющие сделать интерфейс конфигураций 1С на управляемых формах удобнее при большом шрифте

Опубликовал Александр Шихов (H-Labs) в раздел Программирование - Работа с интерфейсом

С появлением управляемых форм вообще и БП 3.0 в частности пользователи, которые не хотят портить своё зрение рассматриванием мелкого шрифта, оказались в невыгодном положении. Многих элементов на экране в "тяжёлых" документах вообще оказалось не видно. Все попытки решить вопрос штатными средствами настройки предприятия оказались неэффективны. Вот несколько приёмов, которые буквально в два щелчка мышкой и парой строк кода помогут решить проблему.

1. Убираем шапки в документах в сворачиваемые группы

В "тяжёлых" документах с большими табличными частями и высокими шапками при использовании большого шрифта часто вообще нельзя увидеть ни одной строки.

Решается просто. В последних версиях конфигураций 1С появился элемент "сворачиваемая группа". Убираем в него всю шапку буквально за 10 секунд в конфигураторе и не имеем проблем с отображением строк.

 

2. Включаем скрытую возможность работы с большими шрифтами

Во всех конфигурациях на БСП, включая БП 3.0, например, есть скрытая возможность. При работе на маленьких мониторах можно включить компактный режим отображения форм. Сделать это можно программно в модуле сеанса для всех пользователей сразу всего одной строчкой. Мы, правда, сделали константу, чтобы включать/выключать этот режим. Пример работает в БП 3.0.

		Если ИменаПараметровСеанса = Неопределено Тогда
			
			УстановитьПривилегированныйРежим(Истина);
			
			Пользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
			
			Если Не Пользователь = Неопределено Тогда
				
				Настройка = ХранилищеСистемныхНастроек.Загрузить("Общее/НастройкиКлиентскогоПриложения", "",, Пользователь.Имя);
				
				Если Не ТипЗнч(Настройка) = Тип("НастройкиКлиентскогоПриложения") Тогда
					Настройка = Новый НастройкиКлиентскогоПриложения;
				КонецЕсли;
				
				Настройка.ВариантМасштабаФормКлиентскогоПриложения = ВариантМасштабаФормКлиентскогоПриложения.Компактный;
				ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиКлиентскогоПриложения", "", Настройка,, Пользователь.Имя);
				
			КонецЕсли;
			
		КонецЕсли;

Ключевая строка, вставленная в текст стандартного модуля

Настройка.ВариантМасштабаФормКлиентскогоПриложения = ВариантМасштабаФормКлиентскогоПриложения.Компактный;
				

3. Максимально эксплуатируем "Перейти"

Раньше было принято выводить регистры сведений, связанные со справочником, в отдельные вкладки формы. Теперь от этой привычки стоит отказаться. Во-первых, форма становится менее нагруженной. А во-вторых, отлично отрабатывает стандартный механизм с Ведущим измерением.

P.S. Любителям обзываться Капитаном Очевидностью: да, данная статья не содержит каких-то открытий. Все указанные вещи можно найти на этом ресурсе. Но для начинающих материал окажется полезным. Для них и пишу.:)

См. также

Подписаться Добавить вознаграждение
Комментарии
1. TMV 05.11.15 13:09
(0) ctrl + shift + ~
Lo1jke; angur; freez1301; CratosX; JesteR; ZUL_MTFKA; Rokky78; H-Labs; Quasar; +9 Ответить 3
2. logdog (logdog) 05.11.15 13:44
Вот как сделать константу и переключаться между размерами форм было бы очень кстати.
3. Александр Шихов (H-Labs) 05.11.15 14:01
(2) logdog, ну да. А мы улучшили механизм. Теперь записываем в настройки пользователя. Вообще стало хорошо. Если интересно, могу дополнить с фрагментом текста:)
4. Александр Шихов (H-Labs) 05.11.15 14:13
(1) TMV, Это не одно и то же. Компактный режим сочетанием клавиш не включить. Только "лишние" элементы меню скрываются.
5. Константин Ермоленко (Quasar) 05.11.15 17:34
(1) TMV, Спасибо за комбинацию. Не знал. Порой ее не хватает
6. Алексей 1 (AlX0id) 06.11.15 00:03
Первый пункт в общем-то можно смело заменить на обучение пользователей пользоваться кнопкой "Изменить форму" - сделать в ней дополнительную страницу и выкинуть на нее те элементы, что не нужны на главной странице. И главное - никакого программирования %)
7. Александр Шихов (H-Labs) 06.11.15 08:59
(6) AlX0id, Да, это самый популярный ответ в тех.поддержке 1С. Но на практике люди, скрывшие ненужные сегодня элементы, завтра их не находят и звонят нам. Так что это вредный совет.
8. Алексей 1 (AlX0id) 06.11.15 09:07
(7) H-Labs, то есть, они не способны найти закладку, но способны найти раскрывающуюся вкладку? ) Странные люди,как минимум )

ЗЫ. Нет, не скрыть, а перенести на другую вкладку, если чо.
9. Александр Шихов (H-Labs) 06.11.15 10:28
(8) AlX0id, К сожалению, интерфейс Такси после 2.0 приживается не сразу и не везде. Реальная практика такова. Много проблем продолжаем иметь и по настройкам отчётов, но потихоньку учим народ.
10. Сергей JesteR (JesteR) 06.11.15 12:29
(1) Кстати работает только в режиме "Формы в закладках".
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа