bdd2

Набор внешних печатных форм для ЗУП 3.0

Опубликовал Дмитрий Дмитрий (Дормидон) в раздел Печать - Печатные формы документов

Внешние печатные формы для ЗУП 3.0 (Т-5, Т-5а, Т-9, Т-9а, Т-10, Т-10а, Т-6, Т-6а, Т-60, Т-11, Т-1, Т-1а, Трудовой договор, Приказ на совмещение, Доп соглашение на совмещение, Т-13, Т-8, Т-8а, Т-61)

Печатные формы для ЗУП 3.0 (проверено на 3.0.22.216, 3.0.23.143).

Подлючаются стандартно:

зайдите Администрирование - Печатные формы, отчеты и обработки - Дополнительные печатные формы и обработки, создайте новый элемент и выберите файл печатной формы.

 

Если необходимы другие печатные формы - пишите в комментарии, добавлю.

Скачать файлы

Наименование Файл Версия Размер
Внешние печатные формы ЗУП 3.0.rar
.rar 347,14Kb
21.09.15
127
.rar 347,14Kb 127 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Дон Батон (SpecialPro) 28.09.16 04:46 Сейчас в теме
На стандартную базу не встало из-за несоответствия параметров "1" и "метод объекта не обнаружен".
Подключаются стандартно, а на 3.0.25 не работают.
2. Дмитрий Дмитрий (Дормидон) 14 06.10.16 15:48 Сейчас в теме
(1) SpecialPro, На данной версии конфигурации не тестировались формы. Нужно протестировать и поправить ошибки, в случае возникновения. Судя по тексту ошибки, имена модулей изменены и процедуры.
3. Дон Батон (SpecialPro) 07.10.16 06:01 Сейчас в теме
(2) Дормидон, понять бы, как это делать самому, а то каждый раз тыкать программистов или платить деньги за доработку не очень хочется. А без годного мануала и бутылки не разберусь.
4. Ольга Русанова (LynxX) 73 25.11.16 12:25 Сейчас в теме
В ЗУП КОРП 3.1.1.95
В модуле объекта в функции ПолучитьСтруктуруПараметровПриказаТ1()
заменить строку
Параметры = КадровыйУчет.ПолучитьСтруктуруПараметровКадровогоПриказа();

на
Параметры = КадровыйУчет.ПараметрыКадровогоПриказа();
IT_Avito; +1 Ответить
5. Евгений Беляев (nofear) 28.12.16 11:08 Сейчас в теме
В ЗУП 3.1 для возможности отладки печ.форм также необходимо немного поправить функцию модуля формы УстановитьОграничениеТипа():

Элементы.СсылкаНаОбъект.ОграничениеТипа = Новый ОписаниеТипов("ДокументСсылка.КадровыйПеревод"); //тип документа, к которому подключается печ.форма.
	
	//ВидОбработки = Перечисления.ВидыДополнительныхОтчетовИОбработок[РегистрационныеДанные.Вид];
	
	//ПолноеНазначениеЗначение = ДополнительныеОтчетыИОбработки.НазначаемыеОбъектыМетаданныхПоВидуВнешнегоОбъекта(ВидОбработки);
	//
	//СписокОграниченияТипа = Новый Массив;
	//
	//Если РегистрационныеДанные.Свойство("Назначение") Тогда
	//	Для Каждого ЭлементЗаданноеНазначение Из РегистрационныеДанные.Назначение Цикл
	//		РазделеннаяСтрока = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(ЭлементЗаданноеНазначение, ".");
	//		Если РазделеннаяСтрока[1] = "*" Тогда
	//			НайденныеНазначения = ПолноеНазначениеЗначение.НайтиСтроки(Новый Структура("ВидОбъектаМетаданных", РазделеннаяСтрока[0]));
	//			Для Каждого ЭлементНайденноеНазначение Из НайденныеНазначения Цикл
	//				СписокОграниченияТипа.Добавить(ЭлементНайденноеНазначение.ПолноеИмяОбъектаМетаданных);
	//			КонецЦикла;
	//		Иначе
	//			Если ПолноеНазначениеЗначение.НайтиСтроки(Новый Структура("ПолноеИмяОбъектаМетаданных", ЭлементЗаданноеНазначение)).Количество() > 0 Тогда
	//				СписокОграниченияТипа.Добавить(ЭлементЗаданноеНазначение);
	//			КонецЕсли;
	//		КонецЕсли;
	//	КонецЦикла;
	//КонецЕсли;
	//
	//Если СписокОграниченияТипа.Количество() > 0 Тогда
	//	Для А = 0 По СписокОграниченияТипа.Количество() - 1 Цикл
	//		ЭлементМассива = СписокОграниченияТипа[А];
	//		ПозицияРазделителя = Найти(ЭлементМассива, ".");
	//		Если Лев(ЭлементМассива, ПозицияРазделителя - 1) = "Документ" Тогда
	//			ТипДокумента = Документы[Сред(ЭлементМассива, ПозицияРазделителя + 1)].ПустаяСсылка();
	//			ЭлементМассива = ТипЗнч(ТипДокумента);
	//		ИначеЕсли Лев(ЭлементМассива, ПозицияРазделителя - 1) = "Справочник" Тогда
	//			ТипСправочника = Справочники[Сред(ЭлементМассива, ПозицияРазделителя + 1)].ПустаяСсылка();
	//			ЭлементМассива = ТипЗнч(ТипСправочника);
	//		КонецЕсли;
	//		СписокОграниченияТипа[А] = ЭлементМассива;
	//	КонецЦикла;
	//	Элементы.СсылкаНаОбъект.ОграничениеТипа = Новый ОписаниеТипов(СписокОграниченияТипа);
	//КонецЕсли; 
...Показать Скрыть
6. Александр (alext79) 11.01.17 16:49 Сейчас в теме
вместо Т11 при подключении появляется форма Т9