gifts2017

Заполнение документа "Инвентаризация незавершенного производства"

Опубликовал pallid *** (white_sochi) в раздел Обработки - Обработка документов

Сделал простое расширение с добавлением двух кнопок - "Заполнить" и "Очистить".

Стандартно в документе "Инвентаризация незавершенного производства" (Инвентаризация НЗП) нет возможности заполнить документ автоматически остатками на конец месяца.

 

Сам в принципе код, если кому-то жалко монеток:

&НаКлиенте
Процедура ИНЗП_Заполнить(Команда)
	Если Объект.Состав.Количество() <> 0 Тогда 
		ТекстВопроса = НСтр("ru = 'При заполнении существующие данные будут очищены!
			|Продолжить?'");
		Оповещение = Новый ОписаниеОповещения("ВопросЗаполнитьДанныеЗавершение", ЭтотОбъект);
		ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
	Иначе
		ЗаполнитьДанныеСервер();
	КонецЕсли;

КонецПроцедуры
	
&НаКлиенте
Процедура ВопросЗаполнитьДанныеЗавершение(Результат, ДополнительныеПараметры) Экспорт	
	Если Результат = КодВозвратаДиалога.Да Тогда
		ЗаполнитьДанныеСервер();
	КонецЕсли;	
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьДанныеСервер()
	ОчиститьДанныеСервер();
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	ХозрасчетныйОстатки.Субконто1 КАК НоменклатурнаяГруппа,
	               |	ХозрасчетныйОстатки.СуммаОстатокДт как Сумма,
	               |	ХозрасчетныйОстатки.СуммаНУОстатокДт как СуммаНУ
	               |ИЗ
	               |	РегистрБухгалтерии.Хозрасчетный.Остатки(
	               |			&Дата,
	               |			Счет = &Счет,
	               |			,
	               |			Организация = &Организация
	               |				И Подразделение = &Подразделение) КАК ХозрасчетныйОстатки";
				   
	Запрос.УстановитьПараметр("Организация",Объект.Организация);
	Запрос.УстановитьПараметр("Подразделение",Объект.ПодразделениеОрганизации);
	Запрос.УстановитьПараметр("Счет",Объект.СчетЗатрат);
	Запрос.УстановитьПараметр("Дата",Объект.Дата);
	Результат = Запрос.Выполнить().Выгрузить(); 
	
	Объект.Состав.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры

&НаКлиенте
Процедура ИНЗП_Очистить(Команда)
	Если Объект.Состав.Количество() <> 0 Тогда 
		ТекстВопроса = НСтр("ru = 'Cуществующие данные будут очищены!
			|Продолжить?'");
		Оповещение = Новый ОписаниеОповещения("ВопросОчисткиДанныеЗавершение", ЭтотОбъект);
		ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
	Иначе
		ОчиститьДанныеСервер();
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ВопросОчисткиДанныеЗавершение(Результат, ДополнительныеПараметры) Экспорт
	Если Результат = КодВозвратаДиалога.Да Тогда
		ОчиститьДанныеСервер();
	КонецЕсли;
КонецПроцедуры


&НаСервере
Процедура ОчиститьДанныеСервер()
	Объект.Состав.Очистить();	
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Расширение Инвентаризация незавершенного производства 5
.cfe 43,35Kb
25.11.15
5
.cfe 1 43,35Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа