Расшифровка 6-НДФЛ 2 Раздела

Опубликовал Nik Verg (lotan) в раздел Отчеты - Бухгалтерские

Внешний отчет. Расшифровка 2 Раздела 6-НДФЛ по физ. лицам и документам-регистраторам удержанного НДФЛ для ЗУП 2.5.

Простой отчет по Расшифровке 2 Раздела регламентированного отчета 6-НДФЛ.

Заполняется по алгоритмам заполнения самого отчета, поэтому информация и сортировка полностью совпадает с отчетом.

- Добавлен доработанный отчет под релиз 2.5.101.2

Добавлен доработанный отчет под релиз 2.5.102.1 (в релизе 102.2 механизм заполнения отчета 6-НДФЛ не менялся)

Добавлен доработанный отчет под релиз 2.5.103.1

Добавлен доработанный отчет под релиз 2.5.105.1  (по совету kovgard, добавил Итог по 130 и сделал заполнение отчета через общие модули, что надеюсь избавит меня от постоянного обновления отчетов под каждый релиз)

Добавлен доработанный отчет под релиз 2.5.107.1 (Вернулиь к старой схеме, 1С нам на встечу не идет. Вроде бы, совместно с пользователем as7bs , разобрались где в последней Версии отчета проблема. Кто качал ранее, пишите, скину последнюю версию отчета под 107 релиза.)

Добавлен доработанный отчет под релиз 2.5.110.1

Добавлен доработанный отчет под релиз 2.5.114.1

Добавлен доработанный отчет под релиз 2.5.118.1

P.S

Кто скачал файл, пишите в личку, вышлю последнюю версию.

Скачать файлы

Наименование Файл Версия Размер
Расшифровка_6_НДФЛ_v2_99.2
.erf 13,91Kb
21.07.16
46
.erf 2 13,91Kb 46 Скачать
Расшифровка_6_НДФЛ_v3_101.2
.erf 15,73Kb
21.07.16
75
.erf 3 15,73Kb 75 Скачать
Расшифровка_6_НДФЛ_v4_102.1
.erf 16,12Kb
21.07.16
71
.erf 4 16,12Kb 71 Скачать
Расшифровка_6_НДФЛ_v5_103.1
.erf 16,47Kb
21.07.16
55
.erf 5 16,47Kb 55 Скачать
Расшифровка_6_НДФЛ_v6_105.1
.erf 11,19Kb
21.07.16
29
.erf 6 11,19Kb 29 Скачать
Расшифровка_6_НДФЛ_v7_107.1
.erf 19,12Kb
21.07.16
60
.erf 7 19,12Kb 60 Скачать
Расшифровка_6_НДФЛ_v8_110.1
.erf 19,36Kb
04.10.16
53
.erf 8 19,36Kb 53 Скачать
Расшифровка_6_НДФЛ_v9_114.1
.erf 19,36Kb
05.02.17
28
.erf 9 19,36Kb 28 Скачать
Расшифровка_6_НДФЛ_v10_118.1
.erf 19,73Kb
23.04.17
10
.erf 10 19,73Kb 10 Скачать

См. также

Лучшие комментарии
7. Владимир Епифанов (kovgard) 148 30.04.16 14:34 Сейчас в теме
Спасибо за отчет, пригодился. Единственное, можно было не вытаскивать код из общего модуля:

Функция ДанныеРаздела2()
	
	ПодробныеДанные = Истина;
	НачалоПериода = ДатаНачала;
	ОкончаниеПериода = КонецМесяца(ДатаОкончания);	
	ОписаниеТаблиц = Новый Структура("Раздел2");
	ИмяРасчета = "РасчетПоказателей_6НДФЛ_2016";
	ЗаполнениеРегламентированнойОтчетности.РасчетПоказателей6НДФЛ(ИмяРасчета, НачалоПериода, ОкончаниеПериода, Организация, ОбособленноеПодразделение, ОписаниеТаблиц, ПодробныеДанные);
	Возврат ОписаниеТаблиц.Раздел2;
	
КонецФункции // ДанныеРаздела2()
...Показать Скрыть
21. Алексей Саурин (as7bs) 106 25.07.16 12:21 Сейчас в теме
(20) lotan, Нашел причину. В модуле формы есть следующий код.
Если ПроверятьПересчеты Тогда
 ...
Иначе
 ОписаниеТаблиц.Раздел2 = Запрос.Выполнить().Выгрузить();
КонецЕсли;
...Показать Скрыть

Когда в процессе формирования формы "ПроверятьПересчеты = Ложь" тогда регистратор видно, если "ПроверятьПересчеты = Истина", тогда в расшифровке регистратор не выводится.

Чтобы исправить, нужно добавить в колонку группировок добавить ",Регистратор".
Строку
				ВременнаяТаблица.Свернуть("ДатаФактическогоПолученияДохода,П000020010001,ДатаУдержанияНалога,П000020011001,СрокПеречисленияНалога,П000020012001" + ?(ПодробныеДанные, ",ФизЛицо", ""),"П000020013001,П000020014001");

исправить следующим образом
				ВременнаяТаблица.Свернуть("ДатаФактическогоПолученияДохода,П000020010001,ДатаУдержанияНалога,П000020011001,СрокПеречисленияНалога,П000020012001" + ?(ПодробныеДанные, ",ФизЛицо", "")+",Регистратор","П000020013001,П000020014001");

правильнее наверно будет так:
				ВременнаяТаблица.Свернуть("ДатаФактическогоПолученияДохода,П000020010001,ДатаУдержанияНалога,П000020011001,СрокПеречисленияНалога,П000020012001" + ?(ПодробныеДанные, ",ФизЛицо,Регистратор", ""),"П000020013001,П000020014001");
Остальные комментарии
2. Людмила ? (Lusik) 16 15.04.16 15:45 Сейчас в теме
Добрый день!
Спасибо огромное за отчет! Он супер-полезный!
Однако, мы заметили, что туда не подпадают отпуска, у которых дата удержания раньше даты начисления...
3. Nik Verg (lotan) 57 15.04.16 16:32 Сейчас в теме
(2) Lusik, а в Отчет 6-НДФЛ эти суммы попадают? Этот отчет заполняется по алгоритмам заполнения 6-НДФЛ, то есть строки должны быть 1 в 1.
4. Nik Verg (lotan) 57 17.04.16 22:22 Сейчас в теме
(2) Lusik, не смог воспроизвести Вашу ошибку. У меня такого рода отпуска попадают и в отчет 6-НДФЛ и в мой отчет.
5. DEN DEN (FKLDOZ) 6 19.04.16 13:56 Сейчас в теме
Спасибо за отчет! Бухгалтеру отличная помощь!
6. Aleksey Romanov (aaromanov) 27.04.16 06:49 Сейчас в теме
7. Владимир Епифанов (kovgard) 148 30.04.16 14:34 Сейчас в теме
Спасибо за отчет, пригодился. Единственное, можно было не вытаскивать код из общего модуля:

Функция ДанныеРаздела2()
	
	ПодробныеДанные = Истина;
	НачалоПериода = ДатаНачала;
	ОкончаниеПериода = КонецМесяца(ДатаОкончания);	
	ОписаниеТаблиц = Новый Структура("Раздел2");
	ИмяРасчета = "РасчетПоказателей_6НДФЛ_2016";
	ЗаполнениеРегламентированнойОтчетности.РасчетПоказателей6НДФЛ(ИмяРасчета, НачалоПериода, ОкончаниеПериода, Организация, ОбособленноеПодразделение, ОписаниеТаблиц, ПодробныеДанные);
	Возврат ОписаниеТаблиц.Раздел2;
	
КонецФункции // ДанныеРаздела2()
...Показать Скрыть
8. Владимир Епифанов (kovgard) 148 30.04.16 14:44 Сейчас в теме
Да, и нужно добавить общий итог по строке 130. У 1С алгоритм не совершенен, возможно расхождение со строкой 020.
9. Nik Verg (lotan) 57 30.04.16 18:56 Сейчас в теме
(7) kovgard, думал об этом, можно сделать структуру подобную типовой и уйти с ней в Общий, возможно так и сделаю в следующих релизах, а то много время отнимает рассылка новых релизов. Когда делал, нужно было максимально быстро, а потом надеешься, что переделывать часто не придется, но оказалось не так . :)
Что касаемо Итога по 130, хочу сделать, но сейчас это поле не играет никакого значения. Оно считается информационным и у многих никогда не сойдется с 020, но как бы там не было, принял!
P.S
И честно признаться, не думал, что этот отчет будет пользоваться большой популярность, а получилось вон как... :)
10. Alex Smol (Alteza) 10.06.16 14:25 Сейчас в теме
Отчет хорош, но мне еще пришлось по видам начисления группировать и налоговый вычет выводить. Я думаю неплохо бы добавить сразу)
11. Олег Полозов (asher72) 29 16.06.16 04:16 Сейчас в теме
Че то отчет не отправляется на почту...
12. Nik Verg (lotan) 57 16.06.16 09:20 Сейчас в теме
(11) asher72, напишите почту в личку.
13. Nik Verg (lotan) 57 16.06.16 09:25 Сейчас в теме
(10) Alteza, (8) kovgard, Все пожелания собираю, перед 2 кварталом постараюсь, что-нибудь сотворить.
14. Игорь Гладкий (smooth) 172 15.07.16 00:31 Сейчас в теме
Было бы супер если бы еще и 1 раздел расшифровывался :)
15. Евгения К (Scene1) 21.07.16 14:25 Сейчас в теме
Добрый день. Спасибо за отчет, но у меня почему то не выводит регистратор. Не подскажете, почему такое может быть?
16. Nik Verg (lotan) 57 21.07.16 16:28 Сейчас в теме
(15) Scene1, где-то "Дата получения дохода" > "Даты выплаты дохода". Исправил. Скажите куда кинуть отчет?
17. Алексей Саурин (as7bs) 106 21.07.16 17:10 Сейчас в теме
В версии v6_105.1 расшифровка по документу пропала, я так понял, в связи с заполнением отчета через общие модули.
Обрадовался, прочитав что в v7_107.1 "Вернулиь к старой схеме".
Снова скачал обновление. Но расшифоровки по регистратору, так и не увидел.
Спасибо, что очень помогла в 1 квартале при формировании отчетности.
Но сейчас, без расшифровки по регистратору, данная обработка стала БЕСПОЛЕЗНОЙ.

(16) lotan, Похоже я опоздал с комментарием. Написал, тоже адрес в личку.
18. Nik Verg (lotan) 57 22.07.16 09:12 Сейчас в теме
(17) as7bs, не понял. Я скинул Вам на почту последнюю версию. Она заработала?
Сейчас уже не старая схема разработки, сейчас уже переписывание запросов 1С, они убрали из запроса Регистратор.
19. Алексей Саурин (as7bs) 106 22.07.16 20:13 Сейчас в теме
(18) lotan, Последняя версия, которую вы скинули, показывает регистратор не во всех базах, в некоторых есть, а в некоторых нету.
Причем в некоторых базах, расшифровка, как v7_107, так и v6_105(работающая на общих модулях) показывают данные отличные от тех которые заполняются в самой форме 6-НДФЛ.
20. Nik Verg (lotan) 57 25.07.16 10:06 Сейчас в теме
(19) as7bs, странно, перепроверил 107 на нескольких базах, все ок. Мне хотя бы понять какие у Вас строки выпадают (Например: отпуск, больничный)? Базу дать на опыты есть возможности?
21. Алексей Саурин (as7bs) 106 25.07.16 12:21 Сейчас в теме
(20) lotan, Нашел причину. В модуле формы есть следующий код.
Если ПроверятьПересчеты Тогда
 ...
Иначе
 ОписаниеТаблиц.Раздел2 = Запрос.Выполнить().Выгрузить();
КонецЕсли;
...Показать Скрыть

Когда в процессе формирования формы "ПроверятьПересчеты = Ложь" тогда регистратор видно, если "ПроверятьПересчеты = Истина", тогда в расшифровке регистратор не выводится.

Чтобы исправить, нужно добавить в колонку группировок добавить ",Регистратор".
Строку
				ВременнаяТаблица.Свернуть("ДатаФактическогоПолученияДохода,П000020010001,ДатаУдержанияНалога,П000020011001,СрокПеречисленияНалога,П000020012001" + ?(ПодробныеДанные, ",ФизЛицо", ""),"П000020013001,П000020014001");

исправить следующим образом
				ВременнаяТаблица.Свернуть("ДатаФактическогоПолученияДохода,П000020010001,ДатаУдержанияНалога,П000020011001,СрокПеречисленияНалога,П000020012001" + ?(ПодробныеДанные, ",ФизЛицо", "")+",Регистратор","П000020013001,П000020014001");

правильнее наверно будет так:
				ВременнаяТаблица.Свернуть("ДатаФактическогоПолученияДохода,П000020010001,ДатаУдержанияНалога,П000020011001,СрокПеречисленияНалога,П000020012001" + ?(ПодробныеДанные, ",ФизЛицо,Регистратор", ""),"П000020013001,П000020014001");
22. Алексей Саурин (as7bs) 106 25.07.16 12:34 Сейчас в теме
И еще себе я обработку меняю следующим образом:
В процедуре ПриОткрытии
	ДатаНачала = НачалоКвартала(ТекущаяДата());
	ДатаОкончания = КонецКвартала(ТекущаяДата());

заменяю на
	ДатаНачала = НачалоКвартала(ДобавитьМесяц(ТекущаяДата(),-3)); //АС_
	ДатаОкончания = КонецКвартала(ДобавитьМесяц(ТекущаяДата(),-3)); //АС_

Чтобы постоянно не менять период на прошлый квартал при открытии обработки. Т.к. отчет мы обычно формируем в следующем квартале.
23. Nik Verg (lotan) 57 25.07.16 12:40 Сейчас в теме
(21) as7bs, я понял. Да, у меня не заходит сюда, поэтому было все Ок.
24. Евгения К (Scene1) 25.07.16 16:48 Сейчас в теме
25. Евгений Рыбасов (rybasov) 26.07.16 17:47 Сейчас в теме
Можно и мне скинуть на почту ashvets@it-cr.ru последнюю версию
26. Nik Verg (lotan) 57 27.07.16 09:37 Сейчас в теме
Товарищи, пишите в личку насчет свежей версии отчета :)
27. Андрей вадимович (mentozavr) 25 30.08.16 17:10 Сейчас в теме
Доброго времени суток. Скачал ваш отчет "Расшифровка_6_НДФЛ_Отчет_v8_107.1". Запустил на 108 релизе. Формировать не хочет. В чем причина может быть. Спасибо заранее
28. Nik Verg (lotan) 57 30.08.16 17:39 Сейчас в теме
(27) mentozavr, Добрый. У нас каждый релиз с боем обновляется. Поэтому, я стараюсь делать обновление отчета исключительно под релизы перед сдачей отчета. Примерно во второй половине Сентября я начну разбираться с теми изменениям, которые навояли 1С и дорабатывать отчет. Напишите в личку, как появится новая версия отчета я Вам свежий скину.
29. Андрей вадимович (mentozavr) 25 30.08.16 18:31 Сейчас в теме
(28) lotan, Спасибо уже написал
30. Андрей вадимович (mentozavr) 25 30.08.16 18:35 Сейчас в теме
(28) lotan, Зачем им нужны эти изменения, зачем регистр каверкать
31. Nik Verg (lotan) 57 31.08.16 09:28 Сейчас в теме
(30) mentozavr, я думаю этот вопрос лучше сразу задавать руководству нашей страны. :)
1С тупо пытается подогнать работу программы под чрезвычайно запутанные законы, вот и все.
32. Андрей вадимович (mentozavr) 25 26.09.16 15:17 Сейчас в теме
(31) lotan, Новой версии обработки еще нет?? Спасибо