gifts2017

Проверка часового пояса

Опубликовал Александр Куденцов (kudenzov) в раздел Программирование - Практика программирования

При использовании терминалок для удаленных баз, иногда при входе в базу данных необходимо исключить возможность входа пользователей с компьютеров с другим часовым поясом. Например, работают в Новосибирской базе с временем UTC +6 и пытаются зайти в базу с UTC +3.

Данная ситуация возникает при размещении баз централизованно и установкой на терминальных серверах времени зоны пользователей.

Существуют следующие методы проверки:

  1. Назначение доступа средствами домена в AD (Active Directory) - работает, но при переезде системные админы часто забывают эти права назначать на определенные компьютеры. 
  2. Проверка часового пояса непосредственно при входе пользователя в 1С (используем именно ее) :

Добавляем константу   

 

Константа.ЧасовойПояс = 3 // Москва

Добавляем функцию проверки при входе в 1С, по результату проверки можно, например, завершить работу пользователя.

Функция ПроверкаЧасовогоПояса()        
    
    Перем  scr;
    Если Константа.ЧасовойПояс > 0 Тогда
        Попытка
            scr = СоздатьОбъект("MSScriptControl.ScriptControl");
            scr.language = "javascript";
            лСкрипт = "function tZone() 
            |    {
            |      nzone =  new Date().getTimezoneOffset()/60*-1;
            |      return(nzone); 
            |}";
            scr.AddCode(лСкрипт);     
            лЧасовойПояс = число(scr.Run("tZone"));
        Исключение
            Сообщить("Не удалось определить часовой пояс","i");
            Возврат 1;
        КонецПопытки;
        
        Если лЧасовойПояс <> Константа.ЧасовойПояс Тогда
            Предупреждение("Часовой пояс: +"+Константа.ЧасовойПояс+"   не соответствует системному  +"+лЧасовойПояс+", смените терминалку или обратитесь к администратору"+РазделительСтрок+
            РазделительСтрок+ "Вы нарушите время документов в базе данных!", 10);
            Возврат 0;
        Иначе        
            Сообщить("UTC +"+лЧасовойПояс);
        КонецЕсли;
        
    КонецЕсли;
    Возврат 1;
    
КонецФункции    // ПроверкаЧасовогоПояса

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Роберт В е р т и н с к и й (v3rter) 16.05.16 17:34
Это для 8.0/8.1? Вроде бы как с 8.2 появилась ПолучитьЧасовойПоясИнформационнойБазы() и куча связанных функций-процедур.

[quote]ПолучитьЧасовойПоясИнформационнойБазы()
Возвращаемое значение:

Тип: Строка; Неопределено.
Список допустимых часовых поясов может быть получен методом ПолучитьДопустимыеЧасовыеПояса.
Кроме того, возможно задание часовых поясов смещением от универсального времени (часовые пояса GMT) в формате:
GMT{+/-}h[h][:mm]
где hh=0:23, mm=0:59.
Неопределено, если он не был установлен.
Описание:

Получает строку идентификатора часового пояса информационной базы.

Доступность:

Сервер, толстый клиент, внешнее соединение. [/quote]
2. Александр Куденцов (kudenzov) 16.05.16 22:50
это код для 1с77, для 8-ки ипользуйте код для создания объектов MSScriptControl.ScriptControl