gifts2017

Как простой расчет среднего расхода материалов помог маленькому бизнесу

Опубликовал Maxim Maxim (miavolas) в раздел Программирование - Практика программирования

В публикации будет рассказано, как с помощью несложных доработок типового функционала конфигурации Альфа-Авто можно оценить и сравнить стоимость расходных материалов, используемых при покраске одного кузовного элемента разными исполнителями.

В прошедшую пятницу по долгу службы был в небольшой кузовной мастерской, где имел возможность пообщаться с удивительно грустным хозяином этого бизнеса. Более грустное лицо, как мне представляется, могло бы быть только у владельца валютной ипотеки. На мой вопрос, с чем связано плохое настроение, я услышал рассказ, о беспричинно выросших в 2 раза затратах на лакокрасочные материалы... и это при той же выработке цеха за последние пару месяцев. Именно бесконтрольность процесса и отсутствие логического объяснения особенно удручали руководителя. По "случайному стечению" обстоятельств учет эта небольшая организация ведет в специализированной отраслевой конфигурации Альфа-Авто. О том как с помощью несложных доработок типового функционала можно сравнить стоимость расходных материалов используемых при покраске одного кузовного элемента разными исполнителями расскажу ниже

В решении задачи на первоначальном этапе мне виделось две сложности:

- отсутствие возможности увязать выполняемые исполнителем работы и израсходованные материалы;

- сложность оценки эффективности расходования различных по материалов, которые к тому же в разных единицах измерения выражены (уж очнь не хотелось предлагать решение, которое будет "мух с котлетами" складывать, суммируя израсходованное в штуках и граммах)

Заказчик сообщил, что его устроит результат позволяющий оценить среднюю стоимость материалов на один кузовной элемента по документу ремонта. На практике это означает необходимость выделить количество окрашенных элементов

Чего можно добиться как введением дополнительного реквизита для классификации

Так и структурированием каталога авторабот, для последующей программной обработки

И кроме того необходимо структурировать справочник номенклатуры, чтобы можно было сгруппировать позиции и суммировать стоимость расходных материалов

В состав документа заказ-наряд достаточно добавить всего 3 реквизита шапки

Которые будут рассчитываться пред записью документа 

 //ЛКМ-начало 
 Если НЕ ВручнуюСуммаЛКМ тогда 
	 СуммаЛКМ = 0; 
	 ТекстЗапроса = "ВЫБРАТЬ 
	 | СУММА(ЗаказНарядТовары.СуммаВсего) КАК СуммаВсего 
	 |ИЗ 
	 | Документ.ЗаказНаряд.Товары КАК ЗаказНарядТовары 
	 |ГДЕ 
	 | ЗаказНарядТовары.Ссылка = &Ссылка 
	 | И ЗаказНарядТовары.Номенклатура В ИЕРАРХИИ (&НоменклатураГруппаЛКМ)"; 
	 Запрос = Новый Запрос(ТекстЗапроса); 
	 Запрос.УстановитьПараметр("Ссылка", Ссылка); 
	 Запрос.УстановитьПараметр("НоменклатураГруппаЛКМ", 
	 Справочники.ПредопределенныеЭлементы.ГруппаЛКМ.Значение); 
	 Выборка = Запрос.Выполнить().Выбрать(); 
	 Если Выборка.Следующий() тогда 
		 СуммаЛКМ = выборка.СуммаВсего; 
	 КонецЕсли; КонецЕсли; 
	 КоличествоДеталей = 0; 
	 Для Каждого стр из Работы цикл 
		 Если ЗначениеЗаполнено(стр.Работа) тогда 
			 Если стр.Работа.ОтдельнаяДеталь тогда 
				 КоличествоДеталей = КоличествоДеталей + 1; 
			 КонецЕсли; 
		 КонецЕсли; 
	 КонецЦикла; 
	 Если КоличествоДеталей>0 тогда 
		 СуммаЛКМнаОднуДеталь = СуммаЛКМ / КоличествоДеталей; 
	 иначе СуммаЛКМнаОднуДеталь = 0; 
КонецЕсли; 
 //ЛКМ-Конец

В приводимой реализации рассчитанное значение реквизитов документа заказ-наряд которое отображается в списке :

Это позволяет сохранить в регистре "Выработка сотрудников"для каждой работы документа величину средней стоимости материалов. Для чего предлагается ввести дополнительный ресурс регистра

и дополнить функцию "Движение()" модуля набора записей относящегося к упомянутому выше регистру накопления

Если СтрокаРабот.ОтдельнаяДеталь тогда  НоваяЗапись.ЛКМнаДеталь = ДокументОбъект.СуммаЛКМнаОднуДеталь;КонецЕсли;

В этом случае у нас появятся данные для формирования отчета с итоговыми данными. Взяв в качестве исходного отчета конфигурации "Выработку исполнителей" необходимо будет в начало текста запроса добавить новый показатель отчета

не забыв указать его в Итогах

В таких объектах с использованием построителей отчетов, присутствующих и в последних версиях Альфа-Авто изменение состава показателей нужо отражать и в макете, называемом "Параметры"

Описанная выше техническая реализация простого расчета позволяет получить результат в виде

и проанализировать данные колонки "ЛКМ на деталь", содержащие закупочную стоимость, оценивая их для разных исполнителей и автомобилей за предыдущие месяцы.

Вместо заключения

Внесение в конфигурацию изменений и формирование отчетов за прошедшие периоды не стало волшебной палочкой для бизнеса. Анализ данных лишь подтвердил известные организаторам факты о менее эффективном расходовании материалов начинающими работниками и существовании объективно дорогих по себестоимости покрасочных работах, количество которых в последнее время выросло на предприятии. Интересным же для меня результатом анализа данных, показалось исчезновение из списка предполагаемых причин первоначально часто упоминавшегося нецелевого использования материалов.

 

См. также

Вознаграждение за ответ
Сумма: 0 $m
Добавили:
Андрей Камынин (AndrewK990) (0.09 $m)
Подписаться Добавить вознаграждение
Комментарии
1. Вадим Купинов (izofen) 04.07.16 08:48
Интересная статья, но не понятно как получается, что в результирующий отчет попала стоимость расходных материалов в закупочных ценах? глядя на первые картинки складывается впечатление, что стоимость берется из табличной части товары, документа заказ-наряд, которая наверное указывается в ценах продажи.
2. Maxim Maxim (miavolas) 04.07.16 09:20
(1) izofen, Действительно данные в отчет выработка исполнителей попадают из табличной части товары, документа заказ-наряд, где в общем случае фигурируют цены продажи, а не закупа... но в описываемом случае методика работы такова, что расходные материалы не продаются как таковые, и на них цены продажи устанавливаются равными закупочными в момент поступления. Организация зарабатывает выполняя работы и не устанавливая от закупочных цены процент наценки. В случае необходимости, в отчете могли бы фигурировать и данные партионного учета
AndrewK990; +1 Ответить
3. Андрей Камынин (AndrewK990) 04.07.16 09:36
Не могли бы вы к данной публикации приложить файл конфигурации, текст изменений к которому фигурирует в статье? Получается что в большое количество объектов метаданных нужно вносить изменения, и опасаюсь забыть что нибудь.
4. Дарья Чернышова (chernyshova_darya) 04.07.16 09:39
Глядя на макеты с текстами запросов делаю вывод, что речь идет про Альфа-Авто 4ой версии, а если мне не изменяет память сейчас разработчик прелагает 5ую версию, где подобный отчет сделан на СКД. Могут ли описанные вопросы быть отражены в последней версии конфигурации?
5. Maxim Maxim (miavolas) 04.07.16 09:43
(3) AndrewK990, К сожалению файл конфигурации отраслевого решения нельзя разместить в качестве прилагаемого к публикации вложения для скачивания, потому моих строчек кода там очень немного(как видно из статьи), правообладателем на остальные является разработчик
Diego_Iv; +1 Ответить
6. Maxim Maxim (miavolas) 04.07.16 09:46
(4) chernyshova_darya, отчет на СКД формируется на основе запроса к тому же регистру накопления, суть отчета та же
7. Maxim MaximSur (maxim1c) 04.07.16 12:11
Как ваш заказчик планировал сравнивать расход материалов на покраску различных по площади кузовных элементов? цифры объективно будут разными
8. Maxim Maxim (miavolas) 04.07.16 12:19
(7) maxim1c, Действительно существуют различные приблизительные оценки расхода готовой эмали на один кузовной элемент
Например:
дверь – 300 мл;
крыло переднее – 200 мл;
крыло заднее – 300 мл;
крышка багажника – 300-400 мл;
задняя панель – 250 мл;
радиаторная решетка – 100 мл;
крыша кузова – 400 мл;
бампер передний и задний – 250-300 мл;
поверхность капота – 400-500 мл;
порог – 150 мл.

В связи с этим работы группируются по виду деталей, и уже внутри этих групп справочника авторабот производится сравнение
Формируя отчет с группировкой строк "Работа"

9. Валерий Осин (osivv) 07.07.16 11:51
Данная задача решается более просто и себестоимость вычисляется точно:
Есть такой документ "Комплектация", туда забиваются расходники на комплект ЛКМ, после проведения, комплект списывается в производство.
В заказ-наряд помещается через кнопку заполнить-деталями из производства, остается проставить цену продажи или прописать продажную цену товара и она встанет автоматом.
Правда лучше конфигу подправить на тот счет, чтобы комплектация в производство могла вводиться только на основании з-н, чтобы ушлый народ не прочухал фишку и не начал списывать всё подряд.
Данное решение уже давно и успешно работает, все довольны, нареканий нет.
Как-то так.
10. Maxim Maxim (miavolas) 07.07.16 12:43
(9) osivv, Спасибо за предложенное решение, мне на самом деле интересно обсуждать решения отраслевых проблем....
На описываемом предприятии активно используется функционал документов комплектации и разукомплектации, ...
Правда не до конца понял как можно было бы использовать предложенную вами методику для того чтобы увязать стоимость материалов с работами исполнителей? чтобы подсчитать сумму приходящуюся на одну деталь (для некоторых работ из табличной части Работ) стоимость действительно более точно можно определять используя данные партионного учета (как об этом сказано в моем первом ответе на статью)
Сравнить стоимость материалов расходуемых разными исполнителей(малярами) увязав работы с товарами - вот вопрос.

Думая над вашим предложением возможно получилось бы посмотреть на более интересные результаты если переработав все документы предыдущего периода для формирования отчетов(или изначально выстроив так систему) для каждой работы указать документ комплектации.

Наверное каждый полученный комплект необходимо в таком случае называть "Комплект ЛКМ для окраски переднего левого крыла автомобиля VIN ххххх"?

и еще одно описываемом решении для получения данных для анализа не пришлось изменять документов предыдущего периода
11. parts trader Surname (partstrader) 11.07.16 11:51
А как запчасти группировали в справочнике номенклатура?