gifts2017

Вывод Таблицы Значений или Дерева Значений на экран управляемой формы без объявления колонок в реквизитах формы

Опубликовал Павел Панкратов (pavley2002) в раздел Программирование - Практика программирования

Примеры взаимных преобразований Таблицы значения в Дерево значений или Табличный документ с использованием универсальных функций и макетов Системы компоновки данных. Примеры представлены в форме удобной для копирования в разработку.

Переход с обычного на управляемое приложение обязывает программиста изменить уже ставшие привычными приёмы написания программного кода.

В этой статье предложены шаблоны программного кода, которые позволяют выполнять различные операции с Таблицой Значений или Деревом Значений в управляемой форме.

В 1С:классификации Таблица Значений и Дерево Значений (ТЗ и ДЗ) представляют собой не сохраняемый в базе объект. В связи с этим, описание коллекций значений для программирования выполняется оперативно в момент обращения к ним.

Для сокращения трудозатрат программиста, в статье предложена универсальная процедура вывода ТаблицыЗначений или ДереваЗначений на экран. Эта процедура программно заполняет колонки реквизита управляемой формы, что весьма удобно при отладке.

На примерах показаны различия работы с КоллекциямиЗначений в толстом и тонком клиентах управляемой формы.

Из примеров следуют общие правила:

А) для толстого клиента ограничений нет. Примеры 1 и 4.

Б) для тонкого клиента – обработку коллекции необходимо выполнять на сервере, там же следует обеспечить вывод результата на экран.

Предложенная универсальная процедура СоздатьКолонкиУпр() программно добавляет колонки в реквизиты формы и преобразовывает коллекциюЗначений в ДанныеФормы.

Универсальную процедуру СоздатьКолонкиУпр() рекомендуется размещать в общем модуле конфигурации. Если это невозможно, то процедура успешно работает в модуле внешнего отчета.

В обычном приложение аналогом является процедура СоздатьКолонки(), которая удаляет старые колонки и загружает новые колонки из источника данных в табличное поле.

Примечание.

Существуют аналоги рассматриваемой теме  http://infostart.ru/public/191774/   ,     http://infostart.ru/public/296433/  ,  http://infostart.ru/public/356288/  ,  http://infostart.ru/public/73969/    и т.д.  Ссылки на другие сайты не приводятся согласно правилам публикации на Infostart.

Разница между обычным и управляемым приложениями уже была изложена в аналогах.

Эта статья систематизирует методы работы с коллекциями значений и предлагает удобные для копирования варианты программного кода. Цель статьи – сократить трудозатраты программиста при выборе между толстым и тонким клиентами для использования таблицы (ТЗ) или дерева значений (ДЗ) в качестве источника данных для СистемыКомпоновкиДанных (СКД).

Блок-схема подготовки источника внешних данных для СКД на основании не сохраняемых в базе объектов приведена на прилагаемом рисунке.

Третья группа примеров на Видео демонстрирует реализацию всех веток блок – схемы.

Текст озвучки видео.

Сейчас будут показаны варианты программирования работы с таблицей и деревом значений в тонком и толстом клиентах управляемого приложения.

Откроем 1С:Предприятие в Тонком и Толстом клиентах.

Во всех примерах состав колонок Таблицы Значений или Дерева Значений произвольный, то есть заранее не известен. Программное заполнение реквизитов управляемой формы будет выполнено функцией СоздатьКолонкиУпр().

1)  В толстом клиенте никаких ограничений нет. Пример №1 выводит на экран новую таблицу. Пример №4 редактирует существующую таблицу. Все операции можно выполнять на клиенте.

Толстый клиент закрываем.

Остальные примеры рассмотрим в тонком клиенте.

2)  В тонком клиенте (пример №2) дерево создается на сервере. Пример №5 редактирует существующее дерево на сервере.

  1. Пример №6 преобразовывает ДеревоЗначений в таблицу. Это действие востребовано при передаче внешних данных в СКД.

3)  Если программист вынужден передать в обработку КоллекциюЗначений через клиента, то это можно выполнить с помощью временного хранилища. Смотрим пример №3.

  1. Пример №7 показывает как таблицу преобразовать в дерево, используя макет ОсновнаяСхемаКомпоновкиДанных.

4)  Заполним ТаблицуЗначений заново и в примере №8 преобразуем её в табличный документ. Теперь можно напечатать результат.

5)  Далее отключим конфигуратор и демонстрируем, что ручной ввод с экрана новых строк не нарушает алгоритмов преобразования. (Примечание. Работа с добавлением колонок была показано ранее.)

  1. Создаём таблицу значений (Пример.3)
    1.  и добавляем строку вручную.
  2. Преобразовываем таблицу в дерево (Пример.7)
    1.  и добавляем строки в последний уровень и первый,  
  3. Преобразовываем скорректированное дерево в табличный документ по макету ОсновнаяСхемаКомпоновкиДанных. (Пример.9).
    1.  Меняем значение первой колонки
  4. Повторяем преобразование в ТабДок. (Пример.9) и наглядно видим, что ТабличныйДокумент ожидаемый.
  5. Преобразовываем скорректированное дерево в таблицу. (Пример.6)
  6. Скорректированную таблицу преобразовываем в табличный документ по макету ОсновнаяСхемаКомпоновкиДанных.(Пример.8)
  7. На этом заканчиваем демонстрацию приемов программирования КоллекцийЗначений в управляемом приложении.

6)  Третья группа примеров посвящена применению Системы Компоновки Данных (СКД). Здесь будет продемонстрировано практическое использование ранее изложенных приемов для ввода данных в СКД.

  1. Примеры третьей группы полезны программисту в случаях, когда возникает необходимость применить методы обработки данных не доступные в СКД.
  2. Пример 10.1. Получаем табличный документ типовой работой СКД со справочником на основании макетаДЗ.Обращаем внимание, что макетДЗ не имеет настроек на ввод данных из внешнего набора, т.е макетДЗ можно построить конструктором.
  3. Пример 10.2. Получаем тоже самое в форме ДереваЗначений. Добавляем строку и меняем ей родителя на «Блузу».
  4.  Пример 10.3. Возвращает изменённое ДеревоЗначений в формат ТабличногоДокумента по структуре, заданной в макетеДЗ. Такое преобразование востребовано, например, для печати результата типовыми методами.
  5. Видим, что в сложных для программиста случаях, данные табличного документа можно скорректировать либо вручную, либо программно, используя промежуточное дерево значений.
  6. Предварительно преобразуем ДЗ в ТЗ. (Пример.6)
  7. Пример 10.4. Повторяет то же самое для ТаблицыЗначений.   
  8. Техническое решение примеров 10.3 и 10.4 обеспечивает функция ВернутьТабДокСервер(), которая:
    1. В пустой макет «СКДТонкийКлиент» программно устанавливает НаборДанныхОбъект, который заполняем внешними данными из отредактированной ТЗ.
    2. Настройки копируем из макетаДЗ.
    3. Результатом будет требуемый ТабличныйДокумент, учитывающий внесенные изменения в таблицу значений ТЗ.  

7)  Заключение. Демонстрация показала:

  1.  Процедура  СоздатьКолонкиУпр() выполняет такие же функции как процедура. СоздатьКолонки() обычного приложения.
  2. Если исходная коллекция и результат её преобразования размещены в одной управляемой форме, то необходимо очищать колонки источника во избежание дублирования наименований в приёмнике. (Процедура ОчиститьКоллекциюЗначенийНаСервере()).
  3. В тонком клиенте модули управления коллекцией значений обязательно следует размещать на сервере.
  4. Для преобразования коллекции значений в табличной документ с независимым макетомСКД можно применить функцию Скд_ВнешниеДанные().
  5. Независимый макетСКД можно создать на основании другого макета, например, макетДЗ. Для решения этой задачи можно применить функцию ВернутьТабДокСервер(). 
  6. Примечание. Программный код представлен способом, повышающим удобство копирования в разработку. Размеры базовых блоков программного кода, назначенных к копированию в разработку, не превышают четырёх строк.

Желаю успехов всем и каждому.

////////////////////////////////////////////////////////

Описание Процедуры     СоздатьКолонкиУпр()

Синтаксис:

СоздатьКолонкиУпр(<ФормаЭта>, <ИмяРеквизита>, <КоллекцияЗначений>)

Параметры:

<ФормаЭта> (обязательный)

Тип:УправляемаяФорма. Форма, в реквизите которой требуется программно определить состав колонок.

<ИмяРеквизита> (обязательный)

Тип:Строка. Имя реквизита как указано в управляемой форме.  Этому реквизиту следует определить состав колонок. Тип реквизита должен быть либо ТаблицаЗначений, либо ДеревоЗначений.

<КоллекцияЗначений> (обязательный)

Тип:ТаблицаЗначений, ДеревоЗначений, АдресВременногоХранилища. Источник данных, который следует вывести на экран. Тип источника данных должен быть либо ТаблицаЗначений, либо ДеревоЗначений. Причем, для этого реквизита состав колонок указанный в управляемой форме должен быть пустым.

Описание:

Для любого прикладного объекта типа таблицаЗначений или деревоЗначений, программно создаётся состав колонок реквизита управляемой формы. Затем прикладной объект преобразовывается в данные формы и выводится на экран.

Процедура применяется в случаях, когда состав колонок коллекцииЗначений заранее не определён.

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

Описание Функции ВернутьТабДокСервер()

Синтаксис:

ВернутьТабДокСервер (<ТЗисточник >, < АдресМакетаСКД >, < НастройкиСКД_1>)

Параметры:

< ТЗисточник > (обязательный)

Тип:ТаблицаЗначений. Источник данных для формирования результата СКД.

< АдресМакетаСКД > (обязательный)

Тип:Строка. Адрес временного хранилища, в которое помещен макет схемы компоновки данных (Тип:СхемаКомпоновкиДанных).   

< НастройкиСКД _1> (обязательный)

Тип:НастройкиКомпоновкиДанных. Текущие настройки макета СКД.

Описание:

Возвращает ТабличныйДокумент с данными из ТаблицыЗначений (ТЗисточник) преобразованными по структуре МакетаСКД

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

Описание Функции скд_ВнешниеДанные ()

Синтаксис:

Скд_ВнешниеДанные (<ТЗ_внешниеДанные>, <ТипРезультата="ТабДок">, <АдресМакетаСКД="">, <НастройкиСКД=Неопределено>)

Параметры:

< ТЗ_внешниеДанные > (обязательный)

Тип:ТаблицаЗначений. ДанныеФормыКоллекция. Источник данных для формирования результата СКД.

< ТипРезультата > (не обязательный)

Тип:Строка. Допустимые значения: «ТабДок», «ТабличныйДокумент», «ДЗ», «ДеревоЗначений», «ТЗ», «ТаблицаЗначений».

< АдресМакетаСКД > (не обязательный)

 (Тип:Строка).   

< НастройкиСКД > (не обязательный)

Тип:НастройкиКомпоновкиДанных. Текущие настройки макета СКД.

Описание:

Возвращает результат СКД заданного типа с данными из ТаблицыЗначений преобразованными по структуре МакетаСКД

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

&НаСервере
Процедура СоздатьКолонкиУпр(ФормаЭта,ИмяРеквизита, ДеревоТаблицаЗначенийАдрес) Экспорт 
	
	#Если ТолстыйКлиент Тогда
		цЭто="ЭтоТолстыйКлиент";//Отладка
	#ИначеЕсли ТонкийКлиент Тогда
		цЭто="ЭтоТонкийКлиент";//Отладка
	#ИначеЕсли Клиент Тогда
		цЭто="ЭтоКлиент";//Отладка|ОбычноеПриложение
	#ИначеЕсли Сервер Тогда
		цЭто="ЭтоСервер";//Отладка
	#Иначе
		цЭто="ЭтоНеКлиентНеСервер";//Отладка
	#КонецЕсли
	
	
	Вариант=3;
	Если Вариант=2 Тогда
		////Вариант=2;
		
	ИначеЕсли Вариант=3 тогда
		Если ЭтоАдресВременногоХранилища(ДеревоТаблицаЗначенийАдрес) Тогда
			цДеревоТаблицаЗначений = ПолучитьИзВременногоХранилища(ДеревоТаблицаЗначенийАдрес);
		Иначе 	
			цДеревоТаблицаЗначений = ДеревоТаблицаЗначенийАдрес ;
		КонецЕсли;
		//ФормаЭта = РеквизитФормыВЗначение(,Тип("УправляемаяФорма"));		
		
		фрмЭлементы =  ФормаЭта.Элементы;
		цРодитель =  ФормаЭта.Элементы[имяРеквизита];
		цТипЭлемента = Тип("ПолеФормы");
		
		
		мсУдаляемыеКолонкиРеквизита= Новый Массив;
		цРодПодч = цРодитель.ПодчиненныеЭлементы ;
		Для каждого кол Из цРодПодч Цикл
			кол_имя = кол.Имя;
			СтараяКолонкаРеквизита =  кол.ПутьКДанным;
			мсУдаляемыеКолонкиРеквизита.Добавить(СтараяКолонкаРеквизита);
		КонецЦикла;
		
		мсДобавляемыеКолонкиРеквизита = Новый Массив;
		для Каждого кол Из цДеревоТаблицаЗначений.Колонки Цикл
			кол_имя = кол.Имя;
			//ОписаниеТиповДляРеквизита = Новый ОписаниеТипов(ТипыРеквизита);
			ОписаниеТиповДляРеквизита = кол.ТипЗначения;
			
			Если ОписаниеТиповДляРеквизита.СодержитТип(Тип("ХранилищеЗначения")) Тогда
				Продолжить;
			КонецЕсли;				
			
			НоваяКолонка = Новый РеквизитФормы(кол_имя,       // имя
			ОписаниеТиповДляРеквизита,   // тип
			имяРеквизита,              // путь
			кол.Заголовок,             // заголовок
			Ложь);                     // сохраняемые данные
			
			мсДобавляемыеКолонкиРеквизита.Добавить(НоваяКолонка);
		КонецЦикла;	
		//
		
		
		#Если НаСервере Тогда           
			ФормаЭта.ИзменитьРеквизиты(мсДобавляемыеКолонкиРеквизита,мсУдаляемыеКолонкиРеквизита);            
		#Иначе            
			ц="ЭтоБлин";	
		#КонецЕсли		
		
		Для каждого новКолонка Из мсДобавляемыеКолонкиРеквизита Цикл
			этаКолонкаЕсть = ФормаЭта.Элементы.Найти(новКолонка.Имя);
			Если этаКолонкаЕсть<>Неопределено Тогда
				//Продолжить;
				ФормаЭта.Элементы.Удалить(этаКолонкаЕсть);
			КонецЕсли;
			
			Попытка
				кол_имя =новКолонка.Имя;
				новЭлем = ФормаЭта.Элементы.Добавить(кол_имя, цТипЭлемента, цРодитель); 
				новЭлем.Вид = ВидПоляФормы.ПолеВвода;
				новЭлем.ПутьКДанным = имяРеквизита+"."+кол_имя;
			Исключение
				//Если ФлагЭтоЯ Тогда
				цОш = ОписаниеОшибки();
				сооб = Новый СообщениеПользователю;
				сооб.Текст = кол_имя+" : "+цОш;
				сооб.Поле = кол_имя;
				сооб.Сообщить();
				//Продолжить;
				//КонецЕсли;  
			КонецПопытки;	
			
		КонецЦикла;    
		
		#Если не ТонкийКлиент Тогда           
			ЗначениеВДанныеФормы(цДеревоТаблицаЗначений,ФормаЭта[ИмяРеквизита]);
		#КонецЕсли
		
	КонецЕсли; 
	
	
КонецПроцедуры
R03;
Функция ВернутьТабДокСервер(цРезультатСКД1, цАдресМакетаСКД1, цНастройкиИсточник1) Экспорт 
	Перем  ТабДок2;
	
	цСхемаКомпоновкиДанныхИсточник1 = ПолучитьИзВременногоХранилища(цАдресМакетаСКД1);
	цНаборыДанныхИсточник1 = цСхемаКомпоновкиДанныхИсточник1.НаборыДанных ;
	
	цСхемаКомпоновкиДанныхИсточникТабДок2  =  ПолучитьОбщийМакет("СКДтонкийКлиент");
	//цСхемаКомпоновкиДанныхИсточникТабДок2  =  ПолучитьМакет("СКДтонкийКлиент"); //внешнйОтчет
	
	цНаборыДанныхИсточникТабДок2 = цСхемаКомпоновкиДанныхИсточникТабДок2.НаборыДанных ;
	цНаборыДанныхИсточникТабДок2.Очистить();
	цНаборДанныхТабДок2 = цНаборыДанныхИсточникТабДок2.Добавить(Тип("НаборДанныхОбъектСхемыКомпоновкиДанных"));
	цТемпИмяТЗ_2 = "тзИмяТемп";
	цНаборДанныхТабДок2.имя = цТемпИмяТЗ_2;
	цИмяОбъекта_2 = "тзОбъектТемп";
	//цИмяОбъекта_2 = "тзИсточник";
	цНаборДанныхТабДок2.имяОбъекта = цИмяОбъекта_2;
	цНаборДанныхТабДок2.ИсточникДанных = "ИсточникДанных1";
	
	Для каждого текНаборИсточник1 Из цНаборыДанныхИсточник1 Цикл
		
		Для каждого поле_1 Из текНаборИсточник1.Поля  Цикл
			Попытка
				Если  ТипЗнч(поле_1)= тип("ПолеНабораДанныхСхемыКомпоновкиДанных") Тогда
					
					поле_2 = цНаборДанныхТабДок2.поля.Добавить(тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
					ЗаполнитьЗначенияСвойств(поле_2,поле_1, ,"ТипЗначения");
					
					цтип =  новый ОписаниеТипов(  поле_1.ТипЗначения) ;
					поле_2.ТипЗначения = цтип;
				ИначеЕсли   ТипЗнч(поле_1)= тип("ПапкаПолейНабораДанныхСхемыКомпоновкиДанных") Тогда
					
					поле_2 = цНаборДанныхТабДок2.поля.Добавить(тип("ПапкаПолейНабораДанныхСхемыКомпоновкиДанных"));
					ЗаполнитьЗначенияСвойств(поле_2,поле_1, ,);
					УбратьИзПутьКДаннымИмяПапки(цРезультатСКД1, поле_1.ПутьКДанным );//ППМ						
				Иначе 
					Сообщение = Новый СообщениеПользователю;
					Сообщение.Текст = "Отказ, поле_1="+поле_1;
					//Сообщение.Поле = "";
					//Сообщение.УстановитьДанные(ЭтотОбъект);
					Сообщение.Сообщить();						
				КонецЕсли;
			Исключение
				цОш= ОписаниеОшибки();
				Сообщение = Новый СообщениеПользователю;
				Сообщение.Текст = цОш+", поле_1="+поле_1;
				//Сообщение.Поле = "";
				//Сообщение.УстановитьДанные(ЭтотОбъект);
				Сообщение.Сообщить();	
			КонецПопытки;
			
		КонецЦикла			                   
	КонецЦикла;
	
	Для каждого текПолеИтога1 Из цСхемаКомпоновкиДанныхИсточник1.ПоляИтога  Цикл
		Попытка
			полеИтога_2 = цСхемаКомпоновкиДанныхИсточникТабДок2.ПоляИтога.Добавить();
			ЗаполнитьЗначенияСвойств(полеИтога_2, текПолеИтога1 );
			
		Исключение
			цОш= ОписаниеОшибки();
			Сообщение = Новый СообщениеПользователю;
			Сообщение.Текст = цОш+", полеИтога_1="+текПолеИтога1;
			//Сообщение.Поле = "";
			//Сообщение.УстановитьДанные(ЭтотОбъект);
			Сообщение.Сообщить();	
		КонецПопытки;
		
	КонецЦикла;
	
	ТабДок2 = скд_ВнешниеДанные(цРезультатСКД1,"ТабДок" , цСхемаКомпоновкиДанныхИсточникТабДок2, цНастройкиИсточник1);
	
	Возврат  ТабДок2;
КонецФункции




R03;

/////////////////////////////////////////////////////////

R03;
Функция  скд_ВнешниеДанные(цТЗ_внешниеДанные, цТипРезультата="ТабДок", цАдресМакетаСКД="", цНастройкиСКД=Неопределено)Экспорт  //Преобразовать коллекциюЗначений в табличный документ
	Перем ВнешниеДанныеСКД;	
	
	Если ВРег(цТипРезультата)="ТАБДОК"  
		ИЛИ ВРег(цТипРезультата)="ТАБЛИЧНЫЙДОКУМЕНТ" 
		Тогда
		цОбъектСКД=Новый ТабличныйДокумент;
		типГенератораСКД = Тип("ГенераторМакетаКомпоновкиДанных");
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
		ПроцессорВывода.УстановитьДокумент(цОбъектСКД);
	Иначе
		Если ВРег(цТипРезультата)="ДЗ"
			ИЛИ  ВРег(цТипРезультата)="ДЕРЕВОЗНАЧЕНИЙ"
			Тогда
			цОбъектСКД=Новый ДеревоЗначений;
		ИначеЕсли ВРег(цТипРезультата)="ТЗ" 
			ИЛИ  ВРег(цТипРезультата)="ТАБЛИЦАЗНАЧЕНИЙ"
			Тогда
			цОбъектСКД=Новый ТаблицаЗначений;
		Иначе 
			цОбъектСКД=Новый ДеревоЗначений;
		КонецЕсли;
		
		типГенератораСКД = Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений");
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
		ПроцессорВывода.УстановитьОбъект(цОбъектСКД);
	КонецЕсли;
	
	Если ТипЗнч(цТЗ_внешниеДанные)=Тип("ТаблицаЗначений") Тогда
		ТЗ = цТЗ_внешниеДанные;
		ВнешниеДанныеСКД = Новый Структура("тзОбъектТемп", ТЗ);
		//ВнешниеДанныеСКД = Новый Структура("ТЗисточник", ТЗ);
	ИначеЕсли ТипЗнч(цТЗ_внешниеДанные)=Тип("ДанныеФормыКоллекция") Тогда
		ТЗ = ДанныеФормыВЗначение(цТЗ_внешниеДанные,Тип("ТаблицаЗначений"));
		ВнешниеДанныеСКД = Новый Структура("тзОбъектТемп", ТЗ);
		//ВнешниеДанныеСКД = Новый Структура("ТЗисточник", ТЗ);
	Иначе
		// это ТабличныйДокумент
	КонецЕсли;
	
	Если ЭтоАдресВременногоХранилища(цАдресМакетаСКД) Тогда
		СхемаКомпоновкиДанных = ПолучитьИзВременногоХранилища(цАдресМакетаСКД) ;
	ИначеЕсли ТипЗнч(цАдресМакетаСКД)= Тип("СхемаКомпоновкиДанных") Тогда
		СхемаКомпоновкиДанных = цАдресМакетаСКД ;
		
	Иначе
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "нет макета СКД";
		//Сообщение.Поле = "";
		//Сообщение.УстановитьДанные(ЭтотОбъект);
		Сообщение.Сообщить();
		Возврат цОбъектСКД;
	КонецЕсли;
	
	
	Если цНастройкиСКД=Неопределено Тогда
		Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;		
	Иначе
		Настройки = цНастройкиСКД;
	КонецЕсли;
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, , ,типГенератораСКД, ,);
	ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеДанныеСКД  );
	ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);   	
	
	Возврат цОбъектСКД;
КонецФункции




R03;

Состав zip.

1.       База данных c примерами для копирования - dt и cf.

2.       Внешняя обработка.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ПримерыВыводаКоллекцииЗначенийНаЭкранУпрФормы
.7z 159,93Kb
13.09.16
17
.7z 159,93Kb 17 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Пишу код как картины (yurii_host) 14.09.16 02:55
Очень хорошо, что ваши процедуры универсальны (это редкость на ИС)

НО есть несколько моментов, которые [лично мне] могут помешать применить ваши процедуры
1. Самодокументируемое название методов - из названия методов должно быть однозначно понятно, что данный метод делает (например, СоздатьКолонкиТаблицыНаУправляемойФорме() ). Без необходимости изучения кода самого метода. Иначе возникают сложности с читаемостью и пониманием при а) вызове метода, б) при понимании кода, из которого вызывается данный метод.
2. Неиспользуемые переменные (например, цЭто и Вариант), а также невыполняемые ветки в операторах Если
3. Большое количество закомментированного кода - лучше удалить, чтобы он не сбивал с толку тех, кто будет использовать ваши методы. Если в коде много подобных закомментированных участков - у других разработчиков возникает опасение, что он еще пока на стадии отладки и работа над ним не закончена. А незаконченные чужие процедуры никто использовать не будет.
4. Большое количество цифр в именах переменных - является моветоном (например, цСхемаКомпоновкиДанныхИсточникТабДок2), вызывает недоверие.

Высказал только самые критичные на мой взгляд недочеты.

Несмотря на мою критику, хочу отметить, что заметна большая проделанная работа (и по написанию процедур, и по подготовке статьи)
Плюс однозначно.
kuzyara; awk; vasiliy_b; dj_serega; mihey; aexeel; Irwin; +7 Ответить
2. Фаниль Исламов (fancy) 15.09.16 07:07
Спасибо за статью, вчера как раз воспользовался, правда пришлось побиться с добавлением колонок реквизита формы ДеревоЗначений - смог добавить лишь только тогда, когда само дерево добавляю в реквизиты формы программно, если же дерево создать в конфигураторе, то колонки никак не хотели добавляться
3. Пишу код как картины (yurii_host) 15.09.16 08:49
(2) fancy, да, я тоже сталкивался с этим. Проблема в том, что если колонка добавлена из конфигуратора, то ни колонку реквизита, ни колонку табличного поля на форме удалить программно нельзя. И это все осложняется тем, что в коде нельзя определить, добавлялась колонка программно или через конфигуратор. Единственный костыль, который я тут нашел - использование попытки. Колонки из реквизита на таблицы нужно удалять по одной в попытке (а не сразу всем массивом), и перед добавлением проверять наличие. При обновлении колонок табличного поля - тоже нужно удалять колонки в попытке и перед добавлением - проверять наличие.
4. Павел Панкратов (pavley2002) 15.09.16 18:31
(2) fancy, Процедуру СоздатьКолонкиУпр() можно применять только для программно добавленных колонок. Это обусловлено применением метода ВсеЭлементыФормы.Удалить(), в 1С:описании которого непосредственно указано:- «Доступно удаление только ранее программно добавленного элемента».
Для устранения возникшей не ясности, в описание процедуры СоздатьКолонкиУпр() добавлена строка - «Причем, для этого реквизита состав колонок указанный в управляемой форме должен быть пустым». Спасибо за указание на неточность.
5. Павел Панкратов (pavley2002) 17.09.16 15:37
(3) yurii_host,
Доступ к элементу формы осуществляется по имени, поэтому дублирование имён внутри элементов сделает управляемую форму не работоспособной. В этой статье защита от дублирования имён выполнена упрощённо через очистку всех элементов перед любым значимым действием. Для этой цели используется процедура ОчиститьКоллекциюЗначенийНаСервере(). При таком алгоритме не возникает необходимость проверять наличие дублирования имен по штучно.
Однако, сама проблема дублирования имён при программном заполнении колонок следующей коллекции значений существует и требует методологической постановки задачи с последующем решением.
Алгоритм близкий к по элементной проверке предложен в http://infostart.ru/public/536800/ . Без функции ПроверитьДублиИменКолонок() в указанной статье невозможно решить поставленную там задачу.
6. Пишу код как картины (yurii_host) 17.09.16 17:38
(5) pavley2002, не понимаю, зачем проверять дубли. Сначала удаляем все колонки, которые можем удалить. Затем добавляем колонки в цикле. Перед добавлением проверяем, присутствует ли колонка с таким именем в коллекции колонок. Если присутствует, то переходим к следующей итерации цикла.

Прикладываю работающий пример. Данный набор процедур использую уже года два. Проверено в продуктиве много раз
Попытка используется два раза, что некрасиво. Но других решений пока не нашел.

Отмечу, что в приведенном примере колонка Склад - добавлена через конфигуратор, а остальные колонки - добавляются программно.

Подход универсальный и не требует какой-то специальной методологической постановки задачи

Вот тут в моей публикации рассматривается другой вопрос, но создание колонок выполняется программно, хотя на этом не заостряется внимание. В примере к публикации для управляемых форм используются этот же блок процедур
Прикрепленные файлы:
ВнешняяОбработка1.epf
7. Николай ~ ~ (kuzyara) 19.09.16 09:03
&НаСервере
Процедура СоздатьКолонкиУпр(ФормаЭта
...

Клинический случай. Дальше читать не стал.
8. Павел Панкратов (pavley2002) 26.09.16 08:47
(7) kuzyara,
Отсутствует конструктивное предложение, хотя бы какое-нибудь. На мой взгляд, накопленный личный медицинский опыт здесь не уместен.
9. Алексей Захаров (almas) 30.10.16 13:12
Скачал, посмотрел. Несмотря на значимость обработки ощущение отвратное. Черт нельзя было малость в удобоваримый читаемый порядок все привести???
10. Павел Панкратов (pavley2002) 01.11.16 09:25
(9) almas,
Не обработка, а универсальная функция представлена в форме, не требующей скачивания файла, я предполагаю, что это заметно. Кроме того, Вам позволено не принуждать себя скачивать файл, который оказывает дурное влияние на настроение, бесполезен или любое другое.

Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа