Отсчет секунд до Нового года

Опубликовал Михаил Кончаренко (Anchoret) в раздел Программирование - Практика программирования

В ожидании Нового года считаем часы и секунды до этого события=)
Перем мСчет;

&НаКлиенте
Процедура Старт(Команда)
	мСчет = 0;
	ПодключитьОбработчикОжидания("Отсчет", 1);
КонецПроцедуры

&НаКлиенте
Процедура Стоп(Команда)
	ОтключитьОбработчикОжидания("Отсчет");
КонецПроцедуры

&НаКлиенте
Процедура Отсчет() 

	//мСчет = мСчет + 1;
	мСчет = КонецГода(ТекущаяДата()) - ТекущаяДата();
	Элементы.ЗначениеТаймера.Заголовок = Время(мСчет);
	ПоказатьОповещениеПользователя(Время(мСчет));

КонецПроцедуры // Отсчет()

&НаКлиенте
Функция Время(Значение)

	Если Значение < 60 Тогда
		Возврат Строка(Значение) + " сек.";
	ИначеЕсли Значение >= 60 И Значение < 60*60 Тогда 
		Возврат Строка(Цел(Значение/60)) + " мин. " + Строка(Значение-Цел(Значение/60)*60) + " сек.";
	ИначеЕсли Значение >= 60*60 и Значение < 60*60*24 Тогда 
		Возврат Строка(Цел(Значение/(60*60))) + " час. " 
				+  Строка(Цел((Значение - (Цел(Значение/(60*60))*60*60))/60)) + " мин. " 
				+ Строка(Значение-Цел(Значение/60)*60) + " сек.";
	ИначеЕсли Значение >= 60*60*24 и Значение < 60*60*24*31 Тогда
		Возврат Строка(Цел(Значение/(60*60))) + " час. " 
				+ Строка(Цел((Значение - (Цел(Значение/(60*60))*60*60))/60)) + " мин. " 
				+ Строка(Значение-Цел(Значение/60)*60) + " сек.";
	КонецЕсли;

КонецФункции // Время()

Внешняя обработка для управляемых форм с отчетом часов, минут, секунд до Нового Года.

Код честно позаимствован тут, за что автору спасибо=)

Скачать файлы

Наименование Файл Версия Размер
ТаймерДоНовогоГода
.epf 6,09Kb
28.12.16
1
.epf 6,09Kb 1 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Максим Евсенкин (tehas) 39 28.12.16 12:05 Сейчас в теме
2. Александр Лыткин (TrinitronOTV) 28.12.16 16:41 Сейчас в теме
(1) Присоединяюсь, С наступающим Новым годом!
3. Марина (MariNew) 28.12.16 16:43 Сейчас в теме
4. Канат Джумадылов (Fox-trot) 49 28.12.16 17:30 Сейчас в теме
(0) не хватает рекурсии в функции Время()
5. Артём Ломакин (myALKleon) 26 28.12.16 18:33 Сейчас в теме
Хм, похоже, благотворительный сбор монеток, хоть бы оформил красиво, автор.
6. Михаил (MishaD) 12 28.12.16 19:03 Сейчас в теме
Эх, нарисовал свою, аналогичную. А вот как бы внедрить ее в конфигурацию БП3, чтобы при старте запускалась, так и не придумал. Права на запуск внешних обработок закрыты. Может кто посоветует ?
Прикрепленные файлы:
ТаймерНовГод.epf
7. Канат Джумадылов (Fox-trot) 49 28.12.16 20:16 Сейчас в теме