gifts2017

Анимация для элементов форм в 1С 8.1

Опубликовал Василий Гиричев (Greymem) в раздел Программирование - Практика программирования

Для тех кто еще ломает голову как создать анимированную кнопку, или что нибудь еще
Коряво конечно, но главное работает с минимальными тормозами

Примерчик
Перем Min;
Перем Max;
Перем ИмяЭлемента;
Процедура

Кнопка1Нажатие(Элемент);
Min=0;  //Начальный кадр 

Max=10; //Конечный 

ИмяЭлемента = Элемент.Имя;
ПодключитьОбработчикОжидания("ОбновитьКартинку", 1, Ложь); //Устанавливаем интервал в секундах 
КонецПроцедуры Процедура 

ОбновитьКартинку();
Если Min < Max Тогда 

Min = Min+1;           //Перемещаемся к след. кадру 

СледующийКадр

(Min, "C:\1\", ".Bmp"); //Первый параметр указывает на то как называется файл след. кадра, второй на папку с этим файлом, третий на его расширение
КонецЕсли;
КонецПроцедуры
Процедура

СледующийКадр(Номер,Размещение,Расширение);
Результат = Размещение+Строка(Номер)+Расширение;

ЭлементыФормы.Найти(ИмяЭлемента).Картинка=Новый Картинка(Результат,Ложь);
КонецПроцедуры 
В случае если же вы хотите использовать циклическую анимацию, то лучше воспользоваться стандартным свойством "Картинка" элемента формы и указать нужный вам GIF файл

См. также

Подписаться Добавить вознаграждение
Комментарии
1. torg1c (torg1c) 13.08.08 19:21
Так вроде обычные анимированные иконки в формате gif поддерживаются.
adhocprog; +1 Ответить
2. torg1c (torg1c) 13.08.08 19:25
P.S. Не заметил что про это было внизу написано.
3. GAUI (Dwarf) 28.11.12 12:50
Далеко не все анимированные gif файлы работают в 1С.
НО есть анимация которая работает в 1С8.2 !!!!
например:
Прикрепленные файлы:
adhocprog; +1 Ответить