gifts2017

Решения задач по расчету зарплаты для подготовки к экзамену 1С : Специалист 8.х по платформе

Опубликовал Сергей Кобяков (Serjik78) в раздел Программирование - Сертификация

Решения задач по расчету зарплаты для подготовки к экзамену 1С : Специалист 8.х по платформе.

Формат RAR, внутри по папкам с номерами задач.

Думаю это будет очень актуально, почему именно эти номера из сборника - всем будет итак понятно :)

Решения задач из сборника: 3.11, 3.21, 3.28, 3.31, 3.34, 3.45, 3.46, 3.47. Задачи расположены по папкам в архиве, решения на базе каркасной конфигурации, которая дается на экзамене. Если эта тема будет интересна, то позже оформлю и выложу решения по БУ и ОУ, само собой с "правильными" номерами задач :)

P/S/ Код открыт. Готов ответить на вопросы почему решал именно так.

 

Доступна полная версия подготовки к экзамену: http://infostart.ru/public/59045/ 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Решения задач по расчету зарплаты
.rar 2,04Mb
20.10.09
785
.rar 2,04Mb 785 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Кобяков (Serjik78) 16.10.09 13:49
Подскажите, уважаемые, здесь можно подобное выкладывать? ;)
2. Сергей Кобяков (Serjik78) 16.10.09 13:59
Надо же, только выложил, а как активно качают :D :D :D
3. Andrey Orlov (Orland) 16.10.09 15:15
4. Монолит (Monolit) 16.10.09 15:18
(2)Извини,хотел на плюс нажать. :cry: Такие штуки нужны.
5. Сергей Кобяков (Serjik78) 16.10.09 15:21
(3) Формат rar, прошу прощения. Напишу комментарий.
6. Сергей Кобяков (Serjik78) 16.10.09 15:22
(4) Нет проблем, но вроде можно минус забрать ;)
8. Amali 16.10.09 17:54
А есть сборник "Решения задач по расчету зарплаты для подготовки к экзамену 1С : Специалист 8.х по платформе." в электронном виде ?
9. Валерий ПК (Source) 16.10.09 20:03
Может есть у кого сборник задач по Управлению торговлей???? Уж очень хочу сдать торговлю :)
10. Сергей Кобяков (Serjik78) 16.10.09 22:32
(8) Есть сборник как на картинке в обеих редакциях (апрель и сентябрь 2009). Там все задачи для подготовки к экзамену по БУ, ОУ, Расчету, БП. Вторая редакция почти не отличается, до сих пор остались перлы вида: "Если водитель в месяце наездил более 1000 часов". Скажите, если я выложу тут ссылку на сборник задач, то не забанят?
11. MagIvan (RailMen) 17.10.09 03:11
По зиуп решебника вроде как нет. Я выложил свои варианты решения по зиуп. Эта тема тож актуальная.
12. Den3D3 (Vass) 17.10.09 12:17
а я сдал его и забыл как страшный сон :D
13. Сергей Кобяков (Serjik78) 17.10.09 13:05
Уважаемые, раздаю сборник задач через личку, открытую ссылку боязно выкладывать.
14. Андрей Снисаренко (Hokum) 17.10.09 13:33
А есть ли в природе решения других задач из сборника?
15. Сергей Кобяков (Serjik78) 17.10.09 20:12
( 14 ) Выложил решения задач по БУ, жаль пока не все. В свободное время прорешаю и дополню, пока выложил 6 решений по БУ из сборника.
16. Антон Лосев (shootnik) 18.10.09 17:24
Поставил плюс за старание и альтруизм. Но мне кажется, что тому кто хочет сдать экзамен надо бы эти задачки самому прорешать!
17. Ярослав Радкевич (WKBAPKA) 18.10.09 21:15
уважаемые, за что плюсы???? за пиратство :o
18. larissa builova (larisab) 18.10.09 21:26
Вроде нет пиратства. Просто решение задач, причем задачи в сборниках 1с учебные. Обмен опытом. 8)
19. Сергей Кобяков (Serjik78) 19.10.09 09:30
( 17 ) В чем пиратство? Сборник официально продается 1С за 1000р. Решаете задачи и идете сдавать экзамен по платформе 8.х. Я выкладываю решения из этого сборника. Кто-то помотрит и скажет, вдруг я ошибся или наоборот ему это будет полезно для самообучения. Мое мнение не безапелляционное, но как человек, который сдавал много экзаменов 1С таково, что нужно самому прорешать много задач прежде чем сдать экзамен. Что плохого если выкладывать решения, чтобы люди научились, а при случае меня самого ткнули носом в неоптимальное / неверное решение?
20. Serg Eli (elizarovs) 19.10.09 09:43
(17) Ну, насколько я понимаю в авторском праве, авторство предлагаемых решений принадлежит уважаемому Serjik78. И если решения он не "списал", то какие могут быть претензии? Распространять чужой сборник, конечно, не стоит, во всяком случае воткрытую. А наличие готовых решений огромный плюс при подготовке к экзамену, что бы кто ни говорил.
21. Serg Eli (elizarovs) 19.10.09 09:46
(16) Все мы учимся на ошибках. Но, говорят, что на чужих как-то приятнее.
22. Александр Доровских (Requiem) 20.10.09 13:08
Задача 3.11
Нет расчета больничных
23. Сергей Кобяков (Serjik78) 20.10.09 15:40
Выложил окончательный вариант по всем видам учета: http://infostart.ru/public/59045/
24. Сергей Кобяков (Serjik78) 20.10.09 16:03
( 22 ) Как нет? А вот это:

ЗапросБольничные = Новый Запрос;
ЗапросБольничные.Текст =
"ВЫБРАТЬ
| ОсновныеНачисления.НомерСтроки,
| ЕСТЬNULL(ВложенныйЗапрос.РезультатПоОкладуПрошлыйМесяц, 0) КАК ОкладЗаПрошлыйМесяц,
| ЕСТЬNULL(ОсновныеНачисленияДанныеГрафика.ЗначениеФактическийПериодДействия, 0) КАК ФактЧасовБольничного
|ИЗ
| РегистрРасчета.ОсновныеНачисления КАК ОсновныеНачисления
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| СУММА(ОсновныеНачисления.Результат) КАК РезультатПоОкладуПрошлыйМесяц,
| ОсновныеНачисления.Сотрудник КАК Сотрудник
| ИЗ
| РегистрРасчета.ОсновныеНачисления КАК ОсновныеНачисления
| ГДЕ
| ОсновныеНачисления.ПериодРегистрации = &ПрошлыйМесяц
| И ОсновныеНачисления.ВидРасчета = &ВидРасчетаОклад
|
| СГРУППИРОВАТЬ ПО
| ОсновныеНачисления.Сотрудник) КАК ВложенныйЗапрос
| ПО ОсновныеНачисления.Сотрудник = ВложенныйЗапрос.Сотрудник
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрРасчета.ОсновныеНачисления.ДанныеГрафика(
| ПериодРегистрации = &ПериодРегистрации
| И Регистратор = &Регистратор) КАК ОсновныеНачисленияДанныеГрафика
| ПО ОсновныеНачисления.НомерСтроки = ОсновныеНачисленияДанныеГрафика.НомерСтроки
|ГДЕ
| ОсновныеНачисления.Регистратор = &Регистратор
| И ОсновныеНачисления.ПериодРегистрации = &ПериодРегистрации
| И ОсновныеНачисления.ВидРасчета = &ВидРасчетаБольничный";

ЗапросБольничные.УстановитьПараметр("ВидРасчетаОклад", ПланыВидовРасчета.ОсновныеНачисления.Оклад);
ЗапросБольничные.УстановитьПараметр("ВидРасчетаБольничный", ПланыВидовРасчета.ОсновныеНачисления.Больничный);
ЗапросБольничные.УстановитьПараметр("Регистратор", Ссылка);
ЗапросБольничные.УстановитьПараметр("ПериодРегистрации", Ссылка.ПериодРегистрации);
ЗапросБольничные.УстановитьПараметр("ПрошлыйМесяц", ДобавитьМесяц(НачалоМесяца(Ссылка.ПериодРегистрации), -1));

РезультатБольничные = ЗапросБольничные.Выполнить();
Если Не РезультатБольничные.Пустой() Тогда
ЗапросДнейПрошлыйМесяц = Новый Запрос;
ЗапросДнейПрошлыйМесяц.Текст =
"ВЫБРАТЬ
| СУММА(ГрафикиРаботы.Значение) КАК Значение
|ИЗ
| РегистрСведений.ГрафикиРаботы КАК ГрафикиРаботы
|ГДЕ
| ГрафикиРаботы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания
| И ГрафикиРаботы.ГрафикРаботы = &ГрафикРаботыПятидневка";

ЗапросДнейПрошлыйМесяц.УстановитьПараметр("ГрафикРаботыПятидневка", Справочники.ГрафикиРаботы.Пятидневка);
ЗапросДнейПрошлыйМесяц.УстановитьПараметр("ДатаНачала", ДобавитьМесяц(НачалоМесяца(Ссылка.ПериодРегистрации), -1));
ЗапросДнейПрошлыйМесяц.УстановитьПараметр("ДатаОкончания", НачалоМесяца(Ссылка.ПериодРегистрации) - 1);

Выборка = ЗапросДнейПрошлыйМесяц.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
ЧасовПрошлыйМесяц = Выборка.Значение;
Иначе
ЧасовПрошлыйМесяц = 0;
КонецЕсли;

Если ЧасовПрошлыйМесяц > 0 Тогда
ВыборкаБольничные = РезультатБольничные.Выбрать();
Пока ВыборкаБольничные.Следующий() Цикл
НаборЗаписей[ВыборкаБольничные.НомерСтроки - 1].Размер = ВыборкаБольничные.ОкладЗаПрошлыйМесяц;

НаборЗаписей[ВыборкаБольничные.НомерСтроки - 1].Результат =
ВыборкаБольничные.ОкладЗаПрошлыйМесяц / ЧасовПрошлыйМесяц * ВыборкаБольничные.ФактЧасовБольничного;
КонецЦикла;
КонецЕсли;
КонецЕсли;
25. Сергей Кобяков (Serjik78) 20.10.09 16:05
( 22 ) Все расчеты вынесены в Общий модуль, возможно не заметили ;) На экзамене могут чуток сбавить за "неоптимальное" решение.
26. Александр Доровских (Requiem) 21.10.09 07:47
(25) Сорри, с общем модуле смотрел, но не обратил внимание что разнесено в 2 процедуры, куда смотрел не понятно.
27. Сергей Кобяков (Serjik78) 21.10.09 09:29
28. EvgeniuXP EvgeniuXP (EvgeniuXP) 25.10.09 13:08
вы бы хотя бы к решенной задаче и текст прилагали бы... теперь надо искать и сборник задач...
29. Роберт Кощенков (rvk68) 03.10.11 17:45
Сборник очень помог в свое время, прорешал задачи по регистрам расчета, а это самое сложное было на тот момент. Всем удачи.
30. Ольга (DanilovaOlga) 01.12.11 11:12
32. Сергей Серебренников (SSO) 07.02.12 06:20
Спасибо за публикацию. Очень полезная вещь. В свое время не сдал экзамен по спецу, так как сам разбирался и программировал. Соответственно идеологии 1с не придерживался. Даже за рабочее решение были сняты балы и экзамен провален. Так что сдача должна быть строго так как хочет экзаменатор. Выучить все решения и воспроизвести.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа