gifts2017

Консоль выполнения произвольных текстов модуля

Опубликовал Владислав Томашевич (tomvlad) в раздел Администрирование - Сервисные утилиты

Обработка "Консоль выполнения произвольных текстов модуля" предназначена для разработки шаблонов, отладки, визуального конструирования текстов модулей системы 1С:Предприятие.

При администрировании информационной базы программисты вынуждены тратить время на создание обработок, которые будут запущены только один раз. А уже через день после использования найти их бывает сложно - часто ли мы задумываемся, прежде чем дать осмысленное название заведомо временному файлу.

Эта обработка хранит дерево текстов модулей, помогает их систематизировать, модифицировать и использовать по мере необходимости.

Для того, чтобы автоматизировать наиболее трудоемкие действия программиста, она включает вспомогательные инструменты:

  1. Визуальные конструкторы:
    1. Конструктор запроса (системный)
    2. Конструктор таблицы значений
    3. Конструктор объекта ссылочного типа универсальный
    4. Конструктор документа
    5. Конструктор справочника
    6. Конструктор набора записей регистров (любых)
  2. Дерево метаданных текущей конфигурации, механизм drag'n'drop
  3. Возможность произвольной обработки данных с использованием встроенных обработок.

Вы все еще создаете разовые обработки (для обычного приложения)? Попробуйте использовать консоль модулей - уверен, Вам понравится.

Скачать файлы

Наименование Файл Версия Размер
Консоль исполнения произвольных текстов модулей (8.2) 876
.epf 191,42Kb
02.09.13
876
.epf 191,42Kb Скачать
Консоль исполнения произвольных текстов модулей (8.1) 1068
.epf 196,23Kb
02.09.13
1068
.epf 196,23Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. alernik@mail.ru Александр Ершов (alexer) 26.11.09 09:41
наверно так встали звезды, что всех на подобные разработки потянуло :)
2. Владислав Томашевич (tomvlad) 26.11.09 09:48
(1) Ага, посмотрел на это http://www.infostart.ru/public/61535/ и подумал, что моя наверное не хуже, полгода уже активно используется, и, возможно многим пригодится. Аналогичных конструкторов, например, ни у кого не видел.
3. alernik@mail.ru Александр Ершов (alexer) 26.11.09 09:51
может в скором будущем воще от конфигуратора откажемся :D
4. Владислав Томашевич (tomvlad) 26.11.09 10:00
(3) А и правда, зачем для написания какой-нибудь ерундовой обработки лезть в конфигуратор?
5. Александр Рытов (Арчибальд) 26.11.09 10:16
(0) Ага, с одноразовыми обработками - беда :(

Мне для обучения/экспериментирования - самое то 8-)
6. Владислав Томашевич (tomvlad) 26.11.09 10:22
(5) Буду рад, если пригодится. Файл с примером лежит отдельно (если нужно).
7. Алексей Коробов (WiseSnake) 26.11.09 11:08
(2) Да 100 лет уже тут лежит :)
Ну Ваши наверно подобротей будут сделаны, хотя я к своей привык, юзаю активно уже больше года...
8. Владислав Томашевич (tomvlad) 26.11.09 11:13
(7) Цели у разработок разные. Тут - универсальный комбайн, здесь - простота использования и помощь в написании за счет применения конструкторов. Ни о каких отчетах в принципе речи не идет, если не формировать их программно из встроенного языка, но это наверное было бы уже извращение.
9. defzyx (NDM) 26.11.09 12:08
;) Нужно переименовать функции и процедуры которые уже есть в типовых, иначе:

ПриОткрытии:
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(545,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповЧисла)
Функция <<?>>ПолучитьОписаниеТиповЧисла(Разрядность,РазрядностьДробнойЧасти=0) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(559,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповДаты)
Функция <<?>>ПолучитьОписаниеТиповДаты(ЧастиДаты) Экспорт
10. Владислав Томашевич (tomvlad) 26.11.09 12:16
(9) Странно, нигде в актуальных типовых ЗУП,БП,КА,УПП,РТ не нашел такую функцию глобальных модулей. Что за конфигурация, релиз?
11. Николай Сенаторов (Mortal) 26.11.09 12:57
Скачал. "+". Пока не смотрел (не успел), но, имхо, будет удобно для тренировок: сравнивать модули обработок и т.д. Спасибо.
12. Владислав Томашевич (tomvlad) 26.11.09 13:21
Всем пардон, вкралась досадная ошибка, приводившая к невозможности сформировать новый файл шаблонов. Ошибку исправил, обновил.
13. Вячеслав Кадацкий (marsohod) 26.11.09 13:23
После перепроведения документов на закладке "Результат выполнения" она присоединила снизу еще кусок формы с "Доступные обработки" и "Выбранные обработки". Выбираю "Отменить проведение документов" и получаю предупреждение "Данная обработка недоступна для типа <Документы>".
Что бы это значило? :o
14. Владислав Томашевич (tomvlad) 26.11.09 14:01
15. Владислав Томашевич (tomvlad) 26.11.09 14:02
Может кто-то выскажется о работе конструкторов?
16. Эстер Коган (e.kogan) 26.11.09 14:52
Просьба всё-таки переформулировать пункты "Конструктор документа" и "Конструктор справочника" :?: :?: :?: Я-то уж разогналась, что кто-то нашёл, как из предприятия конфигурацию на лету менять... :D
17. Владислав Томашевич (tomvlad) 26.11.09 14:56
(16) И на что переформулировать? "Конструктор формирования кода создания нового документа / поиска существующего"? Пусть уж лучше так остается.
18. Ivon (Ivon) 26.11.09 15:11
Поставил плюс, но есть некоторые НО:
1) иногда при составлении кода обработка впихивает в код процедуры и функции, которых нет в конфигурации, такие как ПолучитьОписаниеТиповСтроки и т.п.;
2) вот если бы еще реализовать точки останова - тогда было бы самое оно. Просто написать код и посмотреть, как он выполняется - конечно хорошо, но когда результат не тот, который ожидался - требуется отладка промежуточных итогов. А их нет.
20. Эстер Коган (e.kogan) 26.11.09 17:34
(17) Ну хоть вставить слово "экземпляра" 8-)
21. direktorSan (direktorSan) 26.11.09 19:27
Неплохая разработка. Нашел много хороших идей!
Надо будет применить их в своей. ;)
22. Владимир Денисов (den_vladimir) 26.11.09 19:57
Чета я походу не в теме как из режима предприятия выполнять модули! Буду смотреть! +1!
23. Alexandr_P (Русский) 27.11.09 08:41
24. Андрей Межов (mini_root) 27.11.09 10:32
Посмотрел, плюсую

Конфигуратор не заменит - нету отладки, нельзя модифицировать метаданные и пр. Но для мелких вещей пойдет: прототипирование, тестирование.... Кстати, на основе этой идеи можно сделать систему юнит тестов для эски....

Ты там где в коде вызывается "Выполнить" добавь еще набор функций типа assert* (ЭтоИстина, ЭтоРавно, ЭтоНеПусто), если условие не выполняется - выбрасывается исключение.

Пример:

Функция ЭтоИстина(<результат некоего выражения типа boolean>, <название проверки>)
....
КонецФункции

И добавь возможность задавать код, который будет выполняться перед каждым выполнением текста, и после каждого выполнения (только с корректной обработкой исключений и прочее).

И собственно система внешних юнит тестов готова, причем конфигурацию менять не надо - все будет делаться внешними средствами.

Еще можно переработать систему вставки готового кода для типовых случаев в расширяемую макросистему.

25. Андрей Межов (mini_root) 27.11.09 10:51
(24) Нашел шаблоны, вопрос с макросистемой снят :)
26. Владислав Томашевич (tomvlad) 27.11.09 10:52
(25) Шаблоны пока не работают так как нужно, буду дорабатывать.
27. Андрей Межов (mini_root) 27.11.09 11:00
(26) Не возражаешь, если я чуть-чуть ее доработаю, в плане использования для тестирования?
28. Владислав Томашевич (tomvlad) 27.11.09 11:03
(27) Да ради бога, вот если бы еще доработал контекстную подсказку и шаблоны .... А то пока совершенно нет времени ими заниматься.
29. Трактор Трактор (Трактор) 27.11.09 11:07
Прикольно. Практического применения пока не вижу, подумаю.
30. Владислав Томашевич (tomvlad) 27.11.09 11:18
(29) Пример практического применения:

1. Имелось около сотни различных мелких обработок для различных типовых (и не очень конфигураций). Т.к. конфигурации периодически изменялись, обновлялись обработки также было необходимо держать в актуальном состоянии. Иногда лезь в конфигуратор приходилось из-за изменения вызовов общих модулей или разной прочей ерунды. В результате систематизации имеем несколько файлов модулей для каждой конфигурации для упорядоченного хранения нужных текстов + возможность изменения их на лету.
2. Составление текстов - просто ли вспомнить имя нужного реквизита при составлении кода? А дерево метаданных тут же. :)
3. Просто ли создать документ / справочник? Вспомнить названия реквизитов, табличных частей? Конструктор облегчит Вам жизнь. Функции, вызываемые с помощью конструктора успешно используются более 2-лет в нашей коммерческой разработке "Помощник перехода на использование подсистем расчета заработной платы и кадрового учета в прикладных решениях фирмы «1С» на технологической платформе «1С:Предприятие 8» с конфигураций «Камин:Расчет заработной платы (все версии)»". Весь процесс создания документа (справочника) сводится к созданию структуры полей поиска данного объекта, структуры реквизитов и табличных частей, причем большую часть работы Конструктор документа (Конструктор справочника) сделает за Вас.

P.S. Достаточно?
32. Андрей Межов (mini_root) 27.11.09 11:31
(28) http://slil.ru/28260688 чуть-чуть исправленная версия

Добавлены функции-assert'ы (ЭтоИстина, ЭтоРавно). Добавлена возможность задавать код, который будет выполняться перед выполнением основного кода, и после него (может использоваться например, для создания, удаления тестовых записей). Все сохраняется/загружается.
33. Трактор Трактор (Трактор) 27.11.09 11:41
>> Достаточно?
Достаточно.

Тут мне вспоминаются примочки к 7.7. Народ пользовал их и пищал от них. Я как-то обходился штатными средствами. Здесь ситуация похожа.

Конструктор таблицы значений да, полезен. Я всего дважды создавал тз для помещения во временную таблицу, но эти два раза были тоскливыми. Наверное в следующий раз воспользуюсь твоей обработкой.

Обработка прикольная. Но для начала её использования нужно отойти от некоторых привычек. И не факт что скорость сильно увеличится. Для меня, например, заполнение перечня реквизитов документов не самая сложная задача. Труднее понять чем их заполнять. Откуда брать данные. Составить запрос, да так чтобы конструктором запроса не покоцать комментарии.

Буду размышлять о том как в неё перетащить свои одноразовые обработки. И много ли их у меня.
34. Андрей Межов (mini_root) 27.11.09 11:51
(32) Чегой-то я не подумал, тут же новая система с метриками и бонусами планируется... В общем, кто скачает исправленную версию со slil.ru - скачайте также оригинальную с этой страницы.
35. Андрей Межов (mini_root) 27.11.09 12:00
(28) на выходных может и поковыряю шаблоны, туда бы еще консоль запросов прикрутить какую-нибудь и с учетом шаблонов будет вообще замечательно.
36. stanislav (stasyan) 27.11.09 13:01
Писал себе подобную вещь, иногда пользуюсь. А вот твою, на первый взгляд, с более профессиональным подходом написанную сейчас посмотрю. Люблю такие вещи, спасибо!
37. stanislav (stasyan) 27.11.09 13:15
В "Управление торговлей" падает на имена процедур общего модуля при открытии:
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт

Поправь, пожалуйста!
38. Andrey Sokolenko (chang) 27.11.09 13:57
39. Владислав Томашевич (tomvlad) 27.11.09 14:01
(38) Так напиши, я разве против. У tormozit'a есть замечательная контекстная подсказка. Остается попросить его разрешения использовать. Прикрутишь, выложишь - тебе столько народа спасибо скажет...
40. Andrey Sokolenko (chang) 27.11.09 14:05
41. Владислав Томашевич (tomvlad) 27.11.09 14:06
(40) Суровым челябинским одинэсникам отладчик не нужен :)
42. Andrey Sokolenko (chang) 27.11.09 14:09
(39) я не хаю, вы молодец! Но вижу смысл применения только один: поднялся в кабинет к глав.буху на пять этажей по лестнице, она мне показывает ошибки в программе, ну а пофигуратор забыл выключить у себя, а проверить надо.. эх, если бы еще он внешние обработки править мог! :)
43. Александр Рытов (Арчибальд) 27.11.09 14:11
(41) Чуточку флуда: вот ни разу отладчиком не пользовался за 40 лет :D
44. Трактор Трактор (Трактор) 27.11.09 14:20
(43) Ого! Служебными сообщениями задолбаешься отлаживать.
45. Александр Рытов (Арчибальд) 27.11.09 14:29
(44) а что делать, если первые 20 лет их просто не было. 8-)
46. defzyx (NDM) 27.11.09 14:55
(9) конфа на базе УПП для Украины (старая)
47. akama2001 (akama2001) 27.11.09 15:22
Прошу добавить кнопочку для разбиения запросов по вложенным подзапросам, очень пригодилось бы !!!
48. AntiL (AntiL) 27.11.09 15:31
Обработка написано добро...
Очень нехватает функции подбора кода при вводе кода по комбинации клавиш "Ctrl+ПРОБЕЛ"
49. defzyx (NDM) 27.11.09 16:01
Не все "Классы" метаданных корректно занесены, см.
Прикрепленные файлы:
50. Сергей Старых (tormozit) 27.11.09 23:02
Мое разрешение на подсказку не нужно. Я ее же и писал для всех. Вот только ее легко подключить можно только в рамках конфигурации, но не внешней обработки.
51. Mars (Tsprogrammist1) 01.12.09 08:56
52. Юрий (liouria) 01.12.09 23:22
Не работает цикл "Для счетчик = 0 ПО ... " - не происходит изменения значения счетчика.
Тот же самый кусок кода в составе конфигурации - работает без проблем.
53. Владислав Томашевич (tomvlad) 01.12.09 23:29
(52) Юрий, у Вас ошибка в коде. Приведите фрагмент целиком.
54. Антон Степанов (Stepa86) 12.12.09 10:53
(0) А почему шаблоны текста не *.st используются, а вшитые в обработку? или используются???
55. Александр Смоленский (Alex_Smolensky) 16.12.09 16:46
отличная штука, спасибо!
56. Артур Аюханов (artbear) 13.02.10 19:34
(0) Опиши последние изменения, плиз.
Вижу, что сейчас версия 2.0.0.18 от 30.12.09, а описана только 2.0.0.15
57. Артур Аюханов (artbear) 13.02.10 19:50
(35) Что-нибудь получилось с новой версией?
58. Артур Аюханов (artbear) 13.02.10 20:12
(0) В связи с обращением к запросам и алгоритмам невозможно давать произвольное имя запроса или алгоритма, разрешено только имя в формате идентификатора 1С.

ИМХО либо запрети создавать "плохие" имени, либо в доке/справке/подсказке опиши подобное поведение
59. Артур Аюханов (artbear) 13.02.10 20:21
(0) Баг - при копировании в дереве текстов модулей не копируются алгоритмы и запросы :(
Текст и параметры копируются, а остальное нет.
Совсем не гуд.
версия 2.0.0.18
60. Артур Аюханов (artbear) 13.02.10 20:26
(0) Еще баг - действия по нажатию кнопки Выполнить сверху рядом с кнопкой Параметры отличаются от действия F7 или контекстное меню на имени текста и выборе Выполнить.
По Выполнить - алгоритмы и запросы работают, а по Ф7 нет :( - выдаются синтаксические ошибки.
61. Артур Аюханов (artbear) 13.02.10 22:05
Текущую редакцию довольно легко можно превратить в простую среду по созданию, отладке и тестированию юнит-тестов в 1С.


Принимаем следующие предположения:
1. если код/текст/юнит-тест не работает, он выбрасывает исключение
2. несколько юнит-тестов могут быть объединены в группы
при этих предположениях легко сделать исправления в модуле основной формы браузера блоков кода
и по кнопке Выполнить будут выполняться целые группы тестов.
.
Код ниже вставляем вместо процедуры КоманднаяПанельФормыВыполнить(Кнопка) в модуле основной формы
.
// Артур
Функция ВыполнитьОдинБлокКода(текстМодуля, ДанныеДляКода)
//Процедура КоманднаяПанельФормыВыполнить(Кнопка)

    // Поместим параметры, алгоритмы и запросы в структуры,
    // чтобы к ним можно было обратиться, например Алгоритмы.ОбработкаСправочника

    Параметры = Новый Структура;
    Для каждого ПараметрСтрока Из ДанныеДляКода.ТаблицаПараметров Цикл
        Параметры.Вставить(ПараметрСтрока.Параметр, ПараметрСтрока.ЗначениеПараметра);
    КонецЦикла;

    Алгоритмы = Новый Структура;
    Для каждого АлгоритмСтрока Из ДанныеДляКода.ТаблицаАлгоритмов Цикл
        Алгоритмы.Вставить(АлгоритмСтрока.АлгоритмИмя, АлгоритмСтрока.Алгоритм);
    КонецЦикла;

    Запросы = Новый Структура;
    Для каждого ЗапросСтрока Из ДанныеДляКода.ТаблицаЗапросов Цикл
        Запросы.Вставить(ЗапросСтрока.ЗапросИмя, Новый Запрос(ЗапросСтрока.Запрос));
    КонецЦикла;

    // Выполнение текста

    ТаблицаРезультат.Очистить();

    Если НЕ ДанныеДляКода.ЭтоГруппа Тогда
        Выполнить(текстМодуля); //Выполнить(ЭлементыФормы.ТекстМодуля.ПолучитьТекст());
        Возврат Истина;
    Иначе
        Попытка
            Выполнить(текстМодуля);
            Возврат Истина;
        Исключение
            Сообщить("Код "+ДанныеДляКода.ТекущаяСтрока.ИмяТекста + " неверно отработал - <"+ОписаниеОшибки()+">");
            Возврат Ложь;
        КонецПопытки;
    КонецЕсли;

КонецФункции

// Артур
Процедура КоманднаяПанельФормыВыполнить(Кнопка)
    ДанныеДляКода = Новый Структура;

    текущаяСтрока = ЭлементыФормы.ДеревоТекстов.ТекущаяСтрока;
    подчиненныеСтроки = текущаяСтрока.Строки;
    количествоПодчиненныхСтрок = подчиненныеСтроки.Количество();
    этоГруппаБлоковКода = количествоПодчиненныхСтрок <> 0;

    Если НЕ этоГруппаБлоковКода Тогда
        код = ЭлементыФормы.ТекстМодуля.ПолучитьТекст();

        ДанныеДляКода.Вставить("ЭтоГруппа", Ложь);

        ДанныеДляКода.Вставить("ТаблицаПараметров", ТаблицаПараметров);
        ДанныеДляКода.Вставить("ТаблицаАлгоритмов", ТаблицаАлгоритмов);
        ДанныеДляКода.Вставить("ТаблицаЗапросов", ТаблицаЗапросов);
        ДанныеДляКода.Вставить("ТекущаяСтрока", текущаяСтрока);

        ВыполнитьОдинБлокКода(код, ДанныеДляКода);
    Иначе
        количествоПлохихТестов = 0;
        Для каждого строка Из подчиненныеСтроки Цикл
            код = строка.ТекстМодуля;

            ДанныеДляКода.Вставить("ЭтоГруппа", Истина);

            ДанныеДляКода.Вставить("ТаблицаПараметров", строка.Параметры);
            ДанныеДляКода.Вставить("ТаблицаАлгоритмов", строка.ТаблицаАлгоритмов);
            ДанныеДляКода.Вставить("ТаблицаЗапросов", строка.ТаблицаЗапросов);
            ДанныеДляКода.Вставить("ТекущаяСтрока", строка);

            успешно = ВыполнитьОдинБлокКода(код, ДанныеДляКода);
            Если НЕ успешно Тогда
                количествоПлохихТестов = количествоПлохихТестов + 1;
            КонецЕсли;
        КонецЦикла;

        Если количествоПлохихТестов = 0 Тогда
            Сообщить("ОК");
        Иначе
            Сообщить("Не выполнено <"+количествоПлохихТестов+"> тестов/блоков кода из <"+количествоПодчиненныхСтрок+">");
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
// завершение
...Показать Скрыть


ИМХО очень удобно использовать для тестирования.

ЗЫ в данной редакции кода возможна редакция только на 2-х уровнях иерархии - код и группа кодов. но доработать на любую иерархию несложно.
62. Артур Аюханов (artbear) 13.02.10 23:45
(59+) Еще очень серьезный баг: иногда алгоритмы и запросы просто пропадают, в основном это происходит после простых переключений/активаций разных строк в дереве текстов :(
63. Андрей Межов (mini_root) 14.02.10 21:23
(57) Не, я щас кроме основной работы занимаюсь время от времени только этим

http://code.google.com/p/one-c-connectors/
64. Владислав Томашевич (tomvlad) 15.02.10 09:01
65. Владислав Томашевич (tomvlad) 15.02.10 09:06
(56) В релизах старше 2.0.0.15 изменения касаются только исправления выявленных ошибок.
66. Артур Аюханов (artbear) 15.02.10 12:32
(64) Просьба писать данные по текущему релизу - хотя бы версию и дату.
ИМХО Для этого идеально подходит блог :)
67. Артур Аюханов (artbear) 15.02.10 13:37
(64) Спасибо.
Но еще ошибки есть:
при переносе элемента в другую группу у этого элемента исчезают и алгоритмы, и запросы :(
Поправишь?
68. Артур Аюханов (artbear) 15.02.10 13:37
(65) По (61) что можешь сказать?
Не хочешь превратить свою консоль в еще и в инструмент юнит-тестирования :) ?
69. Владислав Томашевич (tomvlad) 16.02.10 07:56
(67) Исправил
(68) Нет, пока не хочу, да и времени нет
70. Станислав Турчинский (Istur) 02.08.10 18:55
Если зайти в конструктор запроса, то выдает ошибку. При этом запрос выполняется, с этим проблем нет. В режиме конфигуратора ошибки нет.

В принципе эта ошибка не существенна.
Прикрепленные файлы:
72. Михаил Иванов (feel063) 05.10.11 23:25
Ещё бы что-нибудь подобное для управляемых форм))
73. tvv (pmtvv) 09.10.11 14:57
молодец, хорошая обработка
74. Сергей Ожерельев (Поручик) 09.10.11 16:59
75. Алексей Азов (unknown181538) 11.11.11 16:46
76. Артур Трушкин (yavedmin) 17.11.11 18:13
Спасибо! Очень понравилась.
77. AChelentano 28.11.11 12:41
Спасибо. Пользуюсь постоянно.
Статус бар допишите только пожалуйста. Я у себя сделал. Другим тоже может пригодиться.
МимохожийОднако; +1 Ответить 1
78. Кирилл Гезин (kirillsas) 04.01.12 10:20
После перепроведения документов на закладке "Результат выполнения" она присоединила снизу еще кусок формы с "Доступные обработки" и "Выбранные обработки". Выбираю "Отменить проведение документов" и получаю предупреждение "Данная обработка недоступна для типа <Документы>".
Что бы это значило?

при копировании в дереве текстов модулей не копируются алгоритмы и запросы
Текст и параметры копируются, а остальное нет.
Совсем не гуд.
версия 2.0.0.18
79. Александр (МимохожийОднако) 07.01.12 12:01
(77) AChelentano, сбрось сюда свой вариант. Может, кому пригодится.
80. Alex Koso (AlexKoso) 30.01.12 21:08
судя по скринам - чтото феерическое. Автор берегись, я выхожу на путь тестирования :)
81. Сергей Старых (tormozit) 03.02.12 11:14
82. Андрей (andru_dv) 03.02.12 16:01
Попробую в деле этот инструмент. По результатам отпишусь.
83. correct_coding (correct_coding) 28.02.12 23:37
84. Andrey (angy) 21.06.12 11:30
Обработка прикольная , только в том плане что конфиг не надо открывать а все остальное можно написать в обычной консоле запросов + куча багов, идея хорошая, когда быстро нужно чего то исправить а в остальном пользы мне кажется мало, это лично мое мнение. Работа проделана колосальная автору респект...
85. Fomix (fomix) 04.12.12 11:15
Добрый день! Скачал для 8.1 и 8.2. А есть ли разница в них?!
Пока пробую для 8.2 на толстом клиенте. Запустил конструктор объекта ссылочного типа и на тебе:
1. галочки на всех закладках ставятся, но не снимаются.
2. так и не понял как создается текст модуля заполнения объекта, поиска реквизитов и т.п.
3. не заполняются реквизиты табличных частей.
Это что - бета версия или конструктор доделай сам?! Однаааако....
86. Максим Евсенкин (tehas) 05.12.12 12:44
однозначно плюс, вещь мощная =)
87. Сергей Куликов (ksvd) 14.02.13 10:52
Вот спасибо! Пригодилась для выполнения кода по отключению от интернет-поддержки при запуске Бухгалтерии 2.0
88. Ak A (frc) 01.05.13 18:38
(0) не понял - это для создания кода (таблицы-справочники), или для выполнения кода?
89. hobo alone (alonehobo) 21.07.13 21:04
90. Vitalya Гуляев (Vix) 12.09.13 19:28
91. Никола Тесла (alext88) 20.02.14 08:42
92. Александр (alex_sear) 26.02.14 04:28
93. Тимофей Шантин (ShantinTD) 03.12.15 11:25
странно, куда потерял сие чудо? скачивал же уже! За хорошую вещь не жалко еще один $m отдать.
94. Дмитрий Иванов (ChessCat) 18.01.16 23:19
Подскажите пожалуйста инструмент для решения задач которые легко решала эта обработка только для управляемых форм.

Например стандартная задача.

Есть определенный регистр. Регистраторы сделали по нему движения.
Необходимо получить движения по регистру и что то в них поменять без перепроведения документов.
С помощью этой консоли на обычных формах подобная задача решалась очень легко написанием куска кода и выполнением его через консоль.

А как решить эту задачу на управляемых формах ?