gifts2017

Загрузка данных из таблицы Excel в два шага

Опубликовал Ольга Бояринова (olgad946) в раздел Программирование - Практика программирования

Для того, чтобы каждый раз не писать одно и то же, предлагается идея загружать данные из Excel  в два шага.

Шаг первый: выбор файла Excel, настройка параметров чтения – диапазон строк и колонок,  выбор листа, просмотр загруженных данных в таблице значений 1С.

На форме переключателем указывается способ определения количества загружаемых  строк:

  1. Пока есть данные во всех указанных колонках – в текстовом поле указывается одно или несколько номеров колонок, разделенных точкой с запятой «;», если в строке в одной из колонок содержится пустое значение, загрузка прекращается
  2. Пока есть данные хотя бы в одной из указанных колонок – если встречается строка, в которой одновременно во всех колонках пустое значение – импорт прекращается
  3. Загружать указанное количество строк – загружается указанное количество строк

Флажок «Включить колонку уровня строки в файле Excel» предназначен для включения в таблицу указателя уровня строки исходного файла.

По кнопке «Просмотр»  данные из исходного файла загружаются в таблицу значений и выводятся на экран.

Шаг второй: передача полученной таблицы значений в произвольную обработку для решения некоторой прикладной задачи.

Пишется другая обработка, которая решает прикладную часть задачи загрузки. Для этого надо в процедуру ПриОткрытии() вставить текст как в примере:

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Загрузка данных из таблиц Excel в два шага
.ert 41,00Kb
24.01.10
406
.ert 41,00Kb 406 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр (D9ID9I_SaIIIa) 25.01.10 00:14
(0)"Для того, чтобы каждый раз не писать одно и то же, предлагается идея загружать данные из Excel в два шага."
хм...по моему чего то не хватает в заголовке и в содержательной части,или я чего то недопонимаю...
+скриншоты мелкие
\\каждый извращается по своему :D
2. igor Nemo (karabas1980) 25.01.10 04:48
Да уж... Для скриншотов лупы явно не хватает
3. Аркадий Кучер (Abadonna) 25.01.10 14:20
(0)
Пока есть данные во всех указанных колонках – в текстовом поле указывается одно или несколько номеров колонок, разделенных точкой с запятой «;», если в строке в одной из колонок содержится пустое значение, загрузка прекращается

И чего только народ не придумает ;)
E.Workbooks.Open(Сокрлп(ИмяФайла));
Строк=E.Cells.SpecialCells(11).Row;    // строка последней ячейки
Столбцов=E.Cells.SpecialCells(11).Column; // столбец последней ячейки  
...Показать Скрыть
4. Александр Рытов (Арчибальд) 27.01.10 09:06
(3) В соответствии с этикой Конфуция, ты должен был отплюсоваться ;)
5. Михаил Хаов (мх) 27.01.10 11:35
Рациональное зерно в предложении есть.
Несмотря на высказанные замечания по реализации.
Можно развить предложение дальше: сделать эту обработку вызываемой с параметрами. При автоматизации обработки полученных от различных поставщиков накладных такой подход может быть весьма полезен
6. Аркадий Кучер (Abadonna) 27.01.10 12:15
(4)
В соответствии с этикой Конфуция, ты должен был отплюсоваться

А в соответствии с этикой Абадонны, это мне кто-нить должен спасибо сказать, кто не знал, о существовании SpecialCells, а в частности, о
SpecialCells(11)
7. Александр Рытов (Арчибальд) 27.01.10 12:28
(6) Ты отвечаешь за тех, кого приручаешь, в частности, за тех, кому сообщаешь о SpecialCells 8-)
8. Аркадий Кучер (Abadonna) 27.01.10 12:41
(7)
Ты отвечаешь за тех, кого приручаешь

Это называется по другому:
Ни одно доброе дело не останется безнаказанным!

;)
9. Александр Рытов (Арчибальд) 27.01.10 12:45
(8) Верно. Вот и "накажи" себя сам ;)
10. Аркадий Кучер (Abadonna) 27.01.10 12:46
(9)
Верно. Вот и "накажи" себя сам

Ну и скажи тогда: на какую из своих разработок мне минус поставить? :D
11. Александр Рытов (Арчибальд) 27.01.10 12:50
(10) Поскольку на свою минус не получится, поставь плюс сюда. Наказание будет в укорах совести за отданный якобы незаслуженный плюс. :)
12. Аркадий Кучер (Abadonna) 27.01.10 12:50
А ставить плюс на СоздатьОбъект("Excel.Application") не буду никогда, аж по трем причинам:
1. Кто его пользует незаконно - ворюган
2. Кто купил - дурачок
3. И есть, наконец, http://infostart.ru/public/59436/
Работа с xls-файлами на считывание/запись напрямую (не требует наличия Excel или Open Office)
13. Александр Рытов (Арчибальд) 27.01.10 12:54
(12)
1. Кто его пользует незаконно - ворюган
2. Кто купил - дурачок
Я не покупал, но и не крал - пользуюсь корпоративной лицензией. :D
Так что заслуживает внимания только 3-я позиция.
Жадница
14. Игорь Исхаков (Ish_2) 27.01.10 13:03
(6) Ну, я не знал. Но кто кому что должен - запутался.
По Арчибальду выходит ты мне должен плюс поставить, а я тебе - простое спасибо.
15. Аркадий Кучер (Abadonna) 27.01.10 13:14
(13)
Я не покупал, но и не крал - пользуюсь корпоративной лицензией.

Либо вы её брали давно, когда она дешево стоила, либо твоя корпорация - дурачок. А на моей бывшей работе спокойно снесли всем доменной политикой все Офисы, поставили Open Office (так же автоматом, при входе в систему) - юзвери поворчали немного, привыкли и работают себе спокойненько
16. Александр Рытов (Арчибальд) 27.01.10 13:14
(14)
1. Арчибальд прав.
2. Если кто-то считает, что Арчибальд ошибается, значит он чего-то не учитывает. Например, контекст формы.
17. Александр Рытов (Арчибальд) 27.01.10 15:20
(15) Шо вы мне зубы заговариваете? Вам это, право, не с руки. 8-)
18. Аркадий Кучер (Abadonna) 27.01.10 20:56
(17) Арчи, я так и не понял за что я должен плюс поставить.
Вот написанная лет пять назад функция:
Функция ReadExcel(ИмяФайла) Экспорт
	Попытка 
		E=СоздатьОбъект("Excel.Application");
	Исключение
		Предупреждение("Excel на компьютере не установлен!");
		Возврат ПолучитьПустоеЗначение();
	КонецПопытки;   
	E.Workbooks.Open(Сокрлп(ИмяФайла));
	Строк=E.Cells.SpecialCells(11).Row;    // строка последней ячейки
	Столбцов=E.Cells.SpecialCells(11).Column; // столбец последней ячейки  
	фТЗ=СоздатьОбъект("ТаблицаЗначений");
	Для А=1 По Столбцов Цикл
		фТЗ.НоваяКолонка(); 
	КонецЦикла;
	Для Стр=1 По Строк Цикл 
		Состояние("Обработано "+Строка(Стр)+" строк из "+Строка(Строк));
		фТЗ.НоваяСтрока(Стр);
		Для Столб=1 По Столбцов Цикл 
			фТЗ.УстановитьЗначение(Стр,Столб,СокрЛП(E.Cells(Стр,Столб).Value));
		КонецЦикла; 
	КонецЦикла;
	E.Workbooks.Close();   
	Возврат фТЗ;
КонецФункции
...Показать Скрыть


Что-то мне подозревается, что она делает почти как раз то, про что статья;)
И не надо "каждый раз не писать одно и то же", вызови функцию в любом отчете, поимей готовую ТЗ и делай с ней, что хочешь.

P.S. Если с номером листа, тогда так
Функция ReadExcel(ИмяФайла,Лист=1) Экспорт
и, соотвественно:
Строк=E.Sheets(Лист).Cells.SpecialCells(11).Row;
Столбцов=E.Sheets(Лист).Cells.SpecialCells(11).Column;
19. Александр Рытов (Арчибальд) 28.01.10 09:24
(18) Связался черт с младенцем :D
За это младенцу (младенцЕ) и плюс. Я так дУмаю 8-)
20. Аркадий Кучер (Abadonna) 28.01.10 09:41
(19) Лежала бы в профайле фотка, да если бы мне еще и интерфейс понравился, я бы плюсанул даже не читая про что тут. ;) Вот так!
Да и ваще - может бы и поставил, но теперь из вредности (из-за тебя) точно не поставлю. Так что радуйся, что не минус :D
21. Александр Рытов (Арчибальд) 28.01.10 09:52
(20)
из вредности (из-за тебя)
Арчибальд = Вредность Абадонны
Ни хрена себе теорема. Доказывай!
22. Аркадий Кучер (Abadonna) 28.01.10 09:55
(21) Не теорема, а аксиома:
Хочешь, чтобы Абадонна чего-нибудь не сделал - проси очень настойчиво его это сделать ;)
23. Александр Рытов (Арчибальд) 28.01.10 09:59
24. Аркадий Кучер (Abadonna) 28.01.10 10:01
(23)
Обратное тоже верно?

Это односторонняя функция ;)
Триггер уже перекинулся, поэтому вопрос рейтинга этой разработки уже обсуждению не подлежит :D
P.S. А если по честному - жуть до чего дикий принцип решения изложен
25. Александр Рытов (Арчибальд) 28.01.10 10:18
(24) Поверю на слово - я не читал.
26. Аркадий Кучер (Abadonna) 28.01.10 10:40
(25)
Поверю на слово - я не читал.

Советник, блин. Развел тут фаворитизм :D
27. Александр Рытов (Арчибальд) 28.01.10 12:15
(26) Фаворитизм здесь ни при чем. Это ностальгия. Вспомнилось, как я кувыркался с импортом из екселя за заре знакомства с одноэсиной. Всплакнул :cry:
28. Аркадий Кучер (Abadonna) 28.01.10 12:21
(27)На заре я с ним и кувыркаться не стал, просто сохранял сразу xls в dbase4, а работа с dbf - это было как раз то, что я самое первое в 1С освоил;)
Вот эта, кстати, вообще моя самая первая на 7.7:
http://infostart.ru/public/14639/
29. Александр Рытов (Арчибальд) 28.01.10 12:35
(28) С этим-то было просто: Клиппером вдоль и поперек ДОСовской 1С я рассекал уверенно. А в Ексель вообще не лазил. Впервые увидел году в 2000, позже своих экономистов :o
30. Аркадий Кучер (Abadonna) 28.01.10 18:31
Если вдруг кому-нибудь понадобится, вот полностью работоспособный отчет:
Функция глОткрытьФайл(Маска="") Экспорт   
	Перем ИмяФайла,ИмяКаталога;
	Маска_="Файлы "+Маска+"|*."+Маска;   
	Если СокрЛП(Маска)="" Тогда
		Маска_="Все файлы |*.*"  
	КонецЕсли;
	Если ФС.ВыбратьФайл(0,ИмяФайла,ИмяКаталога,"Открыть файл",Маска_)=1 Тогда 
		Возврат ИмяКаталога+ИмяФайла;   //полное имя открытого файла     
	Иначе
		Возврат ""; 
	КонецЕсли;
КонецФункции   

Функция ReadExcel(ИмяФайла,Лист=1) Экспорт
	Попытка 
		E=СоздатьОбъект("Excel.Application");
	Исключение
		Предупреждение("Excel на компьютере не установлен!");
		Возврат ПолучитьПустоеЗначение();
	КонецПопытки;   
	E.Workbooks.Open(Сокрлп(ИмяФайла));
	Строк=E.Sheets(Лист).Cells.SpecialCells(11).Row;    // строка последней ячейки
	Столбцов=E.Sheets(Лист).Cells.SpecialCells(11).Column; // столбец последней ячейки  
	фТЗ=СоздатьОбъект("ТаблицаЗначений");
	Для А=1 По Столбцов Цикл
		фТЗ.НоваяКолонка(); 
	КонецЦикла;
	Для Стр=1 По Строк Цикл 
		Состояние("Обработано "+Строка(Стр)+" строк из "+Строка(Строк));
		фТЗ.НоваяСтрока(Стр);
		Для Столб=1 По Столбцов Цикл 
			фТЗ.УстановитьЗначение(Стр,Столб,СокрЛП(E.Sheets(Лист).Cells(Стр,Столб).Value));
		КонецЦикла; 
	КонецЦикла;
	E.Workbooks.Close();   
	Возврат фТЗ;
КонецФункции

Процедура Сформировать()      
	ИмяФайла=глОткрытьФайл("xls");
	Если СокрЛП(ИмяФайла)="" Тогда Возврат; КонецЕсли;
	ТЗ.Загрузить(ReadExcel(ИмяФайла,1)); // ТЗ - таблица значений на форме    
	// ну а дальше смотрим визуально, что с ней дальше делать
КонецПроцедуры
...Показать Скрыть

Примечание: функции, конечно, перенести в ГМ или ДопГМ formex, т.е. в отчете останется только процедура Сформировать()
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа