gifts2017

Картотека: Спецодежда и Спецоснастка (счета 10.11.1 и 10.11.2 ) для БП 8.1 ред 1.6

Опубликовал Эдуард (mart-sha) в раздел Отчеты - Бухгалтерские

Картотека по сч 10.11.1 (Спецодежда) и сч 10.11.2 (Спецоснастка) в разрезе Сотрудник (Подразделение) - ЕГО СПЕЦОДЕЖДА.

Видно ОСТАТОК НА НАЧАЛО - ПРИХОД - РАСХОД - ОСТАТОК НА КОНЕЦ МЕСЯЦА. Кроме того есть сообщение: ПОРА СПИСЫВАТЬ!

Проверяем правильность ввода срока эксплуатации (например, вместо 12 месяцев щелкнули 1), пока в виде предупреждения. Проверяем наличие документа "ЗАКРЫТИЕ МЕСЯЦА" с установленной галочкой "Погашение стоимости спецодежды и спецоснастки"

Весь код с комментариями, прошу Ваши замечания и предложения ...

 

Скачать файлы

Наименование Файл Версия Размер
Картотека Спец Одежда 276
.epf 18,89Kb
18.05.10
276
.epf 18,89Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Rusk (Rusk51) 04.03.10 17:54
Расширение файла отсутствует.
2. ПСВ (ПСВ) 04.03.10 20:17
// Выставим переключатель на 1 пункт (че-то не понял как это сделать в его свойствах)
Счет=1;

для переключателя нет реквизита формы и правильного порядка обхода:

http://ifolder.ru/16692096
3. Эдуард (mart-sha) 05.03.10 11:43
Спасибо , добавлю ваш вариант, кстати добавлю счет 10.11.2
4. rasswet (rasswet) 16.04.10 08:55
{Форма.Форма(379)}: Ошибка при вызове метода контекста (Заполнить): Несоответствие типов (параметр номер '1')
ОбластьПодвал.Параметры.Заполнить(Гр1);
по причине:
Несоответствие типов (параметр номер '1')
5. rasswet (rasswet) 16.04.10 09:24
коменты в модуле радуют! кстати можешь попробовать под 2.0 бух сделать.
укажи в шапке, что это под 1.6.
6. Александр (Kruzo) 08.01.11 20:12
Та же ошибка
Ошибка при вызове метода контекста (Заполнить): Несоответствие типов (параметр номер '1')
ОбластьПодвал.Параметры.Заполнить(Гр1);
по причине:
Несоответствие типов (параметр номер '1')
Как побороть сию проблему?
БП 1.6.28.2
Отчет ОЧЕНЬ нежен!
7. Александр (Kruzo) 08.01.11 20:13
Пардон, ошибся.
Отчет ОЧЕНЬ нУжен!
8. Александр (Kruzo) 12.02.11 23:18
Вместо
Для Каждого стр Из Док.Спецодежда Цикл
Если стр.Номенклатура=Номенкл Тогда
// Определим Код и Срок полезого использования
КодИспольз=стр.НазначениеИспользования.Код;
СрокИспольз=стр.НазначениеИспользования.СрокПолезногоИспользования;
КонецЕсли;
КонецЦикла;


Надо указать
Если Счет=0 Тогда
Для Каждого стр Из Док.Спецодежда Цикл
Если стр.Номенклатура=Номенкл Тогда
// Определим Код и Срок полезого использования
КодИспольз=стр.НазначениеИспользования.Код;
СрокИспольз=стр.НазначениеИспользования.СрокПолезногоИспользования;
КонецЕсли;
КонецЦикла;
Иначе
Для Каждого стр Из Док.Спецоснастка Цикл
Если стр.Номенклатура=Номенкл Тогда
// Определим Код и Срок полезого использования
КодИспольз=стр.НазначениеИспользования.Код;
СрокИспольз=стр.НазначениеИспользования.СрокПолезногоИспользования;
КонецЕсли;
КонецЦикла;
КонецЕсли;
9. bonni (bonni80@mail.ru) 07.10.11 03:43
У меня не работает по чему то :-((
10. bonni (bonni80@mail.ru) 07.10.11 03:46
Хорошая тема, жаль под 8.2 нету.
11. Эдуард (mart-sha) 07.10.11 12:33
Переконвертируй в платформе 8,2 и будет работать. Или нужен по БП 2.0 ?
12. Алекс Смирнов (Alex®) 24.10.11 10:17
Нужная штука. А можно сделать чтобы с БП 2.0 работало?
Спасибо.
02RUSlan; +1 Ответить
13. Руслан (02RUSlan) 24.10.11 14:31
А можно сделать чтобы с БП 2.0 работало?
14. Мария Дорошенко (maria7777777) 01.02.14 09:28
все неплохо, но первоначальную стоимость обработка не вытягивает, по нулям показывает
15. Мария Дорошенко (maria7777777) 01.02.14 11:57
Да и еще: Тип цен пока берем по Константе, можно переделать по текущему складу
написано в Коментарии, а почему не выбрать первоначальную цену спецодежды из документа ввод в эксплуатацию, который идет субконто2?
16. Эдуард (mart-sha) 08.04.14 15:59
(15) maria7777777, да идея хорошая, так будет точнее.