Загрузка документов из 7.7 в 8.X

Опубликовал alexer в раздел Обмен - Перенос данных из 1С7.7 в 1C8.X

Тем, кому лень изучать КД, посвящается.
Очередная обработка, позволяющая делать загрузку данных практически из любых документов 7.7 в любые документы 8.Х.

Простенькая обработка рассчитана на тех, кто хоть как-то программирует в 1С. Суть обработки заключается в том, что после выбора необходимого вида документа в семерке и вида документа в восьмерке, текстовое поле заполняется процедурой для загрузки данных. После правки этого текста модуля и нажатия кнопки "Выполнить", произойдет создание документов. Реквизиты в модуль можно перетаскивать методом Drag & Drop.

Ее можно также использовать как помощник для написания процедур модуля при загрузке документов.

Есть возможность сохранения настроек, с помощью "Файл\Сохранить". Настройки сохраняются в папке C:\Temp1C\.

Авось кому еще пригодится данная обработочка.

Файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗагрузкаДоковИз7.7В8.1.epf
.epf 21,68Kb
04.06.10
2583
.epf 21,68Kb 2583 Скачать
ЗагрузкаДоковИз7.7В8.2.epf
.epf 21,98Kb
04.06.10
466
.epf 21,98Kb 466 Скачать

См. также

Лучшие комментарии

20. alexer 24.03.2010 15:38
(19) Именно.
+ 1 [ Dolour; ]
# Ответить
1. ПСВ (файл скачал) 22.03.2010 14:46
{ВнешняяОбработка.ЗагрузкаДокументов.МодульОбъекта(31)}: Ошибка при вызове метода контекста (Записать): Ошибка доступа к файлу 'C:\Program Files\1cv82\8.2.10.77\bin\USER.TXT'
Текст.Записать(ИмяБазы+"USER.TXT");
по причине:
Ошибка доступа к файлу 'C:\Program Files\1cv82\8.2.10.77\bin\USER.TXT'

Да..., впредь буду осторжным прежде чем запускать чужие разработки без анализа кода
Хоть бы предупреждали чтоль, что в реестр лезете!!!
Ответили: (2)
+ 1 [ afonya; ]
# Ответить
120. alexer 03.12.2013 20:30
(119)
1. найти счет можно так же, как вы искали и контрагента:
СпрБанковскиеСчета = Справочники.БанковскиеСчета;
НайденСчет = СпрБанковскиеСчета.НайтиПоРеквизиту("НомерСчета",ДокумV7.Организация.НомерСчета);
Если НайденСчет <> Неопределено Тогда
НовыйДокV8.СчетОрганизации = НайденСчет.Ссылка;
КонецЕсли;

2. С договорами все сложнее, если у вас все договора с наименованием "Основной договор"

3. А со временем документа можно поступить так:
Ч = 0;
М = 0;
С = 0;
ДокумV7.ПолучитьВремя(Ч, М, С);
НовыйДокV8.Дата = Дата(Год(ДокумV7.ДатаДок),Месяц(ДокумV7.ДатаДок),День(ДокумV7.ДатаДок),Ч,М,С);

вроде метод ПолучитьВремя() должен сработать по OLE
Ответили: (121)
+ 1 [ pav-yamal; ]
# Ответить
27. max007446 (файл скачал) 25.03.2010 10:33
Подключился к базе 77 без проблем,составил все соответствия,оибок нет,но по кнопке Выполнить ничего не происходит???:(Что не так?
Ответили: (28)
+ 1 [ budda1; ]
# Ответить

Комментарии

1. ПСВ (файл скачал) 22.03.2010 14:46
{ВнешняяОбработка.ЗагрузкаДокументов.МодульОбъекта(31)}: Ошибка при вызове метода контекста (Записать): Ошибка доступа к файлу 'C:\Program Files\1cv82\8.2.10.77\bin\USER.TXT'
Текст.Записать(ИмяБазы+"USER.TXT");
по причине:
Ошибка доступа к файлу 'C:\Program Files\1cv82\8.2.10.77\bin\USER.TXT'

Да..., впредь буду осторжным прежде чем запускать чужие разработки без анализа кода
Хоть бы предупреждали чтоль, что в реестр лезете!!!
Ответили: (2)
+ 1 [ afonya; ]
# Ответить
2. alexer 22.03.2010 14:55
(1) так обработка только читает реестр.
а после чего происходит ошибка, что-то у меня не воспроизводится?
возможно у вас нет прав на запись к этой папке.
# Ответить
3. ПСВ (файл скачал) 22.03.2010 15:15
при открытии , win7 , контроль учетных записей включен - поэтому и ошибка

наверно вам будет лучше - что то типа

//ИмяБазы=СокрЛП(КаталогПрограммы());

ИмяБазы=СокрЛП(КаталогВременныхФайлов());
Ответили: (4)
# Ответить
4. alexer 22.03.2010 15:26
(3) Спасибо, поправил.
Этот кусок кода я скопировал еще из обработки 7.7.
# Ответить
5. ZLG07 (файл скачал) 22.03.2010 22:24
Уважуха те, как раз нужно было писать экспорт доков из самописной 7, в торговлю 8.1. А тут у тя в принципе все что надо, тем более что с 7 я как то особо и не работал. И кстати небольшой косяк у тя. Когда генерится код, у тя там в товарах, где номенклатура стоит:
НовДок.Номенклатура = НайденнаяНоменклатура, должно быть НовСтр.Номенклатура
Ответили: (7)
# Ответить
6. den_vladimir 23.03.2010 06:45
Сделай плз общий архив, не у всех рейтинг высокий!
Ответили: (7)
# Ответить
7. alexer 23.03.2010 07:43
(5) Поправил.
(6) У меня стоит скачивание для всех зарегистрированных пользователей.
# Ответить
8. Igor2010 (файл скачал) 23.03.2010 09:06
:?: Не смотрел обработку ещё, сори. Документ операция может перенести? :)
Ответили: (9)
# Ответить
9. alexer 23.03.2010 10:36
(8) А почему бы и нет. Выбираете документ Операция, и вперед. ;)
# Ответить
10. del horizonte (файл скачал) 24.03.2010 13:46
только не закидывайте тапками,не пойму как выбрать нужную базу 7-ки?
Ответили: (11)
# Ответить
11. alexer 24.03.2010 13:50
(10) а у вас семерка установлена?
# Ответить
12. del horizonte (файл скачал) 24.03.2010 13:58
ага,установлена.
Ответили: (13)
# Ответить
13. alexer 24.03.2010 14:01
(12) А база в семерке, которую хотите выбрать подключена?
# Ответить
14. del horizonte (файл скачал) 24.03.2010 14:24
да,в семерке база подключена. В список должны автоматически базы выбраться? Документы 8-ки выбираются. А вот базу 7-ки и доки 7-ки не могу выбрать.
Ответили: (15) (34) (36)
# Ответить
15. alexer 24.03.2010 14:38
(14) Да, список семерочных баз формируется при открытии обработки.
А какая у вас операционная система?
# Ответить
16. demonenok (файл скачал) 24.03.2010 14:46
Спасибо за обработку...очень нужная вещичка!!!
:)))
# Ответить
17. del horizonte (файл скачал) 24.03.2010 15:05
XP профешнл.
Ответили: (18)
# Ответить
18. alexer 24.03.2010 15:19
(17) Странно, может вы используете Loader1C, или подобную прогу, а не стандартный запуск 1С v7.
Попробуйте в реестре посмотреть ветку HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\Titles, здесь находится список баз.
# Ответить
19. del horizonte (файл скачал) 24.03.2010 15:36
да,я уже туда посмотрела,скопировать оттуда не могу,но вот несколько путей:
С:\1\zarpl\
D:\zarpl\
С:\ЗиК проба\zarpl\
то есть в список баз должны выводиться базы ,которые прописаны тут: HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\Titles
Ответили: (20)
# Ответить
20. alexer 24.03.2010 15:38
(19) Именно.
+ 1 [ Dolour; ]
# Ответить
21. del horizonte (файл скачал) 24.03.2010 16:16
так там-то пути к базам прописаны.Эх,что ж за невезуха ((
Ответили: (22) (23)
# Ответить
22. alexer 24.03.2010 16:18
(21) Попробуйте запустить обработку на другой машине.
# Ответить
23. alexer 24.03.2010 17:27
(21) Специально для вас сделал кнопку

Загрузить обработку
# Ответить
24. Drew_7 (файл скачал) 24.03.2010 19:02
25. del horizonte (файл скачал) 25.03.2010 10:26
спасибо! :) скачала.выбрала нужную базу(не выгрузку ж?)
D:\zarpl ,попросил авторизацию доступа,выбрала себя ,появилось сообщ. Ошибка подключенияэ
попробую базу с бухгалтерией подключить.
Ответили: (26)
# Ответить
26. alexer 25.03.2010 10:32
(25) Даже и не знаю чем вам еще помочь.
# Ответить
27. max007446 (файл скачал) 25.03.2010 10:33
Подключился к базе 77 без проблем,составил все соответствия,оибок нет,но по кнопке Выполнить ничего не происходит???:(Что не так?
Ответили: (28)
+ 1 [ budda1; ]
# Ответить
28. alexer 25.03.2010 10:45
(27) Может у вас в семерке нет документов выбранного типа за этот период.
# Ответить
29. del horizonte (файл скачал) 25.03.2010 10:58
о!подождите!!с 5 попытки написал вверху путь к базе д-зарпл и доки все в списке отобразил :) :) :) :)
# Ответить
30. del horizonte (файл скачал) 25.03.2010 11:14
*написала :)
# Ответить
31. GJosh (файл скачал) 26.03.2010 08:35
Прекрасная идея! Осталось довести её до абсурда в хорошем смысле этого слова: 77-> 8 есть, добавляйте 77-> 77, 8-> 8, 8-> 77 и т.д. Плюс собрать хорошую отлаженную библиотеку модулей документов. И это будет блестящей альтернативой КД, Переносу данных и т.д.
С удачей!
Ответили: (32)
# Ответить
32. alexer 26.03.2010 08:47
(31) да уж, коллекция библиотек модулей ТиС -> УТ, Бух -> БП, ТиС -> БП и т.д. :D
# Ответить
33. GJosh (файл скачал) 26.03.2010 12:35
А кто Вам сказал, что Вам это придется делать? Народ настругает, Ваше дело собирать ...
# Ответить
34. Djagernaut (файл скачал) 26.03.2010 13:12
{ВнешняяОбработка.ВнешняяОбработка1(14)}: Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса
БазаОлеТек= Новый COMОбъект("V77.Application");

Что может быть?
Ответили: (35)
# Ответить
35. alexer 26.03.2010 13:16
(34) 1С 7.7 платформа установлена?
# Ответить
36. Djagernaut (файл скачал) 26.03.2010 13:17
{ВнешняяОбработка.ВнешняяОбработка1(14)}: Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса
БазаОлеТек= Новый COMОбъект("V77.Application");
# Ответить
37. provnick (файл скачал) 27.03.2010 19:53
НайтиПоКоду, не работает, так, как длина разная, применил НайтиПоНаименованию, заработало, в целом очень гуд!
# Ответить
38. del horizonte (файл скачал) 29.03.2010 13:18
такой вотвопрос:у меня вылезла ошибка по кнопке выполнить:Поле объекта не обнаружено(Номенклатура). Справочника Номенклатура в конфе нету.Можно закоментировать эту строчку?
Те строки ,которые закоментированы, их можно раскомментировать,в зависимости от того какая нужна?
Ответили: (39)
# Ответить
39. alexer 29.03.2010 13:36
(38) Именно, вы сами ответили на свои вопросы :)
# Ответить
40. del horizonte (файл скачал) 30.03.2010 11:12
еще несколько вопросов: присвоить доку в 8-ке я могу только то,что вывелось в семерочном дереве реквизитов?
НовыйДокV8.Сотрудник = ДокумV7.;
Если есть какие-то поля в документе 8-ки,а в 7-ке их не было,то это уже вручную подправлять?(добавлять в восьмерочный документ)
У меня почему-то сотрудника не переносит ((,хотя период регистрации дока,период отпуска переносит.А сотра не хочет...
НовыйДокV8.Физлицо = ДокумV7.Сотрудник;
Ответили: (42)
# Ответить
41. del horizonte (файл скачал) 30.03.2010 11:19
в смысле вот так:
НовыйДокV8.Сотрудник = ДокумV7.Сотрудник;
# Ответить
42. alexer 30.03.2010 11:35
(40) Обработка и не будет переносить элементы справочников, она переносит документы, предполагается что элементы спр уже есть, их нужно только найти, если их нету то нужно создать новый элемент.
например так:
СпрФизЛица = Справочники.ФизическиеЛица;
НайденоФизЛицо = СпрФизЛица.НайтиПоНаименованию(ДокумV7.Сотрудник.Наименование);
Если НайденоФизЛицо = Справочники.ФизическиеЛица.ПустаяСсылка() Тогда
	НовоеФизЛицо = Справочники.ФизическиеЛица.СоздатьЭлемент();
	НовоеФизЛицо.Наименование = ДокумV7.Сотрудник.Наименование;
	НовоеФизЛицо.ДатаРождения = ДокумV7.Сотрудник.ДатаРожд;
	НовоеФизЛицо.ИНН = ДокумV7.Сотрудник.ИНН;
	...
	НовоеФизЛицо.Записать();
	НовыйДокV8.Сотрудник = НовоеФизЛицо.Ссылка;
Иначе
	НовыйДокV8.Сотрудник = НайденоФизЛицо;
КонецЕсли;
...Показать Скрыть
# Ответить
43. ladoga (файл скачал) 01.04.2010 02:22
При загрузке базовой версии 7.7 требует запустить в монопольном режиме
Ответили: (44)
# Ответить
44. alexer 01.04.2010 07:48
(43) Сожалею, но к базовой версии невозможно подключение с помощью механизма OLE.
# Ответить
45. LTanya (файл скачал) 01.04.2010 16:14
Почему все зависает после выбора базы 7.7?
Ответили: (46) (47) (48) (49) (51)
# Ответить
46. alexer 01.04.2010 16:41
(45) Даже не знаю что предположить. :?:
# Ответить
48. V0fka (файл скачал) 02.04.2010 10:13
(45) +1 , таже фигня :(
# Ответить
49. V0fka (файл скачал) 02.04.2010 10:16
(45) Потому что, после выбора базы появляется 7-ное окошко, где нужно выбрать пользователя и пароль :idea:
# Ответить
50. V0fka (файл скачал) 02.04.2010 10:19
LTanya, Потому что, после выбора базы появляется 7-ное окошко, где нужно выбрать пользователя и пароль :idea:
# Ответить
51. V0fka (файл скачал) 02.04.2010 10:21
52. del horizonte (файл скачал) 02.04.2010 11:07
причем,когда у меня 1с у меня распахнуто на весь рабочий стол,я этого окошка с выбором пользователя не могу дождаться(как зависает),а когда уменьшу(чтоб не на весь экран было),то быстро появляется.(При этом и другие программы должны быть свернуты)
Ответили: (53)
# Ответить
53. alexer 02.04.2010 11:15
(52) Скорее всего, окно авторизации прячется за окном 1С v8. Попробуйте комбинацией клавиш Alt+Tab перейти на это окошко.
# Ответить
54. demanru (файл скачал) 02.04.2010 16:57
Респект, видна рука мастера +
# Ответить
55. ralexn49 (файл скачал) 05.04.2010 11:23
Прекрасное подспорье, что сказать умница!
# Ответить
56. LTanya (файл скачал) 06.04.2010 08:01
Ну почему у всех работает, а у меня нет? Тоже хочу.
Ответили: (57)
# Ответить
57. alexer 06.04.2010 09:58
(56) А что не работает?
# Ответить
58. Sedow (файл скачал) 07.04.2010 10:48
а как перенести справочники для того чтобы перенос документов осуществился корректно.
Ответили: (59)
# Ответить
59. alexer 07.04.2010 11:10
(58) Главное чтобы было соответствие справочников по какому-либо реквизиту справочника, например по Коду или Наименованию, если у справочника есть комментарий, то можно в комментарий ввести ссылку элемента справочника с помощью функции ЗначениеВСтрокуВнутр(ЭлементСправочника), а затем из комментария получать нужный элемент, и т.д..
Вот небольшой список обработок выложенных на Инфостарте:
http://infostart.ru/public/20912/
http://infostart.ru/public/16314/
# Ответить
60. sersaz (файл скачал) 15.04.2010 15:40
а есть у кого уже сохраненные *.docset файлы?
# Ответить
61. Sergafan10 (файл скачал) 21.04.2010 08:28
Есть
Ответили: (62)
# Ответить
62. alexer 21.04.2010 08:31
(61) а что есть?
# Ответить
63. JLaikova (файл скачал) 22.04.2010 09:06
Спасибо за обработку, только почему-то выходит Ошибка подключения..
Ответили: (64)
# Ответить
64. alexer 22.04.2010 09:16
(63) а после каких действий появляется ошибка?
Ответили: (65)
# Ответить
65. JLaikova (файл скачал) 22.04.2010 09:21
(64) после того, кака ввожу пароль в семерку..
Ответили: (66)
# Ответить
66. alexer 22.04.2010 09:40
(65) могу предположить, что вы не правильно вводите пароль.
Ответили: (67)
# Ответить
67. JLaikova (файл скачал) 22.04.2010 10:39
(66) все нормально было с паролем, просто еще позапущенно было много всяиго - все закрыла - заработало) Спасибо - супер) буду изучать
Ответили: (68)
# Ответить
68. alexer 22.04.2010 10:41
(67) скорее всего вы уже монопольно открыли эту базу
# Ответить
69. valya977 (файл скачал) 13.05.2010 06:59
Обработка интересная, подскажите что делаю не так :при переносе например строки выписки банка переносится только сумма остальные данные нет.
Ответили: (70)
# Ответить
70. alexer 13.05.2010 07:38
(69) из какой в какую конфигурацию загружаете?
какой у вас текст модуля получился?
# Ответить
71. nextI (файл скачал) 15.05.2010 11:44
у меня обработка не работает к сожалению, при переносе загружаются пустые документы, подскажите что я делаю не так. Заранее благодарю.

(все справочники загружены)
Ответили: (72) (73)
# Ответить
73. alexer 15.05.2010 15:36
(71) хотелось бы видеть текст полученного модуля.
# Ответить
74. nextI (файл скачал) 16.05.2010 10:20
ДокумV8 = Документы.СчетНаОплатуПокупателю;
ДокумV7 = БазаОле.CreateObject("Документ.Счет");
СпрКонтрагент = Справочники.Контрагенты;
СпрНоменклатура = Справочники.Номенклатура;
ДокумV7.ВыбратьДокументы(НачПериода,КонПериода);
Пока ДокумV7.ПолучитьДокумент() = 1 Цикл
Если ДокумV7.Проведен() = 1 Тогда
НовыйДокV8 = ДокумV8.СоздатьДокумент();
НовыйДокV8.Дата = ДокумV7.ДатаДок;
НовыйДокV8.Номер = ДокумV7.НомерДок;
//НовыйДокV8.АдресДоставки = ДокумV7.;
//НовыйДокV8.СтруктурнаяЕдиница = ДокумV7.;
//НовыйДокV8.ВалютаДокумента = ДокумV7.;
//НовыйДокV8.ДоговорКонтрагента = ДокумV7.;
//НовыйДокV8.Комментарий = ДокумV7.;
//НайденКонтрагент = СпрКонтрагент.НайтиПокоду(ДокумV7.Контрагент.Код)
//Если НайденКонтрагент <> Неопределено Тогда
//НовыйДокV8.Контрагент = НайденКонтрагент.Ссылка;
//КонецЕсли;
//НовыйДокV8.КратностьВзаиморасчетов = ДокумV7.;
//НовыйДокV8.КурсВзаиморасчетов = ДокумV7.;
//НовыйДокV8.Организация = ДокумV7.;
//НовыйДокV8.Ответственный = ДокумV7.;
//НовыйДокV8.Склад = ДокумV7.;
//НовыйДокV8.СуммаВключаетНДС = ДокумV7.;
//НовыйДокV8.СуммаДокумента = ДокумV7.;
//НовыйДокV8.ТипЦен = ДокумV7.;
//НовыйДокV8.УчитыватьНДС = ДокумV7.;
//НовыйДокV8.АвторасчетНДС = ДокумV7.;
ДокумV7.ВыбратьСтроки();
Пока ДокумV7.ПолучитьСтроку() = 1 Цикл
// ***** Заполнить ТЧ - Товары *****
//НовСтр = НовыйДокV8.Товары.Добавить();
//НайденаНоменклатура = СпрНоменклатура.НайтиПокоду(ДокумV7.Номенклатура.Код)
//Если НайденаНоменклатура <> Неопределено Тогда
//НовСтр.Номенклатура = НайденаНоменклатура.Ссылка;
//КонецЕсли;
//НовСтр.ЕдиницаИзмерения = ДокумV7.;
//НовСтр.Цена = ДокумV7.;
//НовСтр.Сумма = ДокумV7.;
//НовСтр.СтавкаНДС = ДокумV7.;
//НовСтр.СуммаНДС = ДокумV7.;
//НовСтр.Коэффициент = ДокумV7.;
//НовСтр.Количество = ДокумV7.;
//НовСтр.СуммаБезСкидки = ДокумV7.;
//НовСтр.СуммаСкидки = ДокумV7.;
// ***** Заполнить ТЧ - ВозвратнаяТара *****
//НовСтр = НовыйДокV8.ВозвратнаяТара.Добавить();
//НайденаНоменклатура = СпрНоменклатура.НайтиПокоду(ДокумV7.Номенклатура.Код)
//Если НайденаНоменклатура <> Неопределено Тогда
//НовСтр.Номенклатура = НайденаНоменклатура.Ссылка;
//КонецЕсли;
//НовСтр.Количество = ДокумV7.;
//НовСтр.Цена = ДокумV7.;
//НовСтр.Сумма = ДокумV7.;
// ***** Заполнить ТЧ - Услуги *****
//НовСтр = НовыйДокV8.Услуги.Добавить();
//НовСтр.Содержание = ДокумV7.;
//НовСтр.Количество = ДокумV7.;
//НовСтр.Цена = ДокумV7.;
//НовСтр.Сумма = ДокумV7.;
//НовСтр.СтавкаНДС = ДокумV7.;
//НовСтр.СуммаНДС = ДокумV7.;
//НайденаНоменклатура = СпрНоменклатура.НайтиПокоду(ДокумV7.Номенклатура.Код)
//Если НайденаНоменклатура <> Неопределено Тогда
//НовСтр.Номенклатура = НайденаНоменклатура.Ссылка;
//КонецЕсли;
//НовСтр.СуммаСкидки = ДокумV7.;
//НовСтр.СуммаБезСкидки = ДокумV7.;
КонецЦикла;
НовыйДокV8.Записать();
ЗаполнитьТабЗнчДоков(НовыйДокV8.Ссылка); // нужная обработка
КонецЕсли;
КонецЦикла;
Ответили: (75)
# Ответить
75. alexer 16.05.2010 16:53
(74) у вас даже не раскомментированны нужные вам строки кода :) , вы просто взяли предложенный по умолчанию текст модуля.
Как я уже писал в описании обработки - "обработка рассчитана на тех, кто хоть как-то программирует в 1С", поэтому советую вам обратиться к программисту 1С.
;)
# Ответить
76. addict2blood (файл скачал) 23.05.2010 20:13
спасибо, очень помогло 8-)
# Ответить
77. anig99 (файл скачал) 04.06.2010 09:18
Есть неудобный момент в использовании софтины - не расчитана на много баз 7ки, т.к. сохраняет всё под одним названием в один каталог.....
Можно добавить пару строк в процедуру сохранения, чтобы раскидывал по папкам в соответствии с названием базы (есно в названии не должно быть недопустимых символов)

Если НайтиФайлы("C:\", "Temp1C").Количество() = 0 Тогда
СоздатьКаталог("C:\Temp1C");
КонецЕсли;
Струк = Новый Структура("ПолеСпикаБД,ВидДокументаV7,ВидДокументаV8,НачПериода,КонПериода,ТекстМодуля");
Струк.Вставить("НачПериода",ЭлементыФормы.НачПериода.Значение);
Струк.Вставить("КонПериода",ЭлементыФормы.КонПериода.Значение);
Струк.Вставить("ПолеСпикаБД",ЭлементыФормы.ПолеСпикаБД.Значение);
Струк.Вставить("ВидДокументаV7",ЭлементыФормы.ВидДокументаV7.Значение);
Струк.Вставить("ВидДокументаV8",ЭлементыФормы.ВидДокументаV8.Значение);
Струк.Вставить("ТекстМодуля",ЭлементыФормы.ТекстМодуля.ПолучитьТекст());
Если НайтиФайлы("C:\Temp1C",ЭлементыФормы.ПолеСпикаБД.ВыделенныйТекст).Количество() = 0 Тогда
СоздатьКаталог("C:\Temp1C\"+ЭлементыФормы.ПолеСпикаБД.ВыделенныйТекст);
КонецЕсли;
ЗначениеВФайл("C:\Temp1C\"+ЭлементыФормы.ПолеСпикаБД.ВыделенныйТекст+"\"+ВидДокументаV8+".docset",Струк);
Ответили: (78)
# Ответить
78. alexer 04.06.2010 09:49
(77) Ок, поправил
Ответили: (79)
# Ответить
79. anig99 (файл скачал) 06.06.2010 16:39
(78) ещё кусочек исправленного кода в процедуре КоманднаяПанель2ОткрытьФайл

Если Длг.Выбрать() Тогда
		ИмяФайла = Длг.ПолноеИмяФайла;
		ИмяПути = Длг.Каталог;
		ТекущаяСтрока = НеОпределено;
		Струк = ЗначениеИзФайла(ИмяФайла);
		ЭлементыФормы.НачПериода.Значение = Струк.НачПериода;
		ЭлементыФормы.КонПериода.Значение = Струк.КонПериода;
		Если Струк.ПолеСпикаБД<>ЭлементыФормы.ПолеСпикаБД.Значение Тогда
			Если ЗначениеЗаполнено(ЭлементыФормы.ПолеСпикаБД.Значение) Тогда
				ВопросБД = Вопрос("Использовать текущую БД?",РежимДиалогаВопрос.ДаНет,,КодВозвратаДиалога.Да);
			Иначе
				ВопросБД = КодВозвратаДиалога.Нет	
			КонецЕсли;
			
			Если ВопросБД = КодВозвратаДиалога.Нет Тогда
				Если НайтиФайлы(СтрЗаменить(Струк.ПолеСпикаБД,"""","")).Количество() = 0 Тогда ВвестиЗначение(Струк.ПолеСпикаБД,"путь к БД") КонецЕсли;
				ЭлементыФормы.ПолеСпикаБД.Значение = Струк.ПолеСпикаБД;
				ПолеСпикаБДПриИзменении(Кнопка);
			КонецЕсли;
		КонецЕсли;
		ЭлементыФормы.ВидДокументаV7.Значение = Струк.ВидДокументаV7;
		ВидДокументаV7ПриИзменении(Кнопка);
		ЭлементыФормы.ВидДокументаV8.Значение = Струк.ВидДокументаV8;
		ВидДокументаV8ПриИзменении(Кнопка);
		ЭлементыФормы.ТекстМодуля.УстановитьТекст(Струк.ТекстМодуля);
	КонецЕсли;
...Показать Скрыть
# Ответить
80. juegom (файл скачал) 20.06.2010 14:53
Спасибо огромное, просто за готовую реализацию идеи.

Однако у меня такая трабла - ДокумV7.ДатаДок взятый по ОЛЕ не дает нормального _времени_ документа, всегда 00:00:00. С чем может быть связано ? Имею 7.7 релиз 027, 8.2.10.77 всё под SQL.
Ответили: (81)
# Ответить
81. anig99 (файл скачал) 20.06.2010 22:43
(80) в семерке вроде бы точное время хранится не в поле Дата...
# Ответить
82. juegom (файл скачал) 21.06.2010 08:55
упс..., со временем разобрался.... спасиба...
# Ответить
83. galina3685 (файл скачал) 31.08.2010 14:29
спасибо огромное, очень вовремя нашла!
# Ответить
84. zveruganet (файл скачал) 16.09.2010 01:04
А мне вот так ругается:

{(58,3)}: Процедура или функция с указанным именем не определена (ЗаполнитьТабЗнчДоков)
<<?>>ЗаполнитьТабЗнчДоков(НовыйСпрV8.Ссылка); // добавляет созданые элементы в ТЗ для просмотра
# Ответить
85. sintezenish 21.10.2010 20:34
Скачал файл ЗагрузкаДоковИз7.7В8.2.epf и пробую его открывать в УТ 11 1с 8,2. Открывается пустое окошко и все, в нем ничего нету. что не так делаю, подскажите пожалуйста
Ответили: (86)
# Ответить
86. alexer 22.10.2010 08:24
(85) В 8.2, и тем более в управляемых формах обработка не работает
Ответили: (89)
# Ответить
87. МимохожийОднако (файл скачал) 30.10.2010 09:05
Есть ли готовый код переноса документа "Бухгалтерская справка" в документ "Операция(Б и НУ)"для БП8 1.6 для данной обработки?

dan7i_sasha@list.ru
# Ответить
88. medik1976 (файл скачал) 21.11.2010 23:14
У меня не работает перенос из 77 ТиС в Розницу 8 в частности инвентаризация, оприходование и списание что делать не знаю , помогите если можно на почту medik1976@mail.ru
# Ответить
89. jan27 (файл скачал) 14.02.2011 16:51
(86) надо бы где-нибудь в названии упомянуть, что загрузка по OLE, а то я надеялся что по ADODB :)
# Ответить
90. mkostya (файл скачал) 17.02.2011 13:56
А будет ли V8 to V8
# Ответить
91. LadyDy (файл скачал) 21.03.2011 14:11
У меня почему то ничего не происходит, почему? :cry:
# Ответить
92. swimdog (файл скачал) 18.04.2011 20:59
Добавил закладку для работы со справочниками http://infostart.ru/public/84269/
# Ответить
93. andersss (файл скачал) 26.09.2011 10:12
Спасибо, дороботал под свою задачу!!!
# Ответить
94. andyrk1 (файл скачал) 29.09.2011 18:31
Спасибо большое за обработку, очень полезная и нужная оказалась
# Ответить
95. ilonnaa (файл скачал) 30.09.2011 16:12
Классная обработка, но две строчки сделали её на порядок лучше для меня)
А вот и эти строки:
НачатьТранзакцию();
ЗафиксироватьТранзакцию();
# Ответить
100. AlekseiLeit (файл скачал) 14.11.2011 17:04
спасибо. пригодилось
# Ответить
101. westinka (файл скачал) 22.11.2011 14:15
вещь на самом деле очень нужная, т.к. многие конторы не ждали "щастья" от 1с и писали свои конфы, для производств и т.п. а теперь приходится все это переписывать, т.к. не надо изобретать велосипед по переносу, а что то есть готовое, то автору респект, т.к. очень помог
# Ответить
102. Jancoy (файл скачал) 24.11.2011 12:56
мне тоже пригодилась, так что кто ищет, тот всегда найдет :)))))))))
# Ответить
104. xDee (файл скачал) 15.12.2011 18:17
спасибо. пригодилось
# Ответить
105. nanik 22.12.2011 02:22
Спасибо, посмотрим что получится.
# Ответить
106. Redhatych (файл скачал) 25.01.2012 23:34
огромное спасибище! выручил! плюсанул бы 10 раз - не меньше :)
# Ответить
107. trolja 15.02.2012 10:57
а кто-нибудь настраивал правила для переноса Заявок на кассовый расход в бГУ 82? Абсолютно не хватает времени, а другие обработки с инфостарта не помогли.
# Ответить
108. ASoft (файл скачал) 20.02.2012 21:23
Спасибо. Была взята за основу для собственного переноса данных. Плюсую.
# Ответить
109. oldtype (файл скачал) 23.02.2012 12:36
Прекрасная обработка,перенес с ее помощью ПП из Бух 7.7 в БП 2.0.Но не смог выбрать проводки операции БУХ 7.7 (остатки),т.к. прогамма сообщает,что нет такого метода в ДокумV77.Помогите пожалуйста.
# Ответить
110. IEmelya 10.03.2012 13:17
Спасибо за обработку, буду разбираться.
Если б еще от автора кратенький help для "чайников".
Спасибо!
# Ответить
111. vitaspsp 22.03.2012 12:51
Огромное респектиЩе автору!!! Переносил документы из Школьное питание ПРОФ 7.7 в Школьное питание 1.3.0.6. Этого нет даже в стандартной обработке, которая идёт с вышеупомянутой конфигурацией, конечно кривовато пока не напишешь нормального обработчика - не переносится. Не надо настраивать правил конвертаций и всё такое, напрямую к базе подрубился и делай чего хочешь.
Ответили: (128)
# Ответить
112. Styvi (файл скачал) 03.09.2012 13:35
Спасибо, будем пробовать приспосабливать под 8.2 с управляемыми формами (главное, идея и код)...
# Ответить
113. kuzmina_ann 18.09.2012 13:25
Хотела перенести справочник контрагентов из Бух 7.7 в Бух 8.2. Табличная часть в справочнике в 8.2 не открывается, а банковский счет и договор у контрагента не переносятся, хотя соответствие прописываю
# Ответить
114. Serg_F1 18.09.2012 14:04
У меня есть отличная обработка по переносу ЗКР через ОLE, пользовался неоднократно если надо пиши вот на это мыло Kudravtsev@ooof1.ru,скину обязательно, сам пользовался и радовался что есть умные люди перегружает без проблем за любой период причем не надо заморачиваться по поводу выгрузки из 77, сама подключается к базе и перегружает ЗКР. В общем пиши если надо. брал тоже где то здесь
# Ответить
115. DimanYa (файл скачал) 09.10.2012 05:38
Переношу вашей обработкой данные, но возникла одна небольшая проблемка. Можете подсказать?
Суть проблемы такова: при подключение к Базе 1С 7.7 я получаю документ и могу работать со всеми его реквизитами, кроме реквизитов в которых содержатся другие объекты. Например документ "Поступление доп. расходов" у которого есть реквизит "Основание" в котором содержится документ основание. При обращении к данному реквизиту я получаю значение Com-объект и больше ничего получить не могу. Ни номера его, ни даты.
Может подскажете, как можно вытащить дополнительно эту информацию?
# Ответить
116. andru_dv (файл скачал) 22.12.2012 21:37
Интересная вещь. Жаль что раньше её не нашёл. Теперь уже не так актуально т.к. изучил КД...
# Ответить
117. Bukaska (файл скачал) 22.12.2012 21:59
Спасибо! Тоже скачала файл)
(116) andru_dv, Я ещё пока что до конвертации не дошла,пока более новичок)
# Ответить
118. Bacemo 01.02.2013 21:52
Спасибо. Я попробовал. Получилось очень хорошо. Только вот на ХР. а 8-ка не смогла выполнить
# Ответить
119. pav-yamal 03.12.2013 18:02
Приветствую,

Переношу из v7.7 в v8.2 документы "Счет"
помогите разобраться новичку, как установить реквизиты "банковский счет" и "договоры"

а так же как указать время документов при записи, так как записывает 0:00:00.

ДокумV8 = Документы.СчетНаОплатуПокупателю;
ДокумV7 = БазаОле.CreateObject("Документ.Счет");
СпрКонтрагент = Справочники.Контрагенты;
СпрНоменклатура = Справочники.Номенклатура;
СпрОрганизации = Справочники.Организации;
ДокумV7.ВыбратьДокументы(НачПериода,КонПериода);
Пока ДокумV7.ПолучитьДокумент() = 1 Цикл
Если ДокумV7.Проведен() = 1 Тогда
НовыйДокV8 = ДокумV8.СоздатьДокумент();
НовыйДокV8.Дата = ДокумV7.ДатаДок;
НовыйДокV8.Номер = ДокумV7.НомерДок;
НовыйДокV8.Комментарий = ДокумV7.Комментарий;

НайденКонтрагент = СпрКонтрагент.НайтиПоНаименованию(ДокумV7.Контрагент.Наименование);
Если НайденКонтрагент <> Неопределено Тогда
НовыйДокV8.Контрагент = НайденКонтрагент.Ссылка;
КонецЕсли;

НайденаОрганизация = СпрОрганизации.НайтиПоНаименованию(ДокумV7.Организация);
Если НайденКонтрагент <> Неопределено Тогда
НовыйДокV8.Организация = НайденаОрганизация.Ссылка;
КонецЕсли;

НовыйДокV8.ОрганизацияПолучатель = НайденаОрганизация;
//НовыйДокV8.Ответственный = ДокумV7.;
НовыйДокV8.СуммаДокумента = ДокумV7.Сумма;
НовыйДокV8.ТипЦен = ДокумV7.ТипЦен;

ДокумV7.ВыбратьСтроки();
Пока ДокумV7.ПолучитьСтроку() = 1 Цикл

// ***** Заполнить ТЧ - Услуги *****
НовСтр = НовыйДокV8.Услуги.Добавить();
НовСтр.Количество = ДокумV7.Количество;
НовСтр.Цена = ДокумV7.Цена;
НовСтр.Сумма = ДокумV7.Сумма;
НовСтр.СуммаНДС = ДокумV7.НДС;
НайденаНоменклатура = СпрНоменклатура.НайтиПоНаименованию(ДокумV7.Товар.Наименование);
Если НайденаНоменклатура <> Неопределено Тогда
НовСтр.Номенклатура = НайденаНоменклатура.Ссылка;
КонецЕсли;
НовСтр.Содержание = НайденаНоменклатура.Ссылка;
КонецЦикла;
НовыйДокV8.Записать();
ЗаполнитьТабЗнчДоков(НовыйДокV8.Ссылка); // нужная обработка
КонецЕсли;
КонецЦикла;
Ответили: (120)
# Ответить
120. alexer 03.12.2013 20:30
(119)
1. найти счет можно так же, как вы искали и контрагента:
СпрБанковскиеСчета = Справочники.БанковскиеСчета;
НайденСчет = СпрБанковскиеСчета.НайтиПоРеквизиту("НомерСчета",ДокумV7.Организация.НомерСчета);
Если НайденСчет <> Неопределено Тогда
НовыйДокV8.СчетОрганизации = НайденСчет.Ссылка;
КонецЕсли;

2. С договорами все сложнее, если у вас все договора с наименованием "Основной договор"

3. А со временем документа можно поступить так:
Ч = 0;
М = 0;
С = 0;
ДокумV7.ПолучитьВремя(Ч, М, С);
НовыйДокV8.Дата = Дата(Год(ДокумV7.ДатаДок),Месяц(ДокумV7.ДатаДок),День(ДокумV7.ДатаДок),Ч,М,С);

вроде метод ПолучитьВремя() должен сработать по OLE
Ответили: (121)
+ 1 [ pav-yamal; ]
# Ответить
121. pav-yamal 03.12.2013 22:29
(120) alexer,

Большое спасибо за помощь!

Наименование договоров по принципу "Основной договор"
Можно просто установить реквизит Договор например = "Реализация услуг"?

Еще нужно выгружать документы "Реализация товаров и услуг" и Счета-Фактуры, а у меня уже тут затыки ))
# Ответить
122. pav-yamal 23.12.2013 15:43
Приветствую,

Счета на оплату перенес.
Теперь переношу "Реализацию товаров и услуг.
Все реквизиты переносятся в идеале, только не могу получить и установить "руководителя" и "Главного бухгалтера"
уже голову сломал. помогите разобраться.
Ответили: (123)
# Ответить
123. pav-yamal 24.12.2013 13:24
(122) pav-yamal,

Снимается, разобрался
# Ответить
124. flash82 17.06.2014 13:33
а как можно протестировать данную обработку?
# Ответить
125. mashyr 09.07.2014 13:37
Есть ли возможность выбора только платежек?
Ответили: (126)
# Ответить
126. alexer 10.07.2014 11:13
(125) mashyr,
да конечно. написав код в тексте модуля, вы можете сохранить эти настройки в файл, чтобы в следующй раз открыть сохраненные настройки
# Ответить
127. Vadim75 22.10.2014 16:20
Еще не скачивал, предварительно хотелось бы узнать, как здесь реализована создание иерархической структуры для нового элемента в справочнике (контрагенты или номенклатура)? Спасибо.
# Ответить
128. Nik39 (файл скачал) 19.05.2016 13:15
(111) vitaspsp, подскажите, как запустили обработку? В дошкольном питании версия 2.2 открывает только как управляемое приложение, и обработка в виде пустого окошка..(
Ответили: (129)
# Ответить
129. alexer 20.05.2016 10:40
(128) Nik39, сожалею, но данная обработка не предусмотрена под управляемые формы(((
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл






IE 2016