gifts2017

Загрузка документов из 7.7 в 8.X

Опубликовал alernik@mail.ru Александр Ершов (alexer) в раздел Обмен - Перенос данных из 1С7.7 в 1C8.X

Тем, кому лень изучать КД, посвящается.
Очередная обработка, позволяющая делать загрузку данных практически из любых документов 7.7 в любые документы 8.Х.

Простенькая обработка рассчитана на тех, кто хоть как-то программирует в 1С. Суть обработки заключается в том, что после выбора необходимого вида документа в семерке и вида документа в восьмерке, текстовое поле заполняется процедурой для загрузки данных. После правки этого текста модуля и нажатия кнопки "Выполнить", произойдет создание документов. Реквизиты в модуль можно перетаскивать методом Drag & Drop.

Ее можно также использовать как помощник для написания процедур модуля при загрузке документов.

Есть возможность сохранения настроек, с помощью "Файл\Сохранить". Настройки сохраняются в папке C:\Temp1C\.

Авось кому еще пригодится данная обработочка.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗагрузкаДоковИз7.7В8.1.epf
.epf 21,68Kb
04.06.10
2583
.epf 21,68Kb 2583 Скачать
ЗагрузкаДоковИз7.7В8.2.epf
.epf 21,98Kb
04.06.10
469
.epf 21,98Kb 469 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. ПСВ (ПСВ) 22.03.10 14:46
{ВнешняяОбработка.ЗагрузкаДокументов.МодульОбъекта(31)}: Ошибка при вызове метода контекста (Записать): Ошибка доступа к файлу 'C:\Program Files\1cv82\8.2.10.77\bin\USER.TXT'
Текст.Записать(ИмяБазы+"USER.TXT");
по причине:
Ошибка доступа к файлу 'C:\Program Files\1cv82\8.2.10.77\bin\USER.TXT'

Да..., впредь буду осторжным прежде чем запускать чужие разработки без анализа кода
Хоть бы предупреждали чтоль, что в реестр лезете!!!

2. alernik@mail.ru Александр Ершов (alexer) 22.03.10 14:55
(1) так обработка только читает реестр.
а после чего происходит ошибка, что-то у меня не воспроизводится?
возможно у вас нет прав на запись к этой папке.
3. ПСВ (ПСВ) 22.03.10 15:15
при открытии , win7 , контроль учетных записей включен - поэтому и ошибка

наверно вам будет лучше - что то типа

//ИмяБазы=СокрЛП(КаталогПрограммы());

ИмяБазы=СокрЛП(КаталогВременныхФайлов());


4. alernik@mail.ru Александр Ершов (alexer) 22.03.10 15:26
(3) Спасибо, поправил.
Этот кусок кода я скопировал еще из обработки 7.7.
5. Zl (ZLG07) 22.03.10 22:24
Уважуха те, как раз нужно было писать экспорт доков из самописной 7, в торговлю 8.1. А тут у тя в принципе все что надо, тем более что с 7 я как то особо и не работал. И кстати небольшой косяк у тя. Когда генерится код, у тя там в товарах, где номенклатура стоит:
НовДок.Номенклатура = НайденнаяНоменклатура, должно быть НовСтр.Номенклатура
6. Владимир Денисов (den_vladimir) 23.03.10 06:45
Сделай плз общий архив, не у всех рейтинг высокий!
7. alernik@mail.ru Александр Ершов (alexer) 23.03.10 07:43
(5) Поправил.
(6) У меня стоит скачивание для всех зарегистрированных пользователей.
8. Igor2010 (IgorXml) 23.03.10 09:06
:?: Не смотрел обработку ещё, сори. Документ операция может перенести? :)
9. alernik@mail.ru Александр Ершов (alexer) 23.03.10 10:36
(8) А почему бы и нет. Выбираете документ Операция, и вперед. ;)
10. Руслана Новикова (del horizonte) 24.03.10 13:46
только не закидывайте тапками,не пойму как выбрать нужную базу 7-ки?
11. alernik@mail.ru Александр Ершов (alexer) 24.03.10 13:50
(10) а у вас семерка установлена?
12. Руслана Новикова (del horizonte) 24.03.10 13:58
13. alernik@mail.ru Александр Ершов (alexer) 24.03.10 14:01
(12) А база в семерке, которую хотите выбрать подключена?
14. Руслана Новикова (del horizonte) 24.03.10 14:24
да,в семерке база подключена. В список должны автоматически базы выбраться? Документы 8-ки выбираются. А вот базу 7-ки и доки 7-ки не могу выбрать.
15. alernik@mail.ru Александр Ершов (alexer) 24.03.10 14:38
(14) Да, список семерочных баз формируется при открытии обработки.
А какая у вас операционная система?
16. Lidia Бородина (demonenok) 24.03.10 14:46
Спасибо за обработку...очень нужная вещичка!!!
:)))
17. Руслана Новикова (del horizonte) 24.03.10 15:05
18. alernik@mail.ru Александр Ершов (alexer) 24.03.10 15:19
(17) Странно, может вы используете Loader1C, или подобную прогу, а не стандартный запуск 1С v7.
Попробуйте в реестре посмотреть ветку HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\Titles, здесь находится список баз.
19. Руслана Новикова (del horizonte) 24.03.10 15:36
да,я уже туда посмотрела,скопировать оттуда не могу,но вот несколько путей:
С:\1\zarpl\
D:\zarpl\
С:\ЗиК проба\zarpl\
то есть в список баз должны выводиться базы ,которые прописаны тут: HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\Titles
20. alernik@mail.ru Александр Ершов (alexer) 24.03.10 15:38
21. Руслана Новикова (del horizonte) 24.03.10 16:16
так там-то пути к базам прописаны.Эх,что ж за невезуха ((
22. alernik@mail.ru Александр Ершов (alexer) 24.03.10 16:18
(21) Попробуйте запустить обработку на другой машине.
23. alernik@mail.ru Александр Ершов (alexer) 24.03.10 17:27
24. Andrew Navrotskyi (Drew_7) 24.03.10 19:02
25. Руслана Новикова (del horizonte) 25.03.10 10:26
спасибо! :) скачала.выбрала нужную базу(не выгрузку ж?)
D:\zarpl ,попросил авторизацию доступа,выбрала себя ,появилось сообщ. Ошибка подключенияэ
попробую базу с бухгалтерией подключить.
26. alernik@mail.ru Александр Ершов (alexer) 25.03.10 10:32
(25) Даже и не знаю чем вам еще помочь.
27. Саня Громов (max007446) 25.03.10 10:33
Подключился к базе 77 без проблем,составил все соответствия,оибок нет,но по кнопке Выполнить ничего не происходит???:(Что не так?
28. alernik@mail.ru Александр Ершов (alexer) 25.03.10 10:45
(27) Может у вас в семерке нет документов выбранного типа за этот период.
29. Руслана Новикова (del horizonte) 25.03.10 10:58
о!подождите!!с 5 попытки написал вверху путь к базе д-зарпл и доки все в списке отобразил :) :) :) :)
30. Руслана Новикова (del horizonte) 25.03.10 11:14
31. Геннадий (GJosh) 26.03.10 08:35
Прекрасная идея! Осталось довести её до абсурда в хорошем смысле этого слова: 77-> 8 есть, добавляйте 77-> 77, 8-> 8, 8-> 77 и т.д. Плюс собрать хорошую отлаженную библиотеку модулей документов. И это будет блестящей альтернативой КД, Переносу данных и т.д.
С удачей!
32. alernik@mail.ru Александр Ершов (alexer) 26.03.10 08:47
(31) да уж, коллекция библиотек модулей ТиС -> УТ, Бух -> БП, ТиС -> БП и т.д. :D
33. Геннадий (GJosh) 26.03.10 12:35
А кто Вам сказал, что Вам это придется делать? Народ настругает, Ваше дело собирать ...
34. Георгий Кудин (Djagernaut) 26.03.10 13:12
{ВнешняяОбработка.ВнешняяОбработка1(14)}: Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса
БазаОлеТек= Новый COMОбъект("V77.Application");

Что может быть?
35. alernik@mail.ru Александр Ершов (alexer) 26.03.10 13:16
(34) 1С 7.7 платформа установлена?
36. Георгий Кудин (Djagernaut) 26.03.10 13:17
{ВнешняяОбработка.ВнешняяОбработка1(14)}: Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса
БазаОлеТек= Новый COMОбъект("V77.Application");
37. Николай (provnick) 27.03.10 19:53
НайтиПоКоду, не работает, так, как длина разная, применил НайтиПоНаименованию, заработало, в целом очень гуд!
38. Руслана Новикова (del horizonte) 29.03.10 13:18
такой вотвопрос:у меня вылезла ошибка по кнопке выполнить:Поле объекта не обнаружено(Номенклатура). Справочника Номенклатура в конфе нету.Можно закоментировать эту строчку?
Те строки ,которые закоментированы, их можно раскомментировать,в зависимости от того какая нужна?
39. alernik@mail.ru Александр Ершов (alexer) 29.03.10 13:36
(38) Именно, вы сами ответили на свои вопросы :)
40. Руслана Новикова (del horizonte) 30.03.10 11:12
еще несколько вопросов: присвоить доку в 8-ке я могу только то,что вывелось в семерочном дереве реквизитов?
НовыйДокV8.Сотрудник = ДокумV7.;
Если есть какие-то поля в документе 8-ки,а в 7-ке их не было,то это уже вручную подправлять?(добавлять в восьмерочный документ)
У меня почему-то сотрудника не переносит ((,хотя период регистрации дока,период отпуска переносит.А сотра не хочет...
НовыйДокV8.Физлицо = ДокумV7.Сотрудник;

41. Руслана Новикова (del horizonte) 30.03.10 11:19
в смысле вот так:
НовыйДокV8.Сотрудник = ДокумV7.Сотрудник;
42. alernik@mail.ru Александр Ершов (alexer) 30.03.10 11:35
(40) Обработка и не будет переносить элементы справочников, она переносит документы, предполагается что элементы спр уже есть, их нужно только найти, если их нету то нужно создать новый элемент.
например так:
СпрФизЛица = Справочники.ФизическиеЛица;
НайденоФизЛицо = СпрФизЛица.НайтиПоНаименованию(ДокумV7.Сотрудник.Наименование);
Если НайденоФизЛицо = Справочники.ФизическиеЛица.ПустаяСсылка() Тогда
	НовоеФизЛицо = Справочники.ФизическиеЛица.СоздатьЭлемент();
	НовоеФизЛицо.Наименование = ДокумV7.Сотрудник.Наименование;
	НовоеФизЛицо.ДатаРождения = ДокумV7.Сотрудник.ДатаРожд;
	НовоеФизЛицо.ИНН = ДокумV7.Сотрудник.ИНН;
	...
	НовоеФизЛицо.Записать();
	НовыйДокV8.Сотрудник = НовоеФизЛицо.Ссылка;
Иначе
	НовыйДокV8.Сотрудник = НайденоФизЛицо;
КонецЕсли;
...Показать Скрыть
43. Виктория Исаева (ladoga) 01.04.10 02:22
При загрузке базовой версии 7.7 требует запустить в монопольном режиме
44. alernik@mail.ru Александр Ершов (alexer) 01.04.10 07:48
(43) Сожалею, но к базовой версии невозможно подключение с помощью механизма OLE.
45. Татьяна Локтионова (LTanya) 01.04.10 16:14
Почему все зависает после выбора базы 7.7?
46. alernik@mail.ru Александр Ершов (alexer) 01.04.10 16:41
(45) Даже не знаю что предположить. :?:
48. Владимир (V0fka) 02.04.10 10:13
49. Владимир (V0fka) 02.04.10 10:16
(45) Потому что, после выбора базы появляется 7-ное окошко, где нужно выбрать пользователя и пароль :idea:
50. Владимир (V0fka) 02.04.10 10:19
LTanya, Потому что, после выбора базы появляется 7-ное окошко, где нужно выбрать пользователя и пароль :idea:
52. Руслана Новикова (del horizonte) 02.04.10 11:07
причем,когда у меня 1с у меня распахнуто на весь рабочий стол,я этого окошка с выбором пользователя не могу дождаться(как зависает),а когда уменьшу(чтоб не на весь экран было),то быстро появляется.(При этом и другие программы должны быть свернуты)
53. alernik@mail.ru Александр Ершов (alexer) 02.04.10 11:15
(52) Скорее всего, окно авторизации прячется за окном 1С v8. Попробуйте комбинацией клавиш Alt+Tab перейти на это окошко.
54. Мансур Девятияров (demanru) 02.04.10 16:57
Респект, видна рука мастера +
55. Александр Решетилов (ralexn49) 05.04.10 11:23
Прекрасное подспорье, что сказать умница!
56. Татьяна Локтионова (LTanya) 06.04.10 08:01
Ну почему у всех работает, а у меня нет? Тоже хочу.
57. alernik@mail.ru Александр Ершов (alexer) 06.04.10 09:58
58. Александр (Sedow) 07.04.10 10:48
а как перенести справочники для того чтобы перенос документов осуществился корректно.
59. alernik@mail.ru Александр Ершов (alexer) 07.04.10 11:10
(58) Главное чтобы было соответствие справочников по какому-либо реквизиту справочника, например по Коду или Наименованию, если у справочника есть комментарий, то можно в комментарий ввести ссылку элемента справочника с помощью функции ЗначениеВСтрокуВнутр(ЭлементСправочника), а затем из комментария получать нужный элемент, и т.д..
Вот небольшой список обработок выложенных на Инфостарте:
http://infostart.ru/public/20912/
http://infostart.ru/public/16314/
60. serega (sersaz) 15.04.10 15:40
а есть у кого уже сохраненные *.docset файлы?
61. Язва Жопы (Sergafan10) 21.04.10 08:28
62. alernik@mail.ru Александр Ершов (alexer) 21.04.10 08:31
63. JLaikova (JLaikova) 22.04.10 09:06
Спасибо за обработку, только почему-то выходит Ошибка подключения..
64. alernik@mail.ru Александр Ершов (alexer) 22.04.10 09:16
(63) а после каких действий появляется ошибка?
65. JLaikova (JLaikova) 22.04.10 09:21
(64) после того, кака ввожу пароль в семерку..
66. alernik@mail.ru Александр Ершов (alexer) 22.04.10 09:40
(65) могу предположить, что вы не правильно вводите пароль.
67. JLaikova (JLaikova) 22.04.10 10:39
(66) все нормально было с паролем, просто еще позапущенно было много всяиго - все закрыла - заработало) Спасибо - супер) буду изучать
68. alernik@mail.ru Александр Ершов (alexer) 22.04.10 10:41
(67) скорее всего вы уже монопольно открыли эту базу
69. Наталья (valya977) 13.05.10 06:59
Обработка интересная, подскажите что делаю не так :при переносе например строки выписки банка переносится только сумма остальные данные нет.
70. alernik@mail.ru Александр Ершов (alexer) 13.05.10 07:38
(69) из какой в какую конфигурацию загружаете?
какой у вас текст модуля получился?
71. next next (nextI) 15.05.10 11:44
у меня обработка не работает к сожалению, при переносе загружаются пустые документы, подскажите что я делаю не так. Заранее благодарю.

(все справочники загружены)
73. alernik@mail.ru Александр Ершов (alexer) 15.05.10 15:36
(71) хотелось бы видеть текст полученного модуля.
74. next next (nextI) 16.05.10 10:20
ДокумV8 = Документы.СчетНаОплатуПокупателю;
ДокумV7 = БазаОле.CreateObject("Документ.Счет");
СпрКонтрагент = Справочники.Контрагенты;
СпрНоменклатура = Справочники.Номенклатура;
ДокумV7.ВыбратьДокументы(НачПериода,КонПериода);
Пока ДокумV7.ПолучитьДокумент() = 1 Цикл
Если ДокумV7.Проведен() = 1 Тогда
НовыйДокV8 = ДокумV8.СоздатьДокумент();
НовыйДокV8.Дата = ДокумV7.ДатаДок;
НовыйДокV8.Номер = ДокумV7.НомерДок;
//НовыйДокV8.АдресДоставки = ДокумV7.;
//НовыйДокV8.СтруктурнаяЕдиница = ДокумV7.;
//НовыйДокV8.ВалютаДокумента = ДокумV7.;
//НовыйДокV8.ДоговорКонтрагента = ДокумV7.;
//НовыйДокV8.Комментарий = ДокумV7.;
//НайденКонтрагент = СпрКонтрагент.НайтиПокоду(ДокумV7.Контрагент.Код)
//Если НайденКонтрагент <> Неопределено Тогда
//НовыйДокV8.Контрагент = НайденКонтрагент.Ссылка;
//КонецЕсли;
//НовыйДокV8.КратностьВзаиморасчетов = ДокумV7.;
//НовыйДокV8.КурсВзаиморасчетов = ДокумV7.;
//НовыйДокV8.Организация = ДокумV7.;
//НовыйДокV8.Ответственный = ДокумV7.;
//НовыйДокV8.Склад = ДокумV7.;
//НовыйДокV8.СуммаВключаетНДС = ДокумV7.;
//НовыйДокV8.СуммаДокумента = ДокумV7.;
//НовыйДокV8.ТипЦен = ДокумV7.;
//НовыйДокV8.УчитыватьНДС = ДокумV7.;
//НовыйДокV8.АвторасчетНДС = ДокумV7.;
ДокумV7.ВыбратьСтроки();
Пока ДокумV7.ПолучитьСтроку() = 1 Цикл
// ***** Заполнить ТЧ - Товары *****
//НовСтр = НовыйДокV8.Товары.Добавить();
//НайденаНоменклатура = СпрНоменклатура.НайтиПокоду(ДокумV7.Номенклатура.Код)
//Если НайденаНоменклатура <> Неопределено Тогда
//НовСтр.Номенклатура = НайденаНоменклатура.Ссылка;
//КонецЕсли;
//НовСтр.ЕдиницаИзмерения = ДокумV7.;
//НовСтр.Цена = ДокумV7.;
//НовСтр.Сумма = ДокумV7.;
//НовСтр.СтавкаНДС = ДокумV7.;
//НовСтр.СуммаНДС = ДокумV7.;
//НовСтр.Коэффициент = ДокумV7.;
//НовСтр.Количество = ДокумV7.;
//НовСтр.СуммаБезСкидки = ДокумV7.;
//НовСтр.СуммаСкидки = ДокумV7.;
// ***** Заполнить ТЧ - ВозвратнаяТара *****
//НовСтр = НовыйДокV8.ВозвратнаяТара.Добавить();
//НайденаНоменклатура = СпрНоменклатура.НайтиПокоду(ДокумV7.Номенклатура.Код)
//Если НайденаНоменклатура <> Неопределено Тогда
//НовСтр.Номенклатура = НайденаНоменклатура.Ссылка;
//КонецЕсли;
//НовСтр.Количество = ДокумV7.;
//НовСтр.Цена = ДокумV7.;
//НовСтр.Сумма = ДокумV7.;
// ***** Заполнить ТЧ - Услуги *****
//НовСтр = НовыйДокV8.Услуги.Добавить();
//НовСтр.Содержание = ДокумV7.;
//НовСтр.Количество = ДокумV7.;
//НовСтр.Цена = ДокумV7.;
//НовСтр.Сумма = ДокумV7.;
//НовСтр.СтавкаНДС = ДокумV7.;
//НовСтр.СуммаНДС = ДокумV7.;
//НайденаНоменклатура = СпрНоменклатура.НайтиПокоду(ДокумV7.Номенклатура.Код)
//Если НайденаНоменклатура <> Неопределено Тогда
//НовСтр.Номенклатура = НайденаНоменклатура.Ссылка;
//КонецЕсли;
//НовСтр.СуммаСкидки = ДокумV7.;
//НовСтр.СуммаБезСкидки = ДокумV7.;
КонецЦикла;
НовыйДокV8.Записать();
ЗаполнитьТабЗнчДоков(НовыйДокV8.Ссылка); // нужная обработка
КонецЕсли;
КонецЦикла;
75. alernik@mail.ru Александр Ершов (alexer) 16.05.10 16:53
(74) у вас даже не раскомментированны нужные вам строки кода :) , вы просто взяли предложенный по умолчанию текст модуля.
Как я уже писал в описании обработки - "обработка рассчитана на тех, кто хоть как-то программирует в 1С", поэтому советую вам обратиться к программисту 1С.
;)
76. Плюшко Плюхин (addict2blood) 23.05.10 20:13
спасибо, очень помогло 8-)
77. Александр Медведев (anig99) 04.06.10 09:18
Есть неудобный момент в использовании софтины - не расчитана на много баз 7ки, т.к. сохраняет всё под одним названием в один каталог.....
Можно добавить пару строк в процедуру сохранения, чтобы раскидывал по папкам в соответствии с названием базы (есно в названии не должно быть недопустимых символов)

Если НайтиФайлы("C:\", "Temp1C").Количество() = 0 Тогда
СоздатьКаталог("C:\Temp1C");
КонецЕсли;
Струк = Новый Структура("ПолеСпикаБД,ВидДокументаV7,ВидДокументаV8,НачПериода,КонПериода,ТекстМодуля");
Струк.Вставить("НачПериода",ЭлементыФормы.НачПериода.Значение);
Струк.Вставить("КонПериода",ЭлементыФормы.КонПериода.Значение);
Струк.Вставить("ПолеСпикаБД",ЭлементыФормы.ПолеСпикаБД.Значение);
Струк.Вставить("ВидДокументаV7",ЭлементыФормы.ВидДокументаV7.Значение);
Струк.Вставить("ВидДокументаV8",ЭлементыФормы.ВидДокументаV8.Значение);
Струк.Вставить("ТекстМодуля",ЭлементыФормы.ТекстМодуля.ПолучитьТекст());
Если НайтиФайлы("C:\Temp1C",ЭлементыФормы.ПолеСпикаБД.ВыделенныйТекст).Количество() = 0 Тогда
СоздатьКаталог("C:\Temp1C\"+ЭлементыФормы.ПолеСпикаБД.ВыделенныйТекст);
КонецЕсли;
ЗначениеВФайл("C:\Temp1C\"+ЭлементыФормы.ПолеСпикаБД.ВыделенныйТекст+"\"+ВидДокументаV8+".docset",Струк);
78. alernik@mail.ru Александр Ершов (alexer) 04.06.10 09:49
79. Александр Медведев (anig99) 06.06.10 16:39
(78) ещё кусочек исправленного кода в процедуре КоманднаяПанель2ОткрытьФайл

Если Длг.Выбрать() Тогда
		ИмяФайла = Длг.ПолноеИмяФайла;
		ИмяПути = Длг.Каталог;
		ТекущаяСтрока = НеОпределено;
		Струк = ЗначениеИзФайла(ИмяФайла);
		ЭлементыФормы.НачПериода.Значение = Струк.НачПериода;
		ЭлементыФормы.КонПериода.Значение = Струк.КонПериода;
		Если Струк.ПолеСпикаБД<>ЭлементыФормы.ПолеСпикаБД.Значение Тогда
			Если ЗначениеЗаполнено(ЭлементыФормы.ПолеСпикаБД.Значение) Тогда
				ВопросБД = Вопрос("Использовать текущую БД?",РежимДиалогаВопрос.ДаНет,,КодВозвратаДиалога.Да);
			Иначе
				ВопросБД = КодВозвратаДиалога.Нет	
			КонецЕсли;
			
			Если ВопросБД = КодВозвратаДиалога.Нет Тогда
				Если НайтиФайлы(СтрЗаменить(Струк.ПолеСпикаБД,"""","")).Количество() = 0 Тогда ВвестиЗначение(Струк.ПолеСпикаБД,"путь к БД") КонецЕсли;
				ЭлементыФормы.ПолеСпикаБД.Значение = Струк.ПолеСпикаБД;
				ПолеСпикаБДПриИзменении(Кнопка);
			КонецЕсли;
		КонецЕсли;
		ЭлементыФормы.ВидДокументаV7.Значение = Струк.ВидДокументаV7;
		ВидДокументаV7ПриИзменении(Кнопка);
		ЭлементыФормы.ВидДокументаV8.Значение = Струк.ВидДокументаV8;
		ВидДокументаV8ПриИзменении(Кнопка);
		ЭлементыФормы.ТекстМодуля.УстановитьТекст(Струк.ТекстМодуля);
	КонецЕсли;
...Показать Скрыть
80. Вольдемарыч Добрый (juegom) 20.06.10 14:53
Спасибо огромное, просто за готовую реализацию идеи.

Однако у меня такая трабла - ДокумV7.ДатаДок взятый по ОЛЕ не дает нормального _времени_ документа, всегда 00:00:00. С чем может быть связано ? Имею 7.7 релиз 027, 8.2.10.77 всё под SQL.
81. Александр Медведев (anig99) 20.06.10 22:43
(80) в семерке вроде бы точное время хранится не в поле Дата...
82. Вольдемарыч Добрый (juegom) 21.06.10 08:55
упс..., со временем разобрался.... спасиба...
83. Галина Вяльцева (galina3685) 31.08.10 14:29
спасибо огромное, очень вовремя нашла!
84. Михаил Рыков (zveruganet) 16.09.10 01:04
А мне вот так ругается:

{(58,3)}: Процедура или функция с указанным именем не определена (ЗаполнитьТабЗнчДоков)
<<?>>ЗаполнитьТабЗнчДоков(НовыйСпрV8.Ссылка); // добавляет созданые элементы в ТЗ для просмотра
85. sintezenish 21.10.10 20:34
Скачал файл ЗагрузкаДоковИз7.7В8.2.epf и пробую его открывать в УТ 11 1с 8,2. Открывается пустое окошко и все, в нем ничего нету. что не так делаю, подскажите пожалуйста
86. alernik@mail.ru Александр Ершов (alexer) 22.10.10 08:24
(85) В 8.2, и тем более в управляемых формах обработка не работает
87. Александр (МимохожийОднако) 30.10.10 09:05
Есть ли готовый код переноса документа "Бухгалтерская справка" в документ "Операция(Б и НУ)"для БП8 1.6 для данной обработки?

dan7i_sasha@list.ru
88. Александр (medik1976) 21.11.10 23:14
У меня не работает перенос из 77 ТиС в Розницу 8 в частности инвентаризация, оприходование и списание что делать не знаю , помогите если можно на почту medik1976@mail.ru
89. Alexei Zhovner (jan27) 14.02.11 16:51
(86) надо бы где-нибудь в названии упомянуть, что загрузка по OLE, а то я надеялся что по ADODB :)
90. Максим Костиков (mkostya) 17.02.11 13:56
91. Ксения (LadyDy) 21.03.11 14:11
У меня почему то ничего не происходит, почему? :cry:
92. Илья Васильев (swimdog) 18.04.11 20:59
Добавил закладку для работы со справочниками http://infostart.ru/public/84269/
93. Андрей (andersss) 26.09.11 10:12
Спасибо, дороботал под свою задачу!!!
94. andyrk1 (andyrk1) 29.09.11 18:31
Спасибо большое за обработку, очень полезная и нужная оказалась
95. ghOst Bu (ilonnaa) 30.09.11 16:12
Классная обработка, но две строчки сделали её на порядок лучше для меня)
А вот и эти строки:
НачатьТранзакцию();
ЗафиксироватьТранзакцию();
100. Алексей Лейт (AlekseiLeit) 14.11.11 17:04
101. Инна (westinka) 22.11.11 14:15
вещь на самом деле очень нужная, т.к. многие конторы не ждали "щастья" от 1с и писали свои конфы, для производств и т.п. а теперь приходится все это переписывать, т.к. не надо изобретать велосипед по переносу, а что то есть готовое, то автору респект, т.к. очень помог
102. Jancoy (Jancoy) 24.11.11 12:56
мне тоже пригодилась, так что кто ищет, тот всегда найдет :)))))))))
104. xDee (xDee) 15.12.11 18:17
105. nanik nanik (nanik) 22.12.11 02:22
Спасибо, посмотрим что получится.
106. Александр Гаёв (Redhatych) 25.01.12 23:34
огромное спасибище! выручил! плюсанул бы 10 раз - не меньше :)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа