gifts2017

Исправление UChoice для корректной работы с SQL

Опубликовал Sk0rp (Sk0rp) в раздел Программирование - Практика программирования

Рассказывается как исправить типовой универсальный отчет: "Подбор объектов", что бы он работал с SQL.
В текущей реализации, которая лежит на ИТС без изменений много лет, в SQL базе отобрать объекты по вхождению в группу справочника невозможно, при этом в DBF варианте все работает.

Проиллюстрирую сначала проблему на небольшом простом примере:

Создайте внешний отчет с единственным реквизитом на форме типа: "Справочник.Контрагенты", пусть идентификатор этого реквизита будет "Группа".

В процедуру Сформировать вставьте код:

Процедура Сформировать()
    Перем гУсл1;
    гУсл1 = СоздатьОбъект("СписокЗначений");
    гУсл1.ДобавитьЗначение(Группа.ТекущийЭлемент());

    ТекстЗапроса = "
    |ПеремОбъект = Справочник.Контрагенты.ТекущийЭлемент;
    |Группировка ПеремОбъект Без Групп;
    |Перем1 = Справочник.Контрагенты.Родитель;
    |Условие (Перем1 В гУсл1);
    |";

    Запрос = СоздатьОбъект("Запрос");

    Если Запрос.Выполнить(ТекстЗапроса) = 0 тогда
        Предупреждение("Запрос не выполнен!");
        Возврат;
    КонецЕсли;

    Пока Запрос.Группировка(1, 1) = 1 Цикл
        Сообщить(Запрос.ПеремОбъект);
    КонецЦикла;

КонецПроцедуры

 

Попробуйте выполнить это в SQL базе и в DBF. В DBF, как и должно быть, выведет содержимое группы справочника, а вот в SQL не выведет ничего, - это и есть проблема.

 

Из-за этого в SQL базах не работает и отбор по группе справочника в известной универсальной обработке: UChoice.ert

Попробуйте отобрать ей в SQL базе объекты любого справочника по условию вхождения в группу - список будет пуст. В DBF базе, наоборот, все сработает.

Кроме того в ТиС эта универсальная обработка вставлена в саму конфигурацию под именем: "ПодборОбъектов", - проблемы те же.

 

Меня давно нервировало такое поведение системы, но все время не доходили руки разобраться, почему то работает, то нет. Но наконец руки дошли и вот, что я предлагаю.

Заставить в SQL базе запрос работать так же как в DBF можно как минимум 2-мя путями:

 

1. Перед Запрос.Выполнить(ТекстЗапроса); поставить строку: Запрос.ВключитьSQL(0);

Это недокументированная функция, в случае DBF ничего не делает, а влучае SQL как то меняет внутренню обработку запросов 1С. Запрос начинает работать правильно, но ОЧЕНЬ медленно.

 

2. Изменить текст запроса и вместо:

Условие (Перем1 В гУсл1);

написать:

Условие (гУсл1.Принадлежит(Перем1) = 1);

Согласно теории это тоже должно замедлить выполнение запроса, но на справочниках порядка 100 тыс позиций замедление у меня было в пределах погрешности измерения.

 

Соответственно для исправления UChoice будем использовать второй способ.

 

За формирование текста и выполнение запроса в отчете отвечает:

Процедура Запрос(ВидОбъекта)

В ней нас интересуют буквально самые последние строки перед Запрос.Выполнить():


            Если СокрЛП(ТабУсловия.КолУсловие) = "<>" Тогда
                ТекстЗапроса = ТекстЗапроса + "
                               |Перем" + НомСтр + " = "  + гТипОбъекта + стрТочка + ВидОбъекта + "."
                                                      + ИмяПерем + ";"
                              "Условие (Не(Перем" + НомСтр + " В гУсл" + НомСтр + "));";
            Иначе
                ТекстЗапроса = ТекстЗапроса + "
                               |Перем" + НомСтр + " = "  + гТипОбъекта + стрТочка + ВидОбъекта + "."
                                                      + ИмяПерем + ";"
                              "Условие (Перем" + НомСтр + " " + ТабУсловия.КолУсловие + " гУсл" + НомСтр + ");";
            КонецЕсли;

Их надо исправить на:


            Если СокрЛП(ТабУсловия.КолУсловие) = "<>" Тогда
                ТекстЗапроса = ТекстЗапроса + "
                               |Перем" + НомСтр + " = "  + гТипОбъекта + стрТочка + ВидОбъекта + "."
                                                      + ИмяПерем + ";"
                              "Условие (гУсл" + НомСтр + ".Принадлежит(Перем" + НомСтр + ") = 0);";
            ИначеЕсли СокрЛП(ТабУсловия.КолУсловие) = "В" Тогда
                ТекстЗапроса = ТекстЗапроса + "
                               |Перем" + НомСтр + " = "  + гТипОбъекта + стрТочка + ВидОбъекта + "."
                                                      + ИмяПерем + ";"
                              "Условие (гУсл" + НомСтр + ".Принадлежит(Перем" + НомСтр + ") = 1);";
            Иначе
                ТекстЗапроса = ТекстЗапроса + "
                               |Перем" + НомСтр + " = "  + гТипОбъекта + стрТочка + ВидОбъекта + "."
                                                      + ИмяПерем + ";"
                              "Условие (Перем" + НомСтр + " " + ТабУсловия.КолУсловие + " гУсл" + НомСтр + ");";

            КонецЕсли;

Собственно и все :)

Сохраняйте, пробуйте.

А тем, кто еще пишет под 7.7. стоит запомнить такое поведение SQL движка, - может пригодится.

Скачать файлы

Наименование Файл Версия Размер
Испавленный UChoice.ert 123
.ert 232,00Kb
02.07.13
123
.ert 232,00Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Sk0rp (Sk0rp) 31.03.10 19:20
Так и не разобрался как оформить код, что бы он был с раскраской. Подскажите кто знает, плз.
2. Вячеслав Кадацкий (marsohod) 31.03.10 21:29
3. Владислав Чинючин (vcv) 01.04.10 07:44
Что бы отбор по группам работал достаточно на закладке "Общие свойства" поставить галочку "Включать в выборку группы справочника".
4. Sk0rp (Sk0rp) 01.04.10 15:09
(2) Спасибо, только мне прямо в этой статье раскрасить надо, тот способ не подойдет.
(3) Вы невнимательно читали. Группы в выборке не нужны. Речь вообще не об этом.
5. Вячеслав Кадацкий (marsohod) 09.04.10 13:37
6. Sk0rp (Sk0rp) 04.07.10 12:58
(5) Да, это то, что нужно. Хотя я и не сразу понял это :), спасибо!
7. Вячеслав Кадацкий (marsohod) 04.07.10 13:32
8. Сергей (Che) Коцюра (CheBurator) 17.01.11 22:09
утверждается:
"...Из-за этого в SQL базах не работает и отбор по группе справочника в известной универсальной обработке: UChoice.ert
Попробуйте отобрать ей в SQL базе объекты любого справочника по условию вхождения в группу - список будет пуст."
.
готов продемонстрировать в штатной Учойсе на штатной скульной базе порядок нажатия кнопариков, который приведет к выборке "...объекты любого справочника по условию вхождения в группу" - и список НЕ БУДЕТ ПУСТ!!! о, это - чудо? ;-)
9. Sk0rp (Sk0rp) 18.01.11 10:58
Готов продемонстрировать обратное :)

Если и существует один хитрый путь как обойти ошибку, то это, ИМХО, не повод оставлять обработку нерабочей для всех, кто этого способа не знает.
10. Владимир (white_ven) 11.10.11 15:08
11. Алексей Т. (CratosX) 07.08.13 13:32
хм, удивительно - скачал обработку в надежде на решение этой проблемы, но не помогло. На dbf всегда присутствует выбор обработки объектов, а в SQL всегда скрыты.
Платформа 7.70.021
Прикрепленные файлы:
12. Алексей Т. (CratosX) 07.08.13 13:40
(8) CheBurator, поделитесь знаниями?

Разобрался, не хватало ещё каких-то файликов в папке с UChoise.ert. Помог совет http://www.forum.mista.ru/topic.php?id=420195#8
13. Сергей (Che) Коцюра (CheBurator) 07.08.13 15:57
(12) используй нормальные установщики универсальных обработок с диска ИТС.
смотри также полезности
http://infostart.ru/public/17032/
http://infostart.ru/public/17037/
.
по группе в скуле - внимательно поройся на закладках обработки