gifts2017

Как посчитать сумму в списке документов

Опубликовал Алексей Новоселов (a-novoselov) в раздел Программирование - Практика программирования

Часто возникает необходимость посчитать сумму на форме типа ДокументСписок с текущими отборами... И при большом количестве документов методы с ПостроительЗапроса.ИсточникДанных начинают сильно тормозить, т.к. весь список грузится на клиента. Остается единственное решение - Запрос.

Добавляем подвал в ЭлементыФормы, и вот примерный текст обработчика "ПриПолученииДанных()" списка документов:

Запрос = Новый Запрос();
ТекстОтбора = "";
Список = ДокументСписок;
ш = 0;

 Для Каждого ЭлементНастройкиОтбора Из ЭлементыФормы.Список.НастройкаОтбора Цикл

     Если Список.Отбор[ЭлементНастройкиОтбора.Имя].Использование Тогда

         ВидСравненияЭлементаОтбора = Список.Отбор[ЭлементНастройкиОтбора.Имя].ВидСравнения;
   ш = ш + 1;

         Если ВидСравненияЭлементаОтбора = ВидСравнения.Больше Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " > &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.БольшеИлиРавно Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " >= &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ВИерархии Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра"+ш+")";
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ВСписке Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " В (&ЗначениеПараметра"+ш+")";
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ВСпискеПоИерархии Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра"+ш+")";
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Интервал Тогда
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " > &ЗначениеПараметра"+ш; ш = ш + 1;
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " < &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ИнтервалВключаяГраницы Тогда
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " >= &ЗначениеПараметра"+ш; ш = ш + 1;
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " <= &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ИнтервалВключаяНачало Тогда
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " >= &ЗначениеПараметра"+ш; ш = ш + 1;
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " < &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ИнтервалВключаяОкончание Тогда
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " > &ЗначениеПараметра"+ш; ш = ш + 1;
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " <= &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Меньше Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " < &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.МеньшеИлиРавно Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " <= &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеВИерархии Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра"+ш+"))";
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеВСписке Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " В (&ЗначениеПараметра"+ш+"))";
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеВСпискеПоИерархии Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра"+ш+"))";
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеРавно Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " <> &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеСодержит Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " ПОДОБНО &ЗначениеПараметра"+ш+")";
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, "%" + Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение + "%");
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Равно Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " = &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
         ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Содержит Тогда
             ТекстОтбора = ТекстОтбора + Символы.ПС + "    И ТаблицаСписка." + ЭлементНастройкиОтбора.Имя + " ПОДОБНО &ЗначениеПараметра"+ш;
             Запрос.УстановитьПараметр("ЗначениеПараметра"+ш, "%" + Список.Отбор[ЭлементНастройкиОтбора.Имя].Значение + "%");
         КонецЕсли;

     КонецЕсли;

 КонецЦикла;

 Если ТекстОтбора <> "" Тогда
     ТекстОтбора = "ГДЕ" + Символы.ПС + "    " + Сред(ТекстОтбора, 8);
 КонецЕсли;

 ТекстЗапроса =
 "ВЫБРАТЬ РАЗРЕШЕННЫЕ
 |    Сумма(СуммаДокумента) КАК Сумма
 |ИЗ
 |    Документ.ПриходныйКассовыйОрдер КАК ТаблицаСписка
 |" + ТекстОтбора;

 Запрос.Текст = ТекстЗапроса;

 Выборка = Запрос.Выполнить().Выбрать();

 Если Выборка.Следующий() Тогда
  ЭлементыФормы.Список.Колонки.СуммаДокумента.ТекстПодвала = Формат(Выборка.Сумма, "ЧЦ=15; ЧДЦ=2");
 Иначе
  ЭлементыФормы.Список.Колонки.СуммаДокумента.ТекстПодвала = 0;
 КонецЕсли;

 


Далее меняем в запросе имя таблицы Документ.ПриходныйКассовыйОрдер

на нужное вам и вуаля! Имеем сумму документов, которая вычисляется мнгновенно, с любым отбором.

По материалам http://www.kb.mista.ru/article.php?id=471

См. также

Подписаться Добавить вознаграждение
Комментарии
1. naus (Danil.Potapov) 14.05.10 19:16
ПостроительЗапроса = Новый ПостроительЗапроса;
ПостроительЗапроса.ИсточникДанных = Новый ОписаниеИсточникаДанных(ДокументСписок);
//настройть на вывод только нужного поля.
ПостроительЗапроса.Выполнить();
ПостроительЗапроса.Результат. Выбрать();
//дальше все как у тебя
2. Алексей Константинов (alexk-is) 14.05.10 19:36
Текст модуля в публикации можно раскрасить получше. :)
3. Сергей Ожерельев (Поручик) 14.05.10 21:56
Поддерживаю, раскрась по путёвому.
4. Михаил Ражиков (tango) 17.05.10 09:19
(0) "Добавляем подвал в ЭлементыФормы" или в ЭлементыФормы.ДокументСписок?

| Сумма(ТаблицаСписка.СуммаДокумента) КАК Сумма

Если НЕ ПустаяСтрока(ТекстОтбора) Тогда
ТекстОтбора = "ГДЕ Истина " + ТекстОтбора;
КонецЕсли;
5. Алексей Новоселов (a-novoselov) 18.05.10 07:09
6. Алексей Константинов (alexk-is) 18.05.10 07:42
(5) Ой. А что так страшно-то? :)
7. Алексей Роза (DoctorRoza) 19.05.10 09:59
МногА букоФак .. нИ асилил .. :D )) +
8. Алексей Новоселов (a-novoselov) 19.05.10 13:38
(1) Да, ПостроительЗапроса.Результат. Выбрать(); -
получаем выборку всех документов (их например 100 000) и считаем в цикле общую сумму. Или ПостроительЗапроса.Результат. Выгрузить(); - и по таблице на клиенте считаем сумму колонки. Метод намного проще и нисколечко не будет тормозить на клиент-серверном варианте.
Даже при корректной настройке на вывод нужного поля вся колонка будет выгружаться на клиента, что намного дольше возврата 1й цыфры. Только при ручном назначени ИсточникаДанных построителю мы колонки сможем узнать и типизировать после получения свойства ПостроительЗапроса.Результат... а это опять же получение всего списка... может подскажете как настроить вывод нужного поля до получения результата?
9. Виталий Гуляев (vital1c) 26.12.12 14:27
в динамических списках в отборе также участвуют КриетрииОтбора, поэтому формирование такого запроса например в Списке ЗаказПокупателя в УТ 10.3 при выборе отбора ДокументыПоДоговоруКонтрагента, запрос не выполнится, потому что имя реквизита будет соответсовать критерию отбора, а не реквизита документа.
10. Алексей Новоселов (a-novoselov) 26.12.12 15:57
(9) Да, согласен. Но публикация была сделана для того, чтобы показать как следует делать, показать направление так сказать. Просто встречал на своей практике случаи, когда делалось то же самое через построитель - кода, конечно, меньше в разы, но после перехода отметки в 1000 документов форма начинала открываться по 20-30 секунд, хотя через запрос при любом количестве документов открывается не больше секунды.